Datapolis.WorkBox.Activities Namespace

Datapolis.WorkBox.Activities Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBActivityBase | Base class for WorkBox from scratch activities.


WBActivityBase Class

WBActivityBase Class Datapolis Process System Class Reference
Base class for WorkBox from scratch activities.
Inheritance Hierarchy
SystemObject
System.Workflow.ComponentModelDependencyObject
System.Workflow.ComponentModelActivity
Datapolis.WorkBox.ActivitiesWBActivityBase

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBActivityBase : Activity
Public Class WBActivityBase
    Inherits Activity
public ref class WBActivityBase : public Activity
type WBActivityBase =
    class
        inherit Activity
    end

The WBActivityBase type exposes the following members.

Properties
 | Name | Description
Public property | __Context | Workflow context connected with current activity's workflow.
Public property | __InitParams | Workflow activation properties, like workflow id, web and list information etc.
Public property | __ItemId | Identifier of an item that workflow is executing on.
Public property | __List | List Guid (in string) that activity workflow works on.
Public property | __WorkflowId | Workflow Instance Id
Public property | HistoryLogger | Gets the history logger.
Public property | InitParams | Gets the activity init params
Public property | Logger | Gets the logger.
Top
Methods
 | Name | Description
Protected method | ExecuteBody | Implement acivity execution logic here.
Top
See Also

Reference

Datapolis.WorkBox.Activities Namespace


WBActivityBase Properties

WBActivityBase Properties Datapolis Process System Class Reference

The WBActivityBase type exposes the following members.

Properties
 | Name | Description
Public property | __Context | Workflow context connected with current activity's workflow.
Public property | __InitParams | Workflow activation properties, like workflow id, web and list information etc.
Public property | __ItemId | Identifier of an item that workflow is executing on.
Public property | __List | List Guid (in string) that activity workflow works on.
Public property | __WorkflowId | Workflow Instance Id
Public property | HistoryLogger | Gets the history logger.
Public property | InitParams | Gets the activity init params
Public property | Logger | Gets the logger.
Top
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.__Context Property

WBActivityBase__Context Property Datapolis Process System Class Reference
Workflow context connected with current activity's workflow.

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WorkflowContext __Context { get; set; }
Public Property __Context As WorkflowContext
    Get
    Set
public:
virtual property WorkflowContext^ __Context {
    WorkflowContext^ get () sealed;
    void set (WorkflowContext^ value) sealed;
}
abstract __Context : WorkflowContext with get, set
override __Context : WorkflowContext with get, set

Property Value

Type: WorkflowContext
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.__InitParams Property

WBActivityBase__InitParams Property Datapolis Process System Class Reference
Workflow activation properties, like workflow id, web and list information etc.

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public SPWorkflowActivationProperties __InitParams { get; set; }
Public Property __InitParams As SPWorkflowActivationProperties
    Get
    Set
public:
virtual property SPWorkflowActivationProperties^ __InitParams {
    SPWorkflowActivationProperties^ get () sealed;
    void set (SPWorkflowActivationProperties^ value) sealed;
}
abstract __InitParams : SPWorkflowActivationProperties with get, set
override __InitParams : SPWorkflowActivationProperties with get, set

Property Value

Type: SPWorkflowActivationProperties
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.__ItemId Property

WBActivityBase__ItemId Property Datapolis Process System Class Reference
Identifier of an item that workflow is executing on.

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int __ItemId { get; set; }
Public Property __ItemId As Integer
    Get
    Set
public:
virtual property int __ItemId {
    int get () sealed;
    void set (int value) sealed;
}
abstract __ItemId : int with get, set
override __ItemId : int with get, set

Property Value

Type: Int32
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.__List Property

WBActivityBase__List Property Datapolis Process System Class Reference
List Guid (in string) that activity workflow works on.

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string __List { get; set; }
Public Property __List As String
    Get
    Set
public:
virtual property String^ __List {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract __List : string with get, set
override __List : string with get, set

Property Value

Type: String
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.__WorkflowId Property

WBActivityBase__WorkflowId Property Datapolis Process System Class Reference
Workflow Instance Id

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid __WorkflowId { get; set; }
Public Property __WorkflowId As Guid
    Get
    Set
public:
virtual property Guid __WorkflowId {
    Guid get () sealed;
    void set (Guid value) sealed;
}
abstract __WorkflowId : Guid with get, set
override __WorkflowId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.HistoryLogger Property

WBActivityBaseHistoryLogger Property Datapolis Process System Class Reference
Gets the history logger.

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBHistoryLogger HistoryLogger { get; }
Public ReadOnly Property HistoryLogger As WBHistoryLogger
    Get
public:
property WBHistoryLogger^ HistoryLogger {
    WBHistoryLogger^ get ();
}
member HistoryLogger : WBHistoryLogger with get

Property Value

Type: WBHistoryLogger
The history logger.
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.InitParams Property

WBActivityBaseInitParams Property Datapolis Process System Class Reference
Gets the activity init params

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public SPWorkflowActivationProperties InitParams { get; }
Public ReadOnly Property InitParams As SPWorkflowActivationProperties
    Get
public:
property SPWorkflowActivationProperties^ InitParams {
    SPWorkflowActivationProperties^ get ();
}
member InitParams : SPWorkflowActivationProperties with get

Property Value

Type: SPWorkflowActivationProperties
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.Logger Property

WBActivityBaseLogger Property Datapolis Process System Class Reference
Gets the logger.

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBLogger Logger { get; }
Public ReadOnly Property Logger As WBLogger
    Get
public:
property WBLogger^ Logger {
    WBLogger^ get ();
}
member Logger : WBLogger with get

Property Value

Type: WBLogger
The logger.
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase Methods

WBActivityBase Methods Datapolis Process System Class Reference

The WBActivityBase type exposes the following members.

Methods
 | Name | Description
Protected method | ExecuteBody | Implement acivity execution logic here.
Top
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


WBActivityBase.ExecuteBody Method

WBActivityBaseExecuteBody Method Datapolis Process System Class Reference
Implement acivity execution logic here.

Namespace: Datapolis.WorkBox.Activities
Assembly: Datapolis.WorkBox.Activities (in Datapolis.WorkBox.Activities.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
protected virtual ActivityExecutionStatus ExecuteBody(
    ActivityExecutionContext executionContext
)
Protected Overridable Function ExecuteBody (
    executionContext As ActivityExecutionContext
) As ActivityExecutionStatus
protected:
virtual ActivityExecutionStatus ExecuteBody(
    ActivityExecutionContext^ executionContext
)
abstract ExecuteBody :
        executionContext : ActivityExecutionContext -> ActivityExecutionStatus
override ExecuteBody :
        executionContext : ActivityExecutionContext -> ActivityExecutionStatus

Parameters

executionContext
Type: System.Workflow.ComponentModelActivityExecutionContext
Activity execution context.

Return Value

Type: ActivityExecutionStatus
Never throw any exception here and always return ActivityExecutionStatus.Closed.
See Also

Reference

WBActivityBase Class
Datapolis.WorkBox.Activities Namespace


Datapolis.WorkBox.Common Namespace

Datapolis.WorkBox.Common Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBFunctionExecutionContext |
Public class | WBHistoryLogger | Prepares Workflow History entries
Public class | WBLogger |


WBFunctionExecutionContext Class

WBFunctionExecutionContext Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.CommonWBFunctionExecutionContext

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBFunctionExecutionContext
Public NotInheritable Class WBFunctionExecutionContext
public ref class WBFunctionExecutionContext sealed
[<SealedAttribute>]
type WBFunctionExecutionContext =  class end

The WBFunctionExecutionContext type exposes the following members.

Constructors
 | Name | Description
Public method | WBFunctionExecutionContext | Initializes a new instance of the WBFunctionExecutionContext class
Top
Properties
 | Name | Description
Public property | CorrelationId |
Public property | Locale |
Public property | RegionalSettings |
Top
See Also

Reference

Datapolis.WorkBox.Common Namespace


WBFunctionExecutionContext Constructor

WBFunctionExecutionContext Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBFunctionExecutionContext class

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBFunctionExecutionContext()
Public Sub New
public:
WBFunctionExecutionContext()
new : unit -> WBFunctionExecutionContext
See Also

Reference

WBFunctionExecutionContext Class
Datapolis.WorkBox.Common Namespace


WBFunctionExecutionContext Properties

WBFunctionExecutionContext Properties Datapolis Process System Class Reference

The WBFunctionExecutionContext type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId |
Public property | Locale |
Public property | RegionalSettings |
Top
See Also

Reference

WBFunctionExecutionContext Class
Datapolis.WorkBox.Common Namespace


WBFunctionExecutionContext.CorrelationId Property

WBFunctionExecutionContextCorrelationId Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid CorrelationId { get; }
Public ReadOnly Property CorrelationId As Guid
    Get
public:
property Guid CorrelationId {
    Guid get ();
}
member CorrelationId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBFunctionExecutionContext Class
Datapolis.WorkBox.Common Namespace


WBFunctionExecutionContext.Locale Property

WBFunctionExecutionContextLocale Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public CultureInfo Locale { get; }
Public ReadOnly Property Locale As CultureInfo
    Get
public:
property CultureInfo^ Locale {
    CultureInfo^ get ();
}
member Locale : CultureInfo with get

Property Value

Type: CultureInfo
See Also

Reference

WBFunctionExecutionContext Class
Datapolis.WorkBox.Common Namespace


WBFunctionExecutionContext.RegionalSettings Property

WBFunctionExecutionContextRegionalSettings Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public SPRegionalSettings RegionalSettings { get; }
Public ReadOnly Property RegionalSettings As SPRegionalSettings
    Get
public:
property SPRegionalSettings^ RegionalSettings {
    SPRegionalSettings^ get ();
}
member RegionalSettings : SPRegionalSettings with get

Property Value

Type: SPRegionalSettings
See Also

Reference

WBFunctionExecutionContext Class
Datapolis.WorkBox.Common Namespace


WBHistoryLogger Class

WBHistoryLogger Class Datapolis Process System Class Reference
Prepares Workflow History entries
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.CommonWBHistoryLogger

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class WBHistoryLogger
<SerializableAttribute>
Public NotInheritable Class WBHistoryLogger
[SerializableAttribute]
public ref class WBHistoryLogger sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type WBHistoryLogger =  class end

The WBHistoryLogger type exposes the following members.

Methods
 | Name | Description
Public method | AddAlert(WBLocalizer, Boolean) | Adds the alert to workflow history.
Public method | AddAlert(String, Boolean) | Writes activity alert information to current workfow history list
Public method | AddAlert(WBLocalizer, Boolean, WBLocalizer) | Adds the alert to workflow history.
Public method | AddAlert(WBLocalizer, Boolean, Object) | Adds the alert to workflow history.
Public method | AddAlert(String, Boolean, Object) | Adds the alert to workflow history.
Public method | AddError(WBLocalizer, Boolean) | Adds the error to workflow history.
Public method | AddError(String, Boolean) | Writes activity error information to current workfow history list
Public method | AddError(WBLocalizer, Boolean, Object) | Adds the error to workflow history.
Public method | AddError(WBLocalizer, Exception, Boolean) | Adds the error to workflow history.
Public method | AddError(Exception, WorkflowContext, Boolean) | Adds the error to workflow history.
Public method | AddError(String, Boolean, Object) | Adds the error to workflow history.
Public method | AddError(WBLocalizer, Exception, Boolean, Object) | Adds the error to workflow history.
Public method | ClearAlerts | Clears all alerts information in current activity history
Public method | RemoveAlert | Removes activity alert
Top
See Also

Reference

Datapolis.WorkBox.Common Namespace


WBHistoryLogger Methods

WBHistoryLogger Methods Datapolis Process System Class Reference

The WBHistoryLogger type exposes the following members.

Methods
 | Name | Description
Public method | AddAlert(WBLocalizer, Boolean) | Adds the alert to workflow history.
Public method | AddAlert(String, Boolean) | Writes activity alert information to current workfow history list
Public method | AddAlert(WBLocalizer, Boolean, WBLocalizer) | Adds the alert to workflow history.
Public method | AddAlert(WBLocalizer, Boolean, Object) | Adds the alert to workflow history.
Public method | AddAlert(String, Boolean, Object) | Adds the alert to workflow history.
Public method | AddError(WBLocalizer, Boolean) | Adds the error to workflow history.
Public method | AddError(String, Boolean) | Writes activity error information to current workfow history list
Public method | AddError(WBLocalizer, Boolean, Object) | Adds the error to workflow history.
Public method | AddError(WBLocalizer, Exception, Boolean) | Adds the error to workflow history.
Public method | AddError(Exception, WorkflowContext, Boolean) | Adds the error to workflow history.
Public method | AddError(String, Boolean, Object) | Adds the error to workflow history.
Public method | AddError(WBLocalizer, Exception, Boolean, Object) | Adds the error to workflow history.
Public method | ClearAlerts | Clears all alerts information in current activity history
Public method | RemoveAlert | Removes activity alert
Top
See Also

Reference

WBHistoryLogger Class
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddAlert Method

WBHistoryLoggerAddAlert Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | AddAlert(WBLocalizer, Boolean) | Adds the alert to workflow history.
Public method | AddAlert(String, Boolean) | Writes activity alert information to current workfow history list
Public method | AddAlert(WBLocalizer, Boolean, WBLocalizer) | Adds the alert to workflow history.
Public method | AddAlert(WBLocalizer, Boolean, Object) | Adds the alert to workflow history.
Public method | AddAlert(String, Boolean, Object) | Adds the alert to workflow history.
Top
See Also

Reference

WBHistoryLogger Class
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddAlert Method (WBLocalizer, Boolean)

WBHistoryLoggerAddAlert Method (WBLocalizer, Boolean) Datapolis Process System Class Reference
Adds the alert to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddAlert(
    WBLocalizer localizer,
    bool log
)
Public Sub AddAlert (
    localizer As WBLocalizer,
    log As Boolean
)
public:
void AddAlert(
    WBLocalizer^ localizer,
    bool log
)
member AddAlert :
        localizer : WBLocalizer *
        log : bool -> unit

Parameters

localizer
Type: WBLocalizer
The localizer.
log
Type: SystemBoolean
See Also

Reference

WBHistoryLogger Class
AddAlert Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddAlert Method (String, Boolean)

WBHistoryLoggerAddAlert Method (String, Boolean) Datapolis Process System Class Reference
Writes activity alert information to current workfow history list

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddAlert(
    string message,
    bool log
)
Public Sub AddAlert (
    message As String,
    log As Boolean
)
public:
void AddAlert(
    String^ message,
    bool log
)
member AddAlert :
        message : string *
        log : bool -> unit

Parameters

message
Type: SystemString
log
Type: SystemBoolean
See Also

Reference

WBHistoryLogger Class
AddAlert Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddAlert Method (WBLocalizer, Boolean, WBLocalizer[])

WBHistoryLoggerAddAlert Method (WBLocalizer, Boolean, WBLocalizer) Datapolis Process System Class Reference
Adds the alert to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddAlert(
    WBLocalizer localizer,
    bool log,
    params WBLocalizer[] paramLocalizers
)
Public Sub AddAlert (
    localizer As WBLocalizer,
    log As Boolean,
    ParamArray paramLocalizers As WBLocalizer()
)
public:
void AddAlert(
    WBLocalizer^ localizer,
    bool log,
    ... array<WBLocalizer^>^ paramLocalizers
)
member AddAlert :
        localizer : WBLocalizer *
        log : bool *
        paramLocalizers : WBLocalizer[] -> unit

Parameters

localizer
Type: WBLocalizer
The localizer.
log
Type: SystemBoolean
paramLocalizers
Type: WBLocalizer
The param localizers.
See Also

Reference

WBHistoryLogger Class
AddAlert Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddAlert Method (WBLocalizer, Boolean, Object[])

WBHistoryLoggerAddAlert Method (WBLocalizer, Boolean, Object) Datapolis Process System Class Reference
Adds the alert to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddAlert(
    WBLocalizer localizer,
    bool log,
    params Object[] parameters
)
Public Sub AddAlert (
    localizer As WBLocalizer,
    log As Boolean,
    ParamArray parameters As Object()
)
public:
void AddAlert(
    WBLocalizer^ localizer,
    bool log,
    ... array<Object^>^ parameters
)
member AddAlert :
        localizer : WBLocalizer *
        log : bool *
        parameters : Object[] -> unit

Parameters

localizer
Type: WBLocalizer
The localizer.
log
Type: SystemBoolean
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBHistoryLogger Class
AddAlert Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddAlert Method (String, Boolean, Object[])

WBHistoryLoggerAddAlert Method (String, Boolean, Object) Datapolis Process System Class Reference
Adds the alert to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddAlert(
    string message,
    bool log,
    params Object[] parameters
)
Public Sub AddAlert (
    message As String,
    log As Boolean,
    ParamArray parameters As Object()
)
public:
void AddAlert(
    String^ message,
    bool log,
    ... array<Object^>^ parameters
)
member AddAlert :
        message : string *
        log : bool *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
log
Type: SystemBoolean
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBHistoryLogger Class
AddAlert Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method

WBHistoryLoggerAddError Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | AddError(WBLocalizer, Boolean) | Adds the error to workflow history.
Public method | AddError(String, Boolean) | Writes activity error information to current workfow history list
Public method | AddError(WBLocalizer, Boolean, Object) | Adds the error to workflow history.
Public method | AddError(WBLocalizer, Exception, Boolean) | Adds the error to workflow history.
Public method | AddError(Exception, WorkflowContext, Boolean) | Adds the error to workflow history.
Public method | AddError(String, Boolean, Object) | Adds the error to workflow history.
Public method | AddError(WBLocalizer, Exception, Boolean, Object) | Adds the error to workflow history.
Top
See Also

Reference

WBHistoryLogger Class
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method (WBLocalizer, Boolean)

WBHistoryLoggerAddError Method (WBLocalizer, Boolean) Datapolis Process System Class Reference
Adds the error to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddError(
    WBLocalizer localizer,
    bool log
)
Public Sub AddError (
    localizer As WBLocalizer,
    log As Boolean
)
public:
void AddError(
    WBLocalizer^ localizer,
    bool log
)
member AddError :
        localizer : WBLocalizer *
        log : bool -> unit

Parameters

localizer
Type: WBLocalizer
The localizer.
log
Type: SystemBoolean
See Also

Reference

WBHistoryLogger Class
AddError Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method (String, Boolean)

WBHistoryLoggerAddError Method (String, Boolean) Datapolis Process System Class Reference
Writes activity error information to current workfow history list

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddError(
    string message,
    bool log
)
Public Sub AddError (
    message As String,
    log As Boolean
)
public:
void AddError(
    String^ message,
    bool log
)
member AddError :
        message : string *
        log : bool -> unit

Parameters

message
Type: SystemString
log
Type: SystemBoolean
See Also

Reference

WBHistoryLogger Class
AddError Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method (WBLocalizer, Boolean, Object[])

WBHistoryLoggerAddError Method (WBLocalizer, Boolean, Object) Datapolis Process System Class Reference
Adds the error to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddError(
    WBLocalizer localizer,
    bool log,
    params Object[] parameters
)
Public Sub AddError (
    localizer As WBLocalizer,
    log As Boolean,
    ParamArray parameters As Object()
)
public:
void AddError(
    WBLocalizer^ localizer,
    bool log,
    ... array<Object^>^ parameters
)
member AddError :
        localizer : WBLocalizer *
        log : bool *
        parameters : Object[] -> unit

Parameters

localizer
Type: WBLocalizer
log
Type: SystemBoolean
parameters
Type: SystemObject
See Also

Reference

WBHistoryLogger Class
AddError Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method (WBLocalizer, Exception, Boolean)

WBHistoryLoggerAddError Method (WBLocalizer, Exception, Boolean) Datapolis Process System Class Reference
Adds the error to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddError(
    WBLocalizer localizer,
    Exception exception,
    bool log
)
Public Sub AddError (
    localizer As WBLocalizer,
    exception As Exception,
    log As Boolean
)
public:
void AddError(
    WBLocalizer^ localizer,
    Exception^ exception,
    bool log
)
member AddError :
        localizer : WBLocalizer *
        exception : Exception *
        log : bool -> unit

Parameters

localizer
Type: WBLocalizer
The localizer.
exception
Type: SystemException
The exception.
log
Type: SystemBoolean
See Also

Reference

WBHistoryLogger Class
AddError Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method (Exception, WorkflowContext, Boolean)

WBHistoryLoggerAddError Method (Exception, WorkflowContext, Boolean) Datapolis Process System Class Reference
Adds the error to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddError(
    Exception exception,
    WorkflowContext context,
    bool log
)
Public Sub AddError (
    exception As Exception,
    context As WorkflowContext,
    log As Boolean
)
public:
void AddError(
    Exception^ exception,
    WorkflowContext^ context,
    bool log
)
member AddError :
        exception : Exception *
        context : WorkflowContext *
        log : bool -> unit

Parameters

exception
Type: SystemException
The exception.
context
Type: WorkflowContext
log
Type: SystemBoolean
See Also

Reference

WBHistoryLogger Class
AddError Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method (String, Boolean, Object[])

WBHistoryLoggerAddError Method (String, Boolean, Object) Datapolis Process System Class Reference
Adds the error to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddError(
    string message,
    bool log,
    params Object[] parameters
)
Public Sub AddError (
    message As String,
    log As Boolean,
    ParamArray parameters As Object()
)
public:
void AddError(
    String^ message,
    bool log,
    ... array<Object^>^ parameters
)
member AddError :
        message : string *
        log : bool *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
log
Type: SystemBoolean
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBHistoryLogger Class
AddError Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.AddError Method (WBLocalizer, Exception, Boolean, Object[])

WBHistoryLoggerAddError Method (WBLocalizer, Exception, Boolean, Object) Datapolis Process System Class Reference
Adds the error to workflow history.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void AddError(
    WBLocalizer localizer,
    Exception exception,
    bool log,
    params Object[] parameters
)
Public Sub AddError (
    localizer As WBLocalizer,
    exception As Exception,
    log As Boolean,
    ParamArray parameters As Object()
)
public:
void AddError(
    WBLocalizer^ localizer,
    Exception^ exception,
    bool log,
    ... array<Object^>^ parameters
)
member AddError :
        localizer : WBLocalizer *
        exception : Exception *
        log : bool *
        parameters : Object[] -> unit

Parameters

localizer
Type: WBLocalizer
The localizer.
exception
Type: SystemException
The exception.
log
Type: SystemBoolean
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBHistoryLogger Class
AddError Overload
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.ClearAlerts Method

WBHistoryLoggerClearAlerts Method Datapolis Process System Class Reference
Clears all alerts information in current activity history

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void ClearAlerts()
Public Sub ClearAlerts
public:
void ClearAlerts()
member ClearAlerts : unit -> unit
See Also

Reference

WBHistoryLogger Class
Datapolis.WorkBox.Common Namespace


WBHistoryLogger.RemoveAlert Method

WBHistoryLoggerRemoveAlert Method Datapolis Process System Class Reference
Removes activity alert

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAlert(
    string message
)
Public Sub RemoveAlert (
    message As String
)
public:
void RemoveAlert(
    String^ message
)
member RemoveAlert :
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

WBHistoryLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger Class

WBLogger Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
SPAutoSerializingObject
SPPersistedObject
SPPersistedUpgradableObject
SPService
SPDiagnosticsServiceBase
Datapolis.WorkBox.CommonWBLogger

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WBLogger : SPDiagnosticsServiceBase
<SerializableAttribute>
Public Class WBLogger
    Inherits SPDiagnosticsServiceBase
[SerializableAttribute]
public ref class WBLogger : public SPDiagnosticsServiceBase
[<SerializableAttribute>]
type WBLogger =
    class
        inherit SPDiagnosticsServiceBase
    end

The WBLogger type exposes the following members.

Constructors
 | Name | Description
Public method | WBLogger | Initializes a new instance of the WBLogger class.
Public method | WBLogger(WBLoggingCategory) | Initializes a new instance of the WBLogger class.
Public method | WBLogger(Object) | Initializes a new instance of the WBLogger class.
Public method | WBLogger(String) | Obsolete. Obsolete: Initializes a new instance of the WBLogger class.
Public method | WBLogger(String, SPFarm) | Initializes a new instance of the WBLogger class.
Top
Properties
 | Name | Description
Public property | Applications | (Inherited from SPService.)
Public property | Areas | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanBackupRestoreAsConfiguration | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanRenameOnRestore | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanSelectForBackup | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanSelectForRestore | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanUpgrade | (Inherited from SPPersistedUpgradableObject.)
Public property | CorrelationVisibleID | (Inherited from SPDiagnosticsServiceBase.)
Public property | DiskSizeRequired | (Inherited from SPDiagnosticsServiceBase.)
Public property | Instances | (Inherited from SPService.)
Public property | IsBackwardsCompatible | (Inherited from SPPersistedUpgradableObject.)
Public property | JobDefinitions | (Inherited from SPService.)
Public property | JobHistoryEntries | (Inherited from SPService.)
Public property | NeedsUpgrade | (Inherited from SPPersistedUpgradableObject.)
Public property | NeedsUpgradeIncludeChildren | (Inherited from SPPersistedUpgradableObject.)
Public property | Required | (Inherited from SPService.)
Protected property | ResourceDll | (Inherited from SPDiagnosticsServiceBase.)
Public property | RunningJobs | (Inherited from SPService.)
Public property | UpgradeContext | (Inherited from SPPersistedUpgradableObject.)
Top
Methods
 | Name | Description
Public method | AddBackupObjects | (Inherited from SPDiagnosticsServiceBase.)
Public method | Delete | (Inherited from SPService.)
Public method | GetCreateApplicationLink | (Inherited from SPService.)
Public method | GetCreateApplicationOptions | (Inherited from SPService.)
Public method | High(String) | Logs the specified message as the High level.
Public method | High(String, Object) | Logs the specified message as the High level. Parameters are added to the message.
Public method | Invalidate | (Inherited from SPPersistedUpgradableObject.)
Public method | IsUserLicensedForEntity | (Inherited from SPService.)
Public method | Log(String, WBLogLevel) | Logs the specified message on the given log level.
Public method | Log(String, EventSeverity) | Obsolete.
Public method | Log(String, WBLogLevel, Exception) | Logs the specified message on the given log level. The following expetion properties: Message, StackTrace and Source are added to the log message.
Public method | Log(String, WBLogLevel, Object) | Logs the specified message on the given log level. Parameters are added to the message.
Public method | Log(String, EventSeverity, Exception) | Obsolete.
Public method | Log(String, EventSeverity, Object) | Obsolete.
Public method | Log(String, WBLogLevel, Exception, Object) | Logs the specified message on the given log level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.
Public method | Log(String, EventSeverity, Exception, Object) | Obsolete.
Public method | Medium(String) | Logs the specified message as the Medium level.
Public method | Medium(String, Object) | Logs the specified message as the Medium level. Parameters are added to the message.
Public method | Monitorable(String) | Logs the specified message as the Monitorable level.
Public method | Monitorable(String, Object) | Logs the specified message as the Monitorable level. Parameters are added to the message.
Public method | OnAbort | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnBackup | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnBackupComplete | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnPostRestore | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnPrepareBackup | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnPreRestore | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnRestore | (Inherited from SPDiagnosticsServiceBase.)
Protected method | ProvideAreas | (Inherited from SPDiagnosticsServiceBase.)
Public method | ResetAll | (Inherited from SPDiagnosticsServiceBase.)
Public method | SetAll(TraceSeverity) | (Inherited from SPDiagnosticsServiceBase.)
Public method | SetAll(EventSeverity) | (Inherited from SPDiagnosticsServiceBase.)
Public method | SetAll(TraceSeverity, EventSeverity) | (Inherited from SPDiagnosticsServiceBase.)
Public method | Unexpected(String) | Logs the specified message as the Unexpected level.
Public method | Unexpected(String, Exception) | Logs the specified message as the Unexpected level. The following expetion properties: Message, StackTrace and Source are added to the log message.
Public method | Unexpected(String, Object) | Logs the specified message as the Unexpected level. Parameters are added to the message.
Public method | Unexpected(String, Exception, Object) | Logs the specified message as the Unexpected level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.
Public method | Update | (Inherited from SPDiagnosticsServiceBase.)
Public method | Upgrade | (Inherited from SPPersistedUpgradableObject.)
Public method | Upgrade(Boolean) | (Inherited from SPPersistedUpgradableObject.)
Public method | ValidateBackwardsCompatibility | (Inherited from SPPersistedUpgradableObject.)
Public method | Verbose(String) | Logs the specified message as the Verbose level.
Public method | Verbose(String, Object) | Logs the specified message as the Verbose level. Parameters are added to the message.
Public method | WriteEvent | (Inherited from SPDiagnosticsServiceBase.)
Public method | WriteTrace | (Inherited from SPDiagnosticsServiceBase.)
Top
See Also

Reference

Datapolis.WorkBox.Common Namespace


WBLogger Constructor

WBLogger Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBLogger | Initializes a new instance of the WBLogger class.
Public method | WBLogger(WBLoggingCategory) | Initializes a new instance of the WBLogger class.
Public method | WBLogger(Object) | Initializes a new instance of the WBLogger class.
Public method | WBLogger(String) | Obsolete. Obsolete: Initializes a new instance of the WBLogger class.
Public method | WBLogger(String, SPFarm) | Initializes a new instance of the WBLogger class.
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger Constructor

WBLogger Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBLogger class.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBLogger()
Public Sub New
public:
WBLogger()
new : unit -> WBLogger
See Also

Reference

WBLogger Class
WBLogger Overload
Datapolis.WorkBox.Common Namespace


WBLogger Constructor (WBLoggingCategory)

WBLogger Constructor (WBLoggingCategory) Datapolis Process System Class Reference
Initializes a new instance of the WBLogger class.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBLogger(
    WBLoggingCategory loggingCategory
)
Public Sub New (
    loggingCategory As WBLoggingCategory
)
public:
WBLogger(
    WBLoggingCategory loggingCategory
)
new :
        loggingCategory : WBLoggingCategory -> WBLogger

Parameters

loggingCategory
Type: WBLoggingCategory
See Also

Reference

WBLogger Class
WBLogger Overload
Datapolis.WorkBox.Common Namespace


WBLogger Constructor (Object)

WBLogger Constructor (Object) Datapolis Process System Class Reference
Initializes a new instance of the WBLogger class.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBLogger(
    Object obj
)
Public Sub New (
    obj As Object
)
public:
WBLogger(
    Object^ obj
)
new :
        obj : Object -> WBLogger

Parameters

obj
Type: SystemObject
See Also

Reference

WBLogger Class
WBLogger Overload
Datapolis.WorkBox.Common Namespace


WBLogger Constructor (String)

WBLogger Constructor (String) Datapolis Process System Class Reference

Note: This API is now obsolete.

Obsolete: Initializes a new instance of the WBLogger class.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("use WBLogger(WBLoggingCategory category) instead",
    true)]
public WBLogger(
    string productName
)
<ObsoleteAttribute("use WBLogger(WBLoggingCategory category) instead",
    true)>
Public Sub New (
    productName As String
)
public:
[ObsoleteAttribute(L"use WBLogger(WBLoggingCategory category) instead",
    true)]
WBLogger(
    String^ productName
)
[<ObsoleteAttribute("use WBLogger(WBLoggingCategory category) instead",
    true)>]
new :
        productName : string -> WBLogger

Parameters

productName
Type: SystemString
Name of the product.
See Also

Reference

WBLogger Class
WBLogger Overload
Datapolis.WorkBox.Common Namespace


WBLogger Constructor (String, SPFarm)

WBLogger Constructor (String, SPFarm) Datapolis Process System Class Reference
Initializes a new instance of the WBLogger class.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBLogger(
    string name,
    SPFarm parent
)
Public Sub New (
    name As String,
    parent As SPFarm
)
public:
WBLogger(
    String^ name,
    SPFarm^ parent
)
new :
        name : string *
        parent : SPFarm -> WBLogger

Parameters

name
Type: SystemString
parent
Type: SPFarm
See Also

Reference

WBLogger Class
WBLogger Overload
Datapolis.WorkBox.Common Namespace


WBLogger Properties

WBLogger Properties Datapolis Process System Class Reference

The WBLogger type exposes the following members.

Properties
 | Name | Description
Public property | Applications | (Inherited from SPService.)
Public property | Areas | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanBackupRestoreAsConfiguration | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanRenameOnRestore | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanSelectForBackup | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanSelectForRestore | (Inherited from SPDiagnosticsServiceBase.)
Public property | CanUpgrade | (Inherited from SPPersistedUpgradableObject.)
Public property | CorrelationVisibleID | (Inherited from SPDiagnosticsServiceBase.)
Public property | DiskSizeRequired | (Inherited from SPDiagnosticsServiceBase.)
Public property | Instances | (Inherited from SPService.)
Public property | IsBackwardsCompatible | (Inherited from SPPersistedUpgradableObject.)
Public property | JobDefinitions | (Inherited from SPService.)
Public property | JobHistoryEntries | (Inherited from SPService.)
Public property | NeedsUpgrade | (Inherited from SPPersistedUpgradableObject.)
Public property | NeedsUpgradeIncludeChildren | (Inherited from SPPersistedUpgradableObject.)
Public property | Required | (Inherited from SPService.)
Protected property | ResourceDll | (Inherited from SPDiagnosticsServiceBase.)
Public property | RunningJobs | (Inherited from SPService.)
Public property | UpgradeContext | (Inherited from SPPersistedUpgradableObject.)
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger Methods

WBLogger Methods Datapolis Process System Class Reference

The WBLogger type exposes the following members.

Methods
 | Name | Description
Public method | AddBackupObjects | (Inherited from SPDiagnosticsServiceBase.)
Public method | Delete | (Inherited from SPService.)
Public method | GetCreateApplicationLink | (Inherited from SPService.)
Public method | GetCreateApplicationOptions | (Inherited from SPService.)
Public method | High(String) | Logs the specified message as the High level.
Public method | High(String, Object) | Logs the specified message as the High level. Parameters are added to the message.
Public method | Invalidate | (Inherited from SPPersistedUpgradableObject.)
Public method | IsUserLicensedForEntity | (Inherited from SPService.)
Public method | Log(String, WBLogLevel) | Logs the specified message on the given log level.
Public method | Log(String, EventSeverity) | Obsolete.
Public method | Log(String, WBLogLevel, Exception) | Logs the specified message on the given log level. The following expetion properties: Message, StackTrace and Source are added to the log message.
Public method | Log(String, WBLogLevel, Object) | Logs the specified message on the given log level. Parameters are added to the message.
Public method | Log(String, EventSeverity, Exception) | Obsolete.
Public method | Log(String, EventSeverity, Object) | Obsolete.
Public method | Log(String, WBLogLevel, Exception, Object) | Logs the specified message on the given log level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.
Public method | Log(String, EventSeverity, Exception, Object) | Obsolete.
Public method | Medium(String) | Logs the specified message as the Medium level.
Public method | Medium(String, Object) | Logs the specified message as the Medium level. Parameters are added to the message.
Public method | Monitorable(String) | Logs the specified message as the Monitorable level.
Public method | Monitorable(String, Object) | Logs the specified message as the Monitorable level. Parameters are added to the message.
Public method | OnAbort | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnBackup | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnBackupComplete | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnPostRestore | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnPrepareBackup | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnPreRestore | (Inherited from SPDiagnosticsServiceBase.)
Public method | OnRestore | (Inherited from SPDiagnosticsServiceBase.)
Protected method | ProvideAreas | (Inherited from SPDiagnosticsServiceBase.)
Public method | ResetAll | (Inherited from SPDiagnosticsServiceBase.)
Public method | SetAll(TraceSeverity) | (Inherited from SPDiagnosticsServiceBase.)
Public method | SetAll(EventSeverity) | (Inherited from SPDiagnosticsServiceBase.)
Public method | SetAll(TraceSeverity, EventSeverity) | (Inherited from SPDiagnosticsServiceBase.)
Public method | Unexpected(String) | Logs the specified message as the Unexpected level.
Public method | Unexpected(String, Exception) | Logs the specified message as the Unexpected level. The following expetion properties: Message, StackTrace and Source are added to the log message.
Public method | Unexpected(String, Object) | Logs the specified message as the Unexpected level. Parameters are added to the message.
Public method | Unexpected(String, Exception, Object) | Logs the specified message as the Unexpected level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.
Public method | Update | (Inherited from SPDiagnosticsServiceBase.)
Public method | Upgrade | (Inherited from SPPersistedUpgradableObject.)
Public method | Upgrade(Boolean) | (Inherited from SPPersistedUpgradableObject.)
Public method | ValidateBackwardsCompatibility | (Inherited from SPPersistedUpgradableObject.)
Public method | Verbose(String) | Logs the specified message as the Verbose level.
Public method | Verbose(String, Object) | Logs the specified message as the Verbose level. Parameters are added to the message.
Public method | WriteEvent | (Inherited from SPDiagnosticsServiceBase.)
Public method | WriteTrace | (Inherited from SPDiagnosticsServiceBase.)
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger.High Method

WBLoggerHigh Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | High(String) | Logs the specified message as the High level.
Public method | High(String, Object) | Logs the specified message as the High level. Parameters are added to the message.
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger.High Method (String)

WBLoggerHigh Method (String) Datapolis Process System Class Reference
Logs the specified message as the High level.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void High(
    string message
)
Public Sub High (
    message As String
)
public:
void High(
    String^ message
)
member High :
        message : string -> unit

Parameters

message
Type: SystemString
The message.
See Also

Reference

WBLogger Class
High Overload
Datapolis.WorkBox.Common Namespace


WBLogger.High Method (String, Object[])

WBLoggerHigh Method (String, Object) Datapolis Process System Class Reference
Logs the specified message as the High level. Parameters are added to the message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void High(
    string message,
    params Object[] parameters
)
Public Sub High (
    message As String,
    ParamArray parameters As Object()
)
public:
void High(
    String^ message,
    ... array<Object^>^ parameters
)
member High :
        message : string *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
High Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method

WBLoggerLog Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | Log(String, WBLogLevel) | Logs the specified message on the given log level.
Public method | Log(String, EventSeverity) | Obsolete.
Public method | Log(String, WBLogLevel, Exception) | Logs the specified message on the given log level. The following expetion properties: Message, StackTrace and Source are added to the log message.
Public method | Log(String, WBLogLevel, Object) | Logs the specified message on the given log level. Parameters are added to the message.
Public method | Log(String, EventSeverity, Exception) | Obsolete.
Public method | Log(String, EventSeverity, Object) | Obsolete.
Public method | Log(String, WBLogLevel, Exception, Object) | Logs the specified message on the given log level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.
Public method | Log(String, EventSeverity, Exception, Object) | Obsolete.
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, WBLogLevel)

WBLoggerLog Method (String, WBLogLevel) Datapolis Process System Class Reference
Logs the specified message on the given log level.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Log(
    string message,
    WBLogLevel level
)
Public Sub Log (
    message As String,
    level As WBLogLevel
)
public:
void Log(
    String^ message,
    WBLogLevel level
)
member Log :
        message : string *
        level : WBLogLevel -> unit

Parameters

message
Type: SystemString
The message.
level
Type: WBLogLevel
The level.
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, EventSeverity)

WBLoggerLog Method (String, EventSeverity) Datapolis Process System Class Reference

Note: This API is now obsolete.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public void Log(
    string message,
    EventSeverity eventSeverity
)
<ObsoleteAttribute>
Public Sub Log (
    message As String,
    eventSeverity As EventSeverity
)
public:
[ObsoleteAttribute]
void Log(
    String^ message,
    EventSeverity eventSeverity
)
[<ObsoleteAttribute>]
member Log :
        message : string *
        eventSeverity : EventSeverity -> unit

Parameters

message
Type: SystemString
eventSeverity
Type: EventSeverity
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, WBLogLevel, Exception)

WBLoggerLog Method (String, WBLogLevel, Exception) Datapolis Process System Class Reference
Logs the specified message on the given log level. The following expetion properties: Message, StackTrace and Source are added to the log message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Log(
    string message,
    WBLogLevel level,
    Exception exception
)
Public Sub Log (
    message As String,
    level As WBLogLevel,
    exception As Exception
)
public:
void Log(
    String^ message,
    WBLogLevel level,
    Exception^ exception
)
member Log :
        message : string *
        level : WBLogLevel *
        exception : Exception -> unit

Parameters

message
Type: SystemString
The message.
level
Type: WBLogLevel
The level.
exception
Type: SystemException
The exception.
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, WBLogLevel, Object[])

WBLoggerLog Method (String, WBLogLevel, Object) Datapolis Process System Class Reference
Logs the specified message on the given log level. Parameters are added to the message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Log(
    string message,
    WBLogLevel level,
    params Object[] parameters
)
Public Sub Log (
    message As String,
    level As WBLogLevel,
    ParamArray parameters As Object()
)
public:
void Log(
    String^ message,
    WBLogLevel level,
    ... array<Object^>^ parameters
)
member Log :
        message : string *
        level : WBLogLevel *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
level
Type: WBLogLevel
The level.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, EventSeverity, Exception)

WBLoggerLog Method (String, EventSeverity, Exception) Datapolis Process System Class Reference

Note: This API is now obsolete.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public void Log(
    string message,
    EventSeverity eventSeverity,
    Exception exception
)
<ObsoleteAttribute>
Public Sub Log (
    message As String,
    eventSeverity As EventSeverity,
    exception As Exception
)
public:
[ObsoleteAttribute]
void Log(
    String^ message,
    EventSeverity eventSeverity,
    Exception^ exception
)
[<ObsoleteAttribute>]
member Log :
        message : string *
        eventSeverity : EventSeverity *
        exception : Exception -> unit

Parameters

message
Type: SystemString
eventSeverity
Type: EventSeverity
exception
Type: SystemException
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, EventSeverity, Object[])

WBLoggerLog Method (String, EventSeverity, Object) Datapolis Process System Class Reference

Note: This API is now obsolete.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public void Log(
    string message,
    EventSeverity eventSeverity,
    params Object[] parameters
)
<ObsoleteAttribute>
Public Sub Log (
    message As String,
    eventSeverity As EventSeverity,
    ParamArray parameters As Object()
)
public:
[ObsoleteAttribute]
void Log(
    String^ message,
    EventSeverity eventSeverity,
    ... array<Object^>^ parameters
)
[<ObsoleteAttribute>]
member Log :
        message : string *
        eventSeverity : EventSeverity *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
eventSeverity
Type: EventSeverity
parameters
Type: SystemObject
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, WBLogLevel, Exception, Object[])

WBLoggerLog Method (String, WBLogLevel, Exception, Object) Datapolis Process System Class Reference
Logs the specified message on the given log level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Log(
    string message,
    WBLogLevel level,
    Exception exception,
    params Object[] parameters
)
Public Sub Log (
    message As String,
    level As WBLogLevel,
    exception As Exception,
    ParamArray parameters As Object()
)
public:
void Log(
    String^ message,
    WBLogLevel level,
    Exception^ exception,
    ... array<Object^>^ parameters
)
member Log :
        message : string *
        level : WBLogLevel *
        exception : Exception *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
level
Type: WBLogLevel
The level.
exception
Type: SystemException
The exception.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Log Method (String, EventSeverity, Exception, Object[])

WBLoggerLog Method (String, EventSeverity, Exception, Object) Datapolis Process System Class Reference

Note: This API is now obsolete.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public void Log(
    string message,
    EventSeverity eventSeverity,
    Exception exception,
    params Object[] parameters
)
<ObsoleteAttribute>
Public Sub Log (
    message As String,
    eventSeverity As EventSeverity,
    exception As Exception,
    ParamArray parameters As Object()
)
public:
[ObsoleteAttribute]
void Log(
    String^ message,
    EventSeverity eventSeverity,
    Exception^ exception,
    ... array<Object^>^ parameters
)
[<ObsoleteAttribute>]
member Log :
        message : string *
        eventSeverity : EventSeverity *
        exception : Exception *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
eventSeverity
Type: EventSeverity
exception
Type: SystemException
parameters
Type: SystemObject
See Also

Reference

WBLogger Class
Log Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Medium Method

WBLoggerMedium Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | Medium(String) | Logs the specified message as the Medium level.
Public method | Medium(String, Object) | Logs the specified message as the Medium level. Parameters are added to the message.
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger.Medium Method (String)

WBLoggerMedium Method (String) Datapolis Process System Class Reference
Logs the specified message as the Medium level.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Medium(
    string message
)
Public Sub Medium (
    message As String
)
public:
void Medium(
    String^ message
)
member Medium :
        message : string -> unit

Parameters

message
Type: SystemString
The message.
See Also

Reference

WBLogger Class
Medium Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Medium Method (String, Object[])

WBLoggerMedium Method (String, Object) Datapolis Process System Class Reference
Logs the specified message as the Medium level. Parameters are added to the message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Medium(
    string message,
    params Object[] parameters
)
Public Sub Medium (
    message As String,
    ParamArray parameters As Object()
)
public:
void Medium(
    String^ message,
    ... array<Object^>^ parameters
)
member Medium :
        message : string *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
Medium Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Monitorable Method

WBLoggerMonitorable Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | Monitorable(String) | Logs the specified message as the Monitorable level.
Public method | Monitorable(String, Object) | Logs the specified message as the Monitorable level. Parameters are added to the message.
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger.Monitorable Method (String)

WBLoggerMonitorable Method (String) Datapolis Process System Class Reference
Logs the specified message as the Monitorable level.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Monitorable(
    string message
)
Public Sub Monitorable (
    message As String
)
public:
void Monitorable(
    String^ message
)
member Monitorable :
        message : string -> unit

Parameters

message
Type: SystemString
The message.
See Also

Reference

WBLogger Class
Monitorable Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Monitorable Method (String, Object[])

WBLoggerMonitorable Method (String, Object) Datapolis Process System Class Reference
Logs the specified message as the Monitorable level. Parameters are added to the message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Monitorable(
    string message,
    params Object[] parameters
)
Public Sub Monitorable (
    message As String,
    ParamArray parameters As Object()
)
public:
void Monitorable(
    String^ message,
    ... array<Object^>^ parameters
)
member Monitorable :
        message : string *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
Monitorable Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Unexpected Method

WBLoggerUnexpected Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | Unexpected(String) | Logs the specified message as the Unexpected level.
Public method | Unexpected(String, Exception) | Logs the specified message as the Unexpected level. The following expetion properties: Message, StackTrace and Source are added to the log message.
Public method | Unexpected(String, Object) | Logs the specified message as the Unexpected level. Parameters are added to the message.
Public method | Unexpected(String, Exception, Object) | Logs the specified message as the Unexpected level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger.Unexpected Method (String)

WBLoggerUnexpected Method (String) Datapolis Process System Class Reference
Logs the specified message as the Unexpected level.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Unexpected(
    string message
)
Public Sub Unexpected (
    message As String
)
public:
void Unexpected(
    String^ message
)
member Unexpected :
        message : string -> unit

Parameters

message
Type: SystemString
The message.
See Also

Reference

WBLogger Class
Unexpected Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Unexpected Method (String, Exception)

WBLoggerUnexpected Method (String, Exception) Datapolis Process System Class Reference
Logs the specified message as the Unexpected level. The following expetion properties: Message, StackTrace and Source are added to the log message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Unexpected(
    string message,
    Exception exception
)
Public Sub Unexpected (
    message As String,
    exception As Exception
)
public:
void Unexpected(
    String^ message,
    Exception^ exception
)
member Unexpected :
        message : string *
        exception : Exception -> unit

Parameters

message
Type: SystemString
The message.
exception
Type: SystemException
The exception.
See Also

Reference

WBLogger Class
Unexpected Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Unexpected Method (String, Object[])

WBLoggerUnexpected Method (String, Object) Datapolis Process System Class Reference
Logs the specified message as the Unexpected level. Parameters are added to the message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Unexpected(
    string message,
    params Object[] parameters
)
Public Sub Unexpected (
    message As String,
    ParamArray parameters As Object()
)
public:
void Unexpected(
    String^ message,
    ... array<Object^>^ parameters
)
member Unexpected :
        message : string *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
Unexpected Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Unexpected Method (String, Exception, Object[])

WBLoggerUnexpected Method (String, Exception, Object) Datapolis Process System Class Reference
Logs the specified message as the Unexpected level. The both expetion properties (Message, StackTrace and Source) and parameters are added to the log message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Unexpected(
    string message,
    Exception exception,
    params Object[] parameters
)
Public Sub Unexpected (
    message As String,
    exception As Exception,
    ParamArray parameters As Object()
)
public:
void Unexpected(
    String^ message,
    Exception^ exception,
    ... array<Object^>^ parameters
)
member Unexpected :
        message : string *
        exception : Exception *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
exception
Type: SystemException
The exception.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
Unexpected Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Verbose Method

WBLoggerVerbose Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | Verbose(String) | Logs the specified message as the Verbose level.
Public method | Verbose(String, Object) | Logs the specified message as the Verbose level. Parameters are added to the message.
Top
See Also

Reference

WBLogger Class
Datapolis.WorkBox.Common Namespace


WBLogger.Verbose Method (String)

WBLoggerVerbose Method (String) Datapolis Process System Class Reference
Logs the specified message as the Verbose level.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Verbose(
    string message
)
Public Sub Verbose (
    message As String
)
public:
void Verbose(
    String^ message
)
member Verbose :
        message : string -> unit

Parameters

message
Type: SystemString
The message.
See Also

Reference

WBLogger Class
Verbose Overload
Datapolis.WorkBox.Common Namespace


WBLogger.Verbose Method (String, Object[])

WBLoggerVerbose Method (String, Object) Datapolis Process System Class Reference
Logs the specified message as the Verbose level. Parameters are added to the message.

Namespace: Datapolis.WorkBox.Common
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Verbose(
    string message,
    params Object[] parameters
)
Public Sub Verbose (
    message As String,
    ParamArray parameters As Object()
)
public:
void Verbose(
    String^ message,
    ... array<Object^>^ parameters
)
member Verbose :
        message : string *
        parameters : Object[] -> unit

Parameters

message
Type: SystemString
The message.
parameters
Type: SystemObject
The parameters.
See Also

Reference

WBLogger Class
Verbose Overload
Datapolis.WorkBox.Common Namespace


Datapolis.WorkBox.Common.PowerShell Namespace

Datapolis.WorkBox.Common.PowerShell Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | Configuration |


Configuration Class

Configuration Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.PowerShellConfiguration

Namespace: Datapolis.WorkBox.Common.PowerShell
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class Configuration
Public Class Configuration
public ref class Configuration
type Configuration =  class end

The Configuration type exposes the following members.

Constructors
 | Name | Description
Public method | Configuration | Initializes a new instance of the Configuration class
Top
Methods
Name | Description
SetAllowCloseActionFormTimeout |
SetDatapolisDatabaseOperationsRetryLimit |
SetDefaultActionFormCss |
SetSubstitutionsAllowedPrincipals |
SetUserMembershipDataResolvingMethod |
Top
See Also

Reference

Datapolis.WorkBox.Common.PowerShell Namespace


Configuration Constructor

Configuration Constructor Datapolis Process System Class Reference
Initializes a new instance of the Configuration class

Namespace: Datapolis.WorkBox.Common.PowerShell
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Configuration()
Public Sub New
public:
Configuration()
new : unit -> Configuration
See Also

Reference

Configuration Class
Datapolis.WorkBox.Common.PowerShell Namespace


Configuration Methods

Configuration Methods Datapolis Process System Class Reference

The Configuration type exposes the following members.

Methods
Name | Description
SetAllowCloseActionFormTimeout |
SetDatapolisDatabaseOperationsRetryLimit |
SetDefaultActionFormCss |
SetSubstitutionsAllowedPrincipals |
SetUserMembershipDataResolvingMethod |
Top
See Also

Reference

Configuration Class
Datapolis.WorkBox.Common.PowerShell Namespace


Configuration.SetAllowCloseActionFormTimeout Method

ConfigurationSetAllowCloseActionFormTimeout Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.PowerShell
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static string SetAllowCloseActionFormTimeout(
    int milliseconds
)
Public Shared Function SetAllowCloseActionFormTimeout (
    milliseconds As Integer
) As String
public:
static String^ SetAllowCloseActionFormTimeout(
    int milliseconds
)
static member SetAllowCloseActionFormTimeout :
        milliseconds : int -> string

Parameters

milliseconds
Type: SystemInt32

Return Value

Type: String
See Also

Reference

Configuration Class
Datapolis.WorkBox.Common.PowerShell Namespace


Configuration.SetDatapolisDatabaseOperationsRetryLimit Method

ConfigurationSetDatapolisDatabaseOperationsRetryLimit Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.PowerShell
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static string SetDatapolisDatabaseOperationsRetryLimit(
    uint limit
)
Public Shared Function SetDatapolisDatabaseOperationsRetryLimit (
    limit As UInteger
) As String
public:
static String^ SetDatapolisDatabaseOperationsRetryLimit(
    unsigned int limit
)
static member SetDatapolisDatabaseOperationsRetryLimit :
        limit : uint32 -> string

Parameters

limit
Type: SystemUInt32

Return Value

Type: String
See Also

Reference

Configuration Class
Datapolis.WorkBox.Common.PowerShell Namespace


Configuration.SetDefaultActionFormCss Method

ConfigurationSetDefaultActionFormCss Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.PowerShell
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static string SetDefaultActionFormCss(
    SPWeb web,
    string cssFilePath
)
Public Shared Function SetDefaultActionFormCss (
    web As SPWeb,
    cssFilePath As String
) As String
public:
static String^ SetDefaultActionFormCss(
    SPWeb^ web,
    String^ cssFilePath
)
static member SetDefaultActionFormCss :
        web : SPWeb *
        cssFilePath : string -> string

Parameters

web
Type: SPWeb
cssFilePath
Type: SystemString

Return Value

Type: String
See Also

Reference

Configuration Class
Datapolis.WorkBox.Common.PowerShell Namespace


Configuration.SetSubstitutionsAllowedPrincipals Method

ConfigurationSetSubstitutionsAllowedPrincipals Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.PowerShell
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static string SetSubstitutionsAllowedPrincipals(
    WBPrincipalType allowedPrincipalTypes
)
Public Shared Function SetSubstitutionsAllowedPrincipals (
    allowedPrincipalTypes As WBPrincipalType
) As String
public:
static String^ SetSubstitutionsAllowedPrincipals(
    WBPrincipalType allowedPrincipalTypes
)
static member SetSubstitutionsAllowedPrincipals :
        allowedPrincipalTypes : WBPrincipalType -> string

Parameters

allowedPrincipalTypes
Type: WBPrincipalType

Return Value

Type: String
See Also

Reference

Configuration Class
Datapolis.WorkBox.Common.PowerShell Namespace


Configuration.SetUserMembershipDataResolvingMethod Method

ConfigurationSetUserMembershipDataResolvingMethod Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.PowerShell
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static string SetUserMembershipDataResolvingMethod(
    WBUserMembershipDataResolvingMethod options
)
Public Shared Function SetUserMembershipDataResolvingMethod (
    options As WBUserMembershipDataResolvingMethod
) As String
public:
static String^ SetUserMembershipDataResolvingMethod(
    WBUserMembershipDataResolvingMethod options
)
static member SetUserMembershipDataResolvingMethod :
        options : WBUserMembershipDataResolvingMethod -> string

Parameters

options
Type: WBUserMembershipDataResolvingMethod

Return Value

Type: String
See Also

Reference

Configuration Class
Datapolis.WorkBox.Common.PowerShell Namespace


Datapolis.WorkBox.Common.Solutions Namespace

Datapolis.WorkBox.Common.Solutions Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBApplication | Base class for applications. Defines input and output parameters that are passed to the WBApplicationInstance
Public class | WBApplicationCollection | Collection of WBApplication objects
Public class | WBApplicationInstance | Datapolis application instance. Object of this class holds values of input/output parameters passed defined by the Datapolis application.
Public class | WBApplicationInstanceCollection | Collection of application instances
Public class | WBApplicationInstanceParameter | Objects of this class represent input/output parameters of Datapolis application instance
Public class | WBApplicationInstanceParameterCollection | Collection of application instance parameters
Public class | WBApplicationInstanceState |
Public class | WBApplicationManager | This class is used to start and finish Datapolis applications
Public class | WBApplicationParameter | Objects of this class represent input/output parameters that are accpeted/returned by an application
Public class | WBApplicationParameterCollection | Collection of WBApplicationParameter objects
Public class | WBApplicationTemplate | Template of Datapolis application. Defines how the application is deployed, removed, upgraded and by which classes it is implemented.
Public class | WBApplicationTemplateDeploymentControl | UserControl used for Datapolis application deployment. Override this class if your application has some information that needs to be displayed/modified before application deployment. This control is displayed in Datapolis solution deployment page (in Central Administration)
Public class | WBJobDeploymentControl | Use this class to create a custom cotrol for job deployment in Datapolis System Settings page
Public class | WBSolution | Base class for solutions. Represents solution that is existing object and may contain applications that can be started.
Public class | WBSolutionCollection | Collection of WBSolution objects
Public class | WBSolutionCustomParam | Data object for Custom Paramter of Solution.
Public class | WBSolutionManager | Use this class to load and manage solutions.
Public class | WBSolutionObject | Object that belongs to a Datapolis solution
Public class | WBSolutionObjectCollection |
Public class | WBSolutionTemplate | Template of Datapolis solution. Defines how the application is deployed, removed, upgraded and by which classes it is implemented.
Public class | WBSolutionTemplateDeploymentControl | Deoployment control of a Datapolis solution. Inherit from this class if you want to add some additonal controls in solution deployment page in Central Administration in Datapolis settings.
Public class | WBSolutionTemplateObject | Objects that belong to the solution template, e.g. workflows in web solution
Public class | WBSolutionTemplateObjectCollection | Collection of objects belonging to the solution template
Public class | WBWebSolution | Implementation of WBSolution class. Solution of this type adds a site to a specified site collection and applies a web template.
Public class | WBWebSolutionTemplate | Template of a web solution. It allows for adding a new site with sepcified template. Solutions of this type can be deployed together with workflows and applications.
Public class | WBWorkflowApplication | This is workflow based Datapolis application.
Public class | WBWorkflowApplicationInstance | Instance of a workflow application, represents a Datapolis workflow instance. Workflow application instance can be started and terminated, it is finished by a workflow.
Public class | WBWorkflowApplicationTemplate | Template for workflow applications based on Datapolis workflows. It is used in combination with web solution. It assumes that files used by Datapolis designer are available in WorkBoxWorkflows folder
Public class | WBWorkflowDefaultSolution | Default solution to wich all the workflows are added (e.g. when there is "workflows only" license). All workflows created before "Datapolis Process System" belong to this solution.
Public class | WBWorkflowSolutionTemplate |
Public class | WBXmlParserException | Exception thrown during templates XML parsing
Enumerations
 | Enumeration | Description
Public enumeration | WBApplicationInstanceStatus | Status of WBApplicationInstance New - new instance Starting - instance is starting InProgress - instance is running Finished - instance has finished Terminated - instance is terminated
Public enumeration | WBApplicationStatus | Status of WBApplication Error - some error occured, e.g. during deployment Deployin - application is being deployed Normal - application is deployed and ready to use Removed - application is removed
Public enumeration | WBSolutionScope | Scope of a WBSolution. Generally solutions have farm scope
Public enumeration | WBSolutionStatus | WBSolution statuses: Scheduled - solution will be deployed by a timer job Deploying - solution is being deployed Deployed - solution was successfully deployed DeployingApps - solution applications are being deployed Faulted - an error occured while solution deployment Removed - solution was removed
Public enumeration | WBSolutionTemplateObjectType | Solution template object types
Public enumeration | WBSolutionType | Type of a WBSolution.


WBApplication Class

WBApplication Class Datapolis Process System Class Reference
Base class for applications. Defines input and output parameters that are passed to the WBApplicationInstance
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplication
Datapolis.WorkBox.Common.SolutionsWBWorkflowApplication

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBApplication
Public MustInherit Class WBApplication
public ref class WBApplication abstract
[<AbstractClassAttribute>]
type WBApplication =  class end

The WBApplication type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplication | Constructor of WBApplication
Top
Properties
 | Name | Description
Public property | ApplicationId | Unique application ID
Public property | ApplicationInstanceAssembly | Full name of assembly where the the application instance class is located
Public property | ApplicationInstanceType | Full name of the application instance class type
Public property | ApplicationStatus | Actual status of the application
Public property | Configuration | Stores custom coniguration for this application. E.g. if the configuration is some text, then you can parse in OnLoad and later set it in OnSave
Public property | Description | Description of the application
Public property | Id | Id of application record in database
Public property | IsPrivate | True if the applicationcan be used only in parent WBSolution
Public property | ParametersIn | List of applciation input parameters
Public property | ParametersOut | List of applcation output parameters
Public property | SolutionId | ID of the parent solution to which the application belongs
Public property | TemplateXml | Teamplate XML of the parent WBApplicationTemplate
Public property | Title | Title of the application
Top
Methods
 | Name | Description
 | GetApplicationsBySolutionId | Returns a collection of applications that belong to a specified solution
Public method | OnLoad | Executed after the application is loaded from the database. Can be used to parse Configuration (e.g. parse text and initialize some fields)
Public method | OnSave | Executed before the application is saved to database. Can be used to update Configuration (e.g. parsed text, XML)
Public method | OnUpgrade | Upgrades application to the latest version
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplication Constructor

WBApplication Constructor Datapolis Process System Class Reference
Constructor of WBApplication

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplication()
Public Sub New
public:
WBApplication()
new : unit -> WBApplication
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication Properties

WBApplication Properties Datapolis Process System Class Reference

The WBApplication type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationId | Unique application ID
Public property | ApplicationInstanceAssembly | Full name of assembly where the the application instance class is located
Public property | ApplicationInstanceType | Full name of the application instance class type
Public property | ApplicationStatus | Actual status of the application
Public property | Configuration | Stores custom coniguration for this application. E.g. if the configuration is some text, then you can parse in OnLoad and later set it in OnSave
Public property | Description | Description of the application
Public property | Id | Id of application record in database
Public property | IsPrivate | True if the applicationcan be used only in parent WBSolution
Public property | ParametersIn | List of applciation input parameters
Public property | ParametersOut | List of applcation output parameters
Public property | SolutionId | ID of the parent solution to which the application belongs
Public property | TemplateXml | Teamplate XML of the parent WBApplicationTemplate
Public property | Title | Title of the application
Top
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.ApplicationId Property

WBApplicationApplicationId Property Datapolis Process System Class Reference
Unique application ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ApplicationId { get; }
Public ReadOnly Property ApplicationId As Guid
    Get
public:
property Guid ApplicationId {
    Guid get ();
}
member ApplicationId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.ApplicationInstanceAssembly Property

WBApplicationApplicationInstanceAssembly Property Datapolis Process System Class Reference
Full name of assembly where the the application instance class is located

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string ApplicationInstanceAssembly { get; }
Public ReadOnly Property ApplicationInstanceAssembly As String
    Get
public:
property String^ ApplicationInstanceAssembly {
    String^ get ();
}
member ApplicationInstanceAssembly : string with get

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.ApplicationInstanceType Property

WBApplicationApplicationInstanceType Property Datapolis Process System Class Reference
Full name of the application instance class type

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string ApplicationInstanceType { get; }
Public ReadOnly Property ApplicationInstanceType As String
    Get
public:
property String^ ApplicationInstanceType {
    String^ get ();
}
member ApplicationInstanceType : string with get

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.ApplicationStatus Property

WBApplicationApplicationStatus Property Datapolis Process System Class Reference
Actual status of the application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationStatus ApplicationStatus { get; }
Public ReadOnly Property ApplicationStatus As WBApplicationStatus
    Get
public:
property WBApplicationStatus ApplicationStatus {
    WBApplicationStatus get ();
}
member ApplicationStatus : WBApplicationStatus with get

Property Value

Type: WBApplicationStatus
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.Configuration Property

WBApplicationConfiguration Property Datapolis Process System Class Reference
Stores custom coniguration for this application. E.g. if the configuration is some text, then you can parse in OnLoad and later set it in OnSave

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Configuration { get; set; }
Public Property Configuration As String
    Get
    Set
public:
property String^ Configuration {
    String^ get ();
    void set (String^ value);
}
member Configuration : string with get, set

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.Description Property

WBApplicationDescription Property Datapolis Process System Class Reference
Description of the application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.Id Property

WBApplicationId Property Datapolis Process System Class Reference
Id of application record in database

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Type: Int32
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.IsPrivate Property

WBApplicationIsPrivate Property Datapolis Process System Class Reference
True if the applicationcan be used only in parent WBSolution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsPrivate { get; set; }
Public Property IsPrivate As Boolean
    Get
    Set
public:
property bool IsPrivate {
    bool get ();
    void set (bool value);
}
member IsPrivate : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.ParametersIn Property

WBApplicationParametersIn Property Datapolis Process System Class Reference
List of applciation input parameters

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameterCollection ParametersIn { get; }
Public ReadOnly Property ParametersIn As WBApplicationParameterCollection
    Get
public:
property WBApplicationParameterCollection^ ParametersIn {
    WBApplicationParameterCollection^ get ();
}
member ParametersIn : WBApplicationParameterCollection with get

Property Value

Type: WBApplicationParameterCollection
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.ParametersOut Property

WBApplicationParametersOut Property Datapolis Process System Class Reference
List of applcation output parameters

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameterCollection ParametersOut { get; }
Public ReadOnly Property ParametersOut As WBApplicationParameterCollection
    Get
public:
property WBApplicationParameterCollection^ ParametersOut {
    WBApplicationParameterCollection^ get ();
}
member ParametersOut : WBApplicationParameterCollection with get

Property Value

Type: WBApplicationParameterCollection
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.SolutionId Property

WBApplicationSolutionId Property Datapolis Process System Class Reference
ID of the parent solution to which the application belongs

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid SolutionId { get; set; }
Public Property SolutionId As Guid
    Get
    Set
public:
property Guid SolutionId {
    Guid get ();
    void set (Guid value);
}
member SolutionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.TemplateXml Property

WBApplicationTemplateXml Property Datapolis Process System Class Reference
Teamplate XML of the parent WBApplicationTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string TemplateXml { get; set; }
Public Property TemplateXml As String
    Get
    Set
public:
property String^ TemplateXml {
    String^ get ();
    void set (String^ value);
}
member TemplateXml : string with get, set

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.Title Property

WBApplicationTitle Property Datapolis Process System Class Reference
Title of the application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication Methods

WBApplication Methods Datapolis Process System Class Reference

The WBApplication type exposes the following members.

Methods
 | Name | Description
 | GetApplicationsBySolutionId | Returns a collection of applications that belong to a specified solution
Public method | OnLoad | Executed after the application is loaded from the database. Can be used to parse Configuration (e.g. parse text and initialize some fields)
Public method | OnSave | Executed before the application is saved to database. Can be used to update Configuration (e.g. parsed text, XML)
Public method | OnUpgrade | Upgrades application to the latest version
Top
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.GetApplicationsBySolutionId Method

WBApplicationGetApplicationsBySolutionId Method Datapolis Process System Class Reference
Returns a collection of applications that belong to a specified solution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBApplicationCollection GetApplicationsBySolutionId(
    Guid solutionId
)
Public Shared Function GetApplicationsBySolutionId (
    solutionId As Guid
) As WBApplicationCollection
public:
static WBApplicationCollection^ GetApplicationsBySolutionId(
    Guid solutionId
)
static member GetApplicationsBySolutionId :
        solutionId : Guid -> WBApplicationCollection

Parameters

solutionId
Type: SystemGuid
Solution unique ID

Return Value

Type: WBApplicationCollection
WBApplicationCollection
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.OnLoad Method

WBApplicationOnLoad Method Datapolis Process System Class Reference
Executed after the application is loaded from the database. Can be used to parse Configuration (e.g. parse text and initialize some fields)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnLoad()
Public Overridable Sub OnLoad
public:
virtual void OnLoad()
abstract OnLoad : unit -> unit
override OnLoad : unit -> unit
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.OnSave Method

WBApplicationOnSave Method Datapolis Process System Class Reference
Executed before the application is saved to database. Can be used to update Configuration (e.g. parsed text, XML)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSave()
Public Overridable Sub OnSave
public:
virtual void OnSave()
abstract OnSave : unit -> unit
override OnSave : unit -> unit
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplication.OnUpgrade Method

WBApplicationOnUpgrade Method Datapolis Process System Class Reference
Upgrades application to the latest version

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnUpgrade()
Public Overridable Sub OnUpgrade
public:
virtual void OnUpgrade()
abstract OnUpgrade : unit -> unit
override OnUpgrade : unit -> unit
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationCollection Class

WBApplicationCollection Class Datapolis Process System Class Reference
Collection of WBApplication objects
Inheritance Hierarchy
SystemObject
WBListWBApplication
Datapolis.WorkBox.Common.SolutionsWBApplicationCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBApplicationCollection : WBList<WBApplication>
Public NotInheritable Class WBApplicationCollection
    Inherits WBList(Of WBApplication)
public ref class WBApplicationCollection sealed : public WBList<WBApplication^>
[<SealedAttribute>]
type WBApplicationCollection =
    class
        inherit WBList<WBApplication>
    end

The WBApplicationCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationCollection | Initializes a new instance of the WBApplicationCollection class
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationCollection Constructor

WBApplicationCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationCollection class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationCollection()
Public Sub New
public:
WBApplicationCollection()
new : unit -> WBApplicationCollection
See Also

Reference

WBApplicationCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance Class

WBApplicationInstance Class Datapolis Process System Class Reference
Datapolis application instance. Object of this class holds values of input/output parameters passed defined by the Datapolis application.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationInstance
Datapolis.WorkBox.Common.SolutionsWBWorkflowApplicationInstance

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBApplicationInstance
Public MustInherit Class WBApplicationInstance
public ref class WBApplicationInstance abstract
[<AbstractClassAttribute>]
type WBApplicationInstance =  class end

The WBApplicationInstance type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInstance | Default contructor of WBApplicationInstance
Top
Properties
 | Name | Description
Public property | ApplicationInstanceContent | Content (configuration) of the application instance in form of XML
Public property | ApplicationInstanceId | Unique identifier
Public property | Id | Identifier in the Datapolis database
Public property | InitiatorSiteId | ID of SPSite where the instance was started
Public property | InitiatorWebApplicationId | ID of SPWebApplication where the instance was started
Public property | InitiatorWebId | ID of SPWeb where the instance was started
Public property | InitiatorWorkflowInstanceId | ID of the workflow instance that started the application
Public property | ParentApplication | Parent object of type WBApplication
Public property | ParentApplicationInstanceId | Unique identifier of the parent instance
Public property | Status | Status of the application instance
Public property | Url | Url always must be absolute address.
Top
Methods
 | Name | Description
Public method | OnLoad | This metod is called after the instance is loaded from the database. Override this method to do some operation after the instance is loaded from the databe, e.g. parse configuration
Public method | OnSave | This method is called before update. Override this method to do some operations before the instance is saved to the database, e.g. parse configuration
Public method | Start | Starts the instance using the provided input parameters
Public method | Terminate | Terminates the instance
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance Constructor

WBApplicationInstance Constructor Datapolis Process System Class Reference
Default contructor of WBApplicationInstance

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstance()
Public Sub New
public:
WBApplicationInstance()
new : unit -> WBApplicationInstance
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance Properties

WBApplicationInstance Properties Datapolis Process System Class Reference

The WBApplicationInstance type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationInstanceContent | Content (configuration) of the application instance in form of XML
Public property | ApplicationInstanceId | Unique identifier
Public property | Id | Identifier in the Datapolis database
Public property | InitiatorSiteId | ID of SPSite where the instance was started
Public property | InitiatorWebApplicationId | ID of SPWebApplication where the instance was started
Public property | InitiatorWebId | ID of SPWeb where the instance was started
Public property | InitiatorWorkflowInstanceId | ID of the workflow instance that started the application
Public property | ParentApplication | Parent object of type WBApplication
Public property | ParentApplicationInstanceId | Unique identifier of the parent instance
Public property | Status | Status of the application instance
Public property | Url | Url always must be absolute address.
Top
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.ApplicationInstanceContent Property

WBApplicationInstanceApplicationInstanceContent Property Datapolis Process System Class Reference
Content (configuration) of the application instance in form of XML

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string ApplicationInstanceContent { get; set; }
Public Property ApplicationInstanceContent As String
    Get
    Set
public:
property String^ ApplicationInstanceContent {
    String^ get ();
    void set (String^ value);
}
member ApplicationInstanceContent : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.ApplicationInstanceId Property

WBApplicationInstanceApplicationInstanceId Property Datapolis Process System Class Reference
Unique identifier

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ApplicationInstanceId { get; }
Public ReadOnly Property ApplicationInstanceId As Guid
    Get
public:
property Guid ApplicationInstanceId {
    Guid get ();
}
member ApplicationInstanceId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.Id Property

WBApplicationInstanceId Property Datapolis Process System Class Reference
Identifier in the Datapolis database

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Type: Int32
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.InitiatorSiteId Property

WBApplicationInstanceInitiatorSiteId Property Datapolis Process System Class Reference
ID of SPSite where the instance was started

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid InitiatorSiteId { get; }
Public ReadOnly Property InitiatorSiteId As Guid
    Get
public:
property Guid InitiatorSiteId {
    Guid get ();
}
member InitiatorSiteId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.InitiatorWebApplicationId Property

WBApplicationInstanceInitiatorWebApplicationId Property Datapolis Process System Class Reference
ID of SPWebApplication where the instance was started

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid InitiatorWebApplicationId { get; }
Public ReadOnly Property InitiatorWebApplicationId As Guid
    Get
public:
property Guid InitiatorWebApplicationId {
    Guid get ();
}
member InitiatorWebApplicationId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.InitiatorWebId Property

WBApplicationInstanceInitiatorWebId Property Datapolis Process System Class Reference
ID of SPWeb where the instance was started

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid InitiatorWebId { get; }
Public ReadOnly Property InitiatorWebId As Guid
    Get
public:
property Guid InitiatorWebId {
    Guid get ();
}
member InitiatorWebId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.InitiatorWorkflowInstanceId Property

WBApplicationInstanceInitiatorWorkflowInstanceId Property Datapolis Process System Class Reference
ID of the workflow instance that started the application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid InitiatorWorkflowInstanceId { get; }
Public ReadOnly Property InitiatorWorkflowInstanceId As Guid
    Get
public:
property Guid InitiatorWorkflowInstanceId {
    Guid get ();
}
member InitiatorWorkflowInstanceId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.ParentApplication Property

WBApplicationInstanceParentApplication Property Datapolis Process System Class Reference
Parent object of type WBApplication

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplication ParentApplication { get; }
Public ReadOnly Property ParentApplication As WBApplication
    Get
public:
property WBApplication^ ParentApplication {
    WBApplication^ get ();
}
member ParentApplication : WBApplication with get

Property Value

Type: WBApplication
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.ParentApplicationInstanceId Property

WBApplicationInstanceParentApplicationInstanceId Property Datapolis Process System Class Reference
Unique identifier of the parent instance

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ParentApplicationInstanceId { get; }
Public ReadOnly Property ParentApplicationInstanceId As Guid
    Get
public:
property Guid ParentApplicationInstanceId {
    Guid get ();
}
member ParentApplicationInstanceId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.Status Property

WBApplicationInstanceStatus Property Datapolis Process System Class Reference
Status of the application instance

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceStatus Status { get; set; }
Public Property Status As WBApplicationInstanceStatus
    Get
    Set
public:
property WBApplicationInstanceStatus Status {
    WBApplicationInstanceStatus get ();
    void set (WBApplicationInstanceStatus value);
}
member Status : WBApplicationInstanceStatus with get, set

Property Value

Type: WBApplicationInstanceStatus
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.Url Property

WBApplicationInstanceUrl Property Datapolis Process System Class Reference
Url always must be absolute address.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
member Url : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance Methods

WBApplicationInstance Methods Datapolis Process System Class Reference

The WBApplicationInstance type exposes the following members.

Methods
 | Name | Description
Public method | OnLoad | This metod is called after the instance is loaded from the database. Override this method to do some operation after the instance is loaded from the databe, e.g. parse configuration
Public method | OnSave | This method is called before update. Override this method to do some operations before the instance is saved to the database, e.g. parse configuration
Public method | Start | Starts the instance using the provided input parameters
Public method | Terminate | Terminates the instance
Top
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.OnLoad Method

WBApplicationInstanceOnLoad Method Datapolis Process System Class Reference
This metod is called after the instance is loaded from the database. Override this method to do some operation after the instance is loaded from the databe, e.g. parse configuration

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnLoad()
Public Overridable Sub OnLoad
public:
virtual void OnLoad()
abstract OnLoad : unit -> unit
override OnLoad : unit -> unit
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.OnSave Method

WBApplicationInstanceOnSave Method Datapolis Process System Class Reference
This method is called before update. Override this method to do some operations before the instance is saved to the database, e.g. parse configuration

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSave()
Public Overridable Sub OnSave
public:
virtual void OnSave()
abstract OnSave : unit -> unit
override OnSave : unit -> unit
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.Start Method

WBApplicationInstanceStart Method Datapolis Process System Class Reference
Starts the instance using the provided input parameters

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void Start(
    WBApplicationInstanceParameterCollection parametersIn
)
Public MustOverride Sub Start (
    parametersIn As WBApplicationInstanceParameterCollection
)
public:
virtual void Start(
    WBApplicationInstanceParameterCollection^ parametersIn
) abstract
abstract Start :
        parametersIn : WBApplicationInstanceParameterCollection -> unit

Parameters

parametersIn
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceParameterCollection
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstance.Terminate Method

WBApplicationInstanceTerminate Method Datapolis Process System Class Reference
Terminates the instance

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void Terminate()
Public MustOverride Sub Terminate
public:
virtual void Terminate() abstract
abstract Terminate : unit -> unit
See Also

Reference

WBApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceCollection Class

WBApplicationInstanceCollection Class Datapolis Process System Class Reference
Collection of application instances
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBApplicationInstance
Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationInstanceCollection : List<WBApplicationInstance>
Public Class WBApplicationInstanceCollection
    Inherits List(Of WBApplicationInstance)
public ref class WBApplicationInstanceCollection : public List<WBApplicationInstance^>
type WBApplicationInstanceCollection =
    class
        inherit List<WBApplicationInstance>
    end

The WBApplicationInstanceCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInstanceCollection | Initializes a new instance of the WBApplicationInstanceCollection class
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceCollection Constructor

WBApplicationInstanceCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationInstanceCollection class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceCollection()
Public Sub New
public:
WBApplicationInstanceCollection()
new : unit -> WBApplicationInstanceCollection
See Also

Reference

WBApplicationInstanceCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameter Class

WBApplicationInstanceParameter Class Datapolis Process System Class Reference
Objects of this class represent input/output parameters of Datapolis application instance
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceParameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationInstanceParameter
Public Class WBApplicationInstanceParameter
public ref class WBApplicationInstanceParameter
type WBApplicationInstanceParameter =  class end

The WBApplicationInstanceParameter type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInstanceParameter | Constructor
Top
Properties
 | Name | Description
Public property | DisplayName | Display name of the parameter (can be resource like $Resources:SomeFile,keyName )
Public property | Name | Name of application parameter
Public property | Value | value of the parameter
Public property | VariableType |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameter Constructor

WBApplicationInstanceParameter Constructor Datapolis Process System Class Reference
Constructor

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceParameter(
    string name,
    string value,
    string displayName,
    WBVariableType variableType
)
Public Sub New (
    name As String,
    value As String,
    displayName As String,
    variableType As WBVariableType
)
public:
WBApplicationInstanceParameter(
    String^ name,
    String^ value,
    String^ displayName,
    WBVariableType variableType
)
new :
        name : string *
        value : string *
        displayName : string *
        variableType : WBVariableType -> WBApplicationInstanceParameter

Parameters

name
Type: SystemString
Parameter name
value
Type: SystemString
Parameter value
displayName
Type: SystemString
Parameter display name
variableType
Type: Datapolis.WorkBox.UtilitiesWBVariableType
See Also

Reference

WBApplicationInstanceParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameter Properties

WBApplicationInstanceParameter Properties Datapolis Process System Class Reference

The WBApplicationInstanceParameter type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | Display name of the parameter (can be resource like $Resources:SomeFile,keyName )
Public property | Name | Name of application parameter
Public property | Value | value of the parameter
Public property | VariableType |
Top
See Also

Reference

WBApplicationInstanceParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameter.DisplayName Property

WBApplicationInstanceParameterDisplayName Property Datapolis Process System Class Reference
Display name of the parameter (can be resource like $Resources:SomeFile,keyName )

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}
member DisplayName : string with get

Property Value

Type: String
See Also

Reference

WBApplicationInstanceParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameter.Name Property

WBApplicationInstanceParameterName Property Datapolis Process System Class Reference
Name of application parameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

WBApplicationInstanceParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameter.Value Property

WBApplicationInstanceParameterValue Property Datapolis Process System Class Reference
value of the parameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameter.VariableType Property

WBApplicationInstanceParameterVariableType Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBVariableType VariableType { get; }
Public ReadOnly Property VariableType As WBVariableType
    Get
public:
property WBVariableType VariableType {
    WBVariableType get ();
}
member VariableType : WBVariableType with get

Property Value

Type: WBVariableType
See Also

Reference

WBApplicationInstanceParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameterCollection Class

WBApplicationInstanceParameterCollection Class Datapolis Process System Class Reference
Collection of application instance parameters
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBApplicationInstanceParameter
Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceParameterCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationInstanceParameterCollection : List<WBApplicationInstanceParameter>
Public Class WBApplicationInstanceParameterCollection
    Inherits List(Of WBApplicationInstanceParameter)
public ref class WBApplicationInstanceParameterCollection : public List<WBApplicationInstanceParameter^>
type WBApplicationInstanceParameterCollection =
    class
        inherit List<WBApplicationInstanceParameter>
    end

The WBApplicationInstanceParameterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInstanceParameterCollection | Creates new instance of Applications Instance Parameter Collection basing on Application Parameters Provide in or out application parameters and then use it to start or finish application by WBApplicationManager
Top
Properties
 | Name | Description
Public property | Item | Gets an application instance parameter by name
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameterCollection Constructor

WBApplicationInstanceParameterCollection Constructor Datapolis Process System Class Reference
Creates new instance of Applications Instance Parameter Collection basing on Application Parameters Provide in or out application parameters and then use it to start or finish application by WBApplicationManager

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceParameterCollection(
    WBApplicationParameterCollection applicationParameterCollection
)
Public Sub New (
    applicationParameterCollection As WBApplicationParameterCollection
)
public:
WBApplicationInstanceParameterCollection(
    WBApplicationParameterCollection^ applicationParameterCollection
)
new :
        applicationParameterCollection : WBApplicationParameterCollection -> WBApplicationInstanceParameterCollection

Parameters

applicationParameterCollection
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationParameterCollection
See Also

Reference

WBApplicationInstanceParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameterCollection Properties

WBApplicationInstanceParameterCollection Properties Datapolis Process System Class Reference

The WBApplicationInstanceParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets an application instance parameter by name
Top
See Also

Reference

WBApplicationInstanceParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceParameterCollection.Item Property

WBApplicationInstanceParameterCollectionItem Property Datapolis Process System Class Reference
Gets an application instance parameter by name

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceParameter this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As WBApplicationInstanceParameter
    Get
public:
property WBApplicationInstanceParameter^ default[String^ name] {
    WBApplicationInstanceParameter^ get (String^ name);
}
member Item : WBApplicationInstanceParameter with get

Parameters

name
Type: SystemString
Name of a parameter

Return Value

Type: WBApplicationInstanceParameter
See Also

Reference

WBApplicationInstanceParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceState Class

WBApplicationInstanceState Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceState

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationInstanceState
Public Class WBApplicationInstanceState
public ref class WBApplicationInstanceState
type WBApplicationInstanceState =  class end

The WBApplicationInstanceState type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInstanceState | Initializes a new instance of the WBApplicationInstanceState class
Top
Properties
 | Name | Description
Public property | Id |
Public property | ParametersOutValues |
Public property | Status |
Public property | Url |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceState Constructor

WBApplicationInstanceState Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationInstanceState class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceState()
Public Sub New
public:
WBApplicationInstanceState()
new : unit -> WBApplicationInstanceState
See Also

Reference

WBApplicationInstanceState Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceState Properties

WBApplicationInstanceState Properties Datapolis Process System Class Reference

The WBApplicationInstanceState type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | ParametersOutValues |
Public property | Status |
Public property | Url |
Top
See Also

Reference

WBApplicationInstanceState Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceState.Id Property

WBApplicationInstanceStateId Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceState Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceState.ParametersOutValues Property

WBApplicationInstanceStateParametersOutValues Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public List<WBApplicationInstanceParameter> ParametersOutValues { get; set; }
Public Property ParametersOutValues As List(Of WBApplicationInstanceParameter)
    Get
    Set
public:
property List<WBApplicationInstanceParameter^>^ ParametersOutValues {
    List<WBApplicationInstanceParameter^>^ get ();
    void set (List<WBApplicationInstanceParameter^>^ value);
}
member ParametersOutValues : List<WBApplicationInstanceParameter> with get, set

Property Value

Type: List WBApplicationInstanceParameter
See Also

Reference

WBApplicationInstanceState Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceState.Status Property

WBApplicationInstanceStateStatus Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceState Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceState.Url Property

WBApplicationInstanceStateUrl Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
member Url : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceState Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationInstanceStatus Enumeration

WBApplicationInstanceStatus Enumeration Datapolis Process System Class Reference
Status of WBApplicationInstance New - new instance Starting - instance is starting InProgress - instance is running Finished - instance has finished Terminated - instance is terminated

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBApplicationInstanceStatus
Public Enumeration WBApplicationInstanceStatus
public enum class WBApplicationInstanceStatus
type WBApplicationInstanceStatus
Members
Member name | Value | Description
New | 0 |
Starting | 1 |
InProgress | 2 |
ErrorOccured | 3 |
Finished | 4 |
Terminated | 5 |
Terminating | 6 |
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager Class

WBApplicationManager Class Datapolis Process System Class Reference
This class is used to start and finish Datapolis applications
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationManager

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationManager
Public Class WBApplicationManager
public ref class WBApplicationManager
type WBApplicationManager =  class end

The WBApplicationManager type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationManager | Initializes a new instance of the WBApplicationManager class
Top
Methods
Name | Description
ApplicationInstanceFinished(Guid, WBApplicationInstanceParameterCollection) | Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)
ApplicationInstanceFinished(Guid, WBApplicationInstanceParameterCollection, SPWeb, SPList, SPListItem, SPWorkflow, SPUser) | Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)
StartApplicationInstance | Starts new application instance (asynchronously, invoking task)
TerminateApplicationInstance | Terminates application instance before it finishes. Should be launched, by the object that has started appliction, when application instance need to be terminated (i.e. workflow started app instance and went out of state) (asynchronously, invoking task)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager Constructor

WBApplicationManager Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationManager class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationManager()
Public Sub New
public:
WBApplicationManager()
new : unit -> WBApplicationManager
See Also

Reference

WBApplicationManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager Methods

WBApplicationManager Methods Datapolis Process System Class Reference

The WBApplicationManager type exposes the following members.

Methods
Name | Description
ApplicationInstanceFinished(Guid, WBApplicationInstanceParameterCollection) | Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)
ApplicationInstanceFinished(Guid, WBApplicationInstanceParameterCollection, SPWeb, SPList, SPListItem, SPWorkflow, SPUser) | Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)
StartApplicationInstance | Starts new application instance (asynchronously, invoking task)
TerminateApplicationInstance | Terminates application instance before it finishes. Should be launched, by the object that has started appliction, when application instance need to be terminated (i.e. workflow started app instance and went out of state) (asynchronously, invoking task)
Top
See Also

Reference

WBApplicationManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager.ApplicationInstanceFinished Method

WBApplicationManagerApplicationInstanceFinished Method Datapolis Process System Class Reference
Overload List
Name | Description
ApplicationInstanceFinished(Guid, WBApplicationInstanceParameterCollection) | Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)
ApplicationInstanceFinished(Guid, WBApplicationInstanceParameterCollection, SPWeb, SPList, SPListItem, SPWorkflow, SPUser) | Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)
Top
See Also

Reference

WBApplicationManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager.ApplicationInstanceFinished Method (Guid, WBApplicationInstanceParameterCollection)

WBApplicationManagerApplicationInstanceFinished Method (Guid, WBApplicationInstanceParameterCollection) Datapolis Process System Class Reference
Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static void ApplicationInstanceFinished(
    Guid applicationInstanceId,
    WBApplicationInstanceParameterCollection parametersOut
)
Public Shared Sub ApplicationInstanceFinished (
    applicationInstanceId As Guid,
    parametersOut As WBApplicationInstanceParameterCollection
)
public:
static void ApplicationInstanceFinished(
    Guid applicationInstanceId,
    WBApplicationInstanceParameterCollection^ parametersOut
)
static member ApplicationInstanceFinished :
        applicationInstanceId : Guid *
        parametersOut : WBApplicationInstanceParameterCollection -> unit

Parameters

applicationInstanceId
Type: SystemGuid
Unique ID of application instance that was finished
parametersOut
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceParameterCollection
Collection of parameters that was returned by application instance
See Also

Reference

WBApplicationManager Class
ApplicationInstanceFinished Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager.ApplicationInstanceFinished Method (Guid, WBApplicationInstanceParameterCollection, SPWeb, SPList, SPListItem, SPWorkflow, SPUser)

WBApplicationManagerApplicationInstanceFinished Method (Guid, WBApplicationInstanceParameterCollection, SPWeb, SPList, SPListItem, SPWorkflow, SPUser) Datapolis Process System Class Reference
Launch when your application has finished. This changes status of application instance and informs object that started this application instances (mainly workflow) that it has finished. (asynchronously, invoking task)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static void ApplicationInstanceFinished(
    Guid applicationInstanceId,
    WBApplicationInstanceParameterCollection parametersOut,
    SPWeb web,
    SPList list,
    SPListItem item,
    SPWorkflow workflow,
    SPUser user
)
Public Shared Sub ApplicationInstanceFinished (
    applicationInstanceId As Guid,
    parametersOut As WBApplicationInstanceParameterCollection,
    web As SPWeb,
    list As SPList,
    item As SPListItem,
    workflow As SPWorkflow,
    user As SPUser
)
public:
static void ApplicationInstanceFinished(
    Guid applicationInstanceId,
    WBApplicationInstanceParameterCollection^ parametersOut,
    SPWeb^ web,
    SPList^ list,
    SPListItem^ item,
    SPWorkflow^ workflow,
    SPUser^ user
)
static member ApplicationInstanceFinished :
        applicationInstanceId : Guid *
        parametersOut : WBApplicationInstanceParameterCollection *
        web : SPWeb *
        list : SPList *
        item : SPListItem *
        workflow : SPWorkflow *
        user : SPUser -> unit

Parameters

applicationInstanceId
Type: SystemGuid
Unique ID of application instance that was finished
parametersOut
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceParameterCollection
Collection of parameters that was returned by application instance
web
Type: SPWeb
SPWeb object from where application instance finished event is invoked (accepts NULLs)
list
Type: SPList
SPList object from where application instance finished event is invoked (accepts NULLs)
item
Type: SPListItem
SPListItem object from where application instance finished event is invoked (accepts NULLs)
workflow
Type: SPWorkflow
SPWorkflow object from where application instance finished event is invoked (accepts NULLs)
user
Type: SPUser
SPUser object who is invoking application instance finished event (accepts NULLs)
See Also

Reference

WBApplicationManager Class
ApplicationInstanceFinished Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager.StartApplicationInstance Method

WBApplicationManagerStartApplicationInstance Method Datapolis Process System Class Reference
Starts new application instance (asynchronously, invoking task)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static Guid StartApplicationInstance(
    Guid applicationId,
    Guid parentApplicationInstanceId,
    WBApplicationInstanceParameterCollection parametersIn,
    SPWeb web,
    SPList list,
    SPListItem item,
    SPWorkflow workflow,
    SPUser user
)
Public Shared Function StartApplicationInstance (
    applicationId As Guid,
    parentApplicationInstanceId As Guid,
    parametersIn As WBApplicationInstanceParameterCollection,
    web As SPWeb,
    list As SPList,
    item As SPListItem,
    workflow As SPWorkflow,
    user As SPUser
) As Guid
public:
static Guid StartApplicationInstance(
    Guid applicationId,
    Guid parentApplicationInstanceId,
    WBApplicationInstanceParameterCollection^ parametersIn,
    SPWeb^ web,
    SPList^ list,
    SPListItem^ item,
    SPWorkflow^ workflow,
    SPUser^ user
)
static member StartApplicationInstance :
        applicationId : Guid *
        parentApplicationInstanceId : Guid *
        parametersIn : WBApplicationInstanceParameterCollection *
        web : SPWeb *
        list : SPList *
        item : SPListItem *
        workflow : SPWorkflow *
        user : SPUser -> Guid

Parameters

applicationId
Type: SystemGuid
Unique ID of Application which instance will be started
parentApplicationInstanceId
Type: SystemGuid
ID of application instance which invoked new application (this task). Is NULL when application is invoked by WB Workflow.
parametersIn
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceParameterCollection
Collection of parameters that will be provided to application instance
web
Type: SPWeb
SPWeb object from where application instance start is invoked (accepts NULLs)
list
Type: SPList
SPList object from where application instance start is invoked (accepts NULLs)
item
Type: SPListItem
SPListItem object from where application instance start is invoked (accepts NULLs)
workflow
Type: SPWorkflow
SPWorkflow object from where application instance start is invoked (accepts NULLs)
user
Type: SPUser
SPUser object who is starting application instance (accepts NULLs)

Return Value

Type: Guid
Unique ID of started application instance
See Also

Reference

WBApplicationManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationManager.TerminateApplicationInstance Method

WBApplicationManagerTerminateApplicationInstance Method Datapolis Process System Class Reference
Terminates application instance before it finishes. Should be launched, by the object that has started appliction, when application instance need to be terminated (i.e. workflow started app instance and went out of state) (asynchronously, invoking task)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static void TerminateApplicationInstance(
    Guid applicationInstanceId,
    SPWeb web,
    SPList list,
    SPListItem item,
    SPWorkflow workflow,
    SPUser user
)
Public Shared Sub TerminateApplicationInstance (
    applicationInstanceId As Guid,
    web As SPWeb,
    list As SPList,
    item As SPListItem,
    workflow As SPWorkflow,
    user As SPUser
)
public:
static void TerminateApplicationInstance(
    Guid applicationInstanceId,
    SPWeb^ web,
    SPList^ list,
    SPListItem^ item,
    SPWorkflow^ workflow,
    SPUser^ user
)
static member TerminateApplicationInstance :
        applicationInstanceId : Guid *
        web : SPWeb *
        list : SPList *
        item : SPListItem *
        workflow : SPWorkflow *
        user : SPUser -> unit

Parameters

applicationInstanceId
Type: SystemGuid
Unique ID of application instance to be terminated
web
Type: SPWeb
SPWeb object from where application instance terminate event is invoked (accepts NULLs)
list
Type: SPList
SPList object from where application instance terminate event is invoked (accepts NULLs)
item
Type: SPListItem
SPListItem object from where application instance terminate event is invoked (accepts NULLs)
workflow
Type: SPWorkflow
SPWorkflow object from where application instance terminate event is invoked (accepts NULLs)
user
Type: SPUser
SPUser object who is invoking application instance terminate event (accepts NULLs)
See Also

Reference

WBApplicationManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter Class

WBApplicationParameter Class Datapolis Process System Class Reference
Objects of this class represent input/output parameters that are accpeted/returned by an application
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationParameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationParameter
Public Class WBApplicationParameter
public ref class WBApplicationParameter
type WBApplicationParameter =  class end

The WBApplicationParameter type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationParameter(String, WBVariableType) | Contructor of WBApplicationParameter
Public method | WBApplicationParameter(String, String) | Contructor of WBApplicationParameter
Public method | WBApplicationParameter(String, WBVariableType, String) | Contructor of WBApplicationParameter
Public method | WBApplicationParameter(String, String, String) | Contructor of WBApplicationParameter
Top
Properties
 | Name | Description
Public property | DisplayName | Display name of the parameter
Public property | Name | Name of the parameter
Public property | Type | Type of the parameter
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter Constructor

WBApplicationParameter Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBApplicationParameter(String, WBVariableType) | Contructor of WBApplicationParameter
Public method | WBApplicationParameter(String, String) | Contructor of WBApplicationParameter
Public method | WBApplicationParameter(String, WBVariableType, String) | Contructor of WBApplicationParameter
Public method | WBApplicationParameter(String, String, String) | Contructor of WBApplicationParameter
Top
See Also

Reference

WBApplicationParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter Constructor (String, WBVariableType)

WBApplicationParameter Constructor (String, WBVariableType) Datapolis Process System Class Reference
Contructor of WBApplicationParameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameter(
    string name,
    WBVariableType type
)
Public Sub New (
    name As String,
    type As WBVariableType
)
public:
WBApplicationParameter(
    String^ name,
    WBVariableType type
)
new :
        name : string *
        type : WBVariableType -> WBApplicationParameter

Parameters

name
Type: SystemString
Name of the parameter
type
Type: Datapolis.WorkBox.UtilitiesWBVariableType
Type of the parameter
See Also

Reference

WBApplicationParameter Class
WBApplicationParameter Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter Constructor (String, String)

WBApplicationParameter Constructor (String, String) Datapolis Process System Class Reference
Contructor of WBApplicationParameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameter(
    string name,
    string type
)
Public Sub New (
    name As String,
    type As String
)
public:
WBApplicationParameter(
    String^ name,
    String^ type
)
new :
        name : string *
        type : string -> WBApplicationParameter

Parameters

name
Type: SystemString
Name of the parameter
type
Type: SystemString
Type of the parameter
See Also

Reference

WBApplicationParameter Class
WBApplicationParameter Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter Constructor (String, WBVariableType, String)

WBApplicationParameter Constructor (String, WBVariableType, String) Datapolis Process System Class Reference
Contructor of WBApplicationParameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameter(
    string name,
    WBVariableType type,
    string displayName
)
Public Sub New (
    name As String,
    type As WBVariableType,
    displayName As String
)
public:
WBApplicationParameter(
    String^ name,
    WBVariableType type,
    String^ displayName
)
new :
        name : string *
        type : WBVariableType *
        displayName : string -> WBApplicationParameter

Parameters

name
Type: SystemString
Name of the parameter
type
Type: Datapolis.WorkBox.UtilitiesWBVariableType
Type of the parameter
displayName
Type: SystemString
Display name of the parameter
See Also

Reference

WBApplicationParameter Class
WBApplicationParameter Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter Constructor (String, String, String)

WBApplicationParameter Constructor (String, String, String) Datapolis Process System Class Reference
Contructor of WBApplicationParameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameter(
    string name,
    string type,
    string displayName
)
Public Sub New (
    name As String,
    type As String,
    displayName As String
)
public:
WBApplicationParameter(
    String^ name,
    String^ type,
    String^ displayName
)
new :
        name : string *
        type : string *
        displayName : string -> WBApplicationParameter

Parameters

name
Type: SystemString
Name of the parameter
type
Type: SystemString
Type of the parameter
displayName
Type: SystemString
Display name of the parameter
See Also

Reference

WBApplicationParameter Class
WBApplicationParameter Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter Properties

WBApplicationParameter Properties Datapolis Process System Class Reference

The WBApplicationParameter type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | Display name of the parameter
Public property | Name | Name of the parameter
Public property | Type | Type of the parameter
Top
See Also

Reference

WBApplicationParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter.DisplayName Property

WBApplicationParameterDisplayName Property Datapolis Process System Class Reference
Display name of the parameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter.Name Property

WBApplicationParameterName Property Datapolis Process System Class Reference
Name of the parameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameter.Type Property

WBApplicationParameterType Property Datapolis Process System Class Reference
Type of the parameter

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBVariableType Type { get; set; }
Public Property Type As WBVariableType
    Get
    Set
public:
property WBVariableType Type {
    WBVariableType get ();
    void set (WBVariableType value);
}
member Type : WBVariableType with get, set

Property Value

Type: WBVariableType
See Also

Reference

WBApplicationParameter Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection Class

WBApplicationParameterCollection Class Datapolis Process System Class Reference
Collection of WBApplicationParameter objects
Inheritance Hierarchy
SystemObject
WBListWBApplicationParameter
Datapolis.WorkBox.Common.SolutionsWBApplicationParameterCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBApplicationParameterCollection : WBList<WBApplicationParameter>
Public NotInheritable Class WBApplicationParameterCollection
    Inherits WBList(Of WBApplicationParameter)
public ref class WBApplicationParameterCollection sealed : public WBList<WBApplicationParameter^>
[<SealedAttribute>]
type WBApplicationParameterCollection =
    class
        inherit WBList<WBApplicationParameter>
    end

The WBApplicationParameterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationParameterCollection | Constructor of WBApplicationParameterCollection
Public method | WBApplicationParameterCollection(String) | WBApplicationParameterCollection
Top
Properties
 | Name | Description
Public property | Item | Gets a parameter by name
Top
Methods
 | Name | Description
Public method | Add(String, WBVariableType, String) |
Public method | Add(String, String, String) |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection Constructor

WBApplicationParameterCollection Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBApplicationParameterCollection | Constructor of WBApplicationParameterCollection
Public method | WBApplicationParameterCollection(String) | WBApplicationParameterCollection
Top
See Also

Reference

WBApplicationParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection Constructor

WBApplicationParameterCollection Constructor Datapolis Process System Class Reference
Constructor of WBApplicationParameterCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameterCollection()
Public Sub New
public:
WBApplicationParameterCollection()
new : unit -> WBApplicationParameterCollection
See Also

Reference

WBApplicationParameterCollection Class
WBApplicationParameterCollection Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection Constructor (String)

WBApplicationParameterCollection Constructor (String) Datapolis Process System Class Reference
WBApplicationParameterCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameterCollection(
    string xml
)
Public Sub New (
    xml As String
)
public:
WBApplicationParameterCollection(
    String^ xml
)
new :
        xml : string -> WBApplicationParameterCollection

Parameters

xml
Type: SystemString
Collection will be initailized with this XML
See Also

Reference

WBApplicationParameterCollection Class
WBApplicationParameterCollection Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection Properties

WBApplicationParameterCollection Properties Datapolis Process System Class Reference

The WBApplicationParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets a parameter by name
Top
See Also

Reference

WBApplicationParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection.Item Property

WBApplicationParameterCollectionItem Property Datapolis Process System Class Reference
Gets a parameter by name

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameter this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As WBApplicationParameter
    Get
public:
property WBApplicationParameter^ default[String^ name] {
    WBApplicationParameter^ get (String^ name);
}
member Item : WBApplicationParameter with get

Parameters

name
Type: SystemString
name of the parameter

Return Value

Type: WBApplicationParameter
See Also

Reference

WBApplicationParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection Methods

WBApplicationParameterCollection Methods Datapolis Process System Class Reference
Methods
 | Name | Description
Public method | Add(String, WBVariableType, String) |
Public method | Add(String, String, String) |
Top
See Also

Reference

WBApplicationParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection.Add Method

WBApplicationParameterCollectionAdd Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | Add(String, WBVariableType, String) |
Public method | Add(String, String, String) |
Top
See Also

Reference

WBApplicationParameterCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection.Add Method (String, WBVariableType, String)

WBApplicationParameterCollectionAdd Method (String, WBVariableType, String) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string name,
    WBVariableType type,
    string displayName
)
Public Sub Add (
    name As String,
    type As WBVariableType,
    displayName As String
)
public:
void Add(
    String^ name,
    WBVariableType type,
    String^ displayName
)
member Add :
        name : string *
        type : WBVariableType *
        displayName : string -> unit

Parameters

name
Type: SystemString
type
Type: Datapolis.WorkBox.UtilitiesWBVariableType
displayName
Type: SystemString
See Also

Reference

WBApplicationParameterCollection Class
Add Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationParameterCollection.Add Method (String, String, String)

WBApplicationParameterCollectionAdd Method (String, String, String) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string name,
    string type,
    string displayName
)
Public Sub Add (
    name As String,
    type As String,
    displayName As String
)
public:
void Add(
    String^ name,
    String^ type,
    String^ displayName
)
member Add :
        name : string *
        type : string *
        displayName : string -> unit

Parameters

name
Type: SystemString
type
Type: SystemString
displayName
Type: SystemString
See Also

Reference

WBApplicationParameterCollection Class
Add Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationStatus Enumeration

WBApplicationStatus Enumeration Datapolis Process System Class Reference
Status of WBApplication Error - some error occured, e.g. during deployment Deployin - application is being deployed Normal - application is deployed and ready to use Removed - application is removed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBApplicationStatus
Public Enumeration WBApplicationStatus
public enum class WBApplicationStatus
type WBApplicationStatus
Members
Member name | Value | Description
Error | 0 |
Deploying | 1 |
Normal | 2 |
Removed | 3 |
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate Class

WBApplicationTemplate Class Datapolis Process System Class Reference
Template of Datapolis application. Defines how the application is deployed, removed, upgraded and by which classes it is implemented.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationTemplate
Datapolis.WorkBox.Common.SolutionsWBWorkflowApplicationTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBApplicationTemplate
Public MustInherit Class WBApplicationTemplate
public ref class WBApplicationTemplate abstract
[<AbstractClassAttribute>]
type WBApplicationTemplate =  class end

The WBApplicationTemplate type exposes the following members.

Constructors
 | Name | Description
Protected method | WBApplicationTemplate | Initializes a new instance of the WBApplicationTemplate class
Top
Properties
 | Name | Description
Public property | Assembly | Assembly of the application, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"
Public property | Class | Class of the application, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplication"
Public property | CustomConfiguration | Custom configuration of the application, e.g. some XML parsed during deployment
Public property | DeploymentControlAssembly | Deployment assembly of the application, e.g. "Datapolis.WorkBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0b41f301d7bd8b8d"
Public property | DeploymentControlClass | Deployment control class of the application, e.g. "Datapolis.WorkBox.ControlTemplates.WBWorkflowApplicationDeploymentControl"
Public property | DeploymentControlVirtualPath | Deployment control virtual path, e.g. "~/_controltemplates/15/WBWorkflowApplicationDeploymentControl.ascx"
Public property | Description | Description of the application
Public property | ID | Unique ID of the application template
Public property | InstanceAssembly | Assembly of the applicaiton instance, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"
Public property | InstanceClass | Class of the application instnace, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationInstance"
Public property | IsPrivate | Is application private or public
Public property | SolutionTemplateID | Unique ID of the parent solution template
Public property | TemplateAssembly | Template assembly, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"
Public property | TemplateClass | Class of the application template, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationTemplate"
Public property | TemplateXml | XML template that defines this application
Public property | Title | Title of the application
Top
Methods
 | Name | Description
Public method | Deploy | Override this class to deploy your application in provided solution. This method is called during deployment in Central Administration
Public method | Remove | Removes the application.
Public method | Upgrade | Upgrades the application. It can be ran in Central Administration.
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate Constructor

WBApplicationTemplate Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationTemplate class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
protected WBApplicationTemplate()
Protected Sub New
protected:
WBApplicationTemplate()
new : unit -> WBApplicationTemplate
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate Properties

WBApplicationTemplate Properties Datapolis Process System Class Reference

The WBApplicationTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Assembly of the application, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"
Public property | Class | Class of the application, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplication"
Public property | CustomConfiguration | Custom configuration of the application, e.g. some XML parsed during deployment
Public property | DeploymentControlAssembly | Deployment assembly of the application, e.g. "Datapolis.WorkBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0b41f301d7bd8b8d"
Public property | DeploymentControlClass | Deployment control class of the application, e.g. "Datapolis.WorkBox.ControlTemplates.WBWorkflowApplicationDeploymentControl"
Public property | DeploymentControlVirtualPath | Deployment control virtual path, e.g. "~/_controltemplates/15/WBWorkflowApplicationDeploymentControl.ascx"
Public property | Description | Description of the application
Public property | ID | Unique ID of the application template
Public property | InstanceAssembly | Assembly of the applicaiton instance, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"
Public property | InstanceClass | Class of the application instnace, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationInstance"
Public property | IsPrivate | Is application private or public
Public property | SolutionTemplateID | Unique ID of the parent solution template
Public property | TemplateAssembly | Template assembly, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"
Public property | TemplateClass | Class of the application template, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationTemplate"
Public property | TemplateXml | XML template that defines this application
Public property | Title | Title of the application
Top
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.Assembly Property

WBApplicationTemplateAssembly Property Datapolis Process System Class Reference
Assembly of the application, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Assembly { get; }
Public ReadOnly Property Assembly As String
    Get
public:
property String^ Assembly {
    String^ get ();
}
member Assembly : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.Class Property

WBApplicationTemplateClass Property Datapolis Process System Class Reference
Class of the application, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplication"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Class { get; }
Public ReadOnly Property Class As String
    Get
public:
property String^ Class {
    String^ get ();
}
member Class : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.CustomConfiguration Property

WBApplicationTemplateCustomConfiguration Property Datapolis Process System Class Reference
Custom configuration of the application, e.g. some XML parsed during deployment

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string CustomConfiguration { get; }
Public ReadOnly Property CustomConfiguration As String
    Get
public:
property String^ CustomConfiguration {
    String^ get ();
}
member CustomConfiguration : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.DeploymentControlAssembly Property

WBApplicationTemplateDeploymentControlAssembly Property Datapolis Process System Class Reference
Deployment assembly of the application, e.g. "Datapolis.WorkBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0b41f301d7bd8b8d"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string DeploymentControlAssembly { get; }
Public ReadOnly Property DeploymentControlAssembly As String
    Get
public:
property String^ DeploymentControlAssembly {
    String^ get ();
}
member DeploymentControlAssembly : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.DeploymentControlClass Property

WBApplicationTemplateDeploymentControlClass Property Datapolis Process System Class Reference
Deployment control class of the application, e.g. "Datapolis.WorkBox.ControlTemplates.WBWorkflowApplicationDeploymentControl"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string DeploymentControlClass { get; }
Public ReadOnly Property DeploymentControlClass As String
    Get
public:
property String^ DeploymentControlClass {
    String^ get ();
}
member DeploymentControlClass : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.DeploymentControlVirtualPath Property

WBApplicationTemplateDeploymentControlVirtualPath Property Datapolis Process System Class Reference
Deployment control virtual path, e.g. "~/_controltemplates/15/WBWorkflowApplicationDeploymentControl.ascx"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string DeploymentControlVirtualPath { get; }
Public ReadOnly Property DeploymentControlVirtualPath As String
    Get
public:
property String^ DeploymentControlVirtualPath {
    String^ get ();
}
member DeploymentControlVirtualPath : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.Description Property

WBApplicationTemplateDescription Property Datapolis Process System Class Reference
Description of the application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.ID Property

WBApplicationTemplateID Property Datapolis Process System Class Reference
Unique ID of the application template

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ID { get; }
Public ReadOnly Property ID As Guid
    Get
public:
property Guid ID {
    Guid get ();
}
member ID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.InstanceAssembly Property

WBApplicationTemplateInstanceAssembly Property Datapolis Process System Class Reference
Assembly of the applicaiton instance, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string InstanceAssembly { get; }
Public ReadOnly Property InstanceAssembly As String
    Get
public:
property String^ InstanceAssembly {
    String^ get ();
}
member InstanceAssembly : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.InstanceClass Property

WBApplicationTemplateInstanceClass Property Datapolis Process System Class Reference
Class of the application instnace, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationInstance"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string InstanceClass { get; }
Public ReadOnly Property InstanceClass As String
    Get
public:
property String^ InstanceClass {
    String^ get ();
}
member InstanceClass : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.IsPrivate Property

WBApplicationTemplateIsPrivate Property Datapolis Process System Class Reference
Is application private or public

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsPrivate { get; }
Public ReadOnly Property IsPrivate As Boolean
    Get
public:
property bool IsPrivate {
    bool get ();
}
member IsPrivate : bool with get

Property Value

Type: Boolean
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.SolutionTemplateID Property

WBApplicationTemplateSolutionTemplateID Property Datapolis Process System Class Reference
Unique ID of the parent solution template

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string SolutionTemplateID { get; }
Public ReadOnly Property SolutionTemplateID As String
    Get
public:
property String^ SolutionTemplateID {
    String^ get ();
}
member SolutionTemplateID : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.TemplateAssembly Property

WBApplicationTemplateTemplateAssembly Property Datapolis Process System Class Reference
Template assembly, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string TemplateAssembly { get; }
Public ReadOnly Property TemplateAssembly As String
    Get
public:
property String^ TemplateAssembly {
    String^ get ();
}
member TemplateAssembly : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.TemplateClass Property

WBApplicationTemplateTemplateClass Property Datapolis Process System Class Reference
Class of the application template, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationTemplate"

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string TemplateClass { get; }
Public ReadOnly Property TemplateClass As String
    Get
public:
property String^ TemplateClass {
    String^ get ();
}
member TemplateClass : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.TemplateXml Property

WBApplicationTemplateTemplateXml Property Datapolis Process System Class Reference
XML template that defines this application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string TemplateXml { get; }
Public ReadOnly Property TemplateXml As String
    Get
public:
property String^ TemplateXml {
    String^ get ();
}
member TemplateXml : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.Title Property

WBApplicationTemplateTitle Property Datapolis Process System Class Reference
Title of the application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate Methods

WBApplicationTemplate Methods Datapolis Process System Class Reference

The WBApplicationTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Deploy | Override this class to deploy your application in provided solution. This method is called during deployment in Central Administration
Public method | Remove | Removes the application.
Public method | Upgrade | Upgrades the application. It can be ran in Central Administration.
Top
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.Deploy Method

WBApplicationTemplateDeploy Method Datapolis Process System Class Reference
Override this class to deploy your application in provided solution. This method is called during deployment in Central Administration

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void Deploy(
    WBApplicationTemplateDeploymentControl control,
    WBApplication application,
    WBSolution solution
)
Public MustOverride Sub Deploy (
    control As WBApplicationTemplateDeploymentControl,
    application As WBApplication,
    solution As WBSolution
)
public:
virtual void Deploy(
    WBApplicationTemplateDeploymentControl^ control,
    WBApplication^ application,
    WBSolution^ solution
) abstract
abstract Deploy :
        control : WBApplicationTemplateDeploymentControl *
        application : WBApplication *
        solution : WBSolution -> unit

Parameters

control
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationTemplateDeploymentControl
Deployment control
application
Type: Datapolis.WorkBox.Common.SolutionsWBApplication
Application to be deployed
solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
Containing solution
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.Remove Method

WBApplicationTemplateRemove Method Datapolis Process System Class Reference
Removes the application.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void Remove(
    WBApplication application
)
Public MustOverride Sub Remove (
    application As WBApplication
)
public:
virtual void Remove(
    WBApplication^ application
) abstract
abstract Remove :
        application : WBApplication -> unit

Parameters

application
Type: Datapolis.WorkBox.Common.SolutionsWBApplication
application to be removed
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplate.Upgrade Method

WBApplicationTemplateUpgrade Method Datapolis Process System Class Reference
Upgrades the application. It can be ran in Central Administration.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void Upgrade(
    WBApplication application
)
Public MustOverride Sub Upgrade (
    application As WBApplication
)
public:
virtual void Upgrade(
    WBApplication^ application
) abstract
abstract Upgrade :
        application : WBApplication -> unit

Parameters

application
Type: Datapolis.WorkBox.Common.SolutionsWBApplication
Application to be upgraded
See Also

Reference

WBApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplateDeploymentControl Class

WBApplicationTemplateDeploymentControl Class Datapolis Process System Class Reference
UserControl used for Datapolis application deployment. Override this class if your application has some information that needs to be displayed/modified before application deployment. This control is displayed in Datapolis solution deployment page (in Central Administration)
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UITemplateControl
System.Web.UIUserControl
Datapolis.WorkBox.Common.SolutionsWBApplicationTemplateDeploymentControl

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBApplicationTemplateDeploymentControl : UserControl
Public MustInherit Class WBApplicationTemplateDeploymentControl
    Inherits UserControl
public ref class WBApplicationTemplateDeploymentControl abstract : public UserControl
[<AbstractClassAttribute>]
type WBApplicationTemplateDeploymentControl =
    class
        inherit UserControl
    end

The WBApplicationTemplateDeploymentControl type exposes the following members.

Constructors
 | Name | Description
Protected method | WBApplicationTemplateDeploymentControl | Initializes a new instance of the WBApplicationTemplateDeploymentControl class
Top
Properties
 | Name | Description
Public property | ApplicationTemplate | Datapolis Application Template
Top
Methods
 | Name | Description
Public method | Validate | This method is called by the Datapolis solution deployment page to check whether the information provided by the user (Administrator) is valid.
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplateDeploymentControl Constructor

WBApplicationTemplateDeploymentControl Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationTemplateDeploymentControl class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
protected WBApplicationTemplateDeploymentControl()
Protected Sub New
protected:
WBApplicationTemplateDeploymentControl()
new : unit -> WBApplicationTemplateDeploymentControl
See Also

Reference

WBApplicationTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplateDeploymentControl Properties

WBApplicationTemplateDeploymentControl Properties Datapolis Process System Class Reference

The WBApplicationTemplateDeploymentControl type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationTemplate | Datapolis Application Template
Top
See Also

Reference

WBApplicationTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplateDeploymentControl.ApplicationTemplate Property

WBApplicationTemplateDeploymentControlApplicationTemplate Property Datapolis Process System Class Reference
Datapolis Application Template

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationTemplate ApplicationTemplate { get; set; }
Public Property ApplicationTemplate As WBApplicationTemplate
    Get
    Set
public:
property WBApplicationTemplate^ ApplicationTemplate {
    WBApplicationTemplate^ get ();
    void set (WBApplicationTemplate^ value);
}
member ApplicationTemplate : WBApplicationTemplate with get, set

Property Value

Type: WBApplicationTemplate
See Also

Reference

WBApplicationTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplateDeploymentControl Methods

WBApplicationTemplateDeploymentControl Methods Datapolis Process System Class Reference

The WBApplicationTemplateDeploymentControl type exposes the following members.

Methods
 | Name | Description
Public method | Validate | This method is called by the Datapolis solution deployment page to check whether the information provided by the user (Administrator) is valid.
Top
See Also

Reference

WBApplicationTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBApplicationTemplateDeploymentControl.Validate Method

WBApplicationTemplateDeploymentControlValidate Method Datapolis Process System Class Reference
This method is called by the Datapolis solution deployment page to check whether the information provided by the user (Administrator) is valid.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract bool Validate()
Public MustOverride Function Validate As Boolean
public:
virtual bool Validate() abstract
abstract Validate : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WBApplicationTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl Class

WBJobDeploymentControl Class Datapolis Process System Class Reference
Use this class to create a custom cotrol for job deployment in Datapolis System Settings page
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UITemplateControl
System.Web.UIUserControl
Datapolis.WorkBox.Common.SolutionsWBJobDeploymentControl

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBJobDeploymentControl : UserControl
Public MustInherit Class WBJobDeploymentControl
    Inherits UserControl
public ref class WBJobDeploymentControl abstract : public UserControl
[<AbstractClassAttribute>]
type WBJobDeploymentControl =
    class
        inherit UserControl
    end

The WBJobDeploymentControl type exposes the following members.

Constructors
 | Name | Description
Protected method | WBJobDeploymentControl | Initializes a new instance of the WBJobDeploymentControl class
Top
Properties
 | Name | Description
Public property | CustomData | Here put custom data that will be used for job deployment
Public property | ParentControlID | This string is concatenated with ID of all web controls in this user control (OnInit)
Top
Methods
 | Name | Description
Public method | GetControlValues | This method is called after the Validate method
Protected method | OnInit | (Overrides UserControlOnInit(EventArgs).)
Public method | SetControlsValues |
Public method | Validate | Returns true if the provided values are correct
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl Constructor

WBJobDeploymentControl Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBJobDeploymentControl class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
protected WBJobDeploymentControl()
Protected Sub New
protected:
WBJobDeploymentControl()
new : unit -> WBJobDeploymentControl
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl Properties

WBJobDeploymentControl Properties Datapolis Process System Class Reference

The WBJobDeploymentControl type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Here put custom data that will be used for job deployment
Public property | ParentControlID | This string is concatenated with ID of all web controls in this user control (OnInit)
Top
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl.CustomData Property

WBJobDeploymentControlCustomData Property Datapolis Process System Class Reference
Here put custom data that will be used for job deployment

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string CustomData { get; set; }
Public Property CustomData As String
    Get
    Set
public:
property String^ CustomData {
    String^ get ();
    void set (String^ value);
}
member CustomData : string with get, set

Property Value

Type: String
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl.ParentControlID Property

WBJobDeploymentControlParentControlID Property Datapolis Process System Class Reference
This string is concatenated with ID of all web controls in this user control (OnInit)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string ParentControlID { get; }
Public ReadOnly Property ParentControlID As String
    Get
public:
property String^ ParentControlID {
    String^ get ();
}
member ParentControlID : string with get

Property Value

Type: String
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl Methods

WBJobDeploymentControl Methods Datapolis Process System Class Reference

The WBJobDeploymentControl type exposes the following members.

Methods
 | Name | Description
Public method | GetControlValues | This method is called after the Validate method
Protected method | OnInit | (Overrides UserControlOnInit(EventArgs).)
Public method | SetControlsValues |
Public method | Validate | Returns true if the provided values are correct
Top
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl.GetControlValues Method

WBJobDeploymentControlGetControlValues Method Datapolis Process System Class Reference
This method is called after the Validate method

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract string GetControlValues()
Public MustOverride Function GetControlValues As String
public:
virtual String^ GetControlValues() abstract
abstract GetControlValues : unit -> string

Return Value

Type: String
values of configuration controls
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl.OnInit Method

WBJobDeploymentControlOnInit Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
protected:
virtual void OnInit(
    EventArgs^ e
) override
abstract OnInit :
        e : EventArgs -> unit
override OnInit :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl.SetControlsValues Method

WBJobDeploymentControlSetControlsValues Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void SetControlsValues(
    string customData
)
Public MustOverride Sub SetControlsValues (
    customData As String
)
public:
virtual void SetControlsValues(
    String^ customData
) abstract
abstract SetControlsValues :
        customData : string -> unit

Parameters

customData
Type: SystemString
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBJobDeploymentControl.Validate Method

WBJobDeploymentControlValidate Method Datapolis Process System Class Reference
Returns true if the provided values are correct

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract bool Validate(
    out string message
)
Public MustOverride Function Validate (
    <OutAttribute> ByRef message As String
) As Boolean
public:
virtual bool Validate(
    [OutAttribute] String^% message
) abstract
abstract Validate :
        message : string byref -> bool

Parameters

message
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

WBJobDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution Class

WBSolution Class Datapolis Process System Class Reference
Base class for solutions. Represents solution that is existing object and may contain applications that can be started.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolution
Datapolis.WorkBox.Common.SolutionsWBWebSolution
Datapolis.WorkBox.Common.SolutionsWBWorkflowDefaultSolution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBSolution
Public MustInherit Class WBSolution
public ref class WBSolution abstract
[<AbstractClassAttribute>]
type WBSolution =  class end

The WBSolution type exposes the following members.

Constructors
 | Name | Description
Protected method | WBSolution | Initializes a new instance of the WBSolution class
Top
Properties
 | Name | Description
Public property | Applications | Returns all applications belonging to this solution
Public property | Configuration | Custom string for specific configuration of solution (like custom xml)
Public property | Description | Description of solution displayed on solution settings page
Public property | IconUrl | Relative (from solution folder) Url to solution icon
Public property | Id | Id of solution record in database
Public property | InternalName | Internal name of the solution, set during deployment. It should uniqually identify the solution
Public property | Name | Name of solution displayed on solution settings page
Public property | Notification | Notification shown on solution settings page Contains notes/errors of solution to be shown for administrator
Public property | SolutionId | Unique solution ID
Public property | SolutionObjects | Objects that belong to this solution, e.g. workflows, applications
Public property | SolutionTemplateId | Unique ID of template from which this solutio was deployed
Public property | Status | Actual status of solution
Public property | TemplateVersion | Version of the template on which the solution is based.
Public property | TemplateXml | XML template on which the solution is based
Public property | Upgradable | Can this solution be upgraded? Value is based on current Version and version stored in xml in SharePoint Root.
Public property | Version | Version of the solution, used to check whether there is an upgrade available
Top
Methods
 | Name | Description
Public method | GetApplications | Returns all applications belonging to this solution
Public method | GetCustomParameters | Gets custom parameters of Solution as value-key collection.
Public method | OnLoad | Executed after solution is loaded from database (after every load of WBSolution object)
Public method | OnSave | Executed before solution is saved to database (after deployment)
Public method | OnUpgrade | Executed after upgrade in database
Public method | SetStatus | Updates status of the solution. Call
Public method | StatusDetails | Actual status details of solution
Public method | Update | Updates this solution object with values (if not null)
Public method | ValidLicense(String) | Returns true if there is a valid license for solution and product
Public method | ValidLicense(String, String) | Returns true if there is a valid license for solution and product
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolution Constructor

WBSolution Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolution class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
protected WBSolution()
Protected Sub New
protected:
WBSolution()
new : unit -> WBSolution
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution Properties

WBSolution Properties Datapolis Process System Class Reference

The WBSolution type exposes the following members.

Properties
 | Name | Description
Public property | Applications | Returns all applications belonging to this solution
Public property | Configuration | Custom string for specific configuration of solution (like custom xml)
Public property | Description | Description of solution displayed on solution settings page
Public property | IconUrl | Relative (from solution folder) Url to solution icon
Public property | Id | Id of solution record in database
Public property | InternalName | Internal name of the solution, set during deployment. It should uniqually identify the solution
Public property | Name | Name of solution displayed on solution settings page
Public property | Notification | Notification shown on solution settings page Contains notes/errors of solution to be shown for administrator
Public property | SolutionId | Unique solution ID
Public property | SolutionObjects | Objects that belong to this solution, e.g. workflows, applications
Public property | SolutionTemplateId | Unique ID of template from which this solutio was deployed
Public property | Status | Actual status of solution
Public property | TemplateVersion | Version of the template on which the solution is based.
Public property | TemplateXml | XML template on which the solution is based
Public property | Upgradable | Can this solution be upgraded? Value is based on current Version and version stored in xml in SharePoint Root.
Public property | Version | Version of the solution, used to check whether there is an upgrade available
Top
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Applications Property

WBSolutionApplications Property Datapolis Process System Class Reference
Returns all applications belonging to this solution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationCollection Applications { get; }
Public ReadOnly Property Applications As WBApplicationCollection
    Get
public:
property WBApplicationCollection^ Applications {
    WBApplicationCollection^ get ();
}
member Applications : WBApplicationCollection with get

Return Value

Type: WBApplicationCollection
WBApplicationCollection applications
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Configuration Property

WBSolutionConfiguration Property Datapolis Process System Class Reference
Custom string for specific configuration of solution (like custom xml)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Configuration { get; set; }
Public Property Configuration As String
    Get
    Set
public:
property String^ Configuration {
    String^ get ();
    void set (String^ value);
}
member Configuration : string with get, set

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Description Property

WBSolutionDescription Property Datapolis Process System Class Reference
Description of solution displayed on solution settings page

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.IconUrl Property

WBSolutionIconUrl Property Datapolis Process System Class Reference
Relative (from solution folder) Url to solution icon

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string IconUrl { get; }
Public ReadOnly Property IconUrl As String
    Get
public:
property String^ IconUrl {
    String^ get ();
}
member IconUrl : string with get

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Id Property

WBSolutionId Property Datapolis Process System Class Reference
Id of solution record in database

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Type: Int32
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.InternalName Property

WBSolutionInternalName Property Datapolis Process System Class Reference
Internal name of the solution, set during deployment. It should uniqually identify the solution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string InternalName { get; }
Public ReadOnly Property InternalName As String
    Get
public:
property String^ InternalName {
    String^ get ();
}
member InternalName : string with get

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Name Property

WBSolutionName Property Datapolis Process System Class Reference
Name of solution displayed on solution settings page

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Notification Property

WBSolutionNotification Property Datapolis Process System Class Reference
Notification shown on solution settings page Contains notes/errors of solution to be shown for administrator

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Notification { get; }
Public ReadOnly Property Notification As String
    Get
public:
property String^ Notification {
    String^ get ();
}
member Notification : string with get

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.SolutionId Property

WBSolutionSolutionId Property Datapolis Process System Class Reference
Unique solution ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid SolutionId { get; set; }
Public Property SolutionId As Guid
    Get
    Set
public:
property Guid SolutionId {
    Guid get ();
    void set (Guid value);
}
member SolutionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.SolutionObjects Property

WBSolutionSolutionObjects Property Datapolis Process System Class Reference
Objects that belong to this solution, e.g. workflows, applications

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionObjectCollection SolutionObjects { get; }
Public ReadOnly Property SolutionObjects As WBSolutionObjectCollection
    Get
public:
property WBSolutionObjectCollection^ SolutionObjects {
    WBSolutionObjectCollection^ get ();
}
member SolutionObjects : WBSolutionObjectCollection with get

Property Value

Type: WBSolutionObjectCollection
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.SolutionTemplateId Property

WBSolutionSolutionTemplateId Property Datapolis Process System Class Reference
Unique ID of template from which this solutio was deployed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string SolutionTemplateId { get; set; }
Public Property SolutionTemplateId As String
    Get
    Set
public:
property String^ SolutionTemplateId {
    String^ get ();
    void set (String^ value);
}
member SolutionTemplateId : string with get, set

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Status Property

WBSolutionStatus Property Datapolis Process System Class Reference
Actual status of solution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionStatus Status { get; }
Public ReadOnly Property Status As WBSolutionStatus
    Get
public:
property WBSolutionStatus Status {
    WBSolutionStatus get ();
}
member Status : WBSolutionStatus with get

Property Value

Type: WBSolutionStatus
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.TemplateVersion Property

WBSolutionTemplateVersion Property Datapolis Process System Class Reference
Version of the template on which the solution is based.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string TemplateVersion { get; }
Public ReadOnly Property TemplateVersion As String
    Get
public:
property String^ TemplateVersion {
    String^ get ();
}
member TemplateVersion : string with get

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.TemplateXml Property

WBSolutionTemplateXml Property Datapolis Process System Class Reference
XML template on which the solution is based

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string TemplateXml { get; }
Public ReadOnly Property TemplateXml As String
    Get
public:
property String^ TemplateXml {
    String^ get ();
}
member TemplateXml : string with get

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Upgradable Property

WBSolutionUpgradable Property Datapolis Process System Class Reference
Can this solution be upgraded? Value is based on current Version and version stored in xml in SharePoint Root.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool Upgradable { get; }
Public ReadOnly Property Upgradable As Boolean
    Get
public:
property bool Upgradable {
    bool get ();
}
member Upgradable : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Version Property

WBSolutionVersion Property Datapolis Process System Class Reference
Version of the solution, used to check whether there is an upgrade available

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
member Version : string with get

Property Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution Methods

WBSolution Methods Datapolis Process System Class Reference

The WBSolution type exposes the following members.

Methods
 | Name | Description
Public method | GetApplications | Returns all applications belonging to this solution
Public method | GetCustomParameters | Gets custom parameters of Solution as value-key collection.
Public method | OnLoad | Executed after solution is loaded from database (after every load of WBSolution object)
Public method | OnSave | Executed before solution is saved to database (after deployment)
Public method | OnUpgrade | Executed after upgrade in database
Public method | SetStatus | Updates status of the solution. Call
Public method | StatusDetails | Actual status details of solution
Public method | Update | Updates this solution object with values (if not null)
Public method | ValidLicense(String) | Returns true if there is a valid license for solution and product
Public method | ValidLicense(String, String) | Returns true if there is a valid license for solution and product
Top
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.GetApplications Method

WBSolutionGetApplications Method Datapolis Process System Class Reference
Returns all applications belonging to this solution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationCollection GetApplications()
Public Function GetApplications As WBApplicationCollection
public:
WBApplicationCollection^ GetApplications()
member GetApplications : unit -> WBApplicationCollection

Return Value

Type: WBApplicationCollection
WBApplicationCollection applications
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.GetCustomParameters Method

WBSolutionGetCustomParameters Method Datapolis Process System Class Reference
Gets custom parameters of Solution as value-key collection.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public virtual List<WBSolutionCustomParam> GetCustomParameters()
Public Overridable Function GetCustomParameters As List(Of WBSolutionCustomParam)
public:
virtual List<WBSolutionCustomParam^>^ GetCustomParameters()
abstract GetCustomParameters : unit -> List<WBSolutionCustomParam>
override GetCustomParameters : unit -> List<WBSolutionCustomParam>

Return Value

Type: List WBSolutionCustomParam
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.OnLoad Method

WBSolutionOnLoad Method Datapolis Process System Class Reference
Executed after solution is loaded from database (after every load of WBSolution object)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void OnLoad()
Public MustOverride Sub OnLoad
public:
virtual void OnLoad() abstract
abstract OnLoad : unit -> unit
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.OnSave Method

WBSolutionOnSave Method Datapolis Process System Class Reference
Executed before solution is saved to database (after deployment)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void OnSave()
Public MustOverride Sub OnSave
public:
virtual void OnSave() abstract
abstract OnSave : unit -> unit
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.OnUpgrade Method

WBSolutionOnUpgrade Method Datapolis Process System Class Reference
Executed after upgrade in database

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void OnUpgrade()
Public MustOverride Sub OnUpgrade
public:
virtual void OnUpgrade() abstract
abstract OnUpgrade : unit -> unit
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.SetStatus Method

WBSolutionSetStatus Method Datapolis Process System Class Reference
Updates status of the solution. Call

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void SetStatus(
    WBSolutionStatus status
)
Public Sub SetStatus (
    status As WBSolutionStatus
)
public:
void SetStatus(
    WBSolutionStatus status
)
member SetStatus :
        status : WBSolutionStatus -> unit

Parameters

status
Type: Datapolis.WorkBox.Common.SolutionsWBSolutionStatus
New status
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.StatusDetails Method

WBSolutionStatusDetails Method Datapolis Process System Class Reference
Actual status details of solution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string StatusDetails()
Public Function StatusDetails As String
public:
String^ StatusDetails()
member StatusDetails : unit -> string

Return Value

Type: String
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.Update Method

WBSolutionUpdate Method Datapolis Process System Class Reference
Updates this solution object with values (if not null)

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Update(
    string name,
    string description,
    string customXml,
    string iconUrl,
    Nullable<WBSolutionStatus> status,
    string notification
)
Public Sub Update (
    name As String,
    description As String,
    customXml As String,
    iconUrl As String,
    status As Nullable(Of WBSolutionStatus),
    notification As String
)
public:
void Update(
    String^ name,
    String^ description,
    String^ customXml,
    String^ iconUrl,
    Nullable<WBSolutionStatus> status,
    String^ notification
)
member Update :
        name : string *
        description : string *
        customXml : string *
        iconUrl : string *
        status : Nullable<WBSolutionStatus> *
        notification : string -> unit

Parameters

name
Type: SystemString
new name
description
Type: SystemString
new description
customXml
Type: SystemString
iconUrl
Type: SystemString
status
Type: SystemNullable WBSolutionStatus
notification
Type: SystemString
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.ValidLicense Method

WBSolutionValidLicense Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | ValidLicense(String) | Returns true if there is a valid license for solution and product
Public method | ValidLicense(String, String) | Returns true if there is a valid license for solution and product
Top
See Also

Reference

WBSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.ValidLicense Method (String)

WBSolutionValidLicense Method (String) Datapolis Process System Class Reference
Returns true if there is a valid license for solution and product

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool ValidLicense(
    string username = null
)
Public Function ValidLicense (
    Optional username As String = Nothing
) As Boolean
public:
bool ValidLicense(
    String^ username = nullptr
)
member ValidLicense :
        ?username : string
(* Defaults:
        let _username = defaultArg username null
*)
-> bool

Parameters

username (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

WBSolution Class
ValidLicense Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBSolution.ValidLicense Method (String, String)

WBSolutionValidLicense Method (String, String) Datapolis Process System Class Reference
Returns true if there is a valid license for solution and product

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool ValidLicense(
    out string message,
    string username = null
)
Public Function ValidLicense (
    <OutAttribute> ByRef message As String,
    Optional username As String = Nothing
) As Boolean
public:
bool ValidLicense(
    [OutAttribute] String^% message,
    String^ username = nullptr
)
member ValidLicense :
        message : string byref *
        ?username : string
(* Defaults:
        let _username = defaultArg username null
*)
-> bool

Parameters

message
Type: SystemString
username (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

WBSolution Class
ValidLicense Overload
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCollection Class

WBSolutionCollection Class Datapolis Process System Class Reference
Collection of WBSolution objects
Inheritance Hierarchy
SystemObject
WBListWBSolution
Datapolis.WorkBox.Common.SolutionsWBSolutionCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSolutionCollection : WBList<WBSolution>
Public NotInheritable Class WBSolutionCollection
    Inherits WBList(Of WBSolution)
public ref class WBSolutionCollection sealed : public WBList<WBSolution^>
[<SealedAttribute>]
type WBSolutionCollection =
    class
        inherit WBList<WBSolution>
    end

The WBSolutionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionCollection | Initializes a new instance of the WBSolutionCollection class
Top
Properties
 | Name | Description
Public property | Item |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCollection Constructor

WBSolutionCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionCollection class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionCollection()
Public Sub New
public:
WBSolutionCollection()
new : unit -> WBSolutionCollection
See Also

Reference

WBSolutionCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCollection Properties

WBSolutionCollection Properties Datapolis Process System Class Reference

The WBSolutionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Top
See Also

Reference

WBSolutionCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCollection.Item Property

WBSolutionCollectionItem Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolution this[
    Guid solutionId
] { get; }
Public ReadOnly Default Property Item (
    solutionId As Guid
) As WBSolution
    Get
public:
property WBSolution^ default[Guid solutionId] {
    WBSolution^ get (Guid solutionId);
}
member Item : WBSolution with get

Parameters

solutionId
Type: SystemGuid

Property Value

Type: WBSolution
See Also

Reference

WBSolutionCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCustomParam Class

WBSolutionCustomParam Class Datapolis Process System Class Reference
Data object for Custom Paramter of Solution.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolutionCustomParam

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBSolutionCustomParam
Public Class WBSolutionCustomParam
public ref class WBSolutionCustomParam
type WBSolutionCustomParam =  class end

The WBSolutionCustomParam type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionCustomParam | Initializes a new instance of the WBSolutionCustomParam class
Top
Properties
 | Name | Description
Public property | Name | System Name of Solution Custom Parameter.
Public property | Title | Localized Name of Solution Custom Parameter.
Public property | Value | Value of Solution Custom Parameter.
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCustomParam Constructor

WBSolutionCustomParam Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionCustomParam class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionCustomParam()
Public Sub New
public:
WBSolutionCustomParam()
new : unit -> WBSolutionCustomParam
See Also

Reference

WBSolutionCustomParam Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCustomParam Properties

WBSolutionCustomParam Properties Datapolis Process System Class Reference

The WBSolutionCustomParam type exposes the following members.

Properties
 | Name | Description
Public property | Name | System Name of Solution Custom Parameter.
Public property | Title | Localized Name of Solution Custom Parameter.
Public property | Value | Value of Solution Custom Parameter.
Top
See Also

Reference

WBSolutionCustomParam Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCustomParam.Name Property

WBSolutionCustomParamName Property Datapolis Process System Class Reference
System Name of Solution Custom Parameter.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionCustomParam Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCustomParam.Title Property

WBSolutionCustomParamTitle Property Datapolis Process System Class Reference
Localized Name of Solution Custom Parameter.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionCustomParam Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionCustomParam.Value Property

WBSolutionCustomParamValue Property Datapolis Process System Class Reference
Value of Solution Custom Parameter.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionCustomParam Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionManager Class

WBSolutionManager Class Datapolis Process System Class Reference
Use this class to load and manage solutions.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolutionManager

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBSolutionManager
Public Class WBSolutionManager
public ref class WBSolutionManager
type WBSolutionManager =  class end

The WBSolutionManager type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionManager | Initializes a new instance of the WBSolutionManager class
Top
Methods
Name | Description
GetSolutionByName | Gets WBSolution by name. Solution name is set during creation, e.g. when deploying a custom solution or adding a site solution
GetSolutionByObjectId | Gets a WBSolution that contains the object
GetSolutionBySolutionId | Gets WBSolution by solution id.
GetSolutionsByTemplateId | Returns a collection of WBSolution objects
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionManager Constructor

WBSolutionManager Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionManager class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionManager()
Public Sub New
public:
WBSolutionManager()
new : unit -> WBSolutionManager
See Also

Reference

WBSolutionManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionManager Methods

WBSolutionManager Methods Datapolis Process System Class Reference

The WBSolutionManager type exposes the following members.

Methods
Name | Description
GetSolutionByName | Gets WBSolution by name. Solution name is set during creation, e.g. when deploying a custom solution or adding a site solution
GetSolutionByObjectId | Gets a WBSolution that contains the object
GetSolutionBySolutionId | Gets WBSolution by solution id.
GetSolutionsByTemplateId | Returns a collection of WBSolution objects
Top
See Also

Reference

WBSolutionManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionManager.GetSolutionByName Method

WBSolutionManagerGetSolutionByName Method Datapolis Process System Class Reference
Gets WBSolution by name. Solution name is set during creation, e.g. when deploying a custom solution or adding a site solution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSolution GetSolutionByName(
    string name
)
Public Shared Function GetSolutionByName (
    name As String
) As WBSolution
public:
static WBSolution^ GetSolutionByName(
    String^ name
)
static member GetSolutionByName :
        name : string -> WBSolution

Parameters

name
Type: SystemString
Name of the solution

Return Value

Type: WBSolution
See Also

Reference

WBSolutionManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionManager.GetSolutionByObjectId Method

WBSolutionManagerGetSolutionByObjectId Method Datapolis Process System Class Reference
Gets a WBSolution that contains the object

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSolution GetSolutionByObjectId(
    string objectId
)
Public Shared Function GetSolutionByObjectId (
    objectId As String
) As WBSolution
public:
static WBSolution^ GetSolutionByObjectId(
    String^ objectId
)
static member GetSolutionByObjectId :
        objectId : string -> WBSolution

Parameters

objectId
Type: SystemString
ID of an object that belongs to a solution. E.g. ID of a Datapolis Workflow

Return Value

Type: WBSolution
See Also

Reference

WBSolutionManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionManager.GetSolutionBySolutionId Method

WBSolutionManagerGetSolutionBySolutionId Method Datapolis Process System Class Reference
Gets WBSolution by solution id.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSolution GetSolutionBySolutionId(
    Guid solutionId
)
Public Shared Function GetSolutionBySolutionId (
    solutionId As Guid
) As WBSolution
public:
static WBSolution^ GetSolutionBySolutionId(
    Guid solutionId
)
static member GetSolutionBySolutionId :
        solutionId : Guid -> WBSolution

Parameters

solutionId
Type: SystemGuid
SolutionId is a Guid that uniquely identifies a solution.

Return Value

Type: WBSolution
See Also

Reference

WBSolutionManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionManager.GetSolutionsByTemplateId Method

WBSolutionManagerGetSolutionsByTemplateId Method Datapolis Process System Class Reference
Returns a collection of WBSolution objects

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSolutionCollection GetSolutionsByTemplateId(
    string templateId
)
Public Shared Function GetSolutionsByTemplateId (
    templateId As String
) As WBSolutionCollection
public:
static WBSolutionCollection^ GetSolutionsByTemplateId(
    String^ templateId
)
static member GetSolutionsByTemplateId :
        templateId : string -> WBSolutionCollection

Parameters

templateId
Type: SystemString
WBSolutionTemplate ID

Return Value

Type: WBSolutionCollection
See Also

Reference

WBSolutionManager Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObject Class

WBSolutionObject Class Datapolis Process System Class Reference
Object that belongs to a Datapolis solution
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolutionObject

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBSolutionObject
Public Class WBSolutionObject
public ref class WBSolutionObject
type WBSolutionObject =  class end

The WBSolutionObject type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionObject | Initializes a new instance of the WBSolutionObject class
Top
Properties
 | Name | Description
Public property | InternalName | Internal name
Public property | Title | Title
Public property | Type | Type of object, e.g. WBWorkflow, WBApplication, Other
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObject Constructor

WBSolutionObject Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionObject class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionObject()
Public Sub New
public:
WBSolutionObject()
new : unit -> WBSolutionObject
See Also

Reference

WBSolutionObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObject Properties

WBSolutionObject Properties Datapolis Process System Class Reference

The WBSolutionObject type exposes the following members.

Properties
 | Name | Description
Public property | InternalName | Internal name
Public property | Title | Title
Public property | Type | Type of object, e.g. WBWorkflow, WBApplication, Other
Top
See Also

Reference

WBSolutionObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObject.InternalName Property

WBSolutionObjectInternalName Property Datapolis Process System Class Reference
Internal name

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string InternalName { get; set; }
Public Property InternalName As String
    Get
    Set
public:
property String^ InternalName {
    String^ get ();
    void set (String^ value);
}
member InternalName : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObject.Title Property

WBSolutionObjectTitle Property Datapolis Process System Class Reference
Title

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObject.Type Property

WBSolutionObjectType Property Datapolis Process System Class Reference
Type of object, e.g. WBWorkflow, WBApplication, Other

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObjectCollection Class

WBSolutionObjectCollection Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
WBListWBSolutionObject
Datapolis.WorkBox.Common.SolutionsWBSolutionObjectCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSolutionObjectCollection : WBList<WBSolutionObject>
Public NotInheritable Class WBSolutionObjectCollection
    Inherits WBList(Of WBSolutionObject)
public ref class WBSolutionObjectCollection sealed : public WBList<WBSolutionObject^>
[<SealedAttribute>]
type WBSolutionObjectCollection =
    class
        inherit WBList<WBSolutionObject>
    end

The WBSolutionObjectCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionObjectCollection | Initializes a new instance of the WBSolutionObjectCollection class
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionObjectCollection Constructor

WBSolutionObjectCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionObjectCollection class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionObjectCollection()
Public Sub New
public:
WBSolutionObjectCollection()
new : unit -> WBSolutionObjectCollection
See Also

Reference

WBSolutionObjectCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionScope Enumeration

WBSolutionScope Enumeration Datapolis Process System Class Reference
Scope of a WBSolution. Generally solutions have farm scope

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBSolutionScope
Public Enumeration WBSolutionScope
public enum class WBSolutionScope
type WBSolutionScope
Members
Member name | Value | Description
Site | 0 |
Web | 1 |
List | 2 |
Farm | 3 |
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionStatus Enumeration

WBSolutionStatus Enumeration Datapolis Process System Class Reference
WBSolution statuses: Scheduled - solution will be deployed by a timer job Deploying - solution is being deployed Deployed - solution was successfully deployed DeployingApps - solution applications are being deployed Faulted - an error occured while solution deployment Removed - solution was removed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBSolutionStatus
Public Enumeration WBSolutionStatus
public enum class WBSolutionStatus
type WBSolutionStatus
Members
Member name | Value | Description
Scheduled | 0 |
Deploying | 1 |
Deployed | 2 |
DeployingApps | 3 |
Faulted | 4 |
Removed | 5 |
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate Class

WBSolutionTemplate Class Datapolis Process System Class Reference
Template of Datapolis solution. Defines how the application is deployed, removed, upgraded and by which classes it is implemented.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolutionTemplate
Datapolis.WorkBox.Common.SolutionsWBWebSolutionTemplate
Datapolis.WorkBox.Common.SolutionsWBWorkflowSolutionTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBSolutionTemplate
Public MustInherit Class WBSolutionTemplate
public ref class WBSolutionTemplate abstract
[<AbstractClassAttribute>]
type WBSolutionTemplate =  class end

The WBSolutionTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionTemplate | Constructor of WBSolutionTemplate
Top
Properties
 | Name | Description
Public property | Active | Is template active
Public property | AllowUpgrade | Does the template allow for upgrades
Public property | CustomConfiguration | Custom configuration of the solution, e.g. some XML parsed during deployment
Public property | Description | Description of the application template
Public property | ID | Unique ID of the solution template
Public property | Title | Title of the solution template
Public property | Version | Version of the solution template
Top
Methods
 | Name | Description
Public method | Deploy | Deploys the solution using the provided control. Return InternalName of the solution that uniquely identifies it
Public method | Remove |
Public method | Upgrade | Upgrades solution to the latest available version
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate Constructor

WBSolutionTemplate Constructor Datapolis Process System Class Reference
Constructor of WBSolutionTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionTemplate()
Public Sub New
public:
WBSolutionTemplate()
new : unit -> WBSolutionTemplate
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate Properties

WBSolutionTemplate Properties Datapolis Process System Class Reference

The WBSolutionTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Active | Is template active
Public property | AllowUpgrade | Does the template allow for upgrades
Public property | CustomConfiguration | Custom configuration of the solution, e.g. some XML parsed during deployment
Public property | Description | Description of the application template
Public property | ID | Unique ID of the solution template
Public property | Title | Title of the solution template
Public property | Version | Version of the solution template
Top
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.Active Property

WBSolutionTemplateActive Property Datapolis Process System Class Reference
Is template active

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool Active { get; }
Public ReadOnly Property Active As Boolean
    Get
public:
property bool Active {
    bool get ();
}
member Active : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.AllowUpgrade Property

WBSolutionTemplateAllowUpgrade Property Datapolis Process System Class Reference
Does the template allow for upgrades

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool AllowUpgrade { get; }
Public ReadOnly Property AllowUpgrade As Boolean
    Get
public:
property bool AllowUpgrade {
    bool get ();
}
member AllowUpgrade : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.CustomConfiguration Property

WBSolutionTemplateCustomConfiguration Property Datapolis Process System Class Reference
Custom configuration of the solution, e.g. some XML parsed during deployment

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string CustomConfiguration { get; }
Public ReadOnly Property CustomConfiguration As String
    Get
public:
property String^ CustomConfiguration {
    String^ get ();
}
member CustomConfiguration : string with get

Property Value

Type: String
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.Description Property

WBSolutionTemplateDescription Property Datapolis Process System Class Reference
Description of the application template

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.ID Property

WBSolutionTemplateID Property Datapolis Process System Class Reference
Unique ID of the solution template

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string ID { get; }
Public ReadOnly Property ID As String
    Get
public:
property String^ ID {
    String^ get ();
}
member ID : string with get

Property Value

Type: String
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.Title Property

WBSolutionTemplateTitle Property Datapolis Process System Class Reference
Title of the solution template

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.Version Property

WBSolutionTemplateVersion Property Datapolis Process System Class Reference
Version of the solution template

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
member Version : string with get

Property Value

Type: String
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate Methods

WBSolutionTemplate Methods Datapolis Process System Class Reference

The WBSolutionTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Deploy | Deploys the solution using the provided control. Return InternalName of the solution that uniquely identifies it
Public method | Remove |
Public method | Upgrade | Upgrades solution to the latest available version
Top
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.Deploy Method

WBSolutionTemplateDeploy Method Datapolis Process System Class Reference
Deploys the solution using the provided control. Return InternalName of the solution that uniquely identifies it

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract string Deploy(
    WBSolutionTemplateDeploymentControl control,
    WBSolution solution
)
Public MustOverride Function Deploy (
    control As WBSolutionTemplateDeploymentControl,
    solution As WBSolution
) As String
public:
virtual String^ Deploy(
    WBSolutionTemplateDeploymentControl^ control,
    WBSolution^ solution
) abstract
abstract Deploy :
        control : WBSolutionTemplateDeploymentControl *
        solution : WBSolution -> string

Parameters

control
Type: Datapolis.WorkBox.Common.SolutionsWBSolutionTemplateDeploymentControl
WBSolutionTemplateDeploymentControl control
solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
WBSolution solution

Return Value

Type: String
InternalName
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.Remove Method

WBSolutionTemplateRemove Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void Remove(
    WBSolution solution
)
Public MustOverride Sub Remove (
    solution As WBSolution
)
public:
virtual void Remove(
    WBSolution^ solution
) abstract
abstract Remove :
        solution : WBSolution -> unit

Parameters

solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplate.Upgrade Method

WBSolutionTemplateUpgrade Method Datapolis Process System Class Reference
Upgrades solution to the latest available version

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract void Upgrade(
    WBSolution solution
)
Public MustOverride Sub Upgrade (
    solution As WBSolution
)
public:
virtual void Upgrade(
    WBSolution^ solution
) abstract
abstract Upgrade :
        solution : WBSolution -> unit

Parameters

solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
Solution to update
See Also

Reference

WBSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateDeploymentControl Class

WBSolutionTemplateDeploymentControl Class Datapolis Process System Class Reference
Deoployment control of a Datapolis solution. Inherit from this class if you want to add some additonal controls in solution deployment page in Central Administration in Datapolis settings.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UITemplateControl
System.Web.UIUserControl
Datapolis.WorkBox.Common.SolutionsWBSolutionTemplateDeploymentControl

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBSolutionTemplateDeploymentControl : UserControl
Public MustInherit Class WBSolutionTemplateDeploymentControl
    Inherits UserControl
public ref class WBSolutionTemplateDeploymentControl abstract : public UserControl
[<AbstractClassAttribute>]
type WBSolutionTemplateDeploymentControl =
    class
        inherit UserControl
    end

The WBSolutionTemplateDeploymentControl type exposes the following members.

Constructors
 | Name | Description
Protected method | WBSolutionTemplateDeploymentControl | Initializes a new instance of the WBSolutionTemplateDeploymentControl class
Top
Properties
 | Name | Description
Public property | SolutionTemplate | Solution Template that will be deployed
Top
Methods
 | Name | Description
Public method | Validate | Override this method to do custom validation
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateDeploymentControl Constructor

WBSolutionTemplateDeploymentControl Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionTemplateDeploymentControl class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
protected WBSolutionTemplateDeploymentControl()
Protected Sub New
protected:
WBSolutionTemplateDeploymentControl()
new : unit -> WBSolutionTemplateDeploymentControl
See Also

Reference

WBSolutionTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateDeploymentControl Properties

WBSolutionTemplateDeploymentControl Properties Datapolis Process System Class Reference

The WBSolutionTemplateDeploymentControl type exposes the following members.

Properties
 | Name | Description
Public property | SolutionTemplate | Solution Template that will be deployed
Top
See Also

Reference

WBSolutionTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateDeploymentControl.SolutionTemplate Property

WBSolutionTemplateDeploymentControlSolutionTemplate Property Datapolis Process System Class Reference
Solution Template that will be deployed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionTemplate SolutionTemplate { get; set; }
Public Property SolutionTemplate As WBSolutionTemplate
    Get
    Set
public:
property WBSolutionTemplate^ SolutionTemplate {
    WBSolutionTemplate^ get ();
    void set (WBSolutionTemplate^ value);
}
member SolutionTemplate : WBSolutionTemplate with get, set

Property Value

Type: WBSolutionTemplate
See Also

Reference

WBSolutionTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateDeploymentControl Methods

WBSolutionTemplateDeploymentControl Methods Datapolis Process System Class Reference

The WBSolutionTemplateDeploymentControl type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Override this method to do custom validation
Top
See Also

Reference

WBSolutionTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateDeploymentControl.Validate Method

WBSolutionTemplateDeploymentControlValidate Method Datapolis Process System Class Reference
Override this method to do custom validation

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public abstract bool Validate()
Public MustOverride Function Validate As Boolean
public:
virtual bool Validate() abstract
abstract Validate : unit -> bool

Return Value

Type: Boolean
is valid
See Also

Reference

WBSolutionTemplateDeploymentControl Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject Class

WBSolutionTemplateObject Class Datapolis Process System Class Reference
Objects that belong to the solution template, e.g. workflows in web solution
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolutionTemplateObject

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBSolutionTemplateObject
Public Class WBSolutionTemplateObject
public ref class WBSolutionTemplateObject
type WBSolutionTemplateObject =  class end

The WBSolutionTemplateObject type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionTemplateObject | Initializes a new instance of the WBSolutionTemplateObject class
Top
Properties
 | Name | Description
Public property | InternalName | Internal name of the object, e.g. workflow name
Public property | Location | Location of the object, e.g. List name
Public property | SiteId | Set this variable if the object is of type WBWorkflow - it is used for deployment
Public property | Type | Type of the object
Public property | WebId | Set this variable if the object is of type WBWorkflow - it is used for deployment
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject Constructor

WBSolutionTemplateObject Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionTemplateObject class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionTemplateObject()
Public Sub New
public:
WBSolutionTemplateObject()
new : unit -> WBSolutionTemplateObject
See Also

Reference

WBSolutionTemplateObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject Properties

WBSolutionTemplateObject Properties Datapolis Process System Class Reference

The WBSolutionTemplateObject type exposes the following members.

Properties
 | Name | Description
Public property | InternalName | Internal name of the object, e.g. workflow name
Public property | Location | Location of the object, e.g. List name
Public property | SiteId | Set this variable if the object is of type WBWorkflow - it is used for deployment
Public property | Type | Type of the object
Public property | WebId | Set this variable if the object is of type WBWorkflow - it is used for deployment
Top
See Also

Reference

WBSolutionTemplateObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject.InternalName Property

WBSolutionTemplateObjectInternalName Property Datapolis Process System Class Reference
Internal name of the object, e.g. workflow name

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string InternalName { get; set; }
Public Property InternalName As String
    Get
    Set
public:
property String^ InternalName {
    String^ get ();
    void set (String^ value);
}
member InternalName : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionTemplateObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject.Location Property

WBSolutionTemplateObjectLocation Property Datapolis Process System Class Reference
Location of the object, e.g. List name

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}
member Location : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionTemplateObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject.SiteId Property

WBSolutionTemplateObjectSiteId Property Datapolis Process System Class Reference
Set this variable if the object is of type WBWorkflow - it is used for deployment

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid SiteId { get; set; }
Public Property SiteId As Guid
    Get
    Set
public:
property Guid SiteId {
    Guid get ();
    void set (Guid value);
}
member SiteId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSolutionTemplateObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject.Type Property

WBSolutionTemplateObjectType Property Datapolis Process System Class Reference
Type of the object

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

WBSolutionTemplateObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObject.WebId Property

WBSolutionTemplateObjectWebId Property Datapolis Process System Class Reference
Set this variable if the object is of type WBWorkflow - it is used for deployment

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WebId { get; set; }
Public Property WebId As Guid
    Get
    Set
public:
property Guid WebId {
    Guid get ();
    void set (Guid value);
}
member WebId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSolutionTemplateObject Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObjectCollection Class

WBSolutionTemplateObjectCollection Class Datapolis Process System Class Reference
Collection of objects belonging to the solution template
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBSolutionTemplateObject
Datapolis.WorkBox.Common.SolutionsWBSolutionTemplateObjectCollection

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBSolutionTemplateObjectCollection : List<WBSolutionTemplateObject>
Public Class WBSolutionTemplateObjectCollection
    Inherits List(Of WBSolutionTemplateObject)
public ref class WBSolutionTemplateObjectCollection : public List<WBSolutionTemplateObject^>
type WBSolutionTemplateObjectCollection =
    class
        inherit List<WBSolutionTemplateObject>
    end

The WBSolutionTemplateObjectCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBSolutionTemplateObjectCollection | Initializes a new instance of the WBSolutionTemplateObjectCollection class
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObjectCollection Constructor

WBSolutionTemplateObjectCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSolutionTemplateObjectCollection class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSolutionTemplateObjectCollection()
Public Sub New
public:
WBSolutionTemplateObjectCollection()
new : unit -> WBSolutionTemplateObjectCollection
See Also

Reference

WBSolutionTemplateObjectCollection Class
Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionTemplateObjectType Enumeration

WBSolutionTemplateObjectType Enumeration Datapolis Process System Class Reference
Solution template object types

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBSolutionTemplateObjectType
Public Enumeration WBSolutionTemplateObjectType
public enum class WBSolutionTemplateObjectType
type WBSolutionTemplateObjectType
Members
Member name | Value | Description
WBWorkflow | 0 |
WBApplication | 1 |
Other | 2 |
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBSolutionType Enumeration

WBSolutionType Enumeration Datapolis Process System Class Reference
Type of a WBSolution.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBSolutionType
Public Enumeration WBSolutionType
public enum class WBSolutionType
type WBSolutionType
Members
Member name | Value | Description
Normal | 1 |
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution Class

WBWebSolution Class Datapolis Process System Class Reference
Implementation of WBSolution class. Solution of this type adds a site to a specified site collection and applies a web template.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolution
Datapolis.WorkBox.Common.SolutionsWBWebSolution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBWebSolution : WBSolution
Public Class WBWebSolution
    Inherits WBSolution
public ref class WBWebSolution : public WBSolution
type WBWebSolution =
    class
        inherit WBSolution
    end

The WBWebSolution type exposes the following members.

Constructors
 | Name | Description
Public method | WBWebSolution | Initializes a new instance of the WBWebSolution class
Top
Properties
 | Name | Description
Public property | Applications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public property | Configuration | Custom string for specific configuration of solution (like custom xml) (Inherited from WBSolution.)
Public property | Description | Description of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | IconUrl | Relative (from solution folder) Url to solution icon (Inherited from WBSolution.)
Public property | Id | Id of solution record in database (Inherited from WBSolution.)
Public property | InternalName | Internal name of the solution, set during deployment. It should uniqually identify the solution (Inherited from WBSolution.)
Public property | Name | Name of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | Notification | Notification shown on solution settings page Contains notes/errors of solution to be shown for administrator (Inherited from WBSolution.)
Public property | SiteId | ID of a site collection to which the solution is deployed
Public property | SolutionId | Unique solution ID (Inherited from WBSolution.)
Public property | SolutionObjects | Objects that belong to this solution, e.g. workflows, applications (Inherited from WBSolution.)
Public property | SolutionTemplateId | Unique ID of template from which this solutio was deployed (Inherited from WBSolution.)
Public property | Status | Actual status of solution (Inherited from WBSolution.)
Public property | TemplateVersion | Version of the template on which the solution is based. (Inherited from WBSolution.)
Public property | TemplateXml | XML template on which the solution is based (Inherited from WBSolution.)
Public property | Upgradable | Can this solution be upgraded? Value is based on current Version and version stored in xml in SharePoint Root. (Inherited from WBSolution.)
Public property | Version | Version of the solution, used to check whether there is an upgrade available (Inherited from WBSolution.)
Public property | WebId | ID of a site to which the solution is deployed
Top
Methods
 | Name | Description
Public method | GetApplications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public method | GetCustomParameters | Gets a list of custom parameters used during solution deployment - they are passed by a user. (Overrides WBSolutionGetCustomParameters.)
Public method | GetSiteId | Returns site collection ID to which the solution is deployed
Public method | OnLoad | (Overrides WBSolutionOnLoad.)
Public method | OnSave | (Overrides WBSolutionOnSave.)
Public method | OnUpgrade | (Overrides WBSolutionOnUpgrade.)
Public method | SetStatus | Updates status of the solution. Call (Inherited from WBSolution.)
Public method | StatusDetails | Actual status details of solution (Inherited from WBSolution.)
Public method | Update | Updates this solution object with values (if not null) (Inherited from WBSolution.)
Public method | ValidLicense(String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Public method | ValidLicense(String, String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution Constructor

WBWebSolution Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBWebSolution class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWebSolution()
Public Sub New
public:
WBWebSolution()
new : unit -> WBWebSolution
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution Properties

WBWebSolution Properties Datapolis Process System Class Reference

The WBWebSolution type exposes the following members.

Properties
 | Name | Description
Public property | Applications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public property | Configuration | Custom string for specific configuration of solution (like custom xml) (Inherited from WBSolution.)
Public property | Description | Description of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | IconUrl | Relative (from solution folder) Url to solution icon (Inherited from WBSolution.)
Public property | Id | Id of solution record in database (Inherited from WBSolution.)
Public property | InternalName | Internal name of the solution, set during deployment. It should uniqually identify the solution (Inherited from WBSolution.)
Public property | Name | Name of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | Notification | Notification shown on solution settings page Contains notes/errors of solution to be shown for administrator (Inherited from WBSolution.)
Public property | SiteId | ID of a site collection to which the solution is deployed
Public property | SolutionId | Unique solution ID (Inherited from WBSolution.)
Public property | SolutionObjects | Objects that belong to this solution, e.g. workflows, applications (Inherited from WBSolution.)
Public property | SolutionTemplateId | Unique ID of template from which this solutio was deployed (Inherited from WBSolution.)
Public property | Status | Actual status of solution (Inherited from WBSolution.)
Public property | TemplateVersion | Version of the template on which the solution is based. (Inherited from WBSolution.)
Public property | TemplateXml | XML template on which the solution is based (Inherited from WBSolution.)
Public property | Upgradable | Can this solution be upgraded? Value is based on current Version and version stored in xml in SharePoint Root. (Inherited from WBSolution.)
Public property | Version | Version of the solution, used to check whether there is an upgrade available (Inherited from WBSolution.)
Public property | WebId | ID of a site to which the solution is deployed
Top
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution.SiteId Property

WBWebSolutionSiteId Property Datapolis Process System Class Reference
ID of a site collection to which the solution is deployed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid SiteId { get; set; }
Public Property SiteId As Guid
    Get
    Set
public:
property Guid SiteId {
    Guid get ();
    void set (Guid value);
}
member SiteId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution.WebId Property

WBWebSolutionWebId Property Datapolis Process System Class Reference
ID of a site to which the solution is deployed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WebId { get; set; }
Public Property WebId As Guid
    Get
    Set
public:
property Guid WebId {
    Guid get ();
    void set (Guid value);
}
member WebId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution Methods

WBWebSolution Methods Datapolis Process System Class Reference

The WBWebSolution type exposes the following members.

Methods
 | Name | Description
Public method | GetApplications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public method | GetCustomParameters | Gets a list of custom parameters used during solution deployment - they are passed by a user. (Overrides WBSolutionGetCustomParameters.)
Public method | GetSiteId | Returns site collection ID to which the solution is deployed
Public method | OnLoad | (Overrides WBSolutionOnLoad.)
Public method | OnSave | (Overrides WBSolutionOnSave.)
Public method | OnUpgrade | (Overrides WBSolutionOnUpgrade.)
Public method | SetStatus | Updates status of the solution. Call (Inherited from WBSolution.)
Public method | StatusDetails | Actual status details of solution (Inherited from WBSolution.)
Public method | Update | Updates this solution object with values (if not null) (Inherited from WBSolution.)
Public method | ValidLicense(String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Public method | ValidLicense(String, String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Top
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution.GetCustomParameters Method

WBWebSolutionGetCustomParameters Method Datapolis Process System Class Reference
Gets a list of custom parameters used during solution deployment - they are passed by a user.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override List<WBSolutionCustomParam> GetCustomParameters()
Public Overrides Function GetCustomParameters As List(Of WBSolutionCustomParam)
public:
virtual List<WBSolutionCustomParam^>^ GetCustomParameters() override
abstract GetCustomParameters : unit -> List<WBSolutionCustomParam>
override GetCustomParameters : unit -> List<WBSolutionCustomParam>

Return Value

Type: List WBSolutionCustomParam
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution.GetSiteId Method

WBWebSolutionGetSiteId Method Datapolis Process System Class Reference
Returns site collection ID to which the solution is deployed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid GetSiteId()
Public Function GetSiteId As Guid
public:
Guid GetSiteId()
member GetSiteId : unit -> Guid

Return Value

Type: Guid
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution.OnLoad Method

WBWebSolutionOnLoad Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnLoad()
Public Overrides Sub OnLoad
public:
virtual void OnLoad() override
abstract OnLoad : unit -> unit
override OnLoad : unit -> unit
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution.OnSave Method

WBWebSolutionOnSave Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnSave()
Public Overrides Sub OnSave
public:
virtual void OnSave() override
abstract OnSave : unit -> unit
override OnSave : unit -> unit
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolution.OnUpgrade Method

WBWebSolutionOnUpgrade Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnUpgrade()
Public Overrides Sub OnUpgrade
public:
virtual void OnUpgrade() override
abstract OnUpgrade : unit -> unit
override OnUpgrade : unit -> unit
See Also

Reference

WBWebSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolutionTemplate Class

WBWebSolutionTemplate Class Datapolis Process System Class Reference
Template of a web solution. It allows for adding a new site with sepcified template. Solutions of this type can be deployed together with workflows and applications.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolutionTemplate
Datapolis.WorkBox.Common.SolutionsWBWebSolutionTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBWebSolutionTemplate : WBSolutionTemplate
Public Class WBWebSolutionTemplate
    Inherits WBSolutionTemplate
public ref class WBWebSolutionTemplate : public WBSolutionTemplate
type WBWebSolutionTemplate =
    class
        inherit WBSolutionTemplate
    end

The WBWebSolutionTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | WBWebSolutionTemplate | Initializes a new instance of the WBWebSolutionTemplate class
Top
Properties
 | Name | Description
Public property | Active | Is template active (Inherited from WBSolutionTemplate.)
Public property | AllowUpgrade | Does the template allow for upgrades (Inherited from WBSolutionTemplate.)
Public property | CustomConfiguration | Custom configuration of the solution, e.g. some XML parsed during deployment (Inherited from WBSolutionTemplate.)
Public property | Description | Description of the application template (Inherited from WBSolutionTemplate.)
Public property | ID | Unique ID of the solution template (Inherited from WBSolutionTemplate.)
Public property | Title | Title of the solution template (Inherited from WBSolutionTemplate.)
Public property | Version | Version of the solution template (Inherited from WBSolutionTemplate.)
Top
Methods
 | Name | Description
Public method | Deploy | (Overrides WBSolutionTemplateDeploy(WBSolutionTemplateDeploymentControl, WBSolution).)
Public method | Remove | (Overrides WBSolutionTemplateRemove(WBSolution).)
Public method | Upgrade | (Overrides WBSolutionTemplateUpgrade(WBSolution).)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolutionTemplate Constructor

WBWebSolutionTemplate Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBWebSolutionTemplate class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWebSolutionTemplate()
Public Sub New
public:
WBWebSolutionTemplate()
new : unit -> WBWebSolutionTemplate
See Also

Reference

WBWebSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolutionTemplate Properties

WBWebSolutionTemplate Properties Datapolis Process System Class Reference

The WBWebSolutionTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Active | Is template active (Inherited from WBSolutionTemplate.)
Public property | AllowUpgrade | Does the template allow for upgrades (Inherited from WBSolutionTemplate.)
Public property | CustomConfiguration | Custom configuration of the solution, e.g. some XML parsed during deployment (Inherited from WBSolutionTemplate.)
Public property | Description | Description of the application template (Inherited from WBSolutionTemplate.)
Public property | ID | Unique ID of the solution template (Inherited from WBSolutionTemplate.)
Public property | Title | Title of the solution template (Inherited from WBSolutionTemplate.)
Public property | Version | Version of the solution template (Inherited from WBSolutionTemplate.)
Top
See Also

Reference

WBWebSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolutionTemplate Methods

WBWebSolutionTemplate Methods Datapolis Process System Class Reference

The WBWebSolutionTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Deploy | (Overrides WBSolutionTemplateDeploy(WBSolutionTemplateDeploymentControl, WBSolution).)
Public method | Remove | (Overrides WBSolutionTemplateRemove(WBSolution).)
Public method | Upgrade | (Overrides WBSolutionTemplateUpgrade(WBSolution).)
Top
See Also

Reference

WBWebSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolutionTemplate.Deploy Method

WBWebSolutionTemplateDeploy Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override string Deploy(
    WBSolutionTemplateDeploymentControl control,
    WBSolution solution
)
Public Overrides Function Deploy (
    control As WBSolutionTemplateDeploymentControl,
    solution As WBSolution
) As String
public:
virtual String^ Deploy(
    WBSolutionTemplateDeploymentControl^ control,
    WBSolution^ solution
) override
abstract Deploy :
        control : WBSolutionTemplateDeploymentControl *
        solution : WBSolution -> string
override Deploy :
        control : WBSolutionTemplateDeploymentControl *
        solution : WBSolution -> string

Parameters

control
Type: Datapolis.WorkBox.Common.SolutionsWBSolutionTemplateDeploymentControl
solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution

Return Value

Type: String
See Also

Reference

WBWebSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolutionTemplate.Remove Method

WBWebSolutionTemplateRemove Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Remove(
    WBSolution solution
)
Public Overrides Sub Remove (
    solution As WBSolution
)
public:
virtual void Remove(
    WBSolution^ solution
) override
abstract Remove :
        solution : WBSolution -> unit
override Remove :
        solution : WBSolution -> unit

Parameters

solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
See Also

Reference

WBWebSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWebSolutionTemplate.Upgrade Method

WBWebSolutionTemplateUpgrade Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Upgrade(
    WBSolution solution
)
Public Overrides Sub Upgrade (
    solution As WBSolution
)
public:
virtual void Upgrade(
    WBSolution^ solution
) override
abstract Upgrade :
        solution : WBSolution -> unit
override Upgrade :
        solution : WBSolution -> unit

Parameters

solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
See Also

Reference

WBWebSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication Class

WBWorkflowApplication Class Datapolis Process System Class Reference
This is workflow based Datapolis application.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplication
Datapolis.WorkBox.Common.SolutionsWBWorkflowApplication

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBWorkflowApplication : WBApplication
Public Class WBWorkflowApplication
    Inherits WBApplication
public ref class WBWorkflowApplication : public WBApplication
type WBWorkflowApplication =
    class
        inherit WBApplication
    end

The WBWorkflowApplication type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowApplication | Constructor of WBWorkflowApplication
Top
Properties
 | Name | Description
Public property | ApplicationId | Unique application ID (Inherited from WBApplication.)
Public property | ApplicationInstanceAssembly | Full name of assembly where the the application instance class is located (Inherited from WBApplication.)
Public property | ApplicationInstanceType | Full name of the application instance class type (Inherited from WBApplication.)
Public property | ApplicationStatus | Actual status of the application (Inherited from WBApplication.)
Public property | Configuration | Stores custom coniguration for this application. E.g. if the configuration is some text, then you can parse in OnLoad and later set it in OnSave (Inherited from WBApplication.)
Public property | Description | Description of the application (Inherited from WBApplication.)
Public property | Id | Id of application record in database (Inherited from WBApplication.)
Public property | IsPrivate | True if the applicationcan be used only in parent WBSolution (Inherited from WBApplication.)
Public property | ListId | List ID
Public property | ParametersIn | List of applciation input parameters (Inherited from WBApplication.)
Public property | ParametersOut | List of applcation output parameters (Inherited from WBApplication.)
Public property | SiteId | Site collection ID
Public property | SolutionId | ID of the parent solution to which the application belongs (Inherited from WBApplication.)
Public property | TemplateXml | Teamplate XML of the parent WBApplicationTemplate (Inherited from WBApplication.)
Public property | Title | Title of the application (Inherited from WBApplication.)
Public property | WebApplicationId | Web Application ID
Public property | WebId | Site ID
Public property | WorkflowAssociationId | Workfow association ID
Top
Methods
 | Name | Description
Public method | InitializeNewWorkflowApplication | Initializes new worklow application
Public method | OnLoad | (Overrides WBApplicationOnLoad.)
Public method | OnSave | (Overrides WBApplicationOnSave.)
Public method | OnUpgrade | Upgrades application to the latest version (Inherited from WBApplication.)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication Constructor

WBWorkflowApplication Constructor Datapolis Process System Class Reference
Constructor of WBWorkflowApplication

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowApplication()
Public Sub New
public:
WBWorkflowApplication()
new : unit -> WBWorkflowApplication
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication Properties

WBWorkflowApplication Properties Datapolis Process System Class Reference

The WBWorkflowApplication type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationId | Unique application ID (Inherited from WBApplication.)
Public property | ApplicationInstanceAssembly | Full name of assembly where the the application instance class is located (Inherited from WBApplication.)
Public property | ApplicationInstanceType | Full name of the application instance class type (Inherited from WBApplication.)
Public property | ApplicationStatus | Actual status of the application (Inherited from WBApplication.)
Public property | Configuration | Stores custom coniguration for this application. E.g. if the configuration is some text, then you can parse in OnLoad and later set it in OnSave (Inherited from WBApplication.)
Public property | Description | Description of the application (Inherited from WBApplication.)
Public property | Id | Id of application record in database (Inherited from WBApplication.)
Public property | IsPrivate | True if the applicationcan be used only in parent WBSolution (Inherited from WBApplication.)
Public property | ListId | List ID
Public property | ParametersIn | List of applciation input parameters (Inherited from WBApplication.)
Public property | ParametersOut | List of applcation output parameters (Inherited from WBApplication.)
Public property | SiteId | Site collection ID
Public property | SolutionId | ID of the parent solution to which the application belongs (Inherited from WBApplication.)
Public property | TemplateXml | Teamplate XML of the parent WBApplicationTemplate (Inherited from WBApplication.)
Public property | Title | Title of the application (Inherited from WBApplication.)
Public property | WebApplicationId | Web Application ID
Public property | WebId | Site ID
Public property | WorkflowAssociationId | Workfow association ID
Top
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.ListId Property

WBWorkflowApplicationListId Property Datapolis Process System Class Reference
List ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ListId { get; }
Public ReadOnly Property ListId As Guid
    Get
public:
property Guid ListId {
    Guid get ();
}
member ListId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.SiteId Property

WBWorkflowApplicationSiteId Property Datapolis Process System Class Reference
Site collection ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid SiteId { get; }
Public ReadOnly Property SiteId As Guid
    Get
public:
property Guid SiteId {
    Guid get ();
}
member SiteId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.WebApplicationId Property

WBWorkflowApplicationWebApplicationId Property Datapolis Process System Class Reference
Web Application ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WebApplicationId { get; }
Public ReadOnly Property WebApplicationId As Guid
    Get
public:
property Guid WebApplicationId {
    Guid get ();
}
member WebApplicationId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.WebId Property

WBWorkflowApplicationWebId Property Datapolis Process System Class Reference
Site ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WebId { get; }
Public ReadOnly Property WebId As Guid
    Get
public:
property Guid WebId {
    Guid get ();
}
member WebId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.WorkflowAssociationId Property

WBWorkflowApplicationWorkflowAssociationId Property Datapolis Process System Class Reference
Workfow association ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WorkflowAssociationId { get; }
Public ReadOnly Property WorkflowAssociationId As Guid
    Get
public:
property Guid WorkflowAssociationId {
    Guid get ();
}
member WorkflowAssociationId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication Methods

WBWorkflowApplication Methods Datapolis Process System Class Reference

The WBWorkflowApplication type exposes the following members.

Methods
 | Name | Description
Public method | InitializeNewWorkflowApplication | Initializes new worklow application
Public method | OnLoad | (Overrides WBApplicationOnLoad.)
Public method | OnSave | (Overrides WBApplicationOnSave.)
Public method | OnUpgrade | Upgrades application to the latest version (Inherited from WBApplication.)
Top
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.InitializeNewWorkflowApplication Method

WBWorkflowApplicationInitializeNewWorkflowApplication Method Datapolis Process System Class Reference
Initializes new worklow application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void InitializeNewWorkflowApplication(
    Guid webApplication,
    Guid siteId,
    Guid webId,
    Guid listId,
    Guid workflowAssociationId
)
Public Sub InitializeNewWorkflowApplication (
    webApplication As Guid,
    siteId As Guid,
    webId As Guid,
    listId As Guid,
    workflowAssociationId As Guid
)
public:
void InitializeNewWorkflowApplication(
    Guid webApplication,
    Guid siteId,
    Guid webId,
    Guid listId,
    Guid workflowAssociationId
)
member InitializeNewWorkflowApplication :
        webApplication : Guid *
        siteId : Guid *
        webId : Guid *
        listId : Guid *
        workflowAssociationId : Guid -> unit

Parameters

webApplication
Type: SystemGuid
SPWebApplicaiton ID
siteId
Type: SystemGuid
SPSite ID
webId
Type: SystemGuid
SPWeb ID
listId
Type: SystemGuid
SPList ID
workflowAssociationId
Type: SystemGuid
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.OnLoad Method

WBWorkflowApplicationOnLoad Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnLoad()
Public Overrides Sub OnLoad
public:
virtual void OnLoad() override
abstract OnLoad : unit -> unit
override OnLoad : unit -> unit
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplication.OnSave Method

WBWorkflowApplicationOnSave Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnSave()
Public Overrides Sub OnSave
public:
virtual void OnSave() override
abstract OnSave : unit -> unit
override OnSave : unit -> unit
See Also

Reference

WBWorkflowApplication Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance Class

WBWorkflowApplicationInstance Class Datapolis Process System Class Reference
Instance of a workflow application, represents a Datapolis workflow instance. Workflow application instance can be started and terminated, it is finished by a workflow.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationInstance
Datapolis.WorkBox.Common.SolutionsWBWorkflowApplicationInstance

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBWorkflowApplicationInstance : WBApplicationInstance
Public Class WBWorkflowApplicationInstance
    Inherits WBApplicationInstance
public ref class WBWorkflowApplicationInstance : public WBApplicationInstance
type WBWorkflowApplicationInstance =
    class
        inherit WBApplicationInstance
    end

The WBWorkflowApplicationInstance type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowApplicationInstance | Initializes a new instance of the WBWorkflowApplicationInstance class
Top
Properties
 | Name | Description
Public property | ApplicationInstanceContent | Content (configuration) of the application instance in form of XML (Inherited from WBApplicationInstance.)
Public property | ApplicationInstanceId | Unique identifier (Inherited from WBApplicationInstance.)
Public property | Id | Identifier in the Datapolis database (Inherited from WBApplicationInstance.)
Public property | InitiatorSiteId | ID of SPSite where the instance was started (Inherited from WBApplicationInstance.)
Public property | InitiatorWebApplicationId | ID of SPWebApplication where the instance was started (Inherited from WBApplicationInstance.)
Public property | InitiatorWebId | ID of SPWeb where the instance was started (Inherited from WBApplicationInstance.)
Public property | InitiatorWorkflowInstanceId | ID of the workflow instance that started the application (Inherited from WBApplicationInstance.)
Public property | ItemId | ID of the item on which the workflow is running
Public property | ParentApplication | Parent object of type WBApplication (Inherited from WBApplicationInstance.)
Public property | ParentApplicationInstanceId | Unique identifier of the parent instance (Inherited from WBApplicationInstance.)
Public property | Status | Status of the application instance (Inherited from WBApplicationInstance.)
Public property | Url | Url always must be absolute address. (Inherited from WBApplicationInstance.)
Public property | WorkflowInstanceId | Workflow Instance ID
Top
Methods
 | Name | Description
Public method | OnLoad | Parses configuration (Overrides WBApplicationInstanceOnLoad.)
Public method | OnSave | Saves configuration (Overrides WBApplicationInstanceOnSave.)
Public method | Start | Start the instance (Overrides WBApplicationInstanceStart(WBApplicationInstanceParameterCollection).)
Public method | Terminate | Terminates the instance. E.g. when workflow that initiated this instance moves to another state. (Overrides WBApplicationInstanceTerminate.)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance Constructor

WBWorkflowApplicationInstance Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBWorkflowApplicationInstance class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowApplicationInstance()
Public Sub New
public:
WBWorkflowApplicationInstance()
new : unit -> WBWorkflowApplicationInstance
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance Properties

WBWorkflowApplicationInstance Properties Datapolis Process System Class Reference

The WBWorkflowApplicationInstance type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationInstanceContent | Content (configuration) of the application instance in form of XML (Inherited from WBApplicationInstance.)
Public property | ApplicationInstanceId | Unique identifier (Inherited from WBApplicationInstance.)
Public property | Id | Identifier in the Datapolis database (Inherited from WBApplicationInstance.)
Public property | InitiatorSiteId | ID of SPSite where the instance was started (Inherited from WBApplicationInstance.)
Public property | InitiatorWebApplicationId | ID of SPWebApplication where the instance was started (Inherited from WBApplicationInstance.)
Public property | InitiatorWebId | ID of SPWeb where the instance was started (Inherited from WBApplicationInstance.)
Public property | InitiatorWorkflowInstanceId | ID of the workflow instance that started the application (Inherited from WBApplicationInstance.)
Public property | ItemId | ID of the item on which the workflow is running
Public property | ParentApplication | Parent object of type WBApplication (Inherited from WBApplicationInstance.)
Public property | ParentApplicationInstanceId | Unique identifier of the parent instance (Inherited from WBApplicationInstance.)
Public property | Status | Status of the application instance (Inherited from WBApplicationInstance.)
Public property | Url | Url always must be absolute address. (Inherited from WBApplicationInstance.)
Public property | WorkflowInstanceId | Workflow Instance ID
Top
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance.ItemId Property

WBWorkflowApplicationInstanceItemId Property Datapolis Process System Class Reference
ID of the item on which the workflow is running

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int ItemId { get; }
Public ReadOnly Property ItemId As Integer
    Get
public:
property int ItemId {
    int get ();
}
member ItemId : int with get

Property Value

Type: Int32
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance.WorkflowInstanceId Property

WBWorkflowApplicationInstanceWorkflowInstanceId Property Datapolis Process System Class Reference
Workflow Instance ID

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WorkflowInstanceId { get; }
Public ReadOnly Property WorkflowInstanceId As Guid
    Get
public:
property Guid WorkflowInstanceId {
    Guid get ();
}
member WorkflowInstanceId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance Methods

WBWorkflowApplicationInstance Methods Datapolis Process System Class Reference

The WBWorkflowApplicationInstance type exposes the following members.

Methods
 | Name | Description
Public method | OnLoad | Parses configuration (Overrides WBApplicationInstanceOnLoad.)
Public method | OnSave | Saves configuration (Overrides WBApplicationInstanceOnSave.)
Public method | Start | Start the instance (Overrides WBApplicationInstanceStart(WBApplicationInstanceParameterCollection).)
Public method | Terminate | Terminates the instance. E.g. when workflow that initiated this instance moves to another state. (Overrides WBApplicationInstanceTerminate.)
Top
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance.OnLoad Method

WBWorkflowApplicationInstanceOnLoad Method Datapolis Process System Class Reference
Parses configuration

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnLoad()
Public Overrides Sub OnLoad
public:
virtual void OnLoad() override
abstract OnLoad : unit -> unit
override OnLoad : unit -> unit
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance.OnSave Method

WBWorkflowApplicationInstanceOnSave Method Datapolis Process System Class Reference
Saves configuration

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnSave()
Public Overrides Sub OnSave
public:
virtual void OnSave() override
abstract OnSave : unit -> unit
override OnSave : unit -> unit
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance.Start Method

WBWorkflowApplicationInstanceStart Method Datapolis Process System Class Reference
Start the instance

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Start(
    WBApplicationInstanceParameterCollection parametersIn
)
Public Overrides Sub Start (
    parametersIn As WBApplicationInstanceParameterCollection
)
public:
virtual void Start(
    WBApplicationInstanceParameterCollection^ parametersIn
) override
abstract Start :
        parametersIn : WBApplicationInstanceParameterCollection -> unit
override Start :
        parametersIn : WBApplicationInstanceParameterCollection -> unit

Parameters

parametersIn
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationInstanceParameterCollection
Collection of input parameters
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationInstance.Terminate Method

WBWorkflowApplicationInstanceTerminate Method Datapolis Process System Class Reference
Terminates the instance. E.g. when workflow that initiated this instance moves to another state.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Terminate()
Public Overrides Sub Terminate
public:
virtual void Terminate() override
abstract Terminate : unit -> unit
override Terminate : unit -> unit
See Also

Reference

WBWorkflowApplicationInstance Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationTemplate Class

WBWorkflowApplicationTemplate Class Datapolis Process System Class Reference
Template for workflow applications based on Datapolis workflows. It is used in combination with web solution. It assumes that files used by Datapolis designer are available in WorkBoxWorkflows folder
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBApplicationTemplate
Datapolis.WorkBox.Common.SolutionsWBWorkflowApplicationTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBWorkflowApplicationTemplate : WBApplicationTemplate
Public Class WBWorkflowApplicationTemplate
    Inherits WBApplicationTemplate
public ref class WBWorkflowApplicationTemplate : public WBApplicationTemplate
type WBWorkflowApplicationTemplate =
    class
        inherit WBApplicationTemplate
    end

The WBWorkflowApplicationTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowApplicationTemplate | Initializes a new instance of the WBWorkflowApplicationTemplate class
Top
Properties
 | Name | Description
Public property | Assembly | Assembly of the application, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8" (Inherited from WBApplicationTemplate.)
Public property | Class | Class of the application, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplication" (Inherited from WBApplicationTemplate.)
Public property | CustomConfiguration | Custom configuration of the application, e.g. some XML parsed during deployment (Inherited from WBApplicationTemplate.)
Public property | DeploymentControlAssembly | Deployment assembly of the application, e.g. "Datapolis.WorkBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0b41f301d7bd8b8d" (Inherited from WBApplicationTemplate.)
Public property | DeploymentControlClass | Deployment control class of the application, e.g. "Datapolis.WorkBox.ControlTemplates.WBWorkflowApplicationDeploymentControl" (Inherited from WBApplicationTemplate.)
Public property | DeploymentControlVirtualPath | Deployment control virtual path, e.g. "~/_controltemplates/15/WBWorkflowApplicationDeploymentControl.ascx" (Inherited from WBApplicationTemplate.)
Public property | Description | Description of the application (Inherited from WBApplicationTemplate.)
Public property | ID | Unique ID of the application template (Inherited from WBApplicationTemplate.)
Public property | InstanceAssembly | Assembly of the applicaiton instance, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8" (Inherited from WBApplicationTemplate.)
Public property | InstanceClass | Class of the application instnace, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationInstance" (Inherited from WBApplicationTemplate.)
Public property | IsPrivate | Is application private or public (Inherited from WBApplicationTemplate.)
Public property | SolutionTemplateID | Unique ID of the parent solution template (Inherited from WBApplicationTemplate.)
Public property | TemplateAssembly | Template assembly, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8" (Inherited from WBApplicationTemplate.)
Public property | TemplateClass | Class of the application template, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationTemplate" (Inherited from WBApplicationTemplate.)
Public property | TemplateXml | XML template that defines this application (Inherited from WBApplicationTemplate.)
Public property | Title | Title of the application (Inherited from WBApplicationTemplate.)
Top
Methods
 | Name | Description
Public method | Deploy | Deploys the application (Overrides WBApplicationTemplateDeploy(WBApplicationTemplateDeploymentControl, WBApplication, WBSolution).)
Public method | Remove | Sets status of the application to removed (Overrides WBApplicationTemplateRemove(WBApplication).)
Public method | Upgrade | (Overrides WBApplicationTemplateUpgrade(WBApplication).)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationTemplate Constructor

WBWorkflowApplicationTemplate Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBWorkflowApplicationTemplate class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowApplicationTemplate()
Public Sub New
public:
WBWorkflowApplicationTemplate()
new : unit -> WBWorkflowApplicationTemplate
See Also

Reference

WBWorkflowApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationTemplate Properties

WBWorkflowApplicationTemplate Properties Datapolis Process System Class Reference

The WBWorkflowApplicationTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Assembly of the application, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8" (Inherited from WBApplicationTemplate.)
Public property | Class | Class of the application, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplication" (Inherited from WBApplicationTemplate.)
Public property | CustomConfiguration | Custom configuration of the application, e.g. some XML parsed during deployment (Inherited from WBApplicationTemplate.)
Public property | DeploymentControlAssembly | Deployment assembly of the application, e.g. "Datapolis.WorkBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0b41f301d7bd8b8d" (Inherited from WBApplicationTemplate.)
Public property | DeploymentControlClass | Deployment control class of the application, e.g. "Datapolis.WorkBox.ControlTemplates.WBWorkflowApplicationDeploymentControl" (Inherited from WBApplicationTemplate.)
Public property | DeploymentControlVirtualPath | Deployment control virtual path, e.g. "~/_controltemplates/15/WBWorkflowApplicationDeploymentControl.ascx" (Inherited from WBApplicationTemplate.)
Public property | Description | Description of the application (Inherited from WBApplicationTemplate.)
Public property | ID | Unique ID of the application template (Inherited from WBApplicationTemplate.)
Public property | InstanceAssembly | Assembly of the applicaiton instance, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8" (Inherited from WBApplicationTemplate.)
Public property | InstanceClass | Class of the application instnace, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationInstance" (Inherited from WBApplicationTemplate.)
Public property | IsPrivate | Is application private or public (Inherited from WBApplicationTemplate.)
Public property | SolutionTemplateID | Unique ID of the parent solution template (Inherited from WBApplicationTemplate.)
Public property | TemplateAssembly | Template assembly, e.g. "Datapolis.WorkBox.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=2c03c3097ac016b8" (Inherited from WBApplicationTemplate.)
Public property | TemplateClass | Class of the application template, e.g. "Datapolis.WorkBox.Common.Solutions.WBWorkflowApplicationTemplate" (Inherited from WBApplicationTemplate.)
Public property | TemplateXml | XML template that defines this application (Inherited from WBApplicationTemplate.)
Public property | Title | Title of the application (Inherited from WBApplicationTemplate.)
Top
See Also

Reference

WBWorkflowApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationTemplate Methods

WBWorkflowApplicationTemplate Methods Datapolis Process System Class Reference

The WBWorkflowApplicationTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Deploy | Deploys the application (Overrides WBApplicationTemplateDeploy(WBApplicationTemplateDeploymentControl, WBApplication, WBSolution).)
Public method | Remove | Sets status of the application to removed (Overrides WBApplicationTemplateRemove(WBApplication).)
Public method | Upgrade | (Overrides WBApplicationTemplateUpgrade(WBApplication).)
Top
See Also

Reference

WBWorkflowApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationTemplate.Deploy Method

WBWorkflowApplicationTemplateDeploy Method Datapolis Process System Class Reference
Deploys the application

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Deploy(
    WBApplicationTemplateDeploymentControl control,
    WBApplication application,
    WBSolution solution
)
Public Overrides Sub Deploy (
    control As WBApplicationTemplateDeploymentControl,
    application As WBApplication,
    solution As WBSolution
)
public:
virtual void Deploy(
    WBApplicationTemplateDeploymentControl^ control,
    WBApplication^ application,
    WBSolution^ solution
) override
abstract Deploy :
        control : WBApplicationTemplateDeploymentControl *
        application : WBApplication *
        solution : WBSolution -> unit
override Deploy :
        control : WBApplicationTemplateDeploymentControl *
        application : WBApplication *
        solution : WBSolution -> unit

Parameters

control
Type: Datapolis.WorkBox.Common.SolutionsWBApplicationTemplateDeploymentControl
Deployment control
application
Type: Datapolis.WorkBox.Common.SolutionsWBApplication
Application to deploy
solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
Parent solution
See Also

Reference

WBWorkflowApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationTemplate.Remove Method

WBWorkflowApplicationTemplateRemove Method Datapolis Process System Class Reference
Sets status of the application to removed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Remove(
    WBApplication application
)
Public Overrides Sub Remove (
    application As WBApplication
)
public:
virtual void Remove(
    WBApplication^ application
) override
abstract Remove :
        application : WBApplication -> unit
override Remove :
        application : WBApplication -> unit

Parameters

application
Type: Datapolis.WorkBox.Common.SolutionsWBApplication
Application to remove
See Also

Reference

WBWorkflowApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowApplicationTemplate.Upgrade Method

WBWorkflowApplicationTemplateUpgrade Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Upgrade(
    WBApplication application
)
Public Overrides Sub Upgrade (
    application As WBApplication
)
public:
virtual void Upgrade(
    WBApplication^ application
) override
abstract Upgrade :
        application : WBApplication -> unit
override Upgrade :
        application : WBApplication -> unit

Parameters

application
Type: Datapolis.WorkBox.Common.SolutionsWBApplication
See Also

Reference

WBWorkflowApplicationTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowDefaultSolution Class

WBWorkflowDefaultSolution Class Datapolis Process System Class Reference
Default solution to wich all the workflows are added (e.g. when there is "workflows only" license). All workflows created before "Datapolis Process System" belong to this solution.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolution
Datapolis.WorkBox.Common.SolutionsWBWorkflowDefaultSolution

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBWorkflowDefaultSolution : WBSolution
Public NotInheritable Class WBWorkflowDefaultSolution
    Inherits WBSolution
public ref class WBWorkflowDefaultSolution sealed : public WBSolution
[<SealedAttribute>]
type WBWorkflowDefaultSolution =
    class
        inherit WBSolution
    end

The WBWorkflowDefaultSolution type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowDefaultSolution | Constructor of WBWorkflowDefaultSolution. This solution is always deployed and it cannot be modified.
Top
Properties
 | Name | Description
Public property | Applications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public property | Configuration | Custom string for specific configuration of solution (like custom xml) (Inherited from WBSolution.)
Public property | Description | Description of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | IconUrl | Relative (from solution folder) Url to solution icon (Inherited from WBSolution.)
Public property | Id | Id of solution record in database (Inherited from WBSolution.)
Public property | InternalName | Internal name of the solution, set during deployment. It should uniqually identify the solution (Inherited from WBSolution.)
Public property | Name | Name of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | Notification | Notification shown on solution settings page Contains notes/errors of solution to be shown for administrator (Inherited from WBSolution.)
Public property | SolutionId | Unique solution ID (Inherited from WBSolution.)
Public property | SolutionObjects | Objects that belong to this solution, e.g. workflows, applications (Inherited from WBSolution.)
Public property | SolutionTemplateId | Unique ID of template from which this solutio was deployed (Inherited from WBSolution.)
Public property | Status | Actual status of solution (Inherited from WBSolution.)
Public property | TemplateVersion | Version of the template on which the solution is based. (Inherited from WBSolution.)
Public property | TemplateXml | XML template on which the solution is based (Inherited from WBSolution.)
Public property | Upgradable | Can this solution be upgraded? Value is based on current Version and version stored in xml in SharePoint Root. (Inherited from WBSolution.)
Public property | Version | Version of the solution, used to check whether there is an upgrade available (Inherited from WBSolution.)
Top
Methods
 | Name | Description
Public method | GetApplications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public method | GetCustomParameters | Gets custom parameters of Solution as value-key collection. (Inherited from WBSolution.)
Public method | OnLoad | (Overrides WBSolutionOnLoad.)
Public method | OnSave | (Overrides WBSolutionOnSave.)
Public method | OnUpgrade | (Overrides WBSolutionOnUpgrade.)
Public method | SetStatus | Updates status of the solution. Call (Inherited from WBSolution.)
Public method | StatusDetails | Actual status details of solution (Inherited from WBSolution.)
Public method | Update | Updates this solution object with values (if not null) (Inherited from WBSolution.)
Public method | ValidLicense(String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Public method | ValidLicense(String, String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowDefaultSolution Constructor

WBWorkflowDefaultSolution Constructor Datapolis Process System Class Reference
Constructor of WBWorkflowDefaultSolution. This solution is always deployed and it cannot be modified.

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowDefaultSolution()
Public Sub New
public:
WBWorkflowDefaultSolution()
new : unit -> WBWorkflowDefaultSolution
See Also

Reference

WBWorkflowDefaultSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowDefaultSolution Properties

WBWorkflowDefaultSolution Properties Datapolis Process System Class Reference

The WBWorkflowDefaultSolution type exposes the following members.

Properties
 | Name | Description
Public property | Applications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public property | Configuration | Custom string for specific configuration of solution (like custom xml) (Inherited from WBSolution.)
Public property | Description | Description of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | IconUrl | Relative (from solution folder) Url to solution icon (Inherited from WBSolution.)
Public property | Id | Id of solution record in database (Inherited from WBSolution.)
Public property | InternalName | Internal name of the solution, set during deployment. It should uniqually identify the solution (Inherited from WBSolution.)
Public property | Name | Name of solution displayed on solution settings page (Inherited from WBSolution.)
Public property | Notification | Notification shown on solution settings page Contains notes/errors of solution to be shown for administrator (Inherited from WBSolution.)
Public property | SolutionId | Unique solution ID (Inherited from WBSolution.)
Public property | SolutionObjects | Objects that belong to this solution, e.g. workflows, applications (Inherited from WBSolution.)
Public property | SolutionTemplateId | Unique ID of template from which this solutio was deployed (Inherited from WBSolution.)
Public property | Status | Actual status of solution (Inherited from WBSolution.)
Public property | TemplateVersion | Version of the template on which the solution is based. (Inherited from WBSolution.)
Public property | TemplateXml | XML template on which the solution is based (Inherited from WBSolution.)
Public property | Upgradable | Can this solution be upgraded? Value is based on current Version and version stored in xml in SharePoint Root. (Inherited from WBSolution.)
Public property | Version | Version of the solution, used to check whether there is an upgrade available (Inherited from WBSolution.)
Top
See Also

Reference

WBWorkflowDefaultSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowDefaultSolution Methods

WBWorkflowDefaultSolution Methods Datapolis Process System Class Reference

The WBWorkflowDefaultSolution type exposes the following members.

Methods
 | Name | Description
Public method | GetApplications | Returns all applications belonging to this solution (Inherited from WBSolution.)
Public method | GetCustomParameters | Gets custom parameters of Solution as value-key collection. (Inherited from WBSolution.)
Public method | OnLoad | (Overrides WBSolutionOnLoad.)
Public method | OnSave | (Overrides WBSolutionOnSave.)
Public method | OnUpgrade | (Overrides WBSolutionOnUpgrade.)
Public method | SetStatus | Updates status of the solution. Call (Inherited from WBSolution.)
Public method | StatusDetails | Actual status details of solution (Inherited from WBSolution.)
Public method | Update | Updates this solution object with values (if not null) (Inherited from WBSolution.)
Public method | ValidLicense(String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Public method | ValidLicense(String, String) | Returns true if there is a valid license for solution and product (Inherited from WBSolution.)
Top
See Also

Reference

WBWorkflowDefaultSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowDefaultSolution.OnLoad Method

WBWorkflowDefaultSolutionOnLoad Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnLoad()
Public Overrides Sub OnLoad
public:
virtual void OnLoad() override
abstract OnLoad : unit -> unit
override OnLoad : unit -> unit
See Also

Reference

WBWorkflowDefaultSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowDefaultSolution.OnSave Method

WBWorkflowDefaultSolutionOnSave Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnSave()
Public Overrides Sub OnSave
public:
virtual void OnSave() override
abstract OnSave : unit -> unit
override OnSave : unit -> unit
See Also

Reference

WBWorkflowDefaultSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowDefaultSolution.OnUpgrade Method

WBWorkflowDefaultSolutionOnUpgrade Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void OnUpgrade()
Public Overrides Sub OnUpgrade
public:
virtual void OnUpgrade() override
abstract OnUpgrade : unit -> unit
override OnUpgrade : unit -> unit
See Also

Reference

WBWorkflowDefaultSolution Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowSolutionTemplate Class

WBWorkflowSolutionTemplate Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SolutionsWBSolutionTemplate
Datapolis.WorkBox.Common.SolutionsWBWorkflowSolutionTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBWorkflowSolutionTemplate : WBSolutionTemplate
Public Class WBWorkflowSolutionTemplate
    Inherits WBSolutionTemplate
public ref class WBWorkflowSolutionTemplate : public WBSolutionTemplate
type WBWorkflowSolutionTemplate =
    class
        inherit WBSolutionTemplate
    end

The WBWorkflowSolutionTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowSolutionTemplate | Constructor of WBWorkflowSolutionTemplate
Top
Properties
 | Name | Description
Public property | Active | Is template active (Inherited from WBSolutionTemplate.)
Public property | AllowUpgrade | Does the template allow for upgrades (Inherited from WBSolutionTemplate.)
Public property | CustomConfiguration | Custom configuration of the solution, e.g. some XML parsed during deployment (Inherited from WBSolutionTemplate.)
Public property | Description | Description of the application template (Inherited from WBSolutionTemplate.)
Public property | ID | Unique ID of the solution template (Inherited from WBSolutionTemplate.)
Public property | Title | Title of the solution template (Inherited from WBSolutionTemplate.)
Public property | Version | Version of the solution template (Inherited from WBSolutionTemplate.)
Top
Methods
 | Name | Description
Public method | Deploy | In a custom solution template the methods below would do what they are supposed to, but this solution template cannot be changed (Overrides WBSolutionTemplateDeploy(WBSolutionTemplateDeploymentControl, WBSolution).)
Public method | Remove | (Overrides WBSolutionTemplateRemove(WBSolution).)
Public method | Upgrade | (Overrides WBSolutionTemplateUpgrade(WBSolution).)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowSolutionTemplate Constructor

WBWorkflowSolutionTemplate Constructor Datapolis Process System Class Reference
Constructor of WBWorkflowSolutionTemplate

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowSolutionTemplate()
Public Sub New
public:
WBWorkflowSolutionTemplate()
new : unit -> WBWorkflowSolutionTemplate
See Also

Reference

WBWorkflowSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowSolutionTemplate Properties

WBWorkflowSolutionTemplate Properties Datapolis Process System Class Reference

The WBWorkflowSolutionTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Active | Is template active (Inherited from WBSolutionTemplate.)
Public property | AllowUpgrade | Does the template allow for upgrades (Inherited from WBSolutionTemplate.)
Public property | CustomConfiguration | Custom configuration of the solution, e.g. some XML parsed during deployment (Inherited from WBSolutionTemplate.)
Public property | Description | Description of the application template (Inherited from WBSolutionTemplate.)
Public property | ID | Unique ID of the solution template (Inherited from WBSolutionTemplate.)
Public property | Title | Title of the solution template (Inherited from WBSolutionTemplate.)
Public property | Version | Version of the solution template (Inherited from WBSolutionTemplate.)
Top
See Also

Reference

WBWorkflowSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowSolutionTemplate Methods

WBWorkflowSolutionTemplate Methods Datapolis Process System Class Reference

The WBWorkflowSolutionTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Deploy | In a custom solution template the methods below would do what they are supposed to, but this solution template cannot be changed (Overrides WBSolutionTemplateDeploy(WBSolutionTemplateDeploymentControl, WBSolution).)
Public method | Remove | (Overrides WBSolutionTemplateRemove(WBSolution).)
Public method | Upgrade | (Overrides WBSolutionTemplateUpgrade(WBSolution).)
Top
See Also

Reference

WBWorkflowSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowSolutionTemplate.Deploy Method

WBWorkflowSolutionTemplateDeploy Method Datapolis Process System Class Reference
In a custom solution template the methods below would do what they are supposed to, but this solution template cannot be changed

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override string Deploy(
    WBSolutionTemplateDeploymentControl control,
    WBSolution solution
)
Public Overrides Function Deploy (
    control As WBSolutionTemplateDeploymentControl,
    solution As WBSolution
) As String
public:
virtual String^ Deploy(
    WBSolutionTemplateDeploymentControl^ control,
    WBSolution^ solution
) override
abstract Deploy :
        control : WBSolutionTemplateDeploymentControl *
        solution : WBSolution -> string
override Deploy :
        control : WBSolutionTemplateDeploymentControl *
        solution : WBSolution -> string

Parameters

control
Type: Datapolis.WorkBox.Common.SolutionsWBSolutionTemplateDeploymentControl
solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution

Return Value

Type: String
See Also

Reference

WBWorkflowSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowSolutionTemplate.Remove Method

WBWorkflowSolutionTemplateRemove Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Remove(
    WBSolution solution
)
Public Overrides Sub Remove (
    solution As WBSolution
)
public:
virtual void Remove(
    WBSolution^ solution
) override
abstract Remove :
        solution : WBSolution -> unit
override Remove :
        solution : WBSolution -> unit

Parameters

solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
See Also

Reference

WBWorkflowSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBWorkflowSolutionTemplate.Upgrade Method

WBWorkflowSolutionTemplateUpgrade Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void Upgrade(
    WBSolution solution
)
Public Overrides Sub Upgrade (
    solution As WBSolution
)
public:
virtual void Upgrade(
    WBSolution^ solution
) override
abstract Upgrade :
        solution : WBSolution -> unit
override Upgrade :
        solution : WBSolution -> unit

Parameters

solution
Type: Datapolis.WorkBox.Common.SolutionsWBSolution
See Also

Reference

WBWorkflowSolutionTemplate Class
Datapolis.WorkBox.Common.Solutions Namespace


WBXmlParserException Class

WBXmlParserException Class Datapolis Process System Class Reference
Exception thrown during templates XML parsing
Inheritance Hierarchy
SystemObject
SystemException
Datapolis.WorkBox.Common.SolutionsWBXmlParserException

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBXmlParserException : Exception
Public Class WBXmlParserException
    Inherits Exception
public ref class WBXmlParserException : public Exception
type WBXmlParserException =
    class
        inherit Exception
    end

The WBXmlParserException type exposes the following members.

Constructors
 | Name | Description
Public method | WBXmlParserException | Initializes a new instance of the WBXmlParserException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions Namespace


WBXmlParserException Constructor

WBXmlParserException Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBXmlParserException class

Namespace: Datapolis.WorkBox.Common.Solutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBXmlParserException(
    string message,
    Exception exception
)
Public Sub New (
    message As String,
    exception As Exception
)
public:
WBXmlParserException(
    String^ message,
    Exception^ exception
)
new :
        message : string *
        exception : Exception -> WBXmlParserException

Parameters

message
Type: SystemString
exception
Type: SystemException
See Also

Reference

WBXmlParserException Class
Datapolis.WorkBox.Common.Solutions Namespace


WBXmlParserException Properties

WBXmlParserException Properties Datapolis Process System Class Reference

The WBXmlParserException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

WBXmlParserException Class
Datapolis.WorkBox.Common.Solutions Namespace


WBXmlParserException Methods

WBXmlParserException Methods Datapolis Process System Class Reference

The WBXmlParserException type exposes the following members.

Methods
 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

WBXmlParserException Class
Datapolis.WorkBox.Common.Solutions Namespace


WBXmlParserException Events

WBXmlParserException Events Datapolis Process System Class Reference

The WBXmlParserException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

WBXmlParserException Class
Datapolis.WorkBox.Common.Solutions Namespace


Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace

Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBApplication | Object that contains data needed for handling Application Finished event inside workflows
Public class | WBApplicationEventArgs | Event args for handling Application Finished event in workflows
Public class | WBApplicationService | Service that is used to handle Application Finished event inside workflow
Interfaces
 | Interface | Description
Public interface | IWBApplicationService | Service interface that is used to handle Application Finished event inside workflow


IWBApplicationService Interface

IWBApplicationService Interface Datapolis Process System Class Reference
Service interface that is used to handle Application Finished event inside workflow

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public interface IWBApplicationService
Public Interface IWBApplicationService
public interface class IWBApplicationService
type IWBApplicationService =  interface end

The IWBApplicationService type exposes the following members.

Events
 | Name | Description
Public event | WBApplicationEvent |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


IWBApplicationService Events

IWBApplicationService Events Datapolis Process System Class Reference

The IWBApplicationService type exposes the following members.

Events
 | Name | Description
Public event | WBApplicationEvent |
Top
See Also

Reference

IWBApplicationService Interface
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


IWBApplicationService.WBApplicationEvent Event

IWBApplicationServiceWBApplicationEvent Event Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<WBApplicationEventArgs> WBApplicationEvent
Event WBApplicationEvent As EventHandler(Of WBApplicationEventArgs)
 event EventHandler<WBApplicationEventArgs^>^ WBApplicationEvent {
    void add (EventHandler<WBApplicationEventArgs^>^ value);
    void remove (EventHandler<WBApplicationEventArgs^>^ value);
}
abstract WBApplicationEvent : IEvent<EventHandler<WBApplicationEventArgs>,
    WBApplicationEventArgs>

Value

Type: SystemEventHandler WBApplicationEventArgs
See Also

Reference

IWBApplicationService Interface
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication Class

WBApplication Class Datapolis Process System Class Reference
Object that contains data needed for handling Application Finished event inside workflows
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.Solutions.ApplicationsEventsWBApplication

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WBApplication : ISerializable
<SerializableAttribute>
Public Class WBApplication
    Implements ISerializable
[SerializableAttribute]
public ref class WBApplication : ISerializable
[<SerializableAttribute>]
type WBApplication =
    class
        interface ISerializable
    end

The WBApplication type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplication | Initializes a new instance of the WBApplication class
Public method | WBApplication(SerializationInfo, StreamingContext) | Initializes a new instance of the WBApplication class
Top
Properties
 | Name | Description
Public property | ID |
Public property | Title |
Top
Methods
 | Name | Description
Public method | GetObjectData |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication Constructor

WBApplication Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBApplication | Initializes a new instance of the WBApplication class
Public method | WBApplication(SerializationInfo, StreamingContext) | Initializes a new instance of the WBApplication class
Top
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication Constructor

WBApplication Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplication class

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplication()
Public Sub New
public:
WBApplication()
new : unit -> WBApplication
See Also

Reference

WBApplication Class
WBApplication Overload
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication Constructor (SerializationInfo, StreamingContext)

WBApplication Constructor (SerializationInfo, StreamingContext) Datapolis Process System Class Reference
Initializes a new instance of the WBApplication class

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplication(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
WBApplication(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> WBApplication

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

WBApplication Class
WBApplication Overload
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication Properties

WBApplication Properties Datapolis Process System Class Reference

The WBApplication type exposes the following members.

Properties
 | Name | Description
Public property | ID |
Public property | Title |
Top
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication.ID Property

WBApplicationID Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication.Title Property

WBApplicationTitle Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication Methods

WBApplication Methods Datapolis Process System Class Reference

The WBApplication type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData |
Top
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplication.GetObjectData Method

WBApplicationGetObjectData Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

WBApplication Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs Class

WBApplicationEventArgs Class Datapolis Process System Class Reference
Event args for handling Application Finished event in workflows
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.Workflow.ActivitiesExternalDataEventArgs
Datapolis.WorkBox.Common.Solutions.ApplicationsEventsWBApplicationEventArgs

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WBApplicationEventArgs : ExternalDataEventArgs
<SerializableAttribute>
Public Class WBApplicationEventArgs
    Inherits ExternalDataEventArgs
[SerializableAttribute]
public ref class WBApplicationEventArgs : public ExternalDataEventArgs
[<SerializableAttribute>]
type WBApplicationEventArgs =
    class
        inherit ExternalDataEventArgs
    end

The WBApplicationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationEventArgs | Initializes a new instance of the WBApplicationEventArgs class
Top
Properties
 | Name | Description
Public property | Identity | Gets or sets the identity of the user that raised the event. (Inherited from ExternalDataEventArgs.)
Public property | InstanceId | Gets or sets the workflow instance identifier for the workflow instance that contains the HandleExternalEventActivity that is expected to handle the event. (Inherited from ExternalDataEventArgs.)
Public property | WaitForIdle | Gets or sets a value that indicates whether the event should be raised immediately, or if the workflow should go idle before raising the event. (Inherited from ExternalDataEventArgs.)
Public property | WorkHandler | Gets or sets the IPendingWork to allow the external code, raising the event, to participate in the batch. (Inherited from ExternalDataEventArgs.)
Public property | WorkItem | Gets or sets the object that contains the external code that raises the event. (Inherited from ExternalDataEventArgs.)
Top
Fields
 | Name | Description
Public field | ApplicationDefinitionId |
Public field | ApplicationId |
Public field | Parameters |
Public field | SomeText |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs Constructor

WBApplicationEventArgs Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationEventArgs class

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationEventArgs(
    Guid id
)
Public Sub New (
    id As Guid
)
public:
WBApplicationEventArgs(
    Guid id
)
new :
        id : Guid -> WBApplicationEventArgs

Parameters

id
Type: SystemGuid
See Also

Reference

WBApplicationEventArgs Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs Properties

WBApplicationEventArgs Properties Datapolis Process System Class Reference

The WBApplicationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Identity | Gets or sets the identity of the user that raised the event. (Inherited from ExternalDataEventArgs.)
Public property | InstanceId | Gets or sets the workflow instance identifier for the workflow instance that contains the HandleExternalEventActivity that is expected to handle the event. (Inherited from ExternalDataEventArgs.)
Public property | WaitForIdle | Gets or sets a value that indicates whether the event should be raised immediately, or if the workflow should go idle before raising the event. (Inherited from ExternalDataEventArgs.)
Public property | WorkHandler | Gets or sets the IPendingWork to allow the external code, raising the event, to participate in the batch. (Inherited from ExternalDataEventArgs.)
Public property | WorkItem | Gets or sets the object that contains the external code that raises the event. (Inherited from ExternalDataEventArgs.)
Top
See Also

Reference

WBApplicationEventArgs Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs Fields

WBApplicationEventArgs Fields Datapolis Process System Class Reference

The WBApplicationEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | ApplicationDefinitionId |
Public field | ApplicationId |
Public field | Parameters |
Public field | SomeText |
Top
See Also

Reference

WBApplicationEventArgs Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs.ApplicationDefinitionId Field

WBApplicationEventArgsApplicationDefinitionId Field Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ApplicationDefinitionId
Public ApplicationDefinitionId As Guid
public:
Guid ApplicationDefinitionId
val mutable ApplicationDefinitionId: Guid

Field Value

Type: Guid
See Also

Reference

WBApplicationEventArgs Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs.ApplicationId Field

WBApplicationEventArgsApplicationId Field Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ApplicationId
Public ApplicationId As Guid
public:
Guid ApplicationId
val mutable ApplicationId: Guid

Field Value

Type: Guid
See Also

Reference

WBApplicationEventArgs Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs.Parameters Field

WBApplicationEventArgsParameters Field Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string Parameters
Public Parameters As String
public:
String^ Parameters
val mutable Parameters: string

Field Value

Type: String
See Also

Reference

WBApplicationEventArgs Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationEventArgs.SomeText Field

WBApplicationEventArgsSomeText Field Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string SomeText
Public SomeText As String
public:
String^ SomeText
val mutable SomeText: string

Field Value

Type: String
See Also

Reference

WBApplicationEventArgs Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService Class

WBApplicationService Class Datapolis Process System Class Reference
Service that is used to handle Application Finished event inside workflow
Inheritance Hierarchy
SystemObject
SPWorkflowExternalDataExchangeService
Datapolis.WorkBox.Common.Solutions.ApplicationsEventsWBApplicationService

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationService : SPWorkflowExternalDataExchangeService,
    IWBApplicationService
Public Class WBApplicationService
    Inherits SPWorkflowExternalDataExchangeService
    Implements IWBApplicationService
public ref class WBApplicationService : public SPWorkflowExternalDataExchangeService,
    IWBApplicationService
type WBApplicationService =
    class
        inherit SPWorkflowExternalDataExchangeService
        interface IWBApplicationService
    end

The WBApplicationService type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationService | Initializes a new instance of the WBApplicationService class
Top
Properties
 | Name | Description
Public property | CurrentWorkflow | (Inherited from SPWorkflowExternalDataExchangeService.)
Public property | ParentCollection | (Inherited from SPWorkflowExternalDataExchangeService.)
Public property | PendingWorkBatch | (Inherited from SPWorkflowExternalDataExchangeService.)
Top
Methods
 | Name | Description
Public method | AddBatch | (Inherited from SPWorkflowExternalDataExchangeService.)
Public method | AfterWorkflowRun | (Inherited from SPWorkflowExternalDataExchangeService.)
Public method | BeforeWorkflowRun | (Inherited from SPWorkflowExternalDataExchangeService.)
Public method | CallEventHandler | Called when event is handled inside workflow. Checks if this is application event and, if yes, handle it. (Overrides SPWorkflowExternalDataExchangeService.CallEventHandler(Type, String, Object, SPWorkflow, String, IPendingWork, Object).)
Public method | CreateSubscription | NOT USED (Overrides SPWorkflowExternalDataExchangeService.CreateSubscription(MessageEventSubscription).)
Public method | DeleteSubscription | NOT USED (Overrides SPWorkflowExternalDataExchangeService.DeleteSubscription(Guid).)
 | ExecuteWBApplicationEvent | Raise event inside workflow - tells workflow to launch methods that are set in xoml to handle this event.
Top
Events
 | Name | Description
Public event | WBApplicationEvent |
Top
See Also

Reference

Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService Constructor

WBApplicationService Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationService class

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationService()
Public Sub New
public:
WBApplicationService()
new : unit -> WBApplicationService
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService Properties

WBApplicationService Properties Datapolis Process System Class Reference

The WBApplicationService type exposes the following members.

Properties
 | Name | Description
Public property | CurrentWorkflow | (Inherited from SPWorkflowExternalDataExchangeService.)
Public property | ParentCollection | (Inherited from SPWorkflowExternalDataExchangeService.)
Public property | PendingWorkBatch | (Inherited from SPWorkflowExternalDataExchangeService.)
Top
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService Methods

WBApplicationService Methods Datapolis Process System Class Reference

The WBApplicationService type exposes the following members.

Methods
 | Name | Description
Public method | AddBatch | (Inherited from SPWorkflowExternalDataExchangeService.)
Public method | AfterWorkflowRun | (Inherited from SPWorkflowExternalDataExchangeService.)
Public method | BeforeWorkflowRun | (Inherited from SPWorkflowExternalDataExchangeService.)
Public method | CallEventHandler | Called when event is handled inside workflow. Checks if this is application event and, if yes, handle it. (Overrides SPWorkflowExternalDataExchangeService.CallEventHandler(Type, String, Object, SPWorkflow, String, IPendingWork, Object).)
Public method | CreateSubscription | NOT USED (Overrides SPWorkflowExternalDataExchangeService.CreateSubscription(MessageEventSubscription).)
Public method | DeleteSubscription | NOT USED (Overrides SPWorkflowExternalDataExchangeService.DeleteSubscription(Guid).)
 | ExecuteWBApplicationEvent | Raise event inside workflow - tells workflow to launch methods that are set in xoml to handle this event.
Top
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService.CallEventHandler Method

WBApplicationServiceCallEventHandler Method Datapolis Process System Class Reference
Called when event is handled inside workflow. Checks if this is application event and, if yes, handle it.

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void CallEventHandler(
    Type eventType,
    string eventName,
    Object[] eventData,
    SPWorkflow workflow,
    string identity,
    IPendingWork workHandler,
    Object workItem
)
Public Overrides Sub CallEventHandler (
    eventType As Type,
    eventName As String,
    eventData As Object(),
    workflow As SPWorkflow,
    identity As String,
    workHandler As IPendingWork,
    workItem As Object
)
public:
virtual void CallEventHandler(
    Type^ eventType,
    String^ eventName,
    array<Object^>^ eventData,
    SPWorkflow^ workflow,
    String^ identity,
    IPendingWork^ workHandler,
    Object^ workItem
) override
abstract CallEventHandler :
        eventType : Type *
        eventName : string *
        eventData : Object[] *
        workflow : SPWorkflow *
        identity : string *
        workHandler : IPendingWork *
        workItem : Object -> unit
override CallEventHandler :
        eventType : Type *
        eventName : string *
        eventData : Object[] *
        workflow : SPWorkflow *
        identity : string *
        workHandler : IPendingWork *
        workItem : Object -> unit

Parameters

eventType
Type: SystemType
eventName
Type: SystemString
eventData
Type: SystemObject
workflow
Type: SPWorkflow
identity
Type: SystemString
workHandler
Type: System.Workflow.RuntimeIPendingWork
workItem
Type: SystemObject
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService.CreateSubscription Method

WBApplicationServiceCreateSubscription Method Datapolis Process System Class Reference
NOT USED

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void CreateSubscription(
    MessageEventSubscription subscription
)
Public Overrides Sub CreateSubscription (
    subscription As MessageEventSubscription
)
public:
virtual void CreateSubscription(
    MessageEventSubscription^ subscription
) override
abstract CreateSubscription :
        subscription : MessageEventSubscription -> unit
override CreateSubscription :
        subscription : MessageEventSubscription -> unit

Parameters

subscription
Type: System.Workflow.ActivitiesMessageEventSubscription
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService.DeleteSubscription Method

WBApplicationServiceDeleteSubscription Method Datapolis Process System Class Reference
NOT USED

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override void DeleteSubscription(
    Guid subscriptionId
)
Public Overrides Sub DeleteSubscription (
    subscriptionId As Guid
)
public:
virtual void DeleteSubscription(
    Guid subscriptionId
) override
abstract DeleteSubscription :
        subscriptionId : Guid -> unit
override DeleteSubscription :
        subscriptionId : Guid -> unit

Parameters

subscriptionId
Type: SystemGuid
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService.ExecuteWBApplicationEvent Method

WBApplicationServiceExecuteWBApplicationEvent Method Datapolis Process System Class Reference
Raise event inside workflow - tells workflow to launch methods that are set in xoml to handle this event.

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static void ExecuteWBApplicationEvent(
    SPWeb web,
    Guid workflowInstanceId,
    Object[] args
)
Public Shared Sub ExecuteWBApplicationEvent (
    web As SPWeb,
    workflowInstanceId As Guid,
    args As Object()
)
public:
static void ExecuteWBApplicationEvent(
    SPWeb^ web,
    Guid workflowInstanceId,
    array<Object^>^ args
)
static member ExecuteWBApplicationEvent :
        web : SPWeb *
        workflowInstanceId : Guid *
        args : Object[] -> unit

Parameters

web
Type: SPWeb
workflowInstanceId
Type: SystemGuid
args
Type: SystemObject
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService Events

WBApplicationService Events Datapolis Process System Class Reference

The WBApplicationService type exposes the following members.

Events
 | Name | Description
Public event | WBApplicationEvent |
Top
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


WBApplicationService.WBApplicationEvent Event

WBApplicationServiceWBApplicationEvent Event Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Solutions.ApplicationsEvents
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<WBApplicationEventArgs> WBApplicationEvent
Public Event WBApplicationEvent As EventHandler(Of WBApplicationEventArgs)
public:
virtual  event EventHandler<WBApplicationEventArgs^>^ WBApplicationEvent {
    void add (EventHandler<WBApplicationEventArgs^>^ value);
    void remove (EventHandler<WBApplicationEventArgs^>^ value);
}
abstract WBApplicationEvent : IEvent<EventHandler<WBApplicationEventArgs>,
    WBApplicationEventArgs>
override WBApplicationEvent : IEvent<EventHandler<WBApplicationEventArgs>,
    WBApplicationEventArgs>

Value

Type: SystemEventHandler WBApplicationEventArgs

Implements

IWBApplicationServiceWBApplicationEvent
See Also

Reference

WBApplicationService Class
Datapolis.WorkBox.Common.Solutions.ApplicationsEvents Namespace


Datapolis.WorkBox.Common.Substitutions Namespace

Datapolis.WorkBox.Common.Substitutions Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBSubstitution | Substitution data class
Public class | WBSubstitutionCollection |
Public class | WBSubstitutionManager |
Public class | WBSubstitutionScope | Substitution scope data class
Public class | WBSubstitutionScopes | Data class
Public class | WBSubstitutionStatusLocalizer |
Enumerations
 | Enumeration | Description
Public enumeration | WBSubstitutionScopeType |
Public enumeration | WBSubstitutionStatus |


WBSubstitution Class

WBSubstitution Class Datapolis Process System Class Reference
Substitution data class
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SubstitutionsWBSubstitution

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSubstitution
Public NotInheritable Class WBSubstitution
public ref class WBSubstitution sealed
[<SealedAttribute>]
type WBSubstitution =  class end

The WBSubstitution type exposes the following members.

Constructors
 | Name | Description
Public method | WBSubstitution | Default constructor
Public method | WBSubstitution(SPUser, WBSubstitutionScope) | Sets passed author
Public method | WBSubstitution(SPUser, ListSPPrincipal, DateTime, DateTime, WBSubstitutionScopes, SPUser, WBSubstitutionScope) | Creates new substitution
Top
Properties
 | Name | Description
Public property | Created | date of replacement creation
Public property | CreatedBy | Returns login of account that create substitution
Public property | CreationScope | Gets creation scopes
Public property | DateFrom | Replacement start date
Public property | DateTo | Replacement end date
Public property | Id | Replacement DB row id
Public property | IsActive | Indicates if substitution is active
Public property | IsReadOnly |
Public property | IsRemove | Indicates if substitution was removed
Public property | Removed | Returns date and time when substitution was removed
Public property | RemovedBy | Returns login of account that removed substitution
Public property | Scopes | Replacement area data container
Public property | Status | Gets substitution's status
Public property | SubstitutedByLogins | Login of the user that can act in behave of another user
Public property | SubstitutionId | Unique id of the replacement
Public property | UserLogin | Login of replaced user
Top
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution Constructor

WBSubstitution Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBSubstitution | Default constructor
Public method | WBSubstitution(SPUser, WBSubstitutionScope) | Sets passed author
Public method | WBSubstitution(SPUser, ListSPPrincipal, DateTime, DateTime, WBSubstitutionScopes, SPUser, WBSubstitutionScope) | Creates new substitution
Top
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution Constructor

WBSubstitution Constructor Datapolis Process System Class Reference
Default constructor

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitution()
Public Sub New
public:
WBSubstitution()
new : unit -> WBSubstitution
See Also

Reference

WBSubstitution Class
WBSubstitution Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution Constructor (SPUser, WBSubstitutionScope)

WBSubstitution Constructor (SPUser, WBSubstitutionScope) Datapolis Process System Class Reference
Sets passed author

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitution(
    SPUser createdby,
    WBSubstitutionScope creationScope
)
Public Sub New (
    createdby As SPUser,
    creationScope As WBSubstitutionScope
)
public:
WBSubstitution(
    SPUser^ createdby,
    WBSubstitutionScope^ creationScope
)
new :
        createdby : SPUser *
        creationScope : WBSubstitutionScope -> WBSubstitution

Parameters

createdby
Type: SPUser
creationScope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
See Also

Reference

WBSubstitution Class
WBSubstitution Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution Constructor (SPUser, List(SPPrincipal), DateTime, DateTime, WBSubstitutionScopes, SPUser, WBSubstitutionScope)

WBSubstitution Constructor (SPUser, ListSPPrincipal, DateTime, DateTime, WBSubstitutionScopes, SPUser, WBSubstitutionScope) Datapolis Process System Class Reference
Creates new substitution

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitution(
    SPUser user,
    List<SPPrincipal> substitutedBy,
    DateTime from,
    DateTime to,
    WBSubstitutionScopes scopes,
    SPUser createdby,
    WBSubstitutionScope creationScope
)
Public Sub New (
    user As SPUser,
    substitutedBy As List(Of SPPrincipal),
    from As DateTime,
    to As DateTime,
    scopes As WBSubstitutionScopes,
    createdby As SPUser,
    creationScope As WBSubstitutionScope
)
public:
WBSubstitution(
    SPUser^ user,
    List<SPPrincipal^>^ substitutedBy,
    DateTime from,
    DateTime to,
    WBSubstitutionScopes^ scopes,
    SPUser^ createdby,
    WBSubstitutionScope^ creationScope
)
new :
        user : SPUser *
        substitutedBy : List<SPPrincipal> *
        from : DateTime *
        to : DateTime *
        scopes : WBSubstitutionScopes *
        createdby : SPUser *
        creationScope : WBSubstitutionScope -> WBSubstitution

Parameters

user
Type: SPUser
substitutedBy
Type: System.Collections.GenericList SPPrincipal
from
Type: SystemDateTime
to
Type: SystemDateTime
scopes
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScopes
createdby
Type: SPUser
creationScope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
See Also

Reference

WBSubstitution Class
WBSubstitution Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution Properties

WBSubstitution Properties Datapolis Process System Class Reference

The WBSubstitution type exposes the following members.

Properties
 | Name | Description
Public property | Created | date of replacement creation
Public property | CreatedBy | Returns login of account that create substitution
Public property | CreationScope | Gets creation scopes
Public property | DateFrom | Replacement start date
Public property | DateTo | Replacement end date
Public property | Id | Replacement DB row id
Public property | IsActive | Indicates if substitution is active
Public property | IsReadOnly |
Public property | IsRemove | Indicates if substitution was removed
Public property | Removed | Returns date and time when substitution was removed
Public property | RemovedBy | Returns login of account that removed substitution
Public property | Scopes | Replacement area data container
Public property | Status | Gets substitution's status
Public property | SubstitutedByLogins | Login of the user that can act in behave of another user
Public property | SubstitutionId | Unique id of the replacement
Public property | UserLogin | Login of replaced user
Top
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.Created Property

WBSubstitutionCreated Property Datapolis Process System Class Reference
date of replacement creation

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public DateTime Created { get; }
Public ReadOnly Property Created As DateTime
    Get
public:
property DateTime Created {
    DateTime get ();
}
member Created : DateTime with get

Property Value

Type: DateTime
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.CreatedBy Property

WBSubstitutionCreatedBy Property Datapolis Process System Class Reference
Returns login of account that create substitution

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string CreatedBy { get; }
Public ReadOnly Property CreatedBy As String
    Get
public:
property String^ CreatedBy {
    String^ get ();
}
member CreatedBy : string with get

Property Value

Type: String
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.CreationScope Property

WBSubstitutionCreationScope Property Datapolis Process System Class Reference
Gets creation scopes

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope CreationScope { get; set; }
Public Property CreationScope As WBSubstitutionScope
    Get
    Set
public:
property WBSubstitutionScope^ CreationScope {
    WBSubstitutionScope^ get ();
    void set (WBSubstitutionScope^ value);
}
member CreationScope : WBSubstitutionScope with get, set

Property Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.DateFrom Property

WBSubstitutionDateFrom Property Datapolis Process System Class Reference
Replacement start date

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public DateTime DateFrom { get; set; }
Public Property DateFrom As DateTime
    Get
    Set
public:
property DateTime DateFrom {
    DateTime get ();
    void set (DateTime value);
}
member DateFrom : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.DateTo Property

WBSubstitutionDateTo Property Datapolis Process System Class Reference
Replacement end date

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTo { get; set; }
Public Property DateTo As DateTime
    Get
    Set
public:
property DateTime DateTo {
    DateTime get ();
    void set (DateTime value);
}
member DateTo : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.Id Property

WBSubstitutionId Property Datapolis Process System Class Reference
Replacement DB row id

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Type: Int32
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.IsActive Property

WBSubstitutionIsActive Property Datapolis Process System Class Reference
Indicates if substitution is active

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get
public:
property bool IsActive {
    bool get ();
}
member IsActive : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.IsReadOnly Property

WBSubstitutionIsReadOnly Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}
member IsReadOnly : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.IsRemove Property

WBSubstitutionIsRemove Property Datapolis Process System Class Reference
Indicates if substitution was removed

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsRemove { get; }
Public ReadOnly Property IsRemove As Boolean
    Get
public:
property bool IsRemove {
    bool get ();
}
member IsRemove : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.Removed Property

WBSubstitutionRemoved Property Datapolis Process System Class Reference
Returns date and time when substitution was removed

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> Removed { get; }
Public ReadOnly Property Removed As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> Removed {
    Nullable<DateTime> get ();
}
member Removed : Nullable<DateTime> with get

Property Value

Type: Nullable DateTime
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.RemovedBy Property

WBSubstitutionRemovedBy Property Datapolis Process System Class Reference
Returns login of account that removed substitution

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string RemovedBy { get; }
Public ReadOnly Property RemovedBy As String
    Get
public:
property String^ RemovedBy {
    String^ get ();
}
member RemovedBy : string with get

Property Value

Type: String
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.Scopes Property

WBSubstitutionScopes Property Datapolis Process System Class Reference
Replacement area data container

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScopes Scopes { get; set; }
Public Property Scopes As WBSubstitutionScopes
    Get
    Set
public:
property WBSubstitutionScopes^ Scopes {
    WBSubstitutionScopes^ get ();
    void set (WBSubstitutionScopes^ value);
}
member Scopes : WBSubstitutionScopes with get, set

Property Value

Type: WBSubstitutionScopes
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.Status Property

WBSubstitutionStatus Property Datapolis Process System Class Reference
Gets substitution's status

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionStatus Status { get; }
Public ReadOnly Property Status As WBSubstitutionStatus
    Get
public:
property WBSubstitutionStatus Status {
    WBSubstitutionStatus get ();
}
member Status : WBSubstitutionStatus with get

Property Value

Type: WBSubstitutionStatus
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.SubstitutedByLogins Property

WBSubstitutionSubstitutedByLogins Property Datapolis Process System Class Reference
Login of the user that can act in behave of another user

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public List<string> SubstitutedByLogins { get; set; }
Public Property SubstitutedByLogins As List(Of String)
    Get
    Set
public:
property List<String^>^ SubstitutedByLogins {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member SubstitutedByLogins : List<string> with get, set

Property Value

Type: List String
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.SubstitutionId Property

WBSubstitutionSubstitutionId Property Datapolis Process System Class Reference
Unique id of the replacement

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid SubstitutionId { get; }
Public ReadOnly Property SubstitutionId As Guid
    Get
public:
property Guid SubstitutionId {
    Guid get ();
}
member SubstitutionId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitution.UserLogin Property

WBSubstitutionUserLogin Property Datapolis Process System Class Reference
Login of replaced user

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string UserLogin { get; set; }
Public Property UserLogin As String
    Get
    Set
public:
property String^ UserLogin {
    String^ get ();
    void set (String^ value);
}
member UserLogin : string with get, set

Property Value

Type: String
See Also

Reference

WBSubstitution Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection Class

WBSubstitutionCollection Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionCollection

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSubstitutionCollection : IList<WBSubstitution>,
    ICollection<WBSubstitution>, IEnumerable<WBSubstitution>, IEnumerable
Public NotInheritable Class WBSubstitutionCollection
    Implements IList(Of WBSubstitution), ICollection(Of WBSubstitution),
    IEnumerable(Of WBSubstitution), IEnumerable
public ref class WBSubstitutionCollection sealed : IList<WBSubstitution^>,
    ICollection<WBSubstitution^>, IEnumerable<WBSubstitution^>, IEnumerable
[<SealedAttribute>]
type WBSubstitutionCollection =
    class
        interface IList<WBSubstitution>
        interface ICollection<WBSubstitution>
        interface IEnumerable<WBSubstitution>
        interface IEnumerable
    end

The WBSubstitutionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBSubstitutionCollection | Initializes a new instance of the WBSubstitutionCollection class
Top
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | ItemGuid |
Public property | ItemInt32 |
Top
Methods
 | Name | Description
Public method | Add | Adds element to the collection
Public method | Clear |
Public method | Contains |
Public method | ContainsId | Chect if collection contains element with specified SubstitutionId
Public method | CopyTo |
Public method | GetEnumerator |
Public method | IndexOf |
Top
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection Constructor

WBSubstitutionCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSubstitutionCollection class

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionCollection()
Public Sub New
public:
WBSubstitutionCollection()
new : unit -> WBSubstitutionCollection
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection Properties

WBSubstitutionCollection Properties Datapolis Process System Class Reference

The WBSubstitutionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | ItemGuid |
Public property | ItemInt32 |
Top
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.Count Property

WBSubstitutionCollectionCount Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.IsReadOnly Property

WBSubstitutionCollectionIsReadOnly Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.Item Property

WBSubstitutionCollectionItem Property Datapolis Process System Class Reference
Overload List
 | Name | Description
Public property | ItemGuid |
Public property | ItemInt32 |
Top
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.Item Property (Guid)

WBSubstitutionCollectionItem Property (Guid) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitution this[
    Guid substitutionId
] { get; }
Public ReadOnly Default Property Item (
    substitutionId As Guid
) As WBSubstitution
    Get
public:
property WBSubstitution^ default[Guid substitutionId] {
    WBSubstitution^ get (Guid substitutionId);
}
member Item : WBSubstitution with get

Parameters

substitutionId
Type: SystemGuid

Property Value

Type: WBSubstitution
See Also

Reference

WBSubstitutionCollection Class
Item Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.Item Property (Int32)

WBSubstitutionCollectionItem Property (Int32) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitution this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As WBSubstitution
    Get
    Set
public:
virtual property WBSubstitution^ default[int index] {
    WBSubstitution^ get (int index) sealed;
    void set (int index, WBSubstitution^ value) sealed;
}
abstract Item : WBSubstitution with get, set
override Item : WBSubstitution with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: WBSubstitution

Implements

IListTItemInt32
See Also

Reference

WBSubstitutionCollection Class
Item Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection Methods

WBSubstitutionCollection Methods Datapolis Process System Class Reference

The WBSubstitutionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds element to the collection
Public method | Clear |
Public method | Contains |
Public method | ContainsId | Chect if collection contains element with specified SubstitutionId
Public method | CopyTo |
Public method | GetEnumerator |
Public method | IndexOf |
Top
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.Add Method

WBSubstitutionCollectionAdd Method Datapolis Process System Class Reference
Adds element to the collection

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    WBSubstitution substitution
)
Public Sub Add (
    substitution As WBSubstitution
)
public:
void Add(
    WBSubstitution^ substitution
)
member Add :
        substitution : WBSubstitution -> unit

Parameters

substitution
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitution
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.Clear Method

WBSubstitutionCollectionClear Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.Contains Method

WBSubstitutionCollectionContains Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    WBSubstitution substitution
)
Public Function Contains (
    substitution As WBSubstitution
) As Boolean
public:
virtual bool Contains(
    WBSubstitution^ substitution
) sealed
abstract Contains :
        substitution : WBSubstitution -> bool
override Contains :
        substitution : WBSubstitution -> bool

Parameters

substitution
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitution

Return Value

Type: Boolean

Implements

ICollectionTContains(T)
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.ContainsId Method

WBSubstitutionCollectionContainsId Method Datapolis Process System Class Reference
Chect if collection contains element with specified SubstitutionId

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsId(
    Guid substitutionId
)
Public Function ContainsId (
    substitutionId As Guid
) As Boolean
public:
bool ContainsId(
    Guid substitutionId
)
member ContainsId :
        substitutionId : Guid -> bool

Parameters

substitutionId
Type: SystemGuid

Return Value

Type: Boolean
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.CopyTo Method

WBSubstitutionCollectionCopyTo Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    WBSubstitution[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As WBSubstitution(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<WBSubstitution^>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : WBSubstitution[] *
        arrayIndex : int -> unit
override CopyTo :
        array : WBSubstitution[] *
        arrayIndex : int -> unit

Parameters

array
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitution
arrayIndex
Type: SystemInt32

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.GetEnumerator Method

WBSubstitutionCollectionGetEnumerator Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<WBSubstitution> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of WBSubstitution)
public:
virtual IEnumerator<WBSubstitution^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<WBSubstitution>
override GetEnumerator : unit -> IEnumerator<WBSubstitution>

Return Value

Type: IEnumerator WBSubstitution

Implements

IEnumerableTGetEnumerator
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionCollection.IndexOf Method

WBSubstitutionCollectionIndexOf Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    WBSubstitution substitution
)
Public Function IndexOf (
    substitution As WBSubstitution
) As Integer
public:
virtual int IndexOf(
    WBSubstitution^ substitution
) sealed
abstract IndexOf :
        substitution : WBSubstitution -> int
override IndexOf :
        substitution : WBSubstitution -> int

Parameters

substitution
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitution

Return Value

Type: Int32

Implements

IListTIndexOf(T)
See Also

Reference

WBSubstitutionCollection Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager Class

WBSubstitutionManager Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionManager

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBSubstitutionManager
Public Class WBSubstitutionManager
public ref class WBSubstitutionManager
type WBSubstitutionManager =  class end

The WBSubstitutionManager type exposes the following members.

Constructors
 | Name | Description
Public method | WBSubstitutionManager | Initializes a new instance of the WBSubstitutionManager class
Top
Methods
Name | Description
Add | Save WBSubstitution data into database
AnyActiveSubstitutionInTheScope |
GetActiveSubstitutionsBySubstitutedBy |
GetActiveSubstitutionsBySubstitutedByAndScope(SPUser, WBSubstitutionScope) | Gets list of WBSubstitution that can be used by user.
GetActiveSubstitutionsBySubstitutedByAndScope(SPUser, WBSubstitutionScope, SPWeb) | Gets list of WBSubstitution that can be used by user.
GetActiveSubstitutionsByUser |
GetAllActiveSubstitutions |
GetAllSubstitutions |
GetOverdueSubstitutions |
GetSubstitutionsByScope(WBSubstitutionScope) |
GetSubstitutionsByScope(WBSubstitutionScope, Int32, Int32, Int32) |
GetSubstitutionsByScopeAndStatus | Gets list of all WBSubstitution in selected WBSubstitutionScope and WBSubstitutionStatus.
GetSubstitutionsByUser |
Load(Guid) | Loads WBSubstitution data from database
Load(Int32) | Loads WBSubstitution data from database
Remove | Marks WBSubstitution as removed
Top
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager Constructor

WBSubstitutionManager Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSubstitutionManager class

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionManager()
Public Sub New
public:
WBSubstitutionManager()
new : unit -> WBSubstitutionManager
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager Methods

WBSubstitutionManager Methods Datapolis Process System Class Reference

The WBSubstitutionManager type exposes the following members.

Methods
Name | Description
Add | Save WBSubstitution data into database
AnyActiveSubstitutionInTheScope |
GetActiveSubstitutionsBySubstitutedBy |
GetActiveSubstitutionsBySubstitutedByAndScope(SPUser, WBSubstitutionScope) | Gets list of WBSubstitution that can be used by user.
GetActiveSubstitutionsBySubstitutedByAndScope(SPUser, WBSubstitutionScope, SPWeb) | Gets list of WBSubstitution that can be used by user.
GetActiveSubstitutionsByUser |
GetAllActiveSubstitutions |
GetAllSubstitutions |
GetOverdueSubstitutions |
GetSubstitutionsByScope(WBSubstitutionScope) |
GetSubstitutionsByScope(WBSubstitutionScope, Int32, Int32, Int32) |
GetSubstitutionsByScopeAndStatus | Gets list of all WBSubstitution in selected WBSubstitutionScope and WBSubstitutionStatus.
GetSubstitutionsByUser |
Load(Guid) | Loads WBSubstitution data from database
Load(Int32) | Loads WBSubstitution data from database
Remove | Marks WBSubstitution as removed
Top
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.Add Method

WBSubstitutionManagerAdd Method Datapolis Process System Class Reference
Save WBSubstitution data into database

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static bool Add(
    WBSubstitution substitution
)
Public Shared Function Add (
    substitution As WBSubstitution
) As Boolean
public:
static bool Add(
    WBSubstitution^ substitution
)
static member Add :
        substitution : WBSubstitution -> bool

Parameters

substitution
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitution

Return Value

Type: Boolean
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.AnyActiveSubstitutionInTheScope Method

WBSubstitutionManagerAnyActiveSubstitutionInTheScope Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static bool AnyActiveSubstitutionInTheScope(
    WBSubstitutionScope scope
)
Public Shared Function AnyActiveSubstitutionInTheScope (
    scope As WBSubstitutionScope
) As Boolean
public:
static bool AnyActiveSubstitutionInTheScope(
    WBSubstitutionScope^ scope
)
static member AnyActiveSubstitutionInTheScope :
        scope : WBSubstitutionScope -> bool

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: Boolean
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetActiveSubstitutionsBySubstitutedBy Method

WBSubstitutionManagerGetActiveSubstitutionsBySubstitutedBy Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetActiveSubstitutionsBySubstitutedBy(
    SPUser substitutedBy
)
Public Shared Function GetActiveSubstitutionsBySubstitutedBy (
    substitutedBy As SPUser
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetActiveSubstitutionsBySubstitutedBy(
    SPUser^ substitutedBy
)
static member GetActiveSubstitutionsBySubstitutedBy :
        substitutedBy : SPUser -> WBSubstitutionCollection

Parameters

substitutedBy
Type: SPUser

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetActiveSubstitutionsBySubstitutedByAndScope Method

WBSubstitutionManagerGetActiveSubstitutionsBySubstitutedByAndScope Method Datapolis Process System Class Reference
Overload List
Name | Description
GetActiveSubstitutionsBySubstitutedByAndScope(SPUser, WBSubstitutionScope) | Gets list of WBSubstitution that can be used by user.
GetActiveSubstitutionsBySubstitutedByAndScope(SPUser, WBSubstitutionScope, SPWeb) | Gets list of WBSubstitution that can be used by user.
Top
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetActiveSubstitutionsBySubstitutedByAndScope Method (SPUser, WBSubstitutionScope)

WBSubstitutionManagerGetActiveSubstitutionsBySubstitutedByAndScope Method (SPUser, WBSubstitutionScope) Datapolis Process System Class Reference
Gets list of WBSubstitution that can be used by user.

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetActiveSubstitutionsBySubstitutedByAndScope(
    SPUser substitutedBy,
    WBSubstitutionScope scope
)
Public Shared Function GetActiveSubstitutionsBySubstitutedByAndScope (
    substitutedBy As SPUser,
    scope As WBSubstitutionScope
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetActiveSubstitutionsBySubstitutedByAndScope(
    SPUser^ substitutedBy,
    WBSubstitutionScope^ scope
)
static member GetActiveSubstitutionsBySubstitutedByAndScope :
        substitutedBy : SPUser *
        scope : WBSubstitutionScope -> WBSubstitutionCollection

Parameters

substitutedBy
Type: SPUser
the user that is acting, user have to be retracted from elevated web so its groups collection is accesible.
scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
GetActiveSubstitutionsBySubstitutedByAndScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetActiveSubstitutionsBySubstitutedByAndScope Method (SPUser, WBSubstitutionScope, SPWeb)

WBSubstitutionManagerGetActiveSubstitutionsBySubstitutedByAndScope Method (SPUser, WBSubstitutionScope, SPWeb) Datapolis Process System Class Reference
Gets list of WBSubstitution that can be used by user.

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetActiveSubstitutionsBySubstitutedByAndScope(
    SPUser substitutedBy,
    WBSubstitutionScope scope,
    SPWeb web
)
Public Shared Function GetActiveSubstitutionsBySubstitutedByAndScope (
    substitutedBy As SPUser,
    scope As WBSubstitutionScope,
    web As SPWeb
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetActiveSubstitutionsBySubstitutedByAndScope(
    SPUser^ substitutedBy,
    WBSubstitutionScope^ scope,
    SPWeb^ web
)
static member GetActiveSubstitutionsBySubstitutedByAndScope :
        substitutedBy : SPUser *
        scope : WBSubstitutionScope *
        web : SPWeb -> WBSubstitutionCollection

Parameters

substitutedBy
Type: SPUser
the user that is acting, user have to be retracted from elevated web so its groups collection is accesible.
scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
web
Type: SPWeb
pass elevated web to force full check that includes user roles and groups.

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
GetActiveSubstitutionsBySubstitutedByAndScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetActiveSubstitutionsByUser Method

WBSubstitutionManagerGetActiveSubstitutionsByUser Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetActiveSubstitutionsByUser(
    SPUser user
)
Public Shared Function GetActiveSubstitutionsByUser (
    user As SPUser
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetActiveSubstitutionsByUser(
    SPUser^ user
)
static member GetActiveSubstitutionsByUser :
        user : SPUser -> WBSubstitutionCollection

Parameters

user
Type: SPUser

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetAllActiveSubstitutions Method

WBSubstitutionManagerGetAllActiveSubstitutions Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetAllActiveSubstitutions()
Public Shared Function GetAllActiveSubstitutions As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetAllActiveSubstitutions()
static member GetAllActiveSubstitutions : unit -> WBSubstitutionCollection

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetAllSubstitutions Method

WBSubstitutionManagerGetAllSubstitutions Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetAllSubstitutions(
    int pageSize,
    int pageNumber,
    out int totalRows
)
Public Shared Function GetAllSubstitutions (
    pageSize As Integer,
    pageNumber As Integer,
    <OutAttribute> ByRef totalRows As Integer
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetAllSubstitutions(
    int pageSize,
    int pageNumber,
    [OutAttribute] int% totalRows
)
static member GetAllSubstitutions :
        pageSize : int *
        pageNumber : int *
        totalRows : int byref -> WBSubstitutionCollection

Parameters

pageSize
Type: SystemInt32
pageNumber
Type: SystemInt32
totalRows
Type: SystemInt32

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetOverdueSubstitutions Method

WBSubstitutionManagerGetOverdueSubstitutions Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetOverdueSubstitutions()
Public Shared Function GetOverdueSubstitutions As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetOverdueSubstitutions()
static member GetOverdueSubstitutions : unit -> WBSubstitutionCollection

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetSubstitutionsByScope Method

WBSubstitutionManagerGetSubstitutionsByScope Method Datapolis Process System Class Reference
Overload List
Name | Description
GetSubstitutionsByScope(WBSubstitutionScope) |
GetSubstitutionsByScope(WBSubstitutionScope, Int32, Int32, Int32) |
Top
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetSubstitutionsByScope Method (WBSubstitutionScope)

WBSubstitutionManagerGetSubstitutionsByScope Method (WBSubstitutionScope) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetSubstitutionsByScope(
    WBSubstitutionScope scope
)
Public Shared Function GetSubstitutionsByScope (
    scope As WBSubstitutionScope
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetSubstitutionsByScope(
    WBSubstitutionScope^ scope
)
static member GetSubstitutionsByScope :
        scope : WBSubstitutionScope -> WBSubstitutionCollection

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
GetSubstitutionsByScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetSubstitutionsByScope Method (WBSubstitutionScope, Int32, Int32, Int32)

WBSubstitutionManagerGetSubstitutionsByScope Method (WBSubstitutionScope, Int32, Int32, Int32) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetSubstitutionsByScope(
    WBSubstitutionScope scope,
    int pageSize,
    int pageNumber,
    out int totalRows
)
Public Shared Function GetSubstitutionsByScope (
    scope As WBSubstitutionScope,
    pageSize As Integer,
    pageNumber As Integer,
    <OutAttribute> ByRef totalRows As Integer
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetSubstitutionsByScope(
    WBSubstitutionScope^ scope,
    int pageSize,
    int pageNumber,
    [OutAttribute] int% totalRows
)
static member GetSubstitutionsByScope :
        scope : WBSubstitutionScope *
        pageSize : int *
        pageNumber : int *
        totalRows : int byref -> WBSubstitutionCollection

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
pageSize
Type: SystemInt32
pageNumber
Type: SystemInt32
totalRows
Type: SystemInt32

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
GetSubstitutionsByScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetSubstitutionsByScopeAndStatus Method

WBSubstitutionManagerGetSubstitutionsByScopeAndStatus Method Datapolis Process System Class Reference
Gets list of all WBSubstitution in selected WBSubstitutionScope and WBSubstitutionStatus.

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetSubstitutionsByScopeAndStatus(
    WBSubstitutionScope scope,
    WBSubstitutionStatus status,
    int pageSize,
    int pageNumber,
    out int totalRows
)
Public Shared Function GetSubstitutionsByScopeAndStatus (
    scope As WBSubstitutionScope,
    status As WBSubstitutionStatus,
    pageSize As Integer,
    pageNumber As Integer,
    <OutAttribute> ByRef totalRows As Integer
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetSubstitutionsByScopeAndStatus(
    WBSubstitutionScope^ scope,
    WBSubstitutionStatus status,
    int pageSize,
    int pageNumber,
    [OutAttribute] int% totalRows
)
static member GetSubstitutionsByScopeAndStatus :
        scope : WBSubstitutionScope *
        status : WBSubstitutionStatus *
        pageSize : int *
        pageNumber : int *
        totalRows : int byref -> WBSubstitutionCollection

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
status
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionStatus
pageSize
Type: SystemInt32
pageNumber
Type: SystemInt32
totalRows
Type: SystemInt32

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.GetSubstitutionsByUser Method

WBSubstitutionManagerGetSubstitutionsByUser Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionCollection GetSubstitutionsByUser(
    SPUser user
)
Public Shared Function GetSubstitutionsByUser (
    user As SPUser
) As WBSubstitutionCollection
public:
static WBSubstitutionCollection^ GetSubstitutionsByUser(
    SPUser^ user
)
static member GetSubstitutionsByUser :
        user : SPUser -> WBSubstitutionCollection

Parameters

user
Type: SPUser

Return Value

Type: WBSubstitutionCollection
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.Load Method

WBSubstitutionManagerLoad Method Datapolis Process System Class Reference
Overload List
Name | Description
Load(Guid) | Loads WBSubstitution data from database
Load(Int32) | Loads WBSubstitution data from database
Top
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.Load Method (Guid)

WBSubstitutionManagerLoad Method (Guid) Datapolis Process System Class Reference
Loads WBSubstitution data from database

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitution Load(
    Guid id
)
Public Shared Function Load (
    id As Guid
) As WBSubstitution
public:
static WBSubstitution^ Load(
    Guid id
)
static member Load :
        id : Guid -> WBSubstitution

Parameters

id
Type: SystemGuid

Return Value

Type: WBSubstitution
See Also

Reference

WBSubstitutionManager Class
Load Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.Load Method (Int32)

WBSubstitutionManagerLoad Method (Int32) Datapolis Process System Class Reference
Loads WBSubstitution data from database

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitution Load(
    int id
)
Public Shared Function Load (
    id As Integer
) As WBSubstitution
public:
static WBSubstitution^ Load(
    int id
)
static member Load :
        id : int -> WBSubstitution

Parameters

id
Type: SystemInt32

Return Value

Type: WBSubstitution
See Also

Reference

WBSubstitutionManager Class
Load Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionManager.Remove Method

WBSubstitutionManagerRemove Method Datapolis Process System Class Reference
Marks WBSubstitution as removed

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static void Remove(
    WBSubstitution substitution,
    SPUser removedBy
)
Public Shared Sub Remove (
    substitution As WBSubstitution,
    removedBy As SPUser
)
public:
static void Remove(
    WBSubstitution^ substitution,
    SPUser^ removedBy
)
static member Remove :
        substitution : WBSubstitution *
        removedBy : SPUser -> unit

Parameters

substitution
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitution
removedBy
Type: SPUser
See Also

Reference

WBSubstitutionManager Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Class

WBSubstitutionScope Class Datapolis Process System Class Reference
Substitution scope data class
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSubstitutionScope
Public NotInheritable Class WBSubstitutionScope
public ref class WBSubstitutionScope sealed
[<SealedAttribute>]
type WBSubstitutionScope =  class end

The WBSubstitutionScope type exposes the following members.

Constructors
 | Name | Description
Public method | WBSubstitutionScope | Creates new farm scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid) | Creates new application scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid) | Creates new site scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid, Guid) | Creates new web scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid, Guid, Guid) | Creates new list scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid, Guid, Guid, Guid) | Creates new list workflow scoped WBSubstitutionScope
Public method | WBSubstitutionScope(WBSubstitutionScopeType, Guid, Guid, Guid, Guid, Guid) | Creates new WBSubstitutionScope
Top
Properties
 | Name | Description
Public property | ApplicationId | Sets and gets guid of the scoped SPApplication
 | Current | ???
Public property | Id | Database id
Public property | IsReadOnly | Checks is object is read only
Public property | ListId | Sets and gets guid of the scoped SPList
Public property | SiteId | Sets and gets guid of the scoped SPSite
Public property | Type | Scope type Farm, Site etc
Public property | WebId | Sets and gets guid of the scoped SPWeb
Public property | WorkflowId | Sets and gets guid of the scoped WBWorkflow
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current WBSubstitutionScope. (Overrides ObjectEquals(Object).)
Public method | Equals(WBSubstitutionScope) | Determines whether the specified WBSubstitutionScope is equal to the current WBSubstitutionScope.
 | GetFrom(SPFarm) | Gets farm scoped WBSubstitutionScope
 | GetFrom(SPWebApplication) | Gets application scoped WBSubstitutionScope
 | GetFrom(SPList) | Gets list scoped WBSubstitutionScope
 | GetFrom(SPSite) | Gets site scoped WBSubstitutionScope
 | GetFrom(SPWeb) | Gets web scoped WBSubstitutionScope
 | GetFrom(SPList, Guid) | Gets list workflow scoped WBSubstitutionScope
 | GetFrom(SPWeb, Guid) | Gets site workflow scoped WBSubstitutionScope
Public method | GetHashCode | Serves as a hash function for a particular type (Overrides ObjectGetHashCode.)
Public method | GetXML | Serialize object to xml
 | Parse | Load WBSubstitutionScope from a string
Public method | ToString | (Overrides ObjectToString.)
Top
Operators
Name | Description
Equality |
(WBSubstitutionScope to String) |
(String to WBSubstitutionScope) |
Inequality |
Top
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor

WBSubstitutionScope Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBSubstitutionScope | Creates new farm scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid) | Creates new application scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid) | Creates new site scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid, Guid) | Creates new web scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid, Guid, Guid) | Creates new list scoped WBSubstitutionScope
Public method | WBSubstitutionScope(Guid, Guid, Guid, Guid, Guid) | Creates new list workflow scoped WBSubstitutionScope
Public method | WBSubstitutionScope(WBSubstitutionScopeType, Guid, Guid, Guid, Guid, Guid) | Creates new WBSubstitutionScope
Top
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor

WBSubstitutionScope Constructor Datapolis Process System Class Reference
Creates new farm scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope()
Public Sub New
public:
WBSubstitutionScope()
new : unit -> WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
WBSubstitutionScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor (Guid)

WBSubstitutionScope Constructor (Guid) Datapolis Process System Class Reference
Creates new application scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope(
    Guid applicationId
)
Public Sub New (
    applicationId As Guid
)
public:
WBSubstitutionScope(
    Guid applicationId
)
new :
        applicationId : Guid -> WBSubstitutionScope

Parameters

applicationId
Type: SystemGuid
See Also

Reference

WBSubstitutionScope Class
WBSubstitutionScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor (Guid, Guid)

WBSubstitutionScope Constructor (Guid, Guid) Datapolis Process System Class Reference
Creates new site scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope(
    Guid applicationId,
    Guid siteId
)
Public Sub New (
    applicationId As Guid,
    siteId As Guid
)
public:
WBSubstitutionScope(
    Guid applicationId,
    Guid siteId
)
new :
        applicationId : Guid *
        siteId : Guid -> WBSubstitutionScope

Parameters

applicationId
Type: SystemGuid
siteId
Type: SystemGuid
See Also

Reference

WBSubstitutionScope Class
WBSubstitutionScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor (Guid, Guid, Guid)

WBSubstitutionScope Constructor (Guid, Guid, Guid) Datapolis Process System Class Reference
Creates new web scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope(
    Guid applicationId,
    Guid siteId,
    Guid webId
)
Public Sub New (
    applicationId As Guid,
    siteId As Guid,
    webId As Guid
)
public:
WBSubstitutionScope(
    Guid applicationId,
    Guid siteId,
    Guid webId
)
new :
        applicationId : Guid *
        siteId : Guid *
        webId : Guid -> WBSubstitutionScope

Parameters

applicationId
Type: SystemGuid
siteId
Type: SystemGuid
webId
Type: SystemGuid
See Also

Reference

WBSubstitutionScope Class
WBSubstitutionScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor (Guid, Guid, Guid, Guid)

WBSubstitutionScope Constructor (Guid, Guid, Guid, Guid) Datapolis Process System Class Reference
Creates new list scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope(
    Guid applicationId,
    Guid siteId,
    Guid webId,
    Guid listId
)
Public Sub New (
    applicationId As Guid,
    siteId As Guid,
    webId As Guid,
    listId As Guid
)
public:
WBSubstitutionScope(
    Guid applicationId,
    Guid siteId,
    Guid webId,
    Guid listId
)
new :
        applicationId : Guid *
        siteId : Guid *
        webId : Guid *
        listId : Guid -> WBSubstitutionScope

Parameters

applicationId
Type: SystemGuid
siteId
Type: SystemGuid
webId
Type: SystemGuid
listId
Type: SystemGuid
See Also

Reference

WBSubstitutionScope Class
WBSubstitutionScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor (Guid, Guid, Guid, Guid, Guid)

WBSubstitutionScope Constructor (Guid, Guid, Guid, Guid, Guid) Datapolis Process System Class Reference
Creates new list workflow scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope(
    Guid applicationId,
    Guid siteId,
    Guid webId,
    Guid listId,
    Guid workflowId
)
Public Sub New (
    applicationId As Guid,
    siteId As Guid,
    webId As Guid,
    listId As Guid,
    workflowId As Guid
)
public:
WBSubstitutionScope(
    Guid applicationId,
    Guid siteId,
    Guid webId,
    Guid listId,
    Guid workflowId
)
new :
        applicationId : Guid *
        siteId : Guid *
        webId : Guid *
        listId : Guid *
        workflowId : Guid -> WBSubstitutionScope

Parameters

applicationId
Type: SystemGuid
siteId
Type: SystemGuid
webId
Type: SystemGuid
listId
Type: SystemGuid
workflowId
Type: SystemGuid
See Also

Reference

WBSubstitutionScope Class
WBSubstitutionScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Constructor (WBSubstitutionScopeType, Guid, Guid, Guid, Guid, Guid)

WBSubstitutionScope Constructor (WBSubstitutionScopeType, Guid, Guid, Guid, Guid, Guid) Datapolis Process System Class Reference
Creates new WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope(
    WBSubstitutionScopeType type,
    Guid applicationId,
    Guid siteId,
    Guid webId,
    Guid listId,
    Guid workflowId
)
Public Sub New (
    type As WBSubstitutionScopeType,
    applicationId As Guid,
    siteId As Guid,
    webId As Guid,
    listId As Guid,
    workflowId As Guid
)
public:
WBSubstitutionScope(
    WBSubstitutionScopeType type,
    Guid applicationId,
    Guid siteId,
    Guid webId,
    Guid listId,
    Guid workflowId
)
new :
        type : WBSubstitutionScopeType *
        applicationId : Guid *
        siteId : Guid *
        webId : Guid *
        listId : Guid *
        workflowId : Guid -> WBSubstitutionScope

Parameters

type
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScopeType
Scope range type
applicationId
Type: SystemGuid
guid of the scoped SPApplication
siteId
Type: SystemGuid
guid of the scoped SPSite
webId
Type: SystemGuid
guid of the scoped SPWeb
listId
Type: SystemGuid
guid of the scoped SPList
workflowId
Type: SystemGuid
guid of the scoped WBWorkflow
See Also

Reference

WBSubstitutionScope Class
WBSubstitutionScope Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Properties

WBSubstitutionScope Properties Datapolis Process System Class Reference

The WBSubstitutionScope type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationId | Sets and gets guid of the scoped SPApplication
 | Current | ???
Public property | Id | Database id
Public property | IsReadOnly | Checks is object is read only
Public property | ListId | Sets and gets guid of the scoped SPList
Public property | SiteId | Sets and gets guid of the scoped SPSite
Public property | Type | Scope type Farm, Site etc
Public property | WebId | Sets and gets guid of the scoped SPWeb
Public property | WorkflowId | Sets and gets guid of the scoped WBWorkflow
Top
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.ApplicationId Property

WBSubstitutionScopeApplicationId Property Datapolis Process System Class Reference
Sets and gets guid of the scoped SPApplication

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ApplicationId { get; set; }
Public Property ApplicationId As Guid
    Get
    Set
public:
property Guid ApplicationId {
    Guid get ();
    void set (Guid value);
}
member ApplicationId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Current Property

WBSubstitutionScopeCurrent Property Datapolis Process System Class Reference
???

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope Current { get; }
Public Shared ReadOnly Property Current As WBSubstitutionScope
    Get
public:
static property WBSubstitutionScope^ Current {
    WBSubstitutionScope^ get ();
}
static member Current : WBSubstitutionScope with get

Property Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Id Property

WBSubstitutionScopeId Property Datapolis Process System Class Reference
Database id

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Type: Int32
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.IsReadOnly Property

WBSubstitutionScopeIsReadOnly Property Datapolis Process System Class Reference
Checks is object is read only

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}
member IsReadOnly : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.ListId Property

WBSubstitutionScopeListId Property Datapolis Process System Class Reference
Sets and gets guid of the scoped SPList

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid ListId { get; set; }
Public Property ListId As Guid
    Get
    Set
public:
property Guid ListId {
    Guid get ();
    void set (Guid value);
}
member ListId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.SiteId Property

WBSubstitutionScopeSiteId Property Datapolis Process System Class Reference
Sets and gets guid of the scoped SPSite

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid SiteId { get; set; }
Public Property SiteId As Guid
    Get
    Set
public:
property Guid SiteId {
    Guid get ();
    void set (Guid value);
}
member SiteId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Type Property

WBSubstitutionScopeType Property Datapolis Process System Class Reference
Scope type Farm, Site etc

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScopeType Type { get; set; }
Public Property Type As WBSubstitutionScopeType
    Get
    Set
public:
property WBSubstitutionScopeType Type {
    WBSubstitutionScopeType get ();
    void set (WBSubstitutionScopeType value);
}
member Type : WBSubstitutionScopeType with get, set

Property Value

Type: WBSubstitutionScopeType
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.WebId Property

WBSubstitutionScopeWebId Property Datapolis Process System Class Reference
Sets and gets guid of the scoped SPWeb

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WebId { get; set; }
Public Property WebId As Guid
    Get
    Set
public:
property Guid WebId {
    Guid get ();
    void set (Guid value);
}
member WebId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.WorkflowId Property

WBSubstitutionScopeWorkflowId Property Datapolis Process System Class Reference
Sets and gets guid of the scoped WBWorkflow

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public Guid WorkflowId { get; set; }
Public Property WorkflowId As Guid
    Get
    Set
public:
property Guid WorkflowId {
    Guid get ();
    void set (Guid value);
}
member WorkflowId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Methods

WBSubstitutionScope Methods Datapolis Process System Class Reference

The WBSubstitutionScope type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current WBSubstitutionScope. (Overrides ObjectEquals(Object).)
Public method | Equals(WBSubstitutionScope) | Determines whether the specified WBSubstitutionScope is equal to the current WBSubstitutionScope.
 | GetFrom(SPFarm) | Gets farm scoped WBSubstitutionScope
 | GetFrom(SPWebApplication) | Gets application scoped WBSubstitutionScope
 | GetFrom(SPList) | Gets list scoped WBSubstitutionScope
 | GetFrom(SPSite) | Gets site scoped WBSubstitutionScope
 | GetFrom(SPWeb) | Gets web scoped WBSubstitutionScope
 | GetFrom(SPList, Guid) | Gets list workflow scoped WBSubstitutionScope
 | GetFrom(SPWeb, Guid) | Gets site workflow scoped WBSubstitutionScope
Public method | GetHashCode | Serves as a hash function for a particular type (Overrides ObjectGetHashCode.)
Public method | GetXML | Serialize object to xml
 | Parse | Load WBSubstitutionScope from a string
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Equals Method

WBSubstitutionScopeEquals Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current WBSubstitutionScope. (Overrides ObjectEquals(Object).)
Public method | Equals(WBSubstitutionScope) | Determines whether the specified WBSubstitutionScope is equal to the current WBSubstitutionScope.
Top
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Equals Method (Object)

WBSubstitutionScopeEquals Method (Object) Datapolis Process System Class Reference
Determines whether the specified Object is equal to the current WBSubstitutionScope.

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

WBSubstitutionScope Class
Equals Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Equals Method (WBSubstitutionScope)

WBSubstitutionScopeEquals Method (WBSubstitutionScope) Datapolis Process System Class Reference
Determines whether the specified WBSubstitutionScope is equal to the current WBSubstitutionScope.

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    WBSubstitutionScope scope
)
Public Function Equals (
    scope As WBSubstitutionScope
) As Boolean
public:
bool Equals(
    WBSubstitutionScope^ scope
)
member Equals :
        scope : WBSubstitutionScope -> bool

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
The WBSubstitutionScope object to compare with the current WBSubstitutionScope object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

WBSubstitutionScope Class
Equals Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method

WBSubstitutionScopeGetFrom Method Datapolis Process System Class Reference
Overload List
Name | Description
GetFrom(SPFarm) | Gets farm scoped WBSubstitutionScope
GetFrom(SPWebApplication) | Gets application scoped WBSubstitutionScope
GetFrom(SPList) | Gets list scoped WBSubstitutionScope
GetFrom(SPSite) | Gets site scoped WBSubstitutionScope
GetFrom(SPWeb) | Gets web scoped WBSubstitutionScope
GetFrom(SPList, Guid) | Gets list workflow scoped WBSubstitutionScope
GetFrom(SPWeb, Guid) | Gets site workflow scoped WBSubstitutionScope
Top
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method (SPFarm)

WBSubstitutionScopeGetFrom Method (SPFarm) Datapolis Process System Class Reference
Gets farm scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope GetFrom(
    SPFarm farm
)
Public Shared Function GetFrom (
    farm As SPFarm
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ GetFrom(
    SPFarm^ farm
)
static member GetFrom :
        farm : SPFarm -> WBSubstitutionScope

Parameters

farm
Type: SPFarm

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
GetFrom Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method (SPWebApplication)

WBSubstitutionScopeGetFrom Method (SPWebApplication) Datapolis Process System Class Reference
Gets application scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope GetFrom(
    SPWebApplication app
)
Public Shared Function GetFrom (
    app As SPWebApplication
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ GetFrom(
    SPWebApplication^ app
)
static member GetFrom :
        app : SPWebApplication -> WBSubstitutionScope

Parameters

app
Type: SPWebApplication

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
GetFrom Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method (SPList)

WBSubstitutionScopeGetFrom Method (SPList) Datapolis Process System Class Reference
Gets list scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope GetFrom(
    SPList list
)
Public Shared Function GetFrom (
    list As SPList
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ GetFrom(
    SPList^ list
)
static member GetFrom :
        list : SPList -> WBSubstitutionScope

Parameters

list
Type: SPList

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
GetFrom Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method (SPSite)

WBSubstitutionScopeGetFrom Method (SPSite) Datapolis Process System Class Reference
Gets site scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope GetFrom(
    SPSite site
)
Public Shared Function GetFrom (
    site As SPSite
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ GetFrom(
    SPSite^ site
)
static member GetFrom :
        site : SPSite -> WBSubstitutionScope

Parameters

site
Type: SPSite

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
GetFrom Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method (SPWeb)

WBSubstitutionScopeGetFrom Method (SPWeb) Datapolis Process System Class Reference
Gets web scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope GetFrom(
    SPWeb web
)
Public Shared Function GetFrom (
    web As SPWeb
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ GetFrom(
    SPWeb^ web
)
static member GetFrom :
        web : SPWeb -> WBSubstitutionScope

Parameters

web
Type: SPWeb

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
GetFrom Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method (SPList, Guid)

WBSubstitutionScopeGetFrom Method (SPList, Guid) Datapolis Process System Class Reference
Gets list workflow scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope GetFrom(
    SPList list,
    Guid workflowID
)
Public Shared Function GetFrom (
    list As SPList,
    workflowID As Guid
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ GetFrom(
    SPList^ list,
    Guid workflowID
)
static member GetFrom :
        list : SPList *
        workflowID : Guid -> WBSubstitutionScope

Parameters

list
Type: SPList
workflowID
Type: SystemGuid

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
GetFrom Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetFrom Method (SPWeb, Guid)

WBSubstitutionScopeGetFrom Method (SPWeb, Guid) Datapolis Process System Class Reference
Gets site workflow scoped WBSubstitutionScope

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope GetFrom(
    SPWeb web,
    Guid workflowID
)
Public Shared Function GetFrom (
    web As SPWeb,
    workflowID As Guid
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ GetFrom(
    SPWeb^ web,
    Guid workflowID
)
static member GetFrom :
        web : SPWeb *
        workflowID : Guid -> WBSubstitutionScope

Parameters

web
Type: SPWeb
workflowID
Type: SystemGuid

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
GetFrom Overload
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetHashCode Method

WBSubstitutionScopeGetHashCode Method Datapolis Process System Class Reference
Serves as a hash function for a particular type

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current WBSubstitutionScope.
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.GetXML Method

WBSubstitutionScopeGetXML Method Datapolis Process System Class Reference
Serialize object to xml

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public XElement GetXML()
Public Function GetXML As XElement
public:
XElement^ GetXML()
member GetXML : unit -> XElement

Return Value

Type: XElement
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Parse Method

WBSubstitutionScopeParse Method Datapolis Process System Class Reference
Load WBSubstitutionScope from a string

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScope Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As WBSubstitutionScope
public:
static WBSubstitutionScope^ Parse(
    String^ s
)
static member Parse :
        s : string -> WBSubstitutionScope

Parameters

s
Type: SystemString

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.ToString Method

WBSubstitutionScopeToString Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Operators and Type Conversions

WBSubstitutionScope Operators and Type Conversions Datapolis Process System Class Reference

The WBSubstitutionScope type exposes the following members.

Operators
Name | Description
Equality |
(WBSubstitutionScope to String) |
(String to WBSubstitutionScope) |
Inequality |
Top
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Equality Operator

WBSubstitutionScopeEquality Operator Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    WBSubstitutionScope s1,
    WBSubstitutionScope s2
)
Public Shared Operator = (
    s1 As WBSubstitutionScope,
    s2 As WBSubstitutionScope
) As Boolean
public:
static bool operator ==(
    WBSubstitutionScope^ s1,
    WBSubstitutionScope^ s2
)
static let inline (=)
        s1 : WBSubstitutionScope *
        s2 : WBSubstitutionScope  : bool

Parameters

s1
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
s2
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: Boolean
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Explicit Conversion (WBSubstitutionScope to String)

WBSubstitutionScope Conversion (WBSubstitutionScope to String) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static explicit operator string (
    WBSubstitutionScope scope
)
Public Shared Narrowing Operator CType (
    scope As WBSubstitutionScope
) As String
static explicit operator String^ (
    WBSubstitutionScope^ scope
)
F# does not support the declaration of new casting operators.

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: String
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope Implicit Conversion (String to WBSubstitutionScope)

WBSubstitutionScope Conversion (String to WBSubstitutionScope) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static implicit operator WBSubstitutionScope (
    string s
)
Public Shared Widening Operator CType (
    s As String
) As WBSubstitutionScope
static implicit operator WBSubstitutionScope^ (
    String^ s
)
F# does not support the declaration of new casting operators.

Parameters

s
Type: SystemString

Return Value

Type: WBSubstitutionScope
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScope.Inequality Operator

WBSubstitutionScopeInequality Operator Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    WBSubstitutionScope s1,
    WBSubstitutionScope s2
)
Public Shared Operator <> (
    s1 As WBSubstitutionScope,
    s2 As WBSubstitutionScope
) As Boolean
public:
static bool operator !=(
    WBSubstitutionScope^ s1,
    WBSubstitutionScope^ s2
)
static let inline (<>)
        s1 : WBSubstitutionScope *
        s2 : WBSubstitutionScope  : bool

Parameters

s1
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
s2
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: Boolean
See Also

Reference

WBSubstitutionScope Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes Class

WBSubstitutionScopes Class Datapolis Process System Class Reference
Data class
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScopes

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSubstitutionScopes : IList<WBSubstitutionScope>,
    ICollection<WBSubstitutionScope>, IEnumerable<WBSubstitutionScope>, IEnumerable
Public NotInheritable Class WBSubstitutionScopes
    Implements IList(Of WBSubstitutionScope), ICollection(Of WBSubstitutionScope),
    IEnumerable(Of WBSubstitutionScope), IEnumerable
public ref class WBSubstitutionScopes sealed : IList<WBSubstitutionScope^>,
    ICollection<WBSubstitutionScope^>, IEnumerable<WBSubstitutionScope^>, IEnumerable
[<SealedAttribute>]
type WBSubstitutionScopes =
    class
        interface IList<WBSubstitutionScope>
        interface ICollection<WBSubstitutionScope>
        interface IEnumerable<WBSubstitutionScope>
        interface IEnumerable
    end

The WBSubstitutionScopes type exposes the following members.

Constructors
 | Name | Description
Public method | WBSubstitutionScopes | Initializes a new instance of the WBSubstitutionScopes class
Top
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Substitution |
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | GetEnumerator |
Public method | GetXML | Serialize object to xml
Public method | IndexOf |
Public method | Insert |
 | Parse |
Public method | Remove |
Public method | RemoveAt |
Public method | SortByType |
Top
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes Constructor

WBSubstitutionScopes Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSubstitutionScopes class

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScopes()
Public Sub New
public:
WBSubstitutionScopes()
new : unit -> WBSubstitutionScopes
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes Properties

WBSubstitutionScopes Properties Datapolis Process System Class Reference

The WBSubstitutionScopes type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Substitution |
Top
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Count Property

WBSubstitutionScopesCount Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.IsReadOnly Property

WBSubstitutionScopesIsReadOnly Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Item Property

WBSubstitutionScopesItem Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitutionScope this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As WBSubstitutionScope
    Get
    Set
public:
virtual property WBSubstitutionScope^ default[int index] {
    WBSubstitutionScope^ get (int index) sealed;
    void set (int index, WBSubstitutionScope^ value) sealed;
}
abstract Item : WBSubstitutionScope with get, set
override Item : WBSubstitutionScope with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: WBSubstitutionScope

Implements

IListTItemInt32
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Substitution Property

WBSubstitutionScopesSubstitution Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSubstitution Substitution { get; }
Public ReadOnly Property Substitution As WBSubstitution
    Get
public:
property WBSubstitution^ Substitution {
    WBSubstitution^ get ();
}
member Substitution : WBSubstitution with get

Property Value

Type: WBSubstitution
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes Methods

WBSubstitutionScopes Methods Datapolis Process System Class Reference

The WBSubstitutionScopes type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | GetEnumerator |
Public method | GetXML | Serialize object to xml
Public method | IndexOf |
Public method | Insert |
 | Parse |
Public method | Remove |
Public method | RemoveAt |
Public method | SortByType |
Top
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Add Method

WBSubstitutionScopesAdd Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    WBSubstitutionScope scope
)
Public Sub Add (
    scope As WBSubstitutionScope
)
public:
virtual void Add(
    WBSubstitutionScope^ scope
) sealed
abstract Add :
        scope : WBSubstitutionScope -> unit
override Add :
        scope : WBSubstitutionScope -> unit

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Implements

ICollectionTAdd(T)
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Clear Method

WBSubstitutionScopesClear Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Contains Method

WBSubstitutionScopesContains Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    WBSubstitutionScope scope
)
Public Function Contains (
    scope As WBSubstitutionScope
) As Boolean
public:
virtual bool Contains(
    WBSubstitutionScope^ scope
) sealed
abstract Contains :
        scope : WBSubstitutionScope -> bool
override Contains :
        scope : WBSubstitutionScope -> bool

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: Boolean

Implements

ICollectionTContains(T)
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.CopyTo Method

WBSubstitutionScopesCopyTo Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    WBSubstitutionScope[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As WBSubstitutionScope(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<WBSubstitutionScope^>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : WBSubstitutionScope[] *
        arrayIndex : int -> unit
override CopyTo :
        array : WBSubstitutionScope[] *
        arrayIndex : int -> unit

Parameters

array
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope
arrayIndex
Type: SystemInt32

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.GetEnumerator Method

WBSubstitutionScopesGetEnumerator Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<WBSubstitutionScope> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of WBSubstitutionScope)
public:
virtual IEnumerator<WBSubstitutionScope^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<WBSubstitutionScope>
override GetEnumerator : unit -> IEnumerator<WBSubstitutionScope>

Return Value

Type: IEnumerator WBSubstitutionScope

Implements

IEnumerableTGetEnumerator
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.GetXML Method

WBSubstitutionScopesGetXML Method Datapolis Process System Class Reference
Serialize object to xml

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public XElement GetXML()
Public Function GetXML As XElement
public:
XElement^ GetXML()
member GetXML : unit -> XElement

Return Value

Type: XElement
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.IndexOf Method

WBSubstitutionScopesIndexOf Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    WBSubstitutionScope scope
)
Public Function IndexOf (
    scope As WBSubstitutionScope
) As Integer
public:
virtual int IndexOf(
    WBSubstitutionScope^ scope
) sealed
abstract IndexOf :
        scope : WBSubstitutionScope -> int
override IndexOf :
        scope : WBSubstitutionScope -> int

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: Int32

Implements

IListTIndexOf(T)
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Insert Method

WBSubstitutionScopesInsert Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int index,
    WBSubstitutionScope scope
)
Public Sub Insert (
    index As Integer,
    scope As WBSubstitutionScope
)
public:
virtual void Insert(
    int index,
    WBSubstitutionScope^ scope
) sealed
abstract Insert :
        index : int *
        scope : WBSubstitutionScope -> unit
override Insert :
        index : int *
        scope : WBSubstitutionScope -> unit

Parameters

index
Type: SystemInt32
scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Implements

IListTInsert(Int32, T)
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Parse Method

WBSubstitutionScopesParse Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static WBSubstitutionScopes Parse(
    string xml
)
Public Shared Function Parse (
    xml As String
) As WBSubstitutionScopes
public:
static WBSubstitutionScopes^ Parse(
    String^ xml
)
static member Parse :
        xml : string -> WBSubstitutionScopes

Parameters

xml
Type: SystemString

Return Value

Type: WBSubstitutionScopes
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.Remove Method

WBSubstitutionScopesRemove Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    WBSubstitutionScope scope
)
Public Function Remove (
    scope As WBSubstitutionScope
) As Boolean
public:
virtual bool Remove(
    WBSubstitutionScope^ scope
) sealed
abstract Remove :
        scope : WBSubstitutionScope -> bool
override Remove :
        scope : WBSubstitutionScope -> bool

Parameters

scope
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionScope

Return Value

Type: Boolean

Implements

ICollectionTRemove(T)
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.RemoveAt Method

WBSubstitutionScopesRemoveAt Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) sealed
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32

Implements

IListTRemoveAt(Int32)
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopes.SortByType Method

WBSubstitutionScopesSortByType Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public void SortByType()
Public Sub SortByType
public:
void SortByType()
member SortByType : unit -> unit
See Also

Reference

WBSubstitutionScopes Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionScopeType Enumeration

WBSubstitutionScopeType Enumeration Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBSubstitutionScopeType
Public Enumeration WBSubstitutionScopeType
public enum class WBSubstitutionScopeType
type WBSubstitutionScopeType
Members
Member name | Value | Description
Invalid | -1 |
Farm | 0 |
Application | 1 |
Site | 2 |
Web | 3 |
List | 4 |
ListWorkflow | 5 |
SiteWorkflow | 20 |
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionStatus Enumeration

WBSubstitutionStatus Enumeration Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public enum WBSubstitutionStatus
Public Enumeration WBSubstitutionStatus
public enum class WBSubstitutionStatus
type WBSubstitutionStatus
Members
Member name | Value | Description
None | 0 |
Active | 1 |
Planned | 2 |
Finished | 3 |
Removed | 4 |
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionStatusLocalizer Class

WBSubstitutionStatusLocalizer Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionStatusLocalizer

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static class WBSubstitutionStatusLocalizer
Public NotInheritable Class WBSubstitutionStatusLocalizer
public ref class WBSubstitutionStatusLocalizer abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WBSubstitutionStatusLocalizer =  class end

The WBSubstitutionStatusLocalizer type exposes the following members.

Methods
Name | Description
Get |
Top
See Also

Reference

Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionStatusLocalizer Methods

WBSubstitutionStatusLocalizer Methods Datapolis Process System Class Reference

The WBSubstitutionStatusLocalizer type exposes the following members.

Methods
Name | Description
Get |
Top
See Also

Reference

WBSubstitutionStatusLocalizer Class
Datapolis.WorkBox.Common.Substitutions Namespace


WBSubstitutionStatusLocalizer.Get Method

WBSubstitutionStatusLocalizerGet Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.Substitutions
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public static string Get(
    WBSubstitutionStatus status,
    CultureInfo ci
)
Public Shared Function Get (
    status As WBSubstitutionStatus,
    ci As CultureInfo
) As String
public:
static String^ Get(
    WBSubstitutionStatus status,
    CultureInfo^ ci
)
static member Get :
        status : WBSubstitutionStatus *
        ci : CultureInfo -> string

Parameters

status
Type: Datapolis.WorkBox.Common.SubstitutionsWBSubstitutionStatus
ci
Type: System.GlobalizationCultureInfo

Return Value

Type: String
See Also

Reference

WBSubstitutionStatusLocalizer Class
Datapolis.WorkBox.Common.Substitutions Namespace


Datapolis.WorkBox.Common.WBInterface Namespace

Datapolis.WorkBox.Common.WBInterface Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBAdministrationManager | This interface provides: - Ability to match given xaml content to selected workflow. If matching succedes then workflow xaml is replaced with the one from user. - Ability to deploy workflow on selected web. It's accesible by multiple ways: - WBAdministration service as a Web Service - Through object model - From PowerShell (both Web Service and Object Model are handled)
Public class | WBInterfaceManager |


WBAdministrationManager Class

WBAdministrationManager Class Datapolis Process System Class Reference
This interface provides: - Ability to match given xaml content to selected workflow. If matching succedes then workflow xaml is replaced with the one from user. - Ability to deploy workflow on selected web. It's accesible by multiple ways: - WBAdministration service as a Web Service - Through object model - From PowerShell (both Web Service and Object Model are handled)
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.WBInterfaceWBAdministrationManager

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBAdministrationManager
Public Class WBAdministrationManager
public ref class WBAdministrationManager
type WBAdministrationManager =  class end

The WBAdministrationManager type exposes the following members.

Constructors
 | Name | Description
Public method | WBAdministrationManager | Initializes a new instance of the WBAdministrationManager class
Top
Methods
 | Name | Description
Public method | DeployWorkflow | Deploys (associates) specified workflow.
Public method | MatchXaml | Matches xaml for specified workflow and then updates this workflow on web.
Top
See Also

Reference

Datapolis.WorkBox.Common.WBInterface Namespace


WBAdministrationManager Constructor

WBAdministrationManager Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBAdministrationManager class

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBAdministrationManager(
    SPWeb web
)
Public Sub New (
    web As SPWeb
)
public:
WBAdministrationManager(
    SPWeb^ web
)
new :
        web : SPWeb -> WBAdministrationManager

Parameters

web
Type: SPWeb
See Also

Reference

WBAdministrationManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBAdministrationManager Methods

WBAdministrationManager Methods Datapolis Process System Class Reference

The WBAdministrationManager type exposes the following members.

Methods
 | Name | Description
Public method | DeployWorkflow | Deploys (associates) specified workflow.
Public method | MatchXaml | Matches xaml for specified workflow and then updates this workflow on web.
Top
See Also

Reference

WBAdministrationManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBAdministrationManager.DeployWorkflow Method

WBAdministrationManagerDeployWorkflow Method Datapolis Process System Class Reference
Deploys (associates) specified workflow.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo DeployWorkflow(
    string workflowName
)
Public Function DeployWorkflow (
    workflowName As String
) As WBResultInfo
public:
WBResultInfo^ DeployWorkflow(
    String^ workflowName
)
member DeployWorkflow :
        workflowName : string -> WBResultInfo

Parameters

workflowName
Type: SystemString

Return Value

Type: WBResultInfo
See Also

Reference

WBAdministrationManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBAdministrationManager.MatchXaml Method

WBAdministrationManagerMatchXaml Method Datapolis Process System Class Reference
Matches xaml for specified workflow and then updates this workflow on web.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo MatchXaml(
    string workflowName,
    string xaml
)
Public Function MatchXaml (
    workflowName As String,
    xaml As String
) As WBResultInfo
public:
WBResultInfo^ MatchXaml(
    String^ workflowName,
    String^ xaml
)
member MatchXaml :
        workflowName : string *
        xaml : string -> WBResultInfo

Parameters

workflowName
Type: SystemString
Workflow which should be matched and updated.
xaml
Type: SystemString
New workflow XAML code which will be matched and saved.

Return Value

Type: WBResultInfo
See Also

Reference

WBAdministrationManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager Class

WBInterfaceManager Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Common.WBInterfaceWBInterfaceManager

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public class WBInterfaceManager
Public Class WBInterfaceManager
public ref class WBInterfaceManager
type WBInterfaceManager =  class end

The WBInterfaceManager type exposes the following members.

Constructors
 | Name | Description
Public method | WBInterfaceManager | Initializes a new instance of the WBInterfaceManager class
Top
Methods
 | Name | Description
Public method | GetAssignedToCount | Returns a number of Workbox workflows that current user can interact with
Public method | GetAssignedToCount(Boolean, Boolean, Boolean) | Returns a number of Workbox workflows that current user and/or its substitution(s) can interact with
Public method | GetAssignedToCountOfSubstitutedUser | Returns a number of Workbox workflows that current user and/or its substitution(s) can interact with
Public method | GetUserWBWorkflowShortInfos |
Public method | GetUserWBWorkflowShortInfosOfSubstitutedUser |
Public method | GetWBActions | Returns information about available actions for items in selected list.
Public method | GetWBAllActions | Returns information about available actions for items in selected list with filled property WorkflowInfos containing whole workflows actions
Public method | GetWBItemInfo | Returns information about Workbox workflow running/completed/available to start on list item.
Public method | GetWBListInfo | Returns information about Workbox workflows on selected list
Public method | GetWBSiteInfo | Returns information about Workbox workflows on selected site
Public method | GetWBWorkflowInfo | Returns information about Workbox workflow - available actions and theirs parameters.
Public method | GetWBWorkflowShortInfos |
Public method | IsWBOnList | Return true if there is at least one deployed workbox workflow on selected list.
Public method | LaunchWBAction | Launches choosen action on Workbox workflow.
Public method | LaunchWBActions | Launches a set of workflow actions.
Public method | SimpleLaunchWBAction | Launches choosen action on Workbox workflow.
Public method | StartWBSiteWorkflow | Starts selected Workbox workflow on site.
Public method | StartWBWorkflow | Starts selected Workbox workflow on list item.
Public method | TerminateWBWorkflow | Terminates Workbox workflow.
Top
See Also

Reference

Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager Constructor

WBInterfaceManager Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBInterfaceManager class

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBInterfaceManager(
    SPWeb web
)
Public Sub New (
    web As SPWeb
)
public:
WBInterfaceManager(
    SPWeb^ web
)
new :
        web : SPWeb -> WBInterfaceManager

Parameters

web
Type: SPWeb
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager Methods

WBInterfaceManager Methods Datapolis Process System Class Reference

The WBInterfaceManager type exposes the following members.

Methods
 | Name | Description
Public method | GetAssignedToCount | Returns a number of Workbox workflows that current user can interact with
Public method | GetAssignedToCount(Boolean, Boolean, Boolean) | Returns a number of Workbox workflows that current user and/or its substitution(s) can interact with
Public method | GetAssignedToCountOfSubstitutedUser | Returns a number of Workbox workflows that current user and/or its substitution(s) can interact with
Public method | GetUserWBWorkflowShortInfos |
Public method | GetUserWBWorkflowShortInfosOfSubstitutedUser |
Public method | GetWBActions | Returns information about available actions for items in selected list.
Public method | GetWBAllActions | Returns information about available actions for items in selected list with filled property WorkflowInfos containing whole workflows actions
Public method | GetWBItemInfo | Returns information about Workbox workflow running/completed/available to start on list item.
Public method | GetWBListInfo | Returns information about Workbox workflows on selected list
Public method | GetWBSiteInfo | Returns information about Workbox workflows on selected site
Public method | GetWBWorkflowInfo | Returns information about Workbox workflow - available actions and theirs parameters.
Public method | GetWBWorkflowShortInfos |
Public method | IsWBOnList | Return true if there is at least one deployed workbox workflow on selected list.
Public method | LaunchWBAction | Launches choosen action on Workbox workflow.
Public method | LaunchWBActions | Launches a set of workflow actions.
Public method | SimpleLaunchWBAction | Launches choosen action on Workbox workflow.
Public method | StartWBSiteWorkflow | Starts selected Workbox workflow on site.
Public method | StartWBWorkflow | Starts selected Workbox workflow on list item.
Public method | TerminateWBWorkflow | Terminates Workbox workflow.
Top
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetAssignedToCount Method

WBInterfaceManagerGetAssignedToCount Method Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | GetAssignedToCount | Returns a number of Workbox workflows that current user can interact with
Public method | GetAssignedToCount(Boolean, Boolean, Boolean) | Returns a number of Workbox workflows that current user and/or its substitution(s) can interact with
Top
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetAssignedToCount Method

WBInterfaceManagerGetAssignedToCount Method Datapolis Process System Class Reference
Returns a number of Workbox workflows that current user can interact with

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int GetAssignedToCount()
Public Function GetAssignedToCount As Integer
public:
int GetAssignedToCount()
member GetAssignedToCount : unit -> int

Return Value

Type: Int32
Number of workflows
See Also

Reference

WBInterfaceManager Class
GetAssignedToCount Overload
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetAssignedToCount Method (Boolean, Boolean, Boolean)

WBInterfaceManagerGetAssignedToCount Method (Boolean, Boolean, Boolean) Datapolis Process System Class Reference
Returns a number of Workbox workflows that current user and/or its substitution(s) can interact with

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int GetAssignedToCount(
    bool withSubstitutions,
    bool onlySubstitutions = false,
    bool ignoreUserItemPermissions = false
)
Public Function GetAssignedToCount (
    withSubstitutions As Boolean,
    Optional onlySubstitutions As Boolean = false,
    Optional ignoreUserItemPermissions As Boolean = false
) As Integer
public:
int GetAssignedToCount(
    bool withSubstitutions,
    bool onlySubstitutions = false,
    bool ignoreUserItemPermissions = false
)
member GetAssignedToCount :
        withSubstitutions : bool *
        ?onlySubstitutions : bool *
        ?ignoreUserItemPermissions : bool
(* Defaults:
        let _onlySubstitutions = defaultArg onlySubstitutions false
        let _ignoreUserItemPermissions = defaultArg ignoreUserItemPermissions false
*)
-> int

Parameters

withSubstitutions
Type: SystemBoolean
onlySubstitutions (Optional)
Type: SystemBoolean
ignoreUserItemPermissions (Optional)
Type: SystemBoolean

Return Value

Type: Int32
Number of workflows
See Also

Reference

WBInterfaceManager Class
GetAssignedToCount Overload
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetAssignedToCountOfSubstitutedUser Method

WBInterfaceManagerGetAssignedToCountOfSubstitutedUser Method Datapolis Process System Class Reference
Returns a number of Workbox workflows that current user and/or its substitution(s) can interact with

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public int GetAssignedToCountOfSubstitutedUser(
    string substitutedUserLogin,
    bool ignoreUserItemPermissions
)
Public Function GetAssignedToCountOfSubstitutedUser (
    substitutedUserLogin As String,
    ignoreUserItemPermissions As Boolean
) As Integer
public:
int GetAssignedToCountOfSubstitutedUser(
    String^ substitutedUserLogin,
    bool ignoreUserItemPermissions
)
member GetAssignedToCountOfSubstitutedUser :
        substitutedUserLogin : string *
        ignoreUserItemPermissions : bool -> int

Parameters

substitutedUserLogin
Type: SystemString
ignoreUserItemPermissions
Type: SystemBoolean

Return Value

Type: Int32
Number of workflows
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetUserWBWorkflowShortInfos Method

WBInterfaceManagerGetUserWBWorkflowShortInfos Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public List<WBWorkflowShortInfo> GetUserWBWorkflowShortInfos(
    int from,
    int to,
    bool withSubstitutions = false,
    bool onlySubstitusions = false,
    bool ignoreUserItemPermissions = false
)
Public Function GetUserWBWorkflowShortInfos (
    from As Integer,
    to As Integer,
    Optional withSubstitutions As Boolean = false,
    Optional onlySubstitusions As Boolean = false,
    Optional ignoreUserItemPermissions As Boolean = false
) As List(Of WBWorkflowShortInfo)
public:
List<WBWorkflowShortInfo^>^ GetUserWBWorkflowShortInfos(
    int from,
    int to,
    bool withSubstitutions = false,
    bool onlySubstitusions = false,
    bool ignoreUserItemPermissions = false
)
member GetUserWBWorkflowShortInfos :
        from : int *
        to : int *
        ?withSubstitutions : bool *
        ?onlySubstitusions : bool *
        ?ignoreUserItemPermissions : bool
(* Defaults:
        let _withSubstitutions = defaultArg withSubstitutions false
        let _onlySubstitusions = defaultArg onlySubstitusions false
        let _ignoreUserItemPermissions = defaultArg ignoreUserItemPermissions false
*)
-> List<WBWorkflowShortInfo>

Parameters

from
Type: SystemInt32
to
Type: SystemInt32
withSubstitutions (Optional)
Type: SystemBoolean
onlySubstitusions (Optional)
Type: SystemBoolean
ignoreUserItemPermissions (Optional)
Type: SystemBoolean

Return Value

Type: List WBWorkflowShortInfo
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetUserWBWorkflowShortInfosOfSubstitutedUser Method

WBInterfaceManagerGetUserWBWorkflowShortInfosOfSubstitutedUser Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public List<WBWorkflowShortInfo> GetUserWBWorkflowShortInfosOfSubstitutedUser(
    int from,
    int to,
    string substitutedUserLogin,
    bool ignoreUserItemPermissions = false
)
Public Function GetUserWBWorkflowShortInfosOfSubstitutedUser (
    from As Integer,
    to As Integer,
    substitutedUserLogin As String,
    Optional ignoreUserItemPermissions As Boolean = false
) As List(Of WBWorkflowShortInfo)
public:
List<WBWorkflowShortInfo^>^ GetUserWBWorkflowShortInfosOfSubstitutedUser(
    int from,
    int to,
    String^ substitutedUserLogin,
    bool ignoreUserItemPermissions = false
)
member GetUserWBWorkflowShortInfosOfSubstitutedUser :
        from : int *
        to : int *
        substitutedUserLogin : string *
        ?ignoreUserItemPermissions : bool
(* Defaults:
        let _ignoreUserItemPermissions = defaultArg ignoreUserItemPermissions false
*)
-> List<WBWorkflowShortInfo>

Parameters

from
Type: SystemInt32
to
Type: SystemInt32
substitutedUserLogin
Type: SystemString
ignoreUserItemPermissions (Optional)
Type: SystemBoolean

Return Value

Type: List WBWorkflowShortInfo
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetWBActions Method

WBInterfaceManagerGetWBActions Method Datapolis Process System Class Reference
Returns information about available actions for items in selected list.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBActions GetWBActions(
    string listUrl,
    int[] itemIds
)
Public Function GetWBActions (
    listUrl As String,
    itemIds As Integer()
) As WBActions
public:
WBActions^ GetWBActions(
    String^ listUrl,
    array<int>^ itemIds
)
member GetWBActions :
        listUrl : string *
        itemIds : int[] -> WBActions

Parameters

listUrl
Type: SystemString
Server relative url to list
itemIds
Type: SystemInt32

Return Value

Type: WBActions
A WBActions object that contains information about available actions.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetWBAllActions Method

WBInterfaceManagerGetWBAllActions Method Datapolis Process System Class Reference
Returns information about available actions for items in selected list with filled property WorkflowInfos containing whole workflows actions

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBAllActions GetWBAllActions(
    string listUrl,
    int[] itemIds
)
Public Function GetWBAllActions (
    listUrl As String,
    itemIds As Integer()
) As WBAllActions
public:
WBAllActions^ GetWBAllActions(
    String^ listUrl,
    array<int>^ itemIds
)
member GetWBAllActions :
        listUrl : string *
        itemIds : int[] -> WBAllActions

Parameters

listUrl
Type: SystemString
Server relative url to list
itemIds
Type: SystemInt32

Return Value

Type: WBAllActions
A WBActions object that contains information about available actions.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetWBItemInfo Method

WBInterfaceManagerGetWBItemInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflow running/completed/available to start on list item.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBItemInfo GetWBItemInfo(
    string listUrl,
    int itemID
)
Public Function GetWBItemInfo (
    listUrl As String,
    itemID As Integer
) As WBItemInfo
public:
WBItemInfo^ GetWBItemInfo(
    String^ listUrl,
    int itemID
)
member GetWBItemInfo :
        listUrl : string *
        itemID : int -> WBItemInfo

Parameters

listUrl
Type: SystemString
Server relative url to list
itemID
Type: SystemInt32
Item ID

Return Value

Type: WBItemInfo
A WBItemInfo object that contains information about Workbox workflows on item.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetWBListInfo Method

WBInterfaceManagerGetWBListInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflows on selected list

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBListInfo GetWBListInfo(
    string listUrl
)
Public Function GetWBListInfo (
    listUrl As String
) As WBListInfo
public:
WBListInfo^ GetWBListInfo(
    String^ listUrl
)
member GetWBListInfo :
        listUrl : string -> WBListInfo

Parameters

listUrl
Type: SystemString
Server relative url to list

Return Value

Type: WBListInfo
A WBListInfo object that contains information about Workbox workflows on list.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetWBSiteInfo Method

WBInterfaceManagerGetWBSiteInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflows on selected site

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfo GetWBSiteInfo()
Public Function GetWBSiteInfo As WBSiteInfo
public:
WBSiteInfo^ GetWBSiteInfo()
member GetWBSiteInfo : unit -> WBSiteInfo

Return Value

Type: WBSiteInfo
A WBSiteInfo object that contains information about Workbox workflows on site.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetWBWorkflowInfo Method

WBInterfaceManagerGetWBWorkflowInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflow - available actions and theirs parameters.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowInfo GetWBWorkflowInfo(
    Guid instanceID
)
Public Function GetWBWorkflowInfo (
    instanceID As Guid
) As WBWorkflowInfo
public:
WBWorkflowInfo^ GetWBWorkflowInfo(
    Guid instanceID
)
member GetWBWorkflowInfo :
        instanceID : Guid -> WBWorkflowInfo

Parameters

instanceID
Type: SystemGuid
Workflow instance ID

Return Value

Type: WBWorkflowInfo
A WBWorkflowInfo object that contains information about Workbox workflow.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.GetWBWorkflowShortInfos Method

WBInterfaceManagerGetWBWorkflowShortInfos Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public List<WBWorkflowShortInfo> GetWBWorkflowShortInfos(
    int from,
    int to
)
Public Function GetWBWorkflowShortInfos (
    from As Integer,
    to As Integer
) As List(Of WBWorkflowShortInfo)
public:
List<WBWorkflowShortInfo^>^ GetWBWorkflowShortInfos(
    int from,
    int to
)
member GetWBWorkflowShortInfos :
        from : int *
        to : int -> List<WBWorkflowShortInfo>

Parameters

from
Type: SystemInt32
to
Type: SystemInt32

Return Value

Type: List WBWorkflowShortInfo
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.IsWBOnList Method

WBInterfaceManagerIsWBOnList Method Datapolis Process System Class Reference
Return true if there is at least one deployed workbox workflow on selected list.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo IsWBOnList(
    string listUrl
)
Public Function IsWBOnList (
    listUrl As String
) As WBResultInfo
public:
WBResultInfo^ IsWBOnList(
    String^ listUrl
)
member IsWBOnList :
        listUrl : string -> WBResultInfo

Parameters

listUrl
Type: SystemString
Server relative url to list

Return Value

Type: WBResultInfo
A WBResultInfo object that represents Workbox workflow existence on list.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.LaunchWBAction Method

WBInterfaceManagerLaunchWBAction Method Datapolis Process System Class Reference
Launches choosen action on Workbox workflow.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo LaunchWBAction(
    Guid instanceID,
    WBActionInfo action
)
Public Function LaunchWBAction (
    instanceID As Guid,
    action As WBActionInfo
) As WBResultInfo
public:
WBResultInfo^ LaunchWBAction(
    Guid instanceID,
    WBActionInfo^ action
)
member LaunchWBAction :
        instanceID : Guid *
        action : WBActionInfo -> WBResultInfo

Parameters

instanceID
Type: SystemGuid
Workbox workflow instance ID
action
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfo
Action to launch (from WBWorkflowInfo.WorkflowActions[])

Return Value

Type: WBResultInfo
A WBResultInfo object that represents action launch result.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.LaunchWBActions Method

WBInterfaceManagerLaunchWBActions Method Datapolis Process System Class Reference
Launches a set of workflow actions.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo LaunchWBActions(
    List<int> itemIDs,
    Guid baseID,
    WBActionInfo action
)
Public Function LaunchWBActions (
    itemIDs As List(Of Integer),
    baseID As Guid,
    action As WBActionInfo
) As WBResultInfo
public:
WBResultInfo^ LaunchWBActions(
    List<int>^ itemIDs,
    Guid baseID,
    WBActionInfo^ action
)
member LaunchWBActions :
        itemIDs : List<int> *
        baseID : Guid *
        action : WBActionInfo -> WBResultInfo

Parameters

itemIDs
Type: System.Collections.GenericList Int32
IDs of items on which works workflows to launch the actions on.
baseID
Type: SystemGuid
BaseID of workflow.
action
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfo
Action to launch (from WBWorkflowInfo.WorkflowActions[]).

Return Value

Type: WBResultInfo
A WBResultInfo object that represents bulk actions launch result.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.SimpleLaunchWBAction Method

WBInterfaceManagerSimpleLaunchWBAction Method Datapolis Process System Class Reference
Launches choosen action on Workbox workflow.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo SimpleLaunchWBAction(
    string listUrl,
    int itemID,
    string workflowName,
    string stateTitle,
    string actionTitle
)
Public Function SimpleLaunchWBAction (
    listUrl As String,
    itemID As Integer,
    workflowName As String,
    stateTitle As String,
    actionTitle As String
) As WBResultInfo
public:
WBResultInfo^ SimpleLaunchWBAction(
    String^ listUrl,
    int itemID,
    String^ workflowName,
    String^ stateTitle,
    String^ actionTitle
)
member SimpleLaunchWBAction :
        listUrl : string *
        itemID : int *
        workflowName : string *
        stateTitle : string *
        actionTitle : string -> WBResultInfo

Parameters

listUrl
Type: SystemString
Server relative url to list
itemID
Type: SystemInt32
Item ID
workflowName
Type: SystemString
Workflow definition name
stateTitle
Type: SystemString
State name
actionTitle
Type: SystemString
Action name

Return Value

Type: WBResultInfo
A WBResultInfo object that represents action launch result.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.StartWBSiteWorkflow Method

WBInterfaceManagerStartWBSiteWorkflow Method Datapolis Process System Class Reference
Starts selected Workbox workflow on site.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo StartWBSiteWorkflow(
    WBSiteInfoWorkflow workflowInfo
)
Public Function StartWBSiteWorkflow (
    workflowInfo As WBSiteInfoWorkflow
) As WBResultInfo
public:
WBResultInfo^ StartWBSiteWorkflow(
    WBSiteInfoWorkflow^ workflowInfo
)
member StartWBSiteWorkflow :
        workflowInfo : WBSiteInfoWorkflow -> WBResultInfo

Parameters

workflowInfo
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfoWorkflow
Workbox workflow to start (from WBSiteInfo.ToBeStartedWorkflows[])

Return Value

Type: WBResultInfo
A WBResultInfo object that represents start workflow result.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.StartWBWorkflow Method

WBInterfaceManagerStartWBWorkflow Method Datapolis Process System Class Reference
Starts selected Workbox workflow on list item.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo StartWBWorkflow(
    string listUrl,
    int itemID,
    WBListInfoWorkflow workflowInfo
)
Public Function StartWBWorkflow (
    listUrl As String,
    itemID As Integer,
    workflowInfo As WBListInfoWorkflow
) As WBResultInfo
public:
WBResultInfo^ StartWBWorkflow(
    String^ listUrl,
    int itemID,
    WBListInfoWorkflow^ workflowInfo
)
member StartWBWorkflow :
        listUrl : string *
        itemID : int *
        workflowInfo : WBListInfoWorkflow -> WBResultInfo

Parameters

listUrl
Type: SystemString
Server relative url to list
itemID
Type: SystemInt32
Item ID
workflowInfo
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBListInfoWorkflow
Workbox workflow to start (from WBItemInfo.ToBeStartedWorkflows[])

Return Value

Type: WBResultInfo
A WBResultInfo object that represents start workflow result.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


WBInterfaceManager.TerminateWBWorkflow Method

WBInterfaceManagerTerminateWBWorkflow Method Datapolis Process System Class Reference
Terminates Workbox workflow.

Namespace: Datapolis.WorkBox.Common.WBInterface
Assembly: Datapolis.WorkBox.Common (in Datapolis.WorkBox.Common.dll) Version: 1.1.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo TerminateWBWorkflow(
    Guid instanceID
)
Public Function TerminateWBWorkflow (
    instanceID As Guid
) As WBResultInfo
public:
WBResultInfo^ TerminateWBWorkflow(
    Guid instanceID
)
member TerminateWBWorkflow :
        instanceID : Guid -> WBResultInfo

Parameters

instanceID
Type: SystemGuid
Workflow instance ID

Return Value

Type: WBResultInfo
A WBResultInfo object that represents terminate workflow result.
See Also

Reference

WBInterfaceManager Class
Datapolis.WorkBox.Common.WBInterface Namespace


Datapolis.WorkBox.Functions Namespace

Datapolis.WorkBox.Functions Namespace Datapolis Process System Class Reference
Interfaces
 | Interface | Description
Public interface | IWBFunctionBase |


IWBFunctionBase Interface

IWBFunctionBase Interface Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Functions
Assembly: Datapolis.WorkBox.Functions (in Datapolis.WorkBox.Functions.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public interface IWBFunctionBase
Public Interface IWBFunctionBase
public interface class IWBFunctionBase
type IWBFunctionBase =  interface end

The IWBFunctionBase type exposes the following members.

Methods
 | Name | Description
Public method | Execute |
Top
See Also

Reference

Datapolis.WorkBox.Functions Namespace


IWBFunctionBase Methods

IWBFunctionBase Methods Datapolis Process System Class Reference

The IWBFunctionBase type exposes the following members.

Methods
 | Name | Description
Public method | Execute |
Top
See Also

Reference

IWBFunctionBase Interface
Datapolis.WorkBox.Functions Namespace


IWBFunctionBase.Execute Method

IWBFunctionBaseExecute Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Functions
Assembly: Datapolis.WorkBox.Functions (in Datapolis.WorkBox.Functions.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
Object Execute(
    WBFunctionExecutionContext functionExecutionContext
)
Function Execute (
    functionExecutionContext As WBFunctionExecutionContext
) As Object
Object^ Execute(
    WBFunctionExecutionContext^ functionExecutionContext
)
abstract Execute :
        functionExecutionContext : WBFunctionExecutionContext -> Object

Parameters

functionExecutionContext
Type: Datapolis.WorkBox.CommonWBFunctionExecutionContext

Return Value

Type: Object
See Also

Reference

IWBFunctionBase Interface
Datapolis.WorkBox.Functions Namespace


Datapolis.WorkBox.Utilities Namespace

Datapolis.WorkBox.Utilities Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBVariables | WBVariables
Public class | XmlSchemaIncludeNormalizer |
Public class | XsdSchemaNormalizer |
Enumerations
 | Enumeration | Description
Public enumeration | WBFormType | WBFormType
Public enumeration | WBLaunchFormType | WBLaunchFormType
Public enumeration | WBVariableType | WBVariableType


WBFormType Enumeration

WBFormType Enumeration Datapolis Process System Class Reference
WBFormType

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public enum WBFormType
Public Enumeration WBFormType
public enum class WBFormType
type WBFormType
Members
Member name | Value | Description
QuickForm | 0 | QuickForm
InfoPathForm | 1 | InfoPathForm
CustomForm | 2 | CustomForm
None | 3 | None
See Also

Reference

Datapolis.WorkBox.Utilities Namespace


WBLaunchFormType Enumeration

WBLaunchFormType Enumeration Datapolis Process System Class Reference
WBLaunchFormType

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public enum WBLaunchFormType
Public Enumeration WBLaunchFormType
public enum class WBLaunchFormType
type WBLaunchFormType
Members
Member name | Value | Description
QuickForm | 0 | QuickForm
CustomForm | 1 | CustomForm
InfoPathForm | 2 | InfoPathForm
None | 3 | None
See Also

Reference

Datapolis.WorkBox.Utilities Namespace


WBVariables Class

WBVariables Class Datapolis Process System Class Reference
WBVariables
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.UtilitiesWBVariables

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static class WBVariables
Public NotInheritable Class WBVariables
public ref class WBVariables abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WBVariables =  class end

The WBVariables type exposes the following members.

Fields
Name | Description
Version | 3.0.0.0
WBInfoNamespace | http://tempuri.org/
WBInterfaceNamespace | http://datapolis.com/wbinterface/
WBXml_xmlns | http://www.w3.org/2001/XMLSchema
Top
See Also

Reference

Datapolis.WorkBox.Utilities Namespace


WBVariables Fields

WBVariables Fields Datapolis Process System Class Reference

The WBVariables type exposes the following members.

Fields
Name | Description
Version | 3.0.0.0
WBInfoNamespace | http://tempuri.org/
WBInterfaceNamespace | http://datapolis.com/wbinterface/
WBXml_xmlns | http://www.w3.org/2001/XMLSchema
Top
See Also

Reference

WBVariables Class
Datapolis.WorkBox.Utilities Namespace


WBVariables.Version Field

WBVariablesVersion Field Datapolis Process System Class Reference
3.0.0.0

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public const string Version = "4.4.0.4737"
Public Const Version As String = "4.4.0.4737"
public:
literal String^ Version = "4.4.0.4737"
static val mutable Version: string

Field Value

Type: String
See Also

Reference

WBVariables Class
Datapolis.WorkBox.Utilities Namespace


WBVariables.WBInfoNamespace Field

WBVariablesWBInfoNamespace Field Datapolis Process System Class Reference
http://tempuri.org/

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public const string WBInfoNamespace = "http://tempuri.org/"
Public Const WBInfoNamespace As String = "http://tempuri.org/"
public:
literal String^ WBInfoNamespace = "http://tempuri.org/"
static val mutable WBInfoNamespace: string

Field Value

Type: String
See Also

Reference

WBVariables Class
Datapolis.WorkBox.Utilities Namespace


WBVariables.WBInterfaceNamespace Field

WBVariablesWBInterfaceNamespace Field Datapolis Process System Class Reference
http://datapolis.com/wbinterface/

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public const string WBInterfaceNamespace = "http://datapolis.com/wbinterface/"
Public Const WBInterfaceNamespace As String = "http://datapolis.com/wbinterface/"
public:
literal String^ WBInterfaceNamespace = "http://datapolis.com/wbinterface/"
static val mutable WBInterfaceNamespace: string

Field Value

Type: String
See Also

Reference

WBVariables Class
Datapolis.WorkBox.Utilities Namespace


WBVariables.WBXml_xmlns Field

WBVariablesWBXml_xmlns Field Datapolis Process System Class Reference
http://www.w3.org/2001/XMLSchema

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public const string WBXml_xmlns = "http://www.w3.org/2001/XMLSchema"
Public Const WBXml_xmlns As String = "http://www.w3.org/2001/XMLSchema"
public:
literal String^ WBXml_xmlns = "http://www.w3.org/2001/XMLSchema"
static val mutable WBXml_xmlns: string

Field Value

Type: String
See Also

Reference

WBVariables Class
Datapolis.WorkBox.Utilities Namespace


WBVariableType Enumeration

WBVariableType Enumeration Datapolis Process System Class Reference
WBVariableType

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public enum WBVariableType
Public Enumeration WBVariableType
public enum class WBVariableType
type WBVariableType
Members
Member name | Value | Description
String | 0 | String
Int | 1 | Int
Bool | 2 | Boolean
Double | 3 | Double
DateTime | 4 | DateTime
Guid | 5 | Guid
Hashtable | 6 | Hashtable
Object | 7 | Object
See Also

Reference

Datapolis.WorkBox.Utilities Namespace


XmlSchemaIncludeNormalizer Class

XmlSchemaIncludeNormalizer Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.UtilitiesXmlSchemaIncludeNormalizer

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class XmlSchemaIncludeNormalizer
Public Class XmlSchemaIncludeNormalizer
public ref class XmlSchemaIncludeNormalizer
type XmlSchemaIncludeNormalizer =  class end

The XmlSchemaIncludeNormalizer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSchemaIncludeNormalizer | Initializes a new instance of the XmlSchemaIncludeNormalizer class
Top
Methods
Name | Description
BuildIncludeFreeXmlSchema |
Top
See Also

Reference

Datapolis.WorkBox.Utilities Namespace


XmlSchemaIncludeNormalizer Constructor

XmlSchemaIncludeNormalizer Constructor Datapolis Process System Class Reference
Initializes a new instance of the XmlSchemaIncludeNormalizer class

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public XmlSchemaIncludeNormalizer()
Public Sub New
public:
XmlSchemaIncludeNormalizer()
new : unit -> XmlSchemaIncludeNormalizer
See Also

Reference

XmlSchemaIncludeNormalizer Class
Datapolis.WorkBox.Utilities Namespace


XmlSchemaIncludeNormalizer Methods

XmlSchemaIncludeNormalizer Methods Datapolis Process System Class Reference

The XmlSchemaIncludeNormalizer type exposes the following members.

Methods
Name | Description
BuildIncludeFreeXmlSchema |
Top
See Also

Reference

XmlSchemaIncludeNormalizer Class
Datapolis.WorkBox.Utilities Namespace


XmlSchemaIncludeNormalizer.BuildIncludeFreeXmlSchema Method

XmlSchemaIncludeNormalizerBuildIncludeFreeXmlSchema Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchema BuildIncludeFreeXmlSchema(
    XmlSchema inSch
)
Public Shared Function BuildIncludeFreeXmlSchema (
    inSch As XmlSchema
) As XmlSchema
public:
static XmlSchema^ BuildIncludeFreeXmlSchema(
    XmlSchema^ inSch
)
static member BuildIncludeFreeXmlSchema :
        inSch : XmlSchema -> XmlSchema

Parameters

inSch
Type: System.Xml.SchemaXmlSchema

Return Value

Type: XmlSchema
See Also

Reference

XmlSchemaIncludeNormalizer Class
Datapolis.WorkBox.Utilities Namespace


XsdSchemaNormalizer Class

XsdSchemaNormalizer Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.UtilitiesXsdSchemaNormalizer

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class XsdSchemaNormalizer
Public Class XsdSchemaNormalizer
public ref class XsdSchemaNormalizer
type XsdSchemaNormalizer =  class end

The XsdSchemaNormalizer type exposes the following members.

Constructors
 | Name | Description
Public method | XsdSchemaNormalizer | Initializes a new instance of the XsdSchemaNormalizer class
Top
Methods
Name | Description
NormalizeXmlSchema(XmlSchema) |
NormalizeXmlSchema(XmlSchemaSet, XmlSchema) |
Top
See Also

Reference

Datapolis.WorkBox.Utilities Namespace


XsdSchemaNormalizer Constructor

XsdSchemaNormalizer Constructor Datapolis Process System Class Reference
Initializes a new instance of the XsdSchemaNormalizer class

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public XsdSchemaNormalizer()
Public Sub New
public:
XsdSchemaNormalizer()
new : unit -> XsdSchemaNormalizer
See Also

Reference

XsdSchemaNormalizer Class
Datapolis.WorkBox.Utilities Namespace


XsdSchemaNormalizer Methods

XsdSchemaNormalizer Methods Datapolis Process System Class Reference
Methods
Name | Description
NormalizeXmlSchema(XmlSchema) |
NormalizeXmlSchema(XmlSchemaSet, XmlSchema) |
Top
See Also

Reference

XsdSchemaNormalizer Class
Datapolis.WorkBox.Utilities Namespace


XsdSchemaNormalizer.NormalizeXmlSchema Method

XsdSchemaNormalizerNormalizeXmlSchema Method Datapolis Process System Class Reference
Overload List
Name | Description
NormalizeXmlSchema(XmlSchema) |
NormalizeXmlSchema(XmlSchemaSet, XmlSchema) |
Top
See Also

Reference

XsdSchemaNormalizer Class
Datapolis.WorkBox.Utilities Namespace


XsdSchemaNormalizer.NormalizeXmlSchema Method (XmlSchema[])

XsdSchemaNormalizerNormalizeXmlSchema Method (XmlSchema) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchema NormalizeXmlSchema(
    params XmlSchema[] schemas
)
Public Shared Function NormalizeXmlSchema (
    ParamArray schemas As XmlSchema()
) As XmlSchema
public:
static XmlSchema^ NormalizeXmlSchema(
    ... array<XmlSchema^>^ schemas
)
static member NormalizeXmlSchema :
        schemas : XmlSchema[] -> XmlSchema

Parameters

schemas
Type: System.Xml.SchemaXmlSchema

Return Value

Type: XmlSchema
See Also

Reference

XsdSchemaNormalizer Class
NormalizeXmlSchema Overload
Datapolis.WorkBox.Utilities Namespace


XsdSchemaNormalizer.NormalizeXmlSchema Method (XmlSchemaSet, XmlSchema)

XsdSchemaNormalizerNormalizeXmlSchema Method (XmlSchemaSet, XmlSchema) Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchema NormalizeXmlSchema(
    XmlSchemaSet set,
    XmlSchema schema
)
Public Shared Function NormalizeXmlSchema (
    set As XmlSchemaSet,
    schema As XmlSchema
) As XmlSchema
public:
static XmlSchema^ NormalizeXmlSchema(
    XmlSchemaSet^ set,
    XmlSchema^ schema
)
static member NormalizeXmlSchema :
        set : XmlSchemaSet *
        schema : XmlSchema -> XmlSchema

Parameters

set
Type: System.Xml.SchemaXmlSchemaSet
schema
Type: System.Xml.SchemaXmlSchema

Return Value

Type: XmlSchema
See Also

Reference

XsdSchemaNormalizer Class
NormalizeXmlSchema Overload
Datapolis.WorkBox.Utilities Namespace


Datapolis.WorkBox.Utilities.WBInterface Namespace

Datapolis.WorkBox.Utilities.WBInterface Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBActionInfo | Represents an action in Workbox workflow.
Public class | WBActionInfoCollection | A collection of WBActionInfo instances.
Public class | WBActionParameter | Represents an action parameter.
Public class | WBActionParameterCollection | A collection of WBActionParameter object instances.
Public class | WBActions | Contains information about actions that can be bulk run on different workflows
Public class | WBAllActions | Contains information about all actions that can be bulk run on different workflows
Public class | WBAllCommonActions | Represents group of actions that can be run on different workflow instances basing on same workflow definition
Public class | WBAllCommonActionsCollection | A collection of WBAllCommonActions objects - contains whole bulk actions information for particular workflow definitions for selected items.
Public class | WBApplicationInfo | Object used for data transfer in WBApplications web service (GetApplications method).
Public class | WBApplicationInstanceParameterInfo | Object used for data transfer in WBApplications web service (RunApplication method).
Public class | WBApplicationInstanceStateInfo | Object used for data transfer in WBApplications web service (GetApplicationInstanceStatus method).
Public class | WBApplicationParameterInfo |
Public class | WBCollectionT |
Public class | WBCommonActions | Represents group of actions that can be run on different workflow instances basing on same workflow definition
Public class | WBCommonActionsCollection | A collection of WBCommonActions objects - contains information for particular workflow definitions.
Public class | WBDictionaryK, V | WBDictionary
Public class | WBFieldInfo | Represents list item's field.
Public class | WBFieldInfoCollection | A collection of WBFieldInfo object instances.
Public class | WBInterfaceBase | WBInterfaceBase
Public class | WBInterfaceCollectionBaseT | WBInterfaceCollectionBase
Public class | WBItemInfo | Gets information about a given list item, including Workbox workflows that are either running, completed or available to start on the item.
Public class | WBItemInfoWorkflow | Represents Workbox workflow on an item. This class allows you to access basic information about the workflow.
Public class | WBItemInfoWorkflowCollection | A collection of WBItemInfoWorkflow objects.
Public class | WBListInfo | Represents Workbox workflows on a list.
Public class | WBListInfoWorkflow | Represents a Workbox workflow definition on a list.
Public class | WBListInfoWorkflowCollection | Represents a collection of WBListInfoWorkflow objects.
Public class | WBResultInfo | Represents the result of WBInfo web service method invoke.
Public class | WBRunAsInfo | Represents an subsitution provided option for action execution in Workbox workflow.
Public class | WBRunAsInfoCollection | Represents an subsitutions provided options for action execution in Workbox workflow.
Public class | WBSiteInfo | Represents Workbox workflows on a site.
Public class | WBSiteInfoWorkflow | Represents a Workbox workflow definition on a site.
Public class | WBSiteInfoWorkflowCollection | Represents a collection of WBSiteInfoWorkflow objects.
Public class | WBWorkflowInfo | Represents the Workbox workflow's instance. Contains full information about the workflow instance.
Public class | WBWorkflowInfoCollection | Represents the Workbox workflow's instances collection. Contains full information about the workflow instances.
Public class | WBWorkflowParameter | Represents a workflow parameter.
Public class | WBWorkflowParameterCollection | Represents a collection of WBWorkflowParameter objects.


WBActionInfo Class

WBActionInfo Class Datapolis Process System Class Reference
Represents an action in Workbox workflow.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBActionInfo : WBInterfaceBase
Public NotInheritable Class WBActionInfo
    Inherits WBInterfaceBase
public ref class WBActionInfo sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBActionInfo =
    class
        inherit WBInterfaceBase
    end

The WBActionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBActionInfo | Initializes a new instance of WBActionInfo.
Top
Properties
 | Name | Description
Public property | Description | Gets the action's description.
Public property | FormFooter | Gets the action's form footer.
Public property | FormHeader | Gets the action's form header.
Public property | FormType | Gets the type of the action's launch form.
Public property | FormURL | Gets the URL address of the action's custom launch form.
Public property | IconUrl | Gets a relative URL of the action icon
Public property | Name | Gets the action's internal name.
Public property | Parameters | Gets the collection of action parameters.
Public property | RedirectURL | Gets the URL address of the page to which the user should be redirected after the action has been successfully executed.
Public property | RunAsUser | Selected as user
Public property | RunAsUserOptions | Collection contains ifo about users avaliebe as run as options
Public property | ShortTitle | Gets the action's short title (ex. "SomeAction"). This member is not serializable.
Public property | Title | Gets the action's full title (e.g. "SomeWorkflow: SomeAction").
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowInstanceId | Gets Workbox workflow instance's ID.
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo Constructor

WBActionInfo Constructor Datapolis Process System Class Reference
Initializes a new instance of WBActionInfo.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionInfo()
Public Sub New
public:
WBActionInfo()
new : unit -> WBActionInfo
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo Properties

WBActionInfo Properties Datapolis Process System Class Reference

The WBActionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the action's description.
Public property | FormFooter | Gets the action's form footer.
Public property | FormHeader | Gets the action's form header.
Public property | FormType | Gets the type of the action's launch form.
Public property | FormURL | Gets the URL address of the action's custom launch form.
Public property | IconUrl | Gets a relative URL of the action icon
Public property | Name | Gets the action's internal name.
Public property | Parameters | Gets the collection of action parameters.
Public property | RedirectURL | Gets the URL address of the page to which the user should be redirected after the action has been successfully executed.
Public property | RunAsUser | Selected as user
Public property | RunAsUserOptions | Collection contains ifo about users avaliebe as run as options
Public property | ShortTitle | Gets the action's short title (ex. "SomeAction"). This member is not serializable.
Public property | Title | Gets the action's full title (e.g. "SomeWorkflow: SomeAction").
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowInstanceId | Gets Workbox workflow instance's ID.
Top
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.Description Property

WBActionInfoDescription Property Datapolis Process System Class Reference
Gets the action's description.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.FormFooter Property

WBActionInfoFormFooter Property Datapolis Process System Class Reference
Gets the action's form footer.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string FormFooter { get; }
Public ReadOnly Property FormFooter As String
    Get
public:
property String^ FormFooter {
    String^ get ();
}
member FormFooter : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.FormHeader Property

WBActionInfoFormHeader Property Datapolis Process System Class Reference
Gets the action's form header.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string FormHeader { get; }
Public ReadOnly Property FormHeader As String
    Get
public:
property String^ FormHeader {
    String^ get ();
}
member FormHeader : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.FormType Property

WBActionInfoFormType Property Datapolis Process System Class Reference
Gets the type of the action's launch form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBLaunchFormType FormType { get; }
Public ReadOnly Property FormType As WBLaunchFormType
    Get
public:
property WBLaunchFormType FormType {
    WBLaunchFormType get ();
}
member FormType : WBLaunchFormType with get

Property Value

Type: WBLaunchFormType
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.FormURL Property

WBActionInfoFormURL Property Datapolis Process System Class Reference
Gets the URL address of the action's custom launch form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string FormURL { get; }
Public ReadOnly Property FormURL As String
    Get
public:
property String^ FormURL {
    String^ get ();
}
member FormURL : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.IconUrl Property

WBActionInfoIconUrl Property Datapolis Process System Class Reference
Gets a relative URL of the action icon

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string IconUrl { get; }
Public ReadOnly Property IconUrl As String
    Get
public:
property String^ IconUrl {
    String^ get ();
}
member IconUrl : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.Name Property

WBActionInfoName Property Datapolis Process System Class Reference
Gets the action's internal name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.Parameters Property

WBActionInfoParameters Property Datapolis Process System Class Reference
Gets the collection of action parameters.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionParameterCollection Parameters { get; }
Public ReadOnly Property Parameters As WBActionParameterCollection
    Get
public:
property WBActionParameterCollection^ Parameters {
    WBActionParameterCollection^ get ();
}
member Parameters : WBActionParameterCollection with get

Property Value

Type: WBActionParameterCollection
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.RedirectURL Property

WBActionInfoRedirectURL Property Datapolis Process System Class Reference
Gets the URL address of the page to which the user should be redirected after the action has been successfully executed.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string RedirectURL { get; }
Public ReadOnly Property RedirectURL As String
    Get
public:
property String^ RedirectURL {
    String^ get ();
}
member RedirectURL : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.RunAsUser Property

WBActionInfoRunAsUser Property Datapolis Process System Class Reference
Selected as user

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBRunAsInfo RunAsUser { get; set; }
Public Property RunAsUser As WBRunAsInfo
    Get
    Set
public:
property WBRunAsInfo^ RunAsUser {
    WBRunAsInfo^ get ();
    void set (WBRunAsInfo^ value);
}
member RunAsUser : WBRunAsInfo with get, set

Property Value

Type: WBRunAsInfo
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.RunAsUserOptions Property

WBActionInfoRunAsUserOptions Property Datapolis Process System Class Reference
Collection contains ifo about users avaliebe as run as options

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBRunAsInfoCollection RunAsUserOptions { get; }
Public ReadOnly Property RunAsUserOptions As WBRunAsInfoCollection
    Get
public:
property WBRunAsInfoCollection^ RunAsUserOptions {
    WBRunAsInfoCollection^ get ();
}
member RunAsUserOptions : WBRunAsInfoCollection with get

Property Value

Type: WBRunAsInfoCollection
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.ShortTitle Property

WBActionInfoShortTitle Property Datapolis Process System Class Reference
Gets the action's short title (ex. "SomeAction"). This member is not serializable.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ShortTitle { get; }
Public ReadOnly Property ShortTitle As String
    Get
public:
property String^ ShortTitle {
    String^ get ();
}
member ShortTitle : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.Title Property

WBActionInfoTitle Property Datapolis Process System Class Reference
Gets the action's full title (e.g. "SomeWorkflow: SomeAction").

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.WorkflowInstanceId Property

WBActionInfoWorkflowInstanceId Property Datapolis Process System Class Reference
Gets Workbox workflow instance's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid WorkflowInstanceId { get; }
Public ReadOnly Property WorkflowInstanceId As Guid
    Get
public:
property Guid WorkflowInstanceId {
    Guid get ();
}
member WorkflowInstanceId : Guid with get

Property Value

Type: Guid
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo Methods

WBActionInfo Methods Datapolis Process System Class Reference

The WBActionInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.GetSchema Method

WBActionInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.GetWBSchema Method

WBActionInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.ReadXml Method

WBActionInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfo.WriteXml Method

WBActionInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBActionInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection Class

WBActionInfoCollection Class Datapolis Process System Class Reference
A collection of WBActionInfo instances.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBActionInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBActionInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfoCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBActionInfoCollection : WBInterfaceCollectionBase<WBActionInfo>
Public NotInheritable Class WBActionInfoCollection
    Inherits WBInterfaceCollectionBase(Of WBActionInfo)
public ref class WBActionInfoCollection sealed : public WBInterfaceCollectionBase<WBActionInfo^>
[<SealedAttribute>]
type WBActionInfoCollection =
    class
        inherit WBInterfaceCollectionBase<WBActionInfo>
    end

The WBActionInfoCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBActionInfoCollection | Initializes a new instance of the WBActionInfoCollection class
Top
Properties
 | Name | Description
Public property | Item | Gets the WBActionInfo object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection Constructor

WBActionInfoCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBActionInfoCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionInfoCollection()
Public Sub New
public:
WBActionInfoCollection()
new : unit -> WBActionInfoCollection
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection Properties

WBActionInfoCollection Properties Datapolis Process System Class Reference

The WBActionInfoCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the WBActionInfo object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection.Item Property

WBActionInfoCollectionItem Property Datapolis Process System Class Reference
Gets the WBActionInfo object with the specified Name property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionInfo this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As WBActionInfo
    Get
public:
property WBActionInfo^ default[String^ name] {
    WBActionInfo^ get (String^ name);
}
member Item : WBActionInfo with get

Parameters

name
Type: SystemString
Action Name

Return Value

Type: WBActionInfo
A WBActionInfo object instance that represents the workflow action
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection Methods

WBActionInfoCollection Methods Datapolis Process System Class Reference

The WBActionInfoCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection.GetSchema Method

WBActionInfoCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection.GetWBSchema Method

WBActionInfoCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection.ReadXml Method

WBActionInfoCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionInfoCollection.WriteXml Method

WBActionInfoCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBActionInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter Class

WBActionParameter Class Datapolis Process System Class Reference
Represents an action parameter.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBActionParameter

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBActionParameter : WBInterfaceBase
Public NotInheritable Class WBActionParameter
    Inherits WBInterfaceBase
public ref class WBActionParameter sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBActionParameter =
    class
        inherit WBInterfaceBase
    end

The WBActionParameter type exposes the following members.

Constructors
 | Name | Description
Public method | WBActionParameter | Initializes a new instance of the WBActionParameter class
Top
Properties
 | Name | Description
Public property | Description | Gets the description of the parameter.
Public property | InternalName | Gets the internal name of the parameter.
Public property | Properties | Gets the properties of the form field generated for the action parameter on Action Launch Form.
Public property | Title | Gets the title of the parameter.
Public property | Type | Gets the WBVariableType value representing the type of the action parameter.
Public property | Value | Gets or sets the parameter's value.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter Constructor

WBActionParameter Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBActionParameter class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionParameter()
Public Sub New
public:
WBActionParameter()
new : unit -> WBActionParameter
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter Properties

WBActionParameter Properties Datapolis Process System Class Reference

The WBActionParameter type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the parameter.
Public property | InternalName | Gets the internal name of the parameter.
Public property | Properties | Gets the properties of the form field generated for the action parameter on Action Launch Form.
Public property | Title | Gets the title of the parameter.
Public property | Type | Gets the WBVariableType value representing the type of the action parameter.
Public property | Value | Gets or sets the parameter's value.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.Description Property

WBActionParameterDescription Property Datapolis Process System Class Reference
Gets the description of the parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.InternalName Property

WBActionParameterInternalName Property Datapolis Process System Class Reference
Gets the internal name of the parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string InternalName { get; }
Public ReadOnly Property InternalName As String
    Get
public:
property String^ InternalName {
    String^ get ();
}
member InternalName : string with get

Property Value

Type: String
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.Properties Property

WBActionParameterProperties Property Datapolis Process System Class Reference
Gets the properties of the form field generated for the action parameter on Action Launch Form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBDictionary<string, string> Properties { get; }
Public ReadOnly Property Properties As WBDictionary(Of String, String)
    Get
public:
property WBDictionary<String^, String^>^ Properties {
    WBDictionary<String^, String^>^ get ();
}
member Properties : WBDictionary<string, string> with get

Property Value

Type: WBDictionary String, String
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.Title Property

WBActionParameterTitle Property Datapolis Process System Class Reference
Gets the title of the parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.Type Property

WBActionParameterType Property Datapolis Process System Class Reference
Gets the WBVariableType value representing the type of the action parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBVariableType Type { get; }
Public ReadOnly Property Type As WBVariableType
    Get
public:
property WBVariableType Type {
    WBVariableType get ();
}
member Type : WBVariableType with get

Property Value

Type: WBVariableType
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.Value Property

WBActionParameterValue Property Datapolis Process System Class Reference
Gets or sets the parameter's value.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter Methods

WBActionParameter Methods Datapolis Process System Class Reference

The WBActionParameter type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.GetSchema Method

WBActionParameterGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.GetWBSchema Method

WBActionParameterGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.ReadXml Method

WBActionParameterReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameter.WriteXml Method

WBActionParameterWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBActionParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection Class

WBActionParameterCollection Class Datapolis Process System Class Reference
A collection of WBActionParameter object instances.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBActionParameter
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBActionParameter
Datapolis.WorkBox.Utilities.WBInterfaceWBActionParameterCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBActionParameterCollection : WBInterfaceCollectionBase<WBActionParameter>
Public NotInheritable Class WBActionParameterCollection
    Inherits WBInterfaceCollectionBase(Of WBActionParameter)
public ref class WBActionParameterCollection sealed : public WBInterfaceCollectionBase<WBActionParameter^>
[<SealedAttribute>]
type WBActionParameterCollection =
    class
        inherit WBInterfaceCollectionBase<WBActionParameter>
    end

The WBActionParameterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBActionParameterCollection | Initializes a new instance of the WBActionParameterCollection class
Top
Properties
 | Name | Description
Public property | Item | Gets the WBActionParameter object with the specified InternalName property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection Constructor

WBActionParameterCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBActionParameterCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionParameterCollection()
Public Sub New
public:
WBActionParameterCollection()
new : unit -> WBActionParameterCollection
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection Properties

WBActionParameterCollection Properties Datapolis Process System Class Reference

The WBActionParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the WBActionParameter object with the specified InternalName property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection.Item Property

WBActionParameterCollectionItem Property Datapolis Process System Class Reference
Gets the WBActionParameter object with the specified InternalName property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionParameter this[
    string internalName
] { get; }
Public ReadOnly Default Property Item (
    internalName As String
) As WBActionParameter
    Get
public:
property WBActionParameter^ default[String^ internalName] {
    WBActionParameter^ get (String^ internalName);
}
member Item : WBActionParameter with get

Parameters

internalName
Type: SystemString
Internal name of the parameter.

Return Value

Type: WBActionParameter
A WBActionParameter object instance representing the action parameter.
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection Methods

WBActionParameterCollection Methods Datapolis Process System Class Reference

The WBActionParameterCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection.GetSchema Method

WBActionParameterCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection.GetWBSchema Method

WBActionParameterCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection.ReadXml Method

WBActionParameterCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActionParameterCollection.WriteXml Method

WBActionParameterCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBActionParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions Class

WBActions Class Datapolis Process System Class Reference
Contains information about actions that can be bulk run on different workflows
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBActions

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBActions : WBInterfaceBase
Public Class WBActions
    Inherits WBInterfaceBase
public ref class WBActions : public WBInterfaceBase
type WBActions =
    class
        inherit WBInterfaceBase
    end

The WBActions type exposes the following members.

Constructors
 | Name | Description
Public method | WBActions | Creates a new instance of WBActions class.
Public method | WBActions(WBCollectionInt32) | Creates a new instance of WBActions class.
Top
Properties
 | Name | Description
Public property | CommonActionsCollection | Gets the collection of WBCommonActions objects, which represent actions that can be bulk run on particular workflow.
Public property | ItemIds | Gets collection of item ids on which provided actions can be run.
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions Constructor

WBActions Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBActions | Creates a new instance of WBActions class.
Public method | WBActions(WBCollectionInt32) | Creates a new instance of WBActions class.
Top
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions Constructor

WBActions Constructor Datapolis Process System Class Reference
Creates a new instance of WBActions class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActions()
Public Sub New
public:
WBActions()
new : unit -> WBActions
See Also

Reference

WBActions Class
WBActions Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions Constructor (WBCollection(Int32))

WBActions Constructor (WBCollectionInt32) Datapolis Process System Class Reference
Creates a new instance of WBActions class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActions(
    WBCollection<int> itemIDs
)
Public Sub New (
    itemIDs As WBCollection(Of Integer)
)
public:
WBActions(
    WBCollection<int>^ itemIDs
)
new :
        itemIDs : WBCollection<int> -> WBActions

Parameters

itemIDs
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBCollection Int32
See Also

Reference

WBActions Class
WBActions Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions Properties

WBActions Properties Datapolis Process System Class Reference

The WBActions type exposes the following members.

Properties
 | Name | Description
Public property | CommonActionsCollection | Gets the collection of WBCommonActions objects, which represent actions that can be bulk run on particular workflow.
Public property | ItemIds | Gets collection of item ids on which provided actions can be run.
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.CommonActionsCollection Property

WBActionsCommonActionsCollection Property Datapolis Process System Class Reference
Gets the collection of WBCommonActions objects, which represent actions that can be bulk run on particular workflow.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCommonActionsCollection CommonActionsCollection { get; }
Public ReadOnly Property CommonActionsCollection As WBCommonActionsCollection
    Get
public:
property WBCommonActionsCollection^ CommonActionsCollection {
    WBCommonActionsCollection^ get ();
}
member CommonActionsCollection : WBCommonActionsCollection with get

Property Value

Type: WBCommonActionsCollection
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.ItemIds Property

WBActionsItemIds Property Datapolis Process System Class Reference
Gets collection of item ids on which provided actions can be run.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCollection<int> ItemIds { get; }
Public ReadOnly Property ItemIds As WBCollection(Of Integer)
    Get
public:
property WBCollection<int>^ ItemIds {
    WBCollection<int>^ get ();
}
member ItemIds : WBCollection<int> with get

Property Value

Type: WBCollection Int32
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.ListDefaultViewUrl Property

WBActionsListDefaultViewUrl Property Datapolis Process System Class Reference
Gets the URL address of the list's default view.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListDefaultViewUrl { get; }
Public ReadOnly Property ListDefaultViewUrl As String
    Get
public:
property String^ ListDefaultViewUrl {
    String^ get ();
}
member ListDefaultViewUrl : string with get

Property Value

Type: String
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.ListID Property

WBActionsListID Property Datapolis Process System Class Reference
Gets the list's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid ListID { get; }
Public ReadOnly Property ListID As Guid
    Get
public:
property Guid ListID {
    Guid get ();
}
member ListID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.ListName Property

WBActionsListName Property Datapolis Process System Class Reference
Gets the list's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListName { get; }
Public ReadOnly Property ListName As String
    Get
public:
property String^ ListName {
    String^ get ();
}
member ListName : string with get

Property Value

Type: String
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.ListUrl Property

WBActionsListUrl Property Datapolis Process System Class Reference
Gets the list's URL address.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListUrl { get; }
Public ReadOnly Property ListUrl As String
    Get
public:
property String^ ListUrl {
    String^ get ();
}
member ListUrl : string with get

Property Value

Type: String
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions Methods

WBActions Methods Datapolis Process System Class Reference

The WBActions type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions._initializeDefaults Method

WBActions_initializeDefaults Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.GetSchema Method

WBActionsGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.GetWBSchema Method

WBActionsGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.ReadXml Method

WBActionsReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions.WriteXml Method

WBActionsWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBActions Fields

WBActions Fields Datapolis Process System Class Reference

The WBActions type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions Class

WBAllActions Class Datapolis Process System Class Reference
Contains information about all actions that can be bulk run on different workflows
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBAllActions

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBAllActions : WBInterfaceBase
Public Class WBAllActions
    Inherits WBInterfaceBase
public ref class WBAllActions : public WBInterfaceBase
type WBAllActions =
    class
        inherit WBInterfaceBase
    end

The WBAllActions type exposes the following members.

Constructors
 | Name | Description
Public method | WBAllActions | Creates a new instance of WBAllActions class.
Public method | WBAllActions(WBCollectionInt32) | Creates a new instance of WBAllActions class.
Top
Properties
 | Name | Description
Public property | AllCommonActionsCollection | Gets the collection of WBCommonActions objects, which represent actions that can be bulk run on particular workflow.
Public property | ItemIds | Gets collection of item ids on which provided actions can be run.
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions Constructor

WBAllActions Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBAllActions | Creates a new instance of WBAllActions class.
Public method | WBAllActions(WBCollectionInt32) | Creates a new instance of WBAllActions class.
Top
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions Constructor

WBAllActions Constructor Datapolis Process System Class Reference
Creates a new instance of WBAllActions class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBAllActions()
Public Sub New
public:
WBAllActions()
new : unit -> WBAllActions
See Also

Reference

WBAllActions Class
WBAllActions Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions Constructor (WBCollection(Int32))

WBAllActions Constructor (WBCollectionInt32) Datapolis Process System Class Reference
Creates a new instance of WBAllActions class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBAllActions(
    WBCollection<int> itemIDs
)
Public Sub New (
    itemIDs As WBCollection(Of Integer)
)
public:
WBAllActions(
    WBCollection<int>^ itemIDs
)
new :
        itemIDs : WBCollection<int> -> WBAllActions

Parameters

itemIDs
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBCollection Int32
See Also

Reference

WBAllActions Class
WBAllActions Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions Properties

WBAllActions Properties Datapolis Process System Class Reference

The WBAllActions type exposes the following members.

Properties
 | Name | Description
Public property | AllCommonActionsCollection | Gets the collection of WBCommonActions objects, which represent actions that can be bulk run on particular workflow.
Public property | ItemIds | Gets collection of item ids on which provided actions can be run.
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.AllCommonActionsCollection Property

WBAllActionsAllCommonActionsCollection Property Datapolis Process System Class Reference
Gets the collection of WBCommonActions objects, which represent actions that can be bulk run on particular workflow.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBAllCommonActionsCollection AllCommonActionsCollection { get; }
Public ReadOnly Property AllCommonActionsCollection As WBAllCommonActionsCollection
    Get
public:
property WBAllCommonActionsCollection^ AllCommonActionsCollection {
    WBAllCommonActionsCollection^ get ();
}
member AllCommonActionsCollection : WBAllCommonActionsCollection with get

Property Value

Type: WBAllCommonActionsCollection
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.ItemIds Property

WBAllActionsItemIds Property Datapolis Process System Class Reference
Gets collection of item ids on which provided actions can be run.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCollection<int> ItemIds { get; }
Public ReadOnly Property ItemIds As WBCollection(Of Integer)
    Get
public:
property WBCollection<int>^ ItemIds {
    WBCollection<int>^ get ();
}
member ItemIds : WBCollection<int> with get

Property Value

Type: WBCollection Int32
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.ListDefaultViewUrl Property

WBAllActionsListDefaultViewUrl Property Datapolis Process System Class Reference
Gets the URL address of the list's default view.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListDefaultViewUrl { get; }
Public ReadOnly Property ListDefaultViewUrl As String
    Get
public:
property String^ ListDefaultViewUrl {
    String^ get ();
}
member ListDefaultViewUrl : string with get

Property Value

Type: String
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.ListID Property

WBAllActionsListID Property Datapolis Process System Class Reference
Gets the list's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid ListID { get; }
Public ReadOnly Property ListID As Guid
    Get
public:
property Guid ListID {
    Guid get ();
}
member ListID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.ListName Property

WBAllActionsListName Property Datapolis Process System Class Reference
Gets the list's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListName { get; }
Public ReadOnly Property ListName As String
    Get
public:
property String^ ListName {
    String^ get ();
}
member ListName : string with get

Property Value

Type: String
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.ListUrl Property

WBAllActionsListUrl Property Datapolis Process System Class Reference
Gets the list's URL address.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListUrl { get; }
Public ReadOnly Property ListUrl As String
    Get
public:
property String^ ListUrl {
    String^ get ();
}
member ListUrl : string with get

Property Value

Type: String
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions Methods

WBAllActions Methods Datapolis Process System Class Reference

The WBAllActions type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions._initializeDefaults Method

WBAllActions_initializeDefaults Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.GetSchema Method

WBAllActionsGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.GetWBSchema Method

WBAllActionsGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.ReadXml Method

WBAllActionsReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions.WriteXml Method

WBAllActionsWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllActions Fields

WBAllActions Fields Datapolis Process System Class Reference

The WBAllActions type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBAllActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions Class

WBAllCommonActions Class Datapolis Process System Class Reference
Represents group of actions that can be run on different workflow instances basing on same workflow definition
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBAllCommonActions

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBAllCommonActions : WBInterfaceBase
Public Class WBAllCommonActions
    Inherits WBInterfaceBase
public ref class WBAllCommonActions : public WBInterfaceBase
type WBAllCommonActions =
    class
        inherit WBInterfaceBase
    end

The WBAllCommonActions type exposes the following members.

Constructors
 | Name | Description
Public method | WBAllCommonActions | Initializes a new instance of WBAllCommonActions.
Top
Properties
 | Name | Description
Public property | ActionStateName | Gets the workflow's actual state name.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowBaseID | Gets the workflow's base ID.
Public property | WorkflowInfos | Gets the collection of WBWorkflowInfo objects that represent workflows and theirs actions available for the current (context) user in the current workflow's state that can be bulk run.
Public property | WorkflowName | Gets the workflow's name.
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | Initializes default values of properties. (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions Constructor

WBAllCommonActions Constructor Datapolis Process System Class Reference
Initializes a new instance of WBAllCommonActions.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBAllCommonActions()
Public Sub New
public:
WBAllCommonActions()
new : unit -> WBAllCommonActions
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions Properties

WBAllCommonActions Properties Datapolis Process System Class Reference

The WBAllCommonActions type exposes the following members.

Properties
 | Name | Description
Public property | ActionStateName | Gets the workflow's actual state name.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowBaseID | Gets the workflow's base ID.
Public property | WorkflowInfos | Gets the collection of WBWorkflowInfo objects that represent workflows and theirs actions available for the current (context) user in the current workflow's state that can be bulk run.
Public property | WorkflowName | Gets the workflow's name.
Top
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.ActionStateName Property

WBAllCommonActionsActionStateName Property Datapolis Process System Class Reference
Gets the workflow's actual state name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ActionStateName { get; }
Public ReadOnly Property ActionStateName As String
    Get
public:
property String^ ActionStateName {
    String^ get ();
}
member ActionStateName : string with get

Property Value

Type: String
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.WorkflowBaseID Property

WBAllCommonActionsWorkflowBaseID Property Datapolis Process System Class Reference
Gets the workflow's base ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid WorkflowBaseID { get; }
Public ReadOnly Property WorkflowBaseID As Guid
    Get
public:
property Guid WorkflowBaseID {
    Guid get ();
}
member WorkflowBaseID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.WorkflowInfos Property

WBAllCommonActionsWorkflowInfos Property Datapolis Process System Class Reference
Gets the collection of WBWorkflowInfo objects that represent workflows and theirs actions available for the current (context) user in the current workflow's state that can be bulk run.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowInfoCollection WorkflowInfos { get; }
Public ReadOnly Property WorkflowInfos As WBWorkflowInfoCollection
    Get
public:
property WBWorkflowInfoCollection^ WorkflowInfos {
    WBWorkflowInfoCollection^ get ();
}
member WorkflowInfos : WBWorkflowInfoCollection with get

Property Value

Type: WBWorkflowInfoCollection
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.WorkflowName Property

WBAllCommonActionsWorkflowName Property Datapolis Process System Class Reference
Gets the workflow's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string WorkflowName { get; }
Public ReadOnly Property WorkflowName As String
    Get
public:
property String^ WorkflowName {
    String^ get ();
}
member WorkflowName : string with get

Property Value

Type: String
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions Methods

WBAllCommonActions Methods Datapolis Process System Class Reference

The WBAllCommonActions type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | Initializes default values of properties. (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions._initializeDefaults Method

WBAllCommonActions_initializeDefaults Method Datapolis Process System Class Reference
Initializes default values of properties.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.GetSchema Method

WBAllCommonActionsGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.GetWBSchema Method

WBAllCommonActionsGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.ReadXml Method

WBAllCommonActionsReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions.WriteXml Method

WBAllCommonActionsWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActions Fields

WBAllCommonActions Fields Datapolis Process System Class Reference

The WBAllCommonActions type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBAllCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection Class

WBAllCommonActionsCollection Class Datapolis Process System Class Reference
A collection of WBAllCommonActions objects - contains whole bulk actions information for particular workflow definitions for selected items.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBAllCommonActions
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBAllCommonActions
Datapolis.WorkBox.Utilities.WBInterfaceWBAllCommonActionsCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBAllCommonActionsCollection : WBInterfaceCollectionBase<WBAllCommonActions>
Public Class WBAllCommonActionsCollection
    Inherits WBInterfaceCollectionBase(Of WBAllCommonActions)
public ref class WBAllCommonActionsCollection : public WBInterfaceCollectionBase<WBAllCommonActions^>
type WBAllCommonActionsCollection =
    class
        inherit WBInterfaceCollectionBase<WBAllCommonActions>
    end

The WBAllCommonActionsCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBAllCommonActionsCollection | Initializes a new instance of the WBAllCommonActionsCollection class
Top
Properties
 | Name | Description
Public property | ItemGuid | Gets the WBAllCommonActions object with the specified Name property.
Public property | ItemString | Gets the WBAllCommonActions object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceCollectionBaseT_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection Constructor

WBAllCommonActionsCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBAllCommonActionsCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBAllCommonActionsCollection()
Public Sub New
public:
WBAllCommonActionsCollection()
new : unit -> WBAllCommonActionsCollection
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection Properties

WBAllCommonActionsCollection Properties Datapolis Process System Class Reference

The WBAllCommonActionsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ItemGuid | Gets the WBAllCommonActions object with the specified Name property.
Public property | ItemString | Gets the WBAllCommonActions object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection.Item Property

WBAllCommonActionsCollectionItem Property Datapolis Process System Class Reference
Overload List
 | Name | Description
Public property | ItemGuid | Gets the WBAllCommonActions object with the specified Name property.
Public property | ItemString | Gets the WBAllCommonActions object with the specified Name property.
Top
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection.Item Property (Guid)

WBAllCommonActionsCollectionItem Property (Guid) Datapolis Process System Class Reference
Gets the WBAllCommonActions object with the specified Name property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBAllCommonActions this[
    Guid workflowBaseID
] { get; }
Public ReadOnly Default Property Item (
    workflowBaseID As Guid
) As WBAllCommonActions
    Get
public:
property WBAllCommonActions^ default[Guid workflowBaseID] {
    WBAllCommonActions^ get (Guid workflowBaseID);
}
member Item : WBAllCommonActions with get

Parameters

workflowBaseID
Type: SystemGuid
Base Id

Return Value

Type: WBAllCommonActions
A WBAllCommonActions object instance that represents the actions that can be bulk run
See Also

Reference

WBAllCommonActionsCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection.Item Property (String)

WBAllCommonActionsCollectionItem Property (String) Datapolis Process System Class Reference
Gets the WBAllCommonActions object with the specified Name property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBAllCommonActions this[
    string workflowName
] { get; }
Public ReadOnly Default Property Item (
    workflowName As String
) As WBAllCommonActions
    Get
public:
property WBAllCommonActions^ default[String^ workflowName] {
    WBAllCommonActions^ get (String^ workflowName);
}
member Item : WBAllCommonActions with get

Parameters

workflowName
Type: SystemString
Workflow Name

Return Value

Type: WBAllCommonActions
A WBAllCommonActions object instance that represents the actions that can be bulk run
See Also

Reference

WBAllCommonActionsCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection Methods

WBAllCommonActionsCollection Methods Datapolis Process System Class Reference

The WBAllCommonActionsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceCollectionBaseT_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection._initializeDefaults Method

WBAllCommonActionsCollection_initializeDefaults Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection.GetSchema Method

WBAllCommonActionsCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection.GetWBSchema Method

WBAllCommonActionsCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection.ReadXml Method

WBAllCommonActionsCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection.WriteXml Method

WBAllCommonActionsCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBAllCommonActionsCollection Fields

WBAllCommonActionsCollection Fields Datapolis Process System Class Reference

The WBAllCommonActionsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBAllCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInfo Class

WBApplicationInfo Class Datapolis Process System Class Reference
Object used for data transfer in WBApplications web service (GetApplications method).
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBApplicationInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationInfo
Public Class WBApplicationInfo
public ref class WBApplicationInfo
type WBApplicationInfo =  class end

The WBApplicationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInfo | Initializes a new instance of the WBApplicationInfo class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Name |
Public property | ParametersIn |
Public property | ParametersOut |
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInfo Constructor

WBApplicationInfo Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationInfo class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInfo()
Public Sub New
public:
WBApplicationInfo()
new : unit -> WBApplicationInfo
See Also

Reference

WBApplicationInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInfo Properties

WBApplicationInfo Properties Datapolis Process System Class Reference

The WBApplicationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name |
Public property | ParametersIn |
Public property | ParametersOut |
Top
See Also

Reference

WBApplicationInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInfo.Id Property

WBApplicationInfoId Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInfo.Name Property

WBApplicationInfoName Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInfo.ParametersIn Property

WBApplicationInfoParametersIn Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public List<WBApplicationParameterInfo> ParametersIn { get; set; }
Public Property ParametersIn As List(Of WBApplicationParameterInfo)
    Get
    Set
public:
property List<WBApplicationParameterInfo^>^ ParametersIn {
    List<WBApplicationParameterInfo^>^ get ();
    void set (List<WBApplicationParameterInfo^>^ value);
}
member ParametersIn : List<WBApplicationParameterInfo> with get, set

Property Value

Type: List WBApplicationParameterInfo
See Also

Reference

WBApplicationInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInfo.ParametersOut Property

WBApplicationInfoParametersOut Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public List<WBApplicationParameterInfo> ParametersOut { get; set; }
Public Property ParametersOut As List(Of WBApplicationParameterInfo)
    Get
    Set
public:
property List<WBApplicationParameterInfo^>^ ParametersOut {
    List<WBApplicationParameterInfo^>^ get ();
    void set (List<WBApplicationParameterInfo^>^ value);
}
member ParametersOut : List<WBApplicationParameterInfo> with get, set

Property Value

Type: List WBApplicationParameterInfo
See Also

Reference

WBApplicationInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceParameterInfo Class

WBApplicationInstanceParameterInfo Class Datapolis Process System Class Reference
Object used for data transfer in WBApplications web service (RunApplication method).
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBApplicationInstanceParameterInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationInstanceParameterInfo
Public Class WBApplicationInstanceParameterInfo
public ref class WBApplicationInstanceParameterInfo
type WBApplicationInstanceParameterInfo =  class end

The WBApplicationInstanceParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInstanceParameterInfo | Initializes a new instance of the WBApplicationInstanceParameterInfo class
Top
Properties
 | Name | Description
Public property | DisplayName |
Public property | Name |
Public property | Value |
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceParameterInfo Constructor

WBApplicationInstanceParameterInfo Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationInstanceParameterInfo class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceParameterInfo(
    string name,
    string value,
    string displayName
)
Public Sub New (
    name As String,
    value As String,
    displayName As String
)
public:
WBApplicationInstanceParameterInfo(
    String^ name,
    String^ value,
    String^ displayName
)
new :
        name : string *
        value : string *
        displayName : string -> WBApplicationInstanceParameterInfo

Parameters

name
Type: SystemString
value
Type: SystemString
displayName
Type: SystemString
See Also

Reference

WBApplicationInstanceParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceParameterInfo Properties

WBApplicationInstanceParameterInfo Properties Datapolis Process System Class Reference

The WBApplicationInstanceParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Name |
Public property | Value |
Top
See Also

Reference

WBApplicationInstanceParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceParameterInfo.DisplayName Property

WBApplicationInstanceParameterInfoDisplayName Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceParameterInfo.Name Property

WBApplicationInstanceParameterInfoName Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceParameterInfo.Value Property

WBApplicationInstanceParameterInfoValue Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceStateInfo Class

WBApplicationInstanceStateInfo Class Datapolis Process System Class Reference
Object used for data transfer in WBApplications web service (GetApplicationInstanceStatus method).
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBApplicationInstanceStateInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationInstanceStateInfo
Public Class WBApplicationInstanceStateInfo
public ref class WBApplicationInstanceStateInfo
type WBApplicationInstanceStateInfo =  class end

The WBApplicationInstanceStateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationInstanceStateInfo | Initializes a new instance of the WBApplicationInstanceStateInfo class
Top
Properties
 | Name | Description
Public property | Id |
Public property | ParametersOutValues |
Public property | Status |
Public property | Url |
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceStateInfo Constructor

WBApplicationInstanceStateInfo Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationInstanceStateInfo class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationInstanceStateInfo()
Public Sub New
public:
WBApplicationInstanceStateInfo()
new : unit -> WBApplicationInstanceStateInfo
See Also

Reference

WBApplicationInstanceStateInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceStateInfo Properties

WBApplicationInstanceStateInfo Properties Datapolis Process System Class Reference

The WBApplicationInstanceStateInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | ParametersOutValues |
Public property | Status |
Public property | Url |
Top
See Also

Reference

WBApplicationInstanceStateInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceStateInfo.Id Property

WBApplicationInstanceStateInfoId Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceStateInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceStateInfo.ParametersOutValues Property

WBApplicationInstanceStateInfoParametersOutValues Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public List<WBApplicationInstanceParameterInfo> ParametersOutValues { get; set; }
Public Property ParametersOutValues As List(Of WBApplicationInstanceParameterInfo)
    Get
    Set
public:
property List<WBApplicationInstanceParameterInfo^>^ ParametersOutValues {
    List<WBApplicationInstanceParameterInfo^>^ get ();
    void set (List<WBApplicationInstanceParameterInfo^>^ value);
}
member ParametersOutValues : List<WBApplicationInstanceParameterInfo> with get, set

Property Value

Type: List WBApplicationInstanceParameterInfo
See Also

Reference

WBApplicationInstanceStateInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceStateInfo.Status Property

WBApplicationInstanceStateInfoStatus Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceStateInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationInstanceStateInfo.Url Property

WBApplicationInstanceStateInfoUrl Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
member Url : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationInstanceStateInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationParameterInfo Class

WBApplicationParameterInfo Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBApplicationParameterInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBApplicationParameterInfo
Public Class WBApplicationParameterInfo
public ref class WBApplicationParameterInfo
type WBApplicationParameterInfo =  class end

The WBApplicationParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBApplicationParameterInfo | Initializes a new instance of the WBApplicationParameterInfo class
Top
Properties
 | Name | Description
Public property | DisplayName |
Public property | Name |
Public property | Type |
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationParameterInfo Constructor

WBApplicationParameterInfo Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBApplicationParameterInfo class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBApplicationParameterInfo()
Public Sub New
public:
WBApplicationParameterInfo()
new : unit -> WBApplicationParameterInfo
See Also

Reference

WBApplicationParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationParameterInfo Properties

WBApplicationParameterInfo Properties Datapolis Process System Class Reference

The WBApplicationParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Name |
Public property | Type |
Top
See Also

Reference

WBApplicationParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationParameterInfo.DisplayName Property

WBApplicationParameterInfoDisplayName Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationParameterInfo.Name Property

WBApplicationParameterInfoName Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBApplicationParameterInfo.Type Property

WBApplicationParameterInfoType Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

WBApplicationParameterInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T) Class

WBCollectionT Class Datapolis Process System Class Reference
Inheritance Hierarchy
SystemObject
System.Collections.GenericList T
Datapolis.WorkBox.Utilities.WBInterfaceWBCollectionT

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBCollection<T> : List<T>,
    IXmlSerializable

Public NotInheritable Class WBCollection(Of T)
    Inherits List(Of T)
    Implements IXmlSerializable
generic<typename T>
public ref class WBCollection sealed : public List<T>,
    IXmlSerializable
[<SealedAttribute>]
type WBCollection<'T> =
    class
        inherit List<'T>
        interface IXmlSerializable
    end

Type Parameters

T

The WBCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | WBCollectionT | Initializes a new instance of the WBCollectionT class
Public method | WBCollectionT(String) | Initializes a new instance of the WBCollectionT class
Top
Properties
 | Name | Description
Public property | EntityName |
Top
Methods
 | Name | Description
Public method | GetSchema |
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml |
Public method | WriteXml |
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T) Constructor

WBCollectionT Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBCollectionT | Initializes a new instance of the WBCollectionT class
Public method | WBCollectionT(String) | Initializes a new instance of the WBCollectionT class
Top
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T) Constructor

WBCollectionT Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBCollectionT class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCollection()
Public Sub New
public:
WBCollection()
new : unit -> WBCollection
See Also

Reference

WBCollectionT Class
WBCollectionT Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T) Constructor (String)

WBCollectionT Constructor (String) Datapolis Process System Class Reference
Initializes a new instance of the WBCollectionT class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCollection(
    string entityName
)
Public Sub New (
    entityName As String
)
public:
WBCollection(
    String^ entityName
)
new :
        entityName : string -> WBCollection

Parameters

entityName
Type: SystemString
See Also

Reference

WBCollectionT Class
WBCollectionT Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T) Properties

WBCollectionT Properties Datapolis Process System Class Reference

The WBCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | EntityName |
Top
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T).EntityName Property

WBCollectionTEntityName Property Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string EntityName { get; }
Public ReadOnly Property EntityName As String
    Get
public:
property String^ EntityName {
    String^ get ();
}
member EntityName : string with get

Property Value

Type: String
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T) Methods

WBCollectionT Methods Datapolis Process System Class Reference

The WBCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema |
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml |
Public method | WriteXml |
Top
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T).GetSchema Method

WBCollectionTGetSchema Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public XmlSchema GetSchema()
Public Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() sealed
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema

Implements

IXmlSerializableGetSchema
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T).GetWBSchema Method

WBCollectionTGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T).ReadXml Method

WBCollectionTReadXml Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public void ReadXml(
    XmlReader reader
)
Public Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) sealed
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCollection(T).WriteXml Method

WBCollectionTWriteXml Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public void WriteXml(
    XmlWriter writer
)
Public Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) sealed
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBCollectionT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions Class

WBCommonActions Class Datapolis Process System Class Reference
Represents group of actions that can be run on different workflow instances basing on same workflow definition
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBCommonActions

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBCommonActions : WBInterfaceBase
Public Class WBCommonActions
    Inherits WBInterfaceBase
public ref class WBCommonActions : public WBInterfaceBase
type WBCommonActions =
    class
        inherit WBInterfaceBase
    end

The WBCommonActions type exposes the following members.

Constructors
 | Name | Description
Public method | WBCommonActions | Initializes a new instance of WBCommonActions.
Top
Properties
 | Name | Description
Public property | ActionStateName | Gets the workflow's actual state name.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowActions | Gets the collection of WBActionInfo objects that represent actions available for the current (context) user in the current workflow's state that can be bulk run.
Public property | WorkflowBaseID | Gets the workflow's base ID.
Public property | WorkflowName | Gets the workflow's name.
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | Initializes default values of properties. (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions Constructor

WBCommonActions Constructor Datapolis Process System Class Reference
Initializes a new instance of WBCommonActions.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCommonActions()
Public Sub New
public:
WBCommonActions()
new : unit -> WBCommonActions
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions Properties

WBCommonActions Properties Datapolis Process System Class Reference

The WBCommonActions type exposes the following members.

Properties
 | Name | Description
Public property | ActionStateName | Gets the workflow's actual state name.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowActions | Gets the collection of WBActionInfo objects that represent actions available for the current (context) user in the current workflow's state that can be bulk run.
Public property | WorkflowBaseID | Gets the workflow's base ID.
Public property | WorkflowName | Gets the workflow's name.
Top
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.ActionStateName Property

WBCommonActionsActionStateName Property Datapolis Process System Class Reference
Gets the workflow's actual state name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ActionStateName { get; }
Public ReadOnly Property ActionStateName As String
    Get
public:
property String^ ActionStateName {
    String^ get ();
}
member ActionStateName : string with get

Property Value

Type: String
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.WorkflowActions Property

WBCommonActionsWorkflowActions Property Datapolis Process System Class Reference
Gets the collection of WBActionInfo objects that represent actions available for the current (context) user in the current workflow's state that can be bulk run.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionInfoCollection WorkflowActions { get; }
Public ReadOnly Property WorkflowActions As WBActionInfoCollection
    Get
public:
property WBActionInfoCollection^ WorkflowActions {
    WBActionInfoCollection^ get ();
}
member WorkflowActions : WBActionInfoCollection with get

Property Value

Type: WBActionInfoCollection
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.WorkflowBaseID Property

WBCommonActionsWorkflowBaseID Property Datapolis Process System Class Reference
Gets the workflow's base ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid WorkflowBaseID { get; }
Public ReadOnly Property WorkflowBaseID As Guid
    Get
public:
property Guid WorkflowBaseID {
    Guid get ();
}
member WorkflowBaseID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.WorkflowName Property

WBCommonActionsWorkflowName Property Datapolis Process System Class Reference
Gets the workflow's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string WorkflowName { get; }
Public ReadOnly Property WorkflowName As String
    Get
public:
property String^ WorkflowName {
    String^ get ();
}
member WorkflowName : string with get

Property Value

Type: String
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions Methods

WBCommonActions Methods Datapolis Process System Class Reference

The WBCommonActions type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | Initializes default values of properties. (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions._initializeDefaults Method

WBCommonActions_initializeDefaults Method Datapolis Process System Class Reference
Initializes default values of properties.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.GetSchema Method

WBCommonActionsGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.GetWBSchema Method

WBCommonActionsGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.ReadXml Method

WBCommonActionsReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions.WriteXml Method

WBCommonActionsWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActions Fields

WBCommonActions Fields Datapolis Process System Class Reference

The WBCommonActions type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBCommonActions Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection Class

WBCommonActionsCollection Class Datapolis Process System Class Reference
A collection of WBCommonActions objects - contains information for particular workflow definitions.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBCommonActions
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBCommonActions
Datapolis.WorkBox.Utilities.WBInterfaceWBCommonActionsCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBCommonActionsCollection : WBInterfaceCollectionBase<WBCommonActions>
Public Class WBCommonActionsCollection
    Inherits WBInterfaceCollectionBase(Of WBCommonActions)
public ref class WBCommonActionsCollection : public WBInterfaceCollectionBase<WBCommonActions^>
type WBCommonActionsCollection =
    class
        inherit WBInterfaceCollectionBase<WBCommonActions>
    end

The WBCommonActionsCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBCommonActionsCollection | Initializes a new instance of the WBCommonActionsCollection class
Top
Properties
 | Name | Description
Public property | ItemGuid | Gets the WBCommonActions object with the specified Name property.
Public property | ItemString | Gets the WBCommonActions object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceCollectionBaseT_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection Constructor

WBCommonActionsCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBCommonActionsCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCommonActionsCollection()
Public Sub New
public:
WBCommonActionsCollection()
new : unit -> WBCommonActionsCollection
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection Properties

WBCommonActionsCollection Properties Datapolis Process System Class Reference

The WBCommonActionsCollection type exposes the following members.

Properties
 | Name | Description
Public property | ItemGuid | Gets the WBCommonActions object with the specified Name property.
Public property | ItemString | Gets the WBCommonActions object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection.Item Property

WBCommonActionsCollectionItem Property Datapolis Process System Class Reference
Overload List
 | Name | Description
Public property | ItemGuid | Gets the WBCommonActions object with the specified Name property.
Public property | ItemString | Gets the WBCommonActions object with the specified Name property.
Top
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection.Item Property (Guid)

WBCommonActionsCollectionItem Property (Guid) Datapolis Process System Class Reference
Gets the WBCommonActions object with the specified Name property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCommonActions this[
    Guid workflowBaseID
] { get; }
Public ReadOnly Default Property Item (
    workflowBaseID As Guid
) As WBCommonActions
    Get
public:
property WBCommonActions^ default[Guid workflowBaseID] {
    WBCommonActions^ get (Guid workflowBaseID);
}
member Item : WBCommonActions with get

Parameters

workflowBaseID
Type: SystemGuid
Base Id

Return Value

Type: WBCommonActions
A WBCommonActions object instance that represents the actions that can be bulk run
See Also

Reference

WBCommonActionsCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection.Item Property (String)

WBCommonActionsCollectionItem Property (String) Datapolis Process System Class Reference
Gets the WBCommonActions object with the specified Name property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBCommonActions this[
    string workflowName
] { get; }
Public ReadOnly Default Property Item (
    workflowName As String
) As WBCommonActions
    Get
public:
property WBCommonActions^ default[String^ workflowName] {
    WBCommonActions^ get (String^ workflowName);
}
member Item : WBCommonActions with get

Parameters

workflowName
Type: SystemString
Workflow Name

Return Value

Type: WBCommonActions
A WBCommonActions object instance that represents the actions that can be bulk run
See Also

Reference

WBCommonActionsCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection Methods

WBCommonActionsCollection Methods Datapolis Process System Class Reference

The WBCommonActionsCollection type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceCollectionBaseT_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection._initializeDefaults Method

WBCommonActionsCollection_initializeDefaults Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection.GetSchema Method

WBCommonActionsCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection.GetWBSchema Method

WBCommonActionsCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection.ReadXml Method

WBCommonActionsCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection.WriteXml Method

WBCommonActionsCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBCommonActionsCollection Fields

WBCommonActionsCollection Fields Datapolis Process System Class Reference

The WBCommonActionsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBCommonActionsCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V) Class

WBDictionaryK, V Class Datapolis Process System Class Reference
WBDictionary
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary K, V
Datapolis.WorkBox.Utilities.WBInterfaceWBDictionaryK, V

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBDictionary<K, V> : Dictionary<K, V>,
    IXmlSerializable

Public NotInheritable Class WBDictionary(Of K, V)
    Inherits Dictionary(Of K, V)
    Implements IXmlSerializable
generic<typename K, typename V>
public ref class WBDictionary sealed : public Dictionary<K, V>,
    IXmlSerializable
[<SealedAttribute>]
type WBDictionary<'K, 'V> =
    class
        inherit Dictionary<'K, 'V>
        interface IXmlSerializable
    end

Type Parameters

K
V

The WBDictionaryK, V type exposes the following members.

Constructors
 | Name | Description
Public method | WBDictionaryK, V | Constructor
Public method | WBDictionaryK, V(String) | Initializes a new instance of the WBDictionaryK, V class
Top
Properties
 | Name | Description
Public property | EntityName | Gets EntityName
Top
Methods
 | Name | Description
Public method | GetSchema |
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml |
Public method | WriteXml |
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V) Constructor

WBDictionaryK, V Constructor Datapolis Process System Class Reference
Overload List
 | Name | Description
Public method | WBDictionaryK, V | Constructor
Public method | WBDictionaryK, V(String) | Initializes a new instance of the WBDictionaryK, V class
Top
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V) Constructor

WBDictionaryK, V Constructor Datapolis Process System Class Reference
Constructor

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBDictionary()
Public Sub New
public:
WBDictionary()
new : unit -> WBDictionary
See Also

Reference

WBDictionaryK, V Class
WBDictionaryK, V Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V) Constructor (String)

WBDictionaryK, V Constructor (String) Datapolis Process System Class Reference
Initializes a new instance of the WBDictionaryK, V class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBDictionary(
    string entityName
)
Public Sub New (
    entityName As String
)
public:
WBDictionary(
    String^ entityName
)
new :
        entityName : string -> WBDictionary

Parameters

entityName
Type: SystemString
See Also

Reference

WBDictionaryK, V Class
WBDictionaryK, V Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V) Properties

WBDictionaryK, V Properties Datapolis Process System Class Reference

The WBDictionaryK, V generic type exposes the following members.

Properties
 | Name | Description
Public property | EntityName | Gets EntityName
Top
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V).EntityName Property

WBDictionaryK, VEntityName Property Datapolis Process System Class Reference
Gets EntityName

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string EntityName { get; }
Public ReadOnly Property EntityName As String
    Get
public:
property String^ EntityName {
    String^ get ();
}
member EntityName : string with get

Property Value

Type: String
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V) Methods

WBDictionaryK, V Methods Datapolis Process System Class Reference

The WBDictionaryK, V generic type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema |
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml |
Public method | WriteXml |
Top
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V).GetSchema Method

WBDictionaryK, VGetSchema Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public XmlSchema GetSchema()
Public Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() sealed
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema

Implements

IXmlSerializableGetSchema
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V).GetWBSchema Method

WBDictionaryK, VGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V).ReadXml Method

WBDictionaryK, VReadXml Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public void ReadXml(
    XmlReader reader
)
Public Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) sealed
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBDictionary(K, V).WriteXml Method

WBDictionaryK, VWriteXml Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public void WriteXml(
    XmlWriter writer
)
Public Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) sealed
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBDictionaryK, V Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo Class

WBFieldInfo Class Datapolis Process System Class Reference
Represents list item's field.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBFieldInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBFieldInfo : WBInterfaceBase
Public NotInheritable Class WBFieldInfo
    Inherits WBInterfaceBase
public ref class WBFieldInfo sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBFieldInfo =
    class
        inherit WBInterfaceBase
    end

The WBFieldInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBFieldInfo | Initializes a new instance of the WBFieldInfo class
Top
Properties
 | Name | Description
Public property | Internalname | Gets InternalName of the list item's field.
Public property | Title | Gets Title of the list item's field.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo Constructor

WBFieldInfo Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBFieldInfo class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBFieldInfo()
Public Sub New
public:
WBFieldInfo()
new : unit -> WBFieldInfo
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo Properties

WBFieldInfo Properties Datapolis Process System Class Reference

The WBFieldInfo type exposes the following members.

Properties
 | Name | Description
Public property | Internalname | Gets InternalName of the list item's field.
Public property | Title | Gets Title of the list item's field.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo.Internalname Property

WBFieldInfoInternalname Property Datapolis Process System Class Reference
Gets InternalName of the list item's field.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Internalname { get; }
Public ReadOnly Property Internalname As String
    Get
public:
property String^ Internalname {
    String^ get ();
}
member Internalname : string with get

Property Value

Type: String
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo.Title Property

WBFieldInfoTitle Property Datapolis Process System Class Reference
Gets Title of the list item's field.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo Methods

WBFieldInfo Methods Datapolis Process System Class Reference

The WBFieldInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo.GetSchema Method

WBFieldInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo.GetWBSchema Method

WBFieldInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo.ReadXml Method

WBFieldInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfo.WriteXml Method

WBFieldInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBFieldInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection Class

WBFieldInfoCollection Class Datapolis Process System Class Reference
A collection of WBFieldInfo object instances.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBFieldInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBFieldInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBFieldInfoCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBFieldInfoCollection : WBInterfaceCollectionBase<WBFieldInfo>
Public NotInheritable Class WBFieldInfoCollection
    Inherits WBInterfaceCollectionBase(Of WBFieldInfo)
public ref class WBFieldInfoCollection sealed : public WBInterfaceCollectionBase<WBFieldInfo^>
[<SealedAttribute>]
type WBFieldInfoCollection =
    class
        inherit WBInterfaceCollectionBase<WBFieldInfo>
    end

The WBFieldInfoCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBFieldInfoCollection | Initializes a new instance of the WBFieldInfoCollection class
Top
Properties
 | Name | Description
Public property | Item | Gets the WBFieldInfo object with the specified InternalName property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection Constructor

WBFieldInfoCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBFieldInfoCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBFieldInfoCollection()
Public Sub New
public:
WBFieldInfoCollection()
new : unit -> WBFieldInfoCollection
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection Properties

WBFieldInfoCollection Properties Datapolis Process System Class Reference

The WBFieldInfoCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the WBFieldInfo object with the specified InternalName property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection.Item Property

WBFieldInfoCollectionItem Property Datapolis Process System Class Reference
Gets the WBFieldInfo object with the specified InternalName property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBFieldInfo this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As WBFieldInfo
    Get
public:
property WBFieldInfo^ default[String^ name] {
    WBFieldInfo^ get (String^ name);
}
member Item : WBFieldInfo with get

Parameters

name
Type: SystemString
Field InternalName.

Return Value

Type: WBFieldInfo
A WBFieldInfo object instance that represents the list item's field.
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection Methods

WBFieldInfoCollection Methods Datapolis Process System Class Reference

The WBFieldInfoCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection.GetSchema Method

WBFieldInfoCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection.GetWBSchema Method

WBFieldInfoCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection.ReadXml Method

WBFieldInfoCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBFieldInfoCollection.WriteXml Method

WBFieldInfoCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBFieldInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase Class

WBInterfaceBase Class Datapolis Process System Class Reference
WBInterfaceBase
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
More...

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBInterfaceBase : IXmlSerializable
Public MustInherit Class WBInterfaceBase
    Implements IXmlSerializable
public ref class WBInterfaceBase abstract : IXmlSerializable
[<AbstractClassAttribute>]
type WBInterfaceBase =
    class
        interface IXmlSerializable
    end

The WBInterfaceBase type exposes the following members.

Constructors
 | Name | Description
Public method | WBInterfaceBase | Creates new instance of WBInterfaceBase.
Top
Properties
 | Name | Description
Public property | Version | Gets the object's version.
Top
Methods
 | Name | Description
 | _fixSchema |
Protected method | _initializeDefaults | Initializes object's fields with default values.
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.
Public method | ReadXml | Generates an object from its XML representation.
Public method | WriteXml | Converts an object into its XML representation.
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property.
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBActionParameter
Datapolis.WorkBox.Utilities.WBInterfaceWBActions
Datapolis.WorkBox.Utilities.WBInterfaceWBAllActions
Datapolis.WorkBox.Utilities.WBInterfaceWBAllCommonActions
Datapolis.WorkBox.Utilities.WBInterfaceWBCommonActions
Datapolis.WorkBox.Utilities.WBInterfaceWBFieldInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBItemInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBItemInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBListInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBListInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBResultInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBRunAsInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowParameter


WBInterfaceBase Constructor

WBInterfaceBase Constructor Datapolis Process System Class Reference
Creates new instance of WBInterfaceBase.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBInterfaceBase()
Public Sub New
public:
WBInterfaceBase()
new : unit -> WBInterfaceBase
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase Properties

WBInterfaceBase Properties Datapolis Process System Class Reference

The WBInterfaceBase type exposes the following members.

Properties
 | Name | Description
Public property | Version | Gets the object's version.
Top
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase.Version Property

WBInterfaceBaseVersion Property Datapolis Process System Class Reference
Gets the object's version.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; protected set; }
Public Property Version As String
    Get
    Protected Set
public:
property String^ Version {
    String^ get ();
    protected: void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase Methods

WBInterfaceBase Methods Datapolis Process System Class Reference

The WBInterfaceBase type exposes the following members.

Methods
 | Name | Description
 | _fixSchema |
Protected method | _initializeDefaults | Initializes object's fields with default values.
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.
Public method | ReadXml | Generates an object from its XML representation.
Public method | WriteXml | Converts an object into its XML representation.
Top
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase._fixSchema Method

WBInterfaceBase_fixSchema Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected static void _fixSchema(
    ref XmlSchema newSchema,
    ref XmlSchemaSet schemaSet
)
Protected Shared Sub _fixSchema (
    ByRef newSchema As XmlSchema,
    ByRef schemaSet As XmlSchemaSet
)
protected:
static void _fixSchema(
    XmlSchema^% newSchema,
    XmlSchemaSet^% schemaSet
)
static member _fixSchema :
        newSchema : XmlSchema byref *
        schemaSet : XmlSchemaSet byref -> unit

Parameters

newSchema
Type: System.Xml.SchemaXmlSchema
schemaSet
Type: System.Xml.SchemaXmlSchemaSet
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase._initializeDefaults Method

WBInterfaceBase_initializeDefaults Method Datapolis Process System Class Reference
Initializes object's fields with default values.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected abstract void _initializeDefaults()
Protected MustOverride Sub _initializeDefaults
protected:
virtual void _initializeDefaults() abstract
abstract _initializeDefaults : unit -> unit
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase.GetSchema Method

WBInterfaceBaseGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract XmlSchema GetSchema()
Public MustOverride Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() abstract
abstract GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase.ReadXml Method

WBInterfaceBaseReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract void ReadXml(
    XmlReader reader
)
Public MustOverride Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) abstract
abstract ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase.WriteXml Method

WBInterfaceBaseWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract void WriteXml(
    XmlWriter writer
)
Public MustOverride Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) abstract
abstract WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase Fields

WBInterfaceBase Fields Datapolis Process System Class Reference

The WBInterfaceBase type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property.
Top
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceBase.ParseExceptionString Field

WBInterfaceBaseParseExceptionString Field Datapolis Process System Class Reference
Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected readonly string ParseExceptionString
Protected ReadOnly ParseExceptionString As String
protected:
initonly String^ ParseExceptionString
val ParseExceptionString: string

Field Value

Type: String
See Also

Reference

WBInterfaceBase Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T) Class

WBInterfaceCollectionBaseT Class Datapolis Process System Class Reference
WBInterfaceCollectionBase
Inheritance Hierarchy
SystemObject
System.Collections.GenericList T
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBaseT
More...

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract class WBInterfaceCollectionBase<T> : List<T>,
    IXmlSerializable

Public MustInherit Class WBInterfaceCollectionBase(Of T)
    Inherits List(Of T)
    Implements IXmlSerializable
generic<typename T>
public ref class WBInterfaceCollectionBase abstract : public List<T>,
    IXmlSerializable
[<AbstractClassAttribute>]
type WBInterfaceCollectionBase<'T> =
    class
        inherit List<'T>
        interface IXmlSerializable
    end

Type Parameters

T

The WBInterfaceCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | WBInterfaceCollectionBaseT | Creates new instance of WBInterfaceCollectionBase.
Top
Properties
 | Name | Description
Public property | Version | Gets the object's version.
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | Initializes object's fields with default values.
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.
Public method | ReadXml | Generates an object from its XML representation.
Public method | WriteXml | Converts an object into its XML representation.
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property.
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace
Inheritance Hierarchy
SystemObject
System.Collections.GenericList T
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBaseT
Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfoCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBActionParameterCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBAllCommonActionsCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBCommonActionsCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBFieldInfoCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBItemInfoWorkflowCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBListInfoWorkflowCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBRunAsInfoCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfoWorkflowCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowInfoCollection
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowParameterCollection


WBInterfaceCollectionBase(T) Constructor

WBInterfaceCollectionBaseT Constructor Datapolis Process System Class Reference
Creates new instance of WBInterfaceCollectionBase.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBInterfaceCollectionBase()
Public Sub New
public:
WBInterfaceCollectionBase()
new : unit -> WBInterfaceCollectionBase
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T) Properties

WBInterfaceCollectionBaseT Properties Datapolis Process System Class Reference

The WBInterfaceCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Version | Gets the object's version.
Top
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T).Version Property

WBInterfaceCollectionBaseTVersion Property Datapolis Process System Class Reference
Gets the object's version.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; protected set; }
Public Property Version As String
    Get
    Protected Set
public:
property String^ Version {
    String^ get ();
    protected: void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T) Methods

WBInterfaceCollectionBaseT Methods Datapolis Process System Class Reference

The WBInterfaceCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | Initializes object's fields with default values.
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.
Public method | ReadXml | Generates an object from its XML representation.
Public method | WriteXml | Converts an object into its XML representation.
Top
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T)._initializeDefaults Method

WBInterfaceCollectionBaseT_initializeDefaults Method Datapolis Process System Class Reference
Initializes object's fields with default values.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected abstract void _initializeDefaults()
Protected MustOverride Sub _initializeDefaults
protected:
virtual void _initializeDefaults() abstract
abstract _initializeDefaults : unit -> unit
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T).GetSchema Method

WBInterfaceCollectionBaseTGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract XmlSchema GetSchema()
Public MustOverride Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() abstract
abstract GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T).ReadXml Method

WBInterfaceCollectionBaseTReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract void ReadXml(
    XmlReader reader
)
Public MustOverride Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) abstract
abstract ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T).WriteXml Method

WBInterfaceCollectionBaseTWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public abstract void WriteXml(
    XmlWriter writer
)
Public MustOverride Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) abstract
abstract WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T) Fields

WBInterfaceCollectionBaseT Fields Datapolis Process System Class Reference

The WBInterfaceCollectionBaseT generic type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property.
Top
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBInterfaceCollectionBase(T).ParseExceptionString Field

WBInterfaceCollectionBaseTParseExceptionString Field Datapolis Process System Class Reference
Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected readonly string ParseExceptionString
Protected ReadOnly ParseExceptionString As String
protected:
initonly String^ ParseExceptionString
val ParseExceptionString: string

Field Value

Type: String
See Also

Reference

WBInterfaceCollectionBaseT Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo Class

WBItemInfo Class Datapolis Process System Class Reference
Gets information about a given list item, including Workbox workflows that are either running, completed or available to start on the item.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBItemInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBItemInfo : WBInterfaceBase
Public NotInheritable Class WBItemInfo
    Inherits WBInterfaceBase
public ref class WBItemInfo sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBItemInfo =
    class
        inherit WBInterfaceBase
    end

The WBItemInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBItemInfo | Constructor
Top
Properties
 | Name | Description
Public property | CompletedWBWorkflows | Gets the collection of WBItemInfoWorkflow objects that represent completed Workbox workflows on the item.
Public property | FieldsAllowedToDisplay | Gets the collection of WBFieldInfo objects that represent the item's fields which can be displayed to the contex user.
Public property | FieldsAllowedToEdit | Gets the collection of WBFieldInfo objects that represent the item's fields which the context user can modify.
Public property | ItemID | Gets the item's ID.
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the name of the list.
Public property | ListUrl | Gets the list's URL address.
Public property | RunningWBWorkflows | Gets the collection of WBItemInfoWorkflow objects that represent Workbox workflows currently running on the item.
Public property | ToBeStartedWorkflows | Gets the collection of WBListInfoWorkflow objects that represent Workbox workflows which can be started on the item.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo Constructor

WBItemInfo Constructor Datapolis Process System Class Reference
Constructor

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBItemInfo()
Public Sub New
public:
WBItemInfo()
new : unit -> WBItemInfo
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo Properties

WBItemInfo Properties Datapolis Process System Class Reference

The WBItemInfo type exposes the following members.

Properties
 | Name | Description
Public property | CompletedWBWorkflows | Gets the collection of WBItemInfoWorkflow objects that represent completed Workbox workflows on the item.
Public property | FieldsAllowedToDisplay | Gets the collection of WBFieldInfo objects that represent the item's fields which can be displayed to the contex user.
Public property | FieldsAllowedToEdit | Gets the collection of WBFieldInfo objects that represent the item's fields which the context user can modify.
Public property | ItemID | Gets the item's ID.
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the name of the list.
Public property | ListUrl | Gets the list's URL address.
Public property | RunningWBWorkflows | Gets the collection of WBItemInfoWorkflow objects that represent Workbox workflows currently running on the item.
Public property | ToBeStartedWorkflows | Gets the collection of WBListInfoWorkflow objects that represent Workbox workflows which can be started on the item.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.CompletedWBWorkflows Property

WBItemInfoCompletedWBWorkflows Property Datapolis Process System Class Reference
Gets the collection of WBItemInfoWorkflow objects that represent completed Workbox workflows on the item.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBItemInfoWorkflowCollection CompletedWBWorkflows { get; }
Public ReadOnly Property CompletedWBWorkflows As WBItemInfoWorkflowCollection
    Get
public:
property WBItemInfoWorkflowCollection^ CompletedWBWorkflows {
    WBItemInfoWorkflowCollection^ get ();
}
member CompletedWBWorkflows : WBItemInfoWorkflowCollection with get

Property Value

Type: WBItemInfoWorkflowCollection
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.FieldsAllowedToDisplay Property

WBItemInfoFieldsAllowedToDisplay Property Datapolis Process System Class Reference
Gets the collection of WBFieldInfo objects that represent the item's fields which can be displayed to the contex user.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBFieldInfoCollection FieldsAllowedToDisplay { get; }
Public ReadOnly Property FieldsAllowedToDisplay As WBFieldInfoCollection
    Get
public:
property WBFieldInfoCollection^ FieldsAllowedToDisplay {
    WBFieldInfoCollection^ get ();
}
member FieldsAllowedToDisplay : WBFieldInfoCollection with get

Property Value

Type: WBFieldInfoCollection
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.FieldsAllowedToEdit Property

WBItemInfoFieldsAllowedToEdit Property Datapolis Process System Class Reference
Gets the collection of WBFieldInfo objects that represent the item's fields which the context user can modify.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBFieldInfoCollection FieldsAllowedToEdit { get; }
Public ReadOnly Property FieldsAllowedToEdit As WBFieldInfoCollection
    Get
public:
property WBFieldInfoCollection^ FieldsAllowedToEdit {
    WBFieldInfoCollection^ get ();
}
member FieldsAllowedToEdit : WBFieldInfoCollection with get

Property Value

Type: WBFieldInfoCollection
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.ItemID Property

WBItemInfoItemID Property Datapolis Process System Class Reference
Gets the item's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public int ItemID { get; }
Public ReadOnly Property ItemID As Integer
    Get
public:
property int ItemID {
    int get ();
}
member ItemID : int with get

Property Value

Type: Int32
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.ListDefaultViewUrl Property

WBItemInfoListDefaultViewUrl Property Datapolis Process System Class Reference
Gets the URL address of the list's default view.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListDefaultViewUrl { get; }
Public ReadOnly Property ListDefaultViewUrl As String
    Get
public:
property String^ ListDefaultViewUrl {
    String^ get ();
}
member ListDefaultViewUrl : string with get

Property Value

Type: String
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.ListID Property

WBItemInfoListID Property Datapolis Process System Class Reference
Gets the list's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid ListID { get; }
Public ReadOnly Property ListID As Guid
    Get
public:
property Guid ListID {
    Guid get ();
}
member ListID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.ListName Property

WBItemInfoListName Property Datapolis Process System Class Reference
Gets the name of the list.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListName { get; }
Public ReadOnly Property ListName As String
    Get
public:
property String^ ListName {
    String^ get ();
}
member ListName : string with get

Property Value

Type: String
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.ListUrl Property

WBItemInfoListUrl Property Datapolis Process System Class Reference
Gets the list's URL address.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListUrl { get; }
Public ReadOnly Property ListUrl As String
    Get
public:
property String^ ListUrl {
    String^ get ();
}
member ListUrl : string with get

Property Value

Type: String
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.RunningWBWorkflows Property

WBItemInfoRunningWBWorkflows Property Datapolis Process System Class Reference
Gets the collection of WBItemInfoWorkflow objects that represent Workbox workflows currently running on the item.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBItemInfoWorkflowCollection RunningWBWorkflows { get; }
Public ReadOnly Property RunningWBWorkflows As WBItemInfoWorkflowCollection
    Get
public:
property WBItemInfoWorkflowCollection^ RunningWBWorkflows {
    WBItemInfoWorkflowCollection^ get ();
}
member RunningWBWorkflows : WBItemInfoWorkflowCollection with get

Property Value

Type: WBItemInfoWorkflowCollection
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.ToBeStartedWorkflows Property

WBItemInfoToBeStartedWorkflows Property Datapolis Process System Class Reference
Gets the collection of WBListInfoWorkflow objects that represent Workbox workflows which can be started on the item.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBListInfoWorkflowCollection ToBeStartedWorkflows { get; }
Public ReadOnly Property ToBeStartedWorkflows As WBListInfoWorkflowCollection
    Get
public:
property WBListInfoWorkflowCollection^ ToBeStartedWorkflows {
    WBListInfoWorkflowCollection^ get ();
}
member ToBeStartedWorkflows : WBListInfoWorkflowCollection with get

Property Value

Type: WBListInfoWorkflowCollection
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo Methods

WBItemInfo Methods Datapolis Process System Class Reference

The WBItemInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.GetSchema Method

WBItemInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.GetWBSchema Method

WBItemInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.ReadXml Method

WBItemInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfo.WriteXml Method

WBItemInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBItemInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow Class

WBItemInfoWorkflow Class Datapolis Process System Class Reference
Represents Workbox workflow on an item. This class allows you to access basic information about the workflow.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBItemInfoWorkflow

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBItemInfoWorkflow : WBInterfaceBase
Public NotInheritable Class WBItemInfoWorkflow
    Inherits WBInterfaceBase
public ref class WBItemInfoWorkflow sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBItemInfoWorkflow =
    class
        inherit WBInterfaceBase
    end

The WBItemInfoWorkflow type exposes the following members.

Constructors
 | Name | Description
Public method | WBItemInfoWorkflow | Initializes a new instance of the WBItemInfoWorkflow class
Top
Properties
 | Name | Description
Public property | AssociationID | Gets the workflow's association ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | Description | Gets the workflow's description.
Public property | EndTime | Gets the end time of the workflow. If the workflow is still running, EndTime will have the following value: 12/31/9999 23:59:59.
Public property | InstanceID | Gets the workflow's instance ID.
Public property | InternalState | Gets the SPWorkflow.InternalState value of the workflow.
Public property | Name | Gets the workflow's name.
Public property | StartTime | Gets the start time of the workflow.
Public property | State | Gets the name of the current workflow's state.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow Constructor

WBItemInfoWorkflow Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBItemInfoWorkflow class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBItemInfoWorkflow()
Public Sub New
public:
WBItemInfoWorkflow()
new : unit -> WBItemInfoWorkflow
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow Properties

WBItemInfoWorkflow Properties Datapolis Process System Class Reference

The WBItemInfoWorkflow type exposes the following members.

Properties
 | Name | Description
Public property | AssociationID | Gets the workflow's association ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | Description | Gets the workflow's description.
Public property | EndTime | Gets the end time of the workflow. If the workflow is still running, EndTime will have the following value: 12/31/9999 23:59:59.
Public property | InstanceID | Gets the workflow's instance ID.
Public property | InternalState | Gets the SPWorkflow.InternalState value of the workflow.
Public property | Name | Gets the workflow's name.
Public property | StartTime | Gets the start time of the workflow.
Public property | State | Gets the name of the current workflow's state.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.AssociationID Property

WBItemInfoWorkflowAssociationID Property Datapolis Process System Class Reference
Gets the workflow's association ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid AssociationID { get; }
Public ReadOnly Property AssociationID As Guid
    Get
public:
property Guid AssociationID {
    Guid get ();
}
member AssociationID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.BaseID Property

WBItemInfoWorkflowBaseID Property Datapolis Process System Class Reference
Gets the workflow's base ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid BaseID { get; }
Public ReadOnly Property BaseID As Guid
    Get
public:
property Guid BaseID {
    Guid get ();
}
member BaseID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.Description Property

WBItemInfoWorkflowDescription Property Datapolis Process System Class Reference
Gets the workflow's description.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.EndTime Property

WBItemInfoWorkflowEndTime Property Datapolis Process System Class Reference
Gets the end time of the workflow. If the workflow is still running, EndTime will have the following value: 12/31/9999 23:59:59.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> EndTime { get; }
Public ReadOnly Property EndTime As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> EndTime {
    Nullable<DateTime> get ();
}
member EndTime : Nullable<DateTime> with get

Property Value

Type: Nullable DateTime
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.InstanceID Property

WBItemInfoWorkflowInstanceID Property Datapolis Process System Class Reference
Gets the workflow's instance ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid InstanceID { get; }
Public ReadOnly Property InstanceID As Guid
    Get
public:
property Guid InstanceID {
    Guid get ();
}
member InstanceID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.InternalState Property

WBItemInfoWorkflowInternalState Property Datapolis Process System Class Reference
Gets the SPWorkflow.InternalState value of the workflow.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string InternalState { get; }
Public ReadOnly Property InternalState As String
    Get
public:
property String^ InternalState {
    String^ get ();
}
member InternalState : string with get

Property Value

Type: String
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.Name Property

WBItemInfoWorkflowName Property Datapolis Process System Class Reference
Gets the workflow's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.StartTime Property

WBItemInfoWorkflowStartTime Property Datapolis Process System Class Reference
Gets the start time of the workflow.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> StartTime { get; }
Public ReadOnly Property StartTime As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> StartTime {
    Nullable<DateTime> get ();
}
member StartTime : Nullable<DateTime> with get

Property Value

Type: Nullable DateTime
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.State Property

WBItemInfoWorkflowState Property Datapolis Process System Class Reference
Gets the name of the current workflow's state.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string State { get; }
Public ReadOnly Property State As String
    Get
public:
property String^ State {
    String^ get ();
}
member State : string with get

Property Value

Type: String
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow Methods

WBItemInfoWorkflow Methods Datapolis Process System Class Reference

The WBItemInfoWorkflow type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.GetSchema Method

WBItemInfoWorkflowGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.GetWBSchema Method

WBItemInfoWorkflowGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.ReadXml Method

WBItemInfoWorkflowReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflow.WriteXml Method

WBItemInfoWorkflowWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBItemInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection Class

WBItemInfoWorkflowCollection Class Datapolis Process System Class Reference
A collection of WBItemInfoWorkflow objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBItemInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBItemInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBItemInfoWorkflowCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBItemInfoWorkflowCollection : WBInterfaceCollectionBase<WBItemInfoWorkflow>
Public NotInheritable Class WBItemInfoWorkflowCollection
    Inherits WBInterfaceCollectionBase(Of WBItemInfoWorkflow)
public ref class WBItemInfoWorkflowCollection sealed : public WBInterfaceCollectionBase<WBItemInfoWorkflow^>
[<SealedAttribute>]
type WBItemInfoWorkflowCollection =
    class
        inherit WBInterfaceCollectionBase<WBItemInfoWorkflow>
    end

The WBItemInfoWorkflowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBItemInfoWorkflowCollection | Initializes a new instance of the WBItemInfoWorkflowCollection class
Top
Properties
 | Name | Description
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection Constructor

WBItemInfoWorkflowCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBItemInfoWorkflowCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBItemInfoWorkflowCollection()
Public Sub New
public:
WBItemInfoWorkflowCollection()
new : unit -> WBItemInfoWorkflowCollection
See Also

Reference

WBItemInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection Properties

WBItemInfoWorkflowCollection Properties Datapolis Process System Class Reference

The WBItemInfoWorkflowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBItemInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection Methods

WBItemInfoWorkflowCollection Methods Datapolis Process System Class Reference

The WBItemInfoWorkflowCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBItemInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection.GetSchema Method

WBItemInfoWorkflowCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBItemInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection.GetWBSchema Method

WBItemInfoWorkflowCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBItemInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection.ReadXml Method

WBItemInfoWorkflowCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBItemInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBItemInfoWorkflowCollection.WriteXml Method

WBItemInfoWorkflowCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBItemInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo Class

WBListInfo Class Datapolis Process System Class Reference
Represents Workbox workflows on a list.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBListInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBListInfo : WBInterfaceBase
Public NotInheritable Class WBListInfo
    Inherits WBInterfaceBase
public ref class WBListInfo sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBListInfo =
    class
        inherit WBInterfaceBase
    end

The WBListInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBListInfo | Creates a new instance of WBListInfo class.
Top
Properties
 | Name | Description
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | ListWBWorkflows | Gets the collection of WBListInfoWorkflow objects that represent Workbox workflows on the list.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo Constructor

WBListInfo Constructor Datapolis Process System Class Reference
Creates a new instance of WBListInfo class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBListInfo()
Public Sub New
public:
WBListInfo()
new : unit -> WBListInfo
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo Properties

WBListInfo Properties Datapolis Process System Class Reference

The WBListInfo type exposes the following members.

Properties
 | Name | Description
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | ListWBWorkflows | Gets the collection of WBListInfoWorkflow objects that represent Workbox workflows on the list.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.ListDefaultViewUrl Property

WBListInfoListDefaultViewUrl Property Datapolis Process System Class Reference
Gets the URL address of the list's default view.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListDefaultViewUrl { get; }
Public ReadOnly Property ListDefaultViewUrl As String
    Get
public:
property String^ ListDefaultViewUrl {
    String^ get ();
}
member ListDefaultViewUrl : string with get

Property Value

Type: String
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.ListID Property

WBListInfoListID Property Datapolis Process System Class Reference
Gets the list's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid ListID { get; }
Public ReadOnly Property ListID As Guid
    Get
public:
property Guid ListID {
    Guid get ();
}
member ListID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.ListName Property

WBListInfoListName Property Datapolis Process System Class Reference
Gets the list's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListName { get; }
Public ReadOnly Property ListName As String
    Get
public:
property String^ ListName {
    String^ get ();
}
member ListName : string with get

Property Value

Type: String
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.ListUrl Property

WBListInfoListUrl Property Datapolis Process System Class Reference
Gets the list's URL address.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListUrl { get; }
Public ReadOnly Property ListUrl As String
    Get
public:
property String^ ListUrl {
    String^ get ();
}
member ListUrl : string with get

Property Value

Type: String
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.ListWBWorkflows Property

WBListInfoListWBWorkflows Property Datapolis Process System Class Reference
Gets the collection of WBListInfoWorkflow objects that represent Workbox workflows on the list.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBListInfoWorkflowCollection ListWBWorkflows { get; }
Public ReadOnly Property ListWBWorkflows As WBListInfoWorkflowCollection
    Get
public:
property WBListInfoWorkflowCollection^ ListWBWorkflows {
    WBListInfoWorkflowCollection^ get ();
}
member ListWBWorkflows : WBListInfoWorkflowCollection with get

Property Value

Type: WBListInfoWorkflowCollection
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo Methods

WBListInfo Methods Datapolis Process System Class Reference

The WBListInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.GetSchema Method

WBListInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.GetWBSchema Method

WBListInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.ReadXml Method

WBListInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfo.WriteXml Method

WBListInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBListInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow Class

WBListInfoWorkflow Class Datapolis Process System Class Reference
Represents a Workbox workflow definition on a list.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBListInfoWorkflow

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBListInfoWorkflow : WBInterfaceBase
Public NotInheritable Class WBListInfoWorkflow
    Inherits WBInterfaceBase
public ref class WBListInfoWorkflow sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBListInfoWorkflow =
    class
        inherit WBInterfaceBase
    end

The WBListInfoWorkflow type exposes the following members.

Constructors
 | Name | Description
Public method | WBListInfoWorkflow | Creates a new instance of WBListInfoWorkflow class.
Top
Properties
 | Name | Description
Public property | AllowManualStart | Gets a Boolean value that indicates if the workflow can be started manually.
Public property | Associated | Gets a Boolean value that indicates whether the workflow is deployed on the list.
Public property | AssociationID | Gets the workflow's association ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | Description | Gets the workflow's description.
Public property | FormType | Gets the type of the workflow's launch form.
Public property | FormURL | Gets the URL address of the workflow's custom launch form.
Public property | Name | Gets the workflow's name.
Public property | Parameters | Gets the collection of the workflow parameters.
Public property | RedirectURL | Gets the URL address of the page to which the user should be redirected after the workflow has been successfully started.
Public property | RequireManagePermission | Gets a Boolean value that indicates if the workflow requires Manage Web or Manage List permission to be started manually.
Public property | StartOnChange | Gets a Boolean value that indicates whether the workflow is set to start when an item is changed.
Public property | StartOnCreate | Gets a Boolean value that indicates whether the workflow is set to start when an item is created.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow Constructor

WBListInfoWorkflow Constructor Datapolis Process System Class Reference
Creates a new instance of WBListInfoWorkflow class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBListInfoWorkflow()
Public Sub New
public:
WBListInfoWorkflow()
new : unit -> WBListInfoWorkflow
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow Properties

WBListInfoWorkflow Properties Datapolis Process System Class Reference

The WBListInfoWorkflow type exposes the following members.

Properties
 | Name | Description
Public property | AllowManualStart | Gets a Boolean value that indicates if the workflow can be started manually.
Public property | Associated | Gets a Boolean value that indicates whether the workflow is deployed on the list.
Public property | AssociationID | Gets the workflow's association ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | Description | Gets the workflow's description.
Public property | FormType | Gets the type of the workflow's launch form.
Public property | FormURL | Gets the URL address of the workflow's custom launch form.
Public property | Name | Gets the workflow's name.
Public property | Parameters | Gets the collection of the workflow parameters.
Public property | RedirectURL | Gets the URL address of the page to which the user should be redirected after the workflow has been successfully started.
Public property | RequireManagePermission | Gets a Boolean value that indicates if the workflow requires Manage Web or Manage List permission to be started manually.
Public property | StartOnChange | Gets a Boolean value that indicates whether the workflow is set to start when an item is changed.
Public property | StartOnCreate | Gets a Boolean value that indicates whether the workflow is set to start when an item is created.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.AllowManualStart Property

WBListInfoWorkflowAllowManualStart Property Datapolis Process System Class Reference
Gets a Boolean value that indicates if the workflow can be started manually.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public bool AllowManualStart { get; }
Public ReadOnly Property AllowManualStart As Boolean
    Get
public:
property bool AllowManualStart {
    bool get ();
}
member AllowManualStart : bool with get

Property Value

Type: Boolean
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.Associated Property

WBListInfoWorkflowAssociated Property Datapolis Process System Class Reference
Gets a Boolean value that indicates whether the workflow is deployed on the list.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public bool Associated { get; }
Public ReadOnly Property Associated As Boolean
    Get
public:
property bool Associated {
    bool get ();
}
member Associated : bool with get

Property Value

Type: Boolean
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.AssociationID Property

WBListInfoWorkflowAssociationID Property Datapolis Process System Class Reference
Gets the workflow's association ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid AssociationID { get; }
Public ReadOnly Property AssociationID As Guid
    Get
public:
property Guid AssociationID {
    Guid get ();
}
member AssociationID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.BaseID Property

WBListInfoWorkflowBaseID Property Datapolis Process System Class Reference
Gets the workflow's base ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid BaseID { get; }
Public ReadOnly Property BaseID As Guid
    Get
public:
property Guid BaseID {
    Guid get ();
}
member BaseID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.Description Property

WBListInfoWorkflowDescription Property Datapolis Process System Class Reference
Gets the workflow's description.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.FormType Property

WBListInfoWorkflowFormType Property Datapolis Process System Class Reference
Gets the type of the workflow's launch form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBLaunchFormType FormType { get; }
Public ReadOnly Property FormType As WBLaunchFormType
    Get
public:
property WBLaunchFormType FormType {
    WBLaunchFormType get ();
}
member FormType : WBLaunchFormType with get

Property Value

Type: WBLaunchFormType
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.FormURL Property

WBListInfoWorkflowFormURL Property Datapolis Process System Class Reference
Gets the URL address of the workflow's custom launch form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string FormURL { get; }
Public ReadOnly Property FormURL As String
    Get
public:
property String^ FormURL {
    String^ get ();
}
member FormURL : string with get

Property Value

Type: String
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.Name Property

WBListInfoWorkflowName Property Datapolis Process System Class Reference
Gets the workflow's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.Parameters Property

WBListInfoWorkflowParameters Property Datapolis Process System Class Reference
Gets the collection of the workflow parameters.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowParameterCollection Parameters { get; }
Public ReadOnly Property Parameters As WBWorkflowParameterCollection
    Get
public:
property WBWorkflowParameterCollection^ Parameters {
    WBWorkflowParameterCollection^ get ();
}
member Parameters : WBWorkflowParameterCollection with get

Property Value

Type: WBWorkflowParameterCollection
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.RedirectURL Property

WBListInfoWorkflowRedirectURL Property Datapolis Process System Class Reference
Gets the URL address of the page to which the user should be redirected after the workflow has been successfully started.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string RedirectURL { get; }
Public ReadOnly Property RedirectURL As String
    Get
public:
property String^ RedirectURL {
    String^ get ();
}
member RedirectURL : string with get

Property Value

Type: String
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.RequireManagePermission Property

WBListInfoWorkflowRequireManagePermission Property Datapolis Process System Class Reference
Gets a Boolean value that indicates if the workflow requires Manage Web or Manage List permission to be started manually.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public bool RequireManagePermission { get; }
Public ReadOnly Property RequireManagePermission As Boolean
    Get
public:
property bool RequireManagePermission {
    bool get ();
}
member RequireManagePermission : bool with get

Property Value

Type: Boolean
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.StartOnChange Property

WBListInfoWorkflowStartOnChange Property Datapolis Process System Class Reference
Gets a Boolean value that indicates whether the workflow is set to start when an item is changed.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public bool StartOnChange { get; }
Public ReadOnly Property StartOnChange As Boolean
    Get
public:
property bool StartOnChange {
    bool get ();
}
member StartOnChange : bool with get

Property Value

Type: Boolean
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.StartOnCreate Property

WBListInfoWorkflowStartOnCreate Property Datapolis Process System Class Reference
Gets a Boolean value that indicates whether the workflow is set to start when an item is created.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public bool StartOnCreate { get; }
Public ReadOnly Property StartOnCreate As Boolean
    Get
public:
property bool StartOnCreate {
    bool get ();
}
member StartOnCreate : bool with get

Property Value

Type: Boolean
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow Methods

WBListInfoWorkflow Methods Datapolis Process System Class Reference

The WBListInfoWorkflow type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.GetSchema Method

WBListInfoWorkflowGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.GetWBSchema Method

WBListInfoWorkflowGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.ReadXml Method

WBListInfoWorkflowReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflow.WriteXml Method

WBListInfoWorkflowWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBListInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection Class

WBListInfoWorkflowCollection Class Datapolis Process System Class Reference
Represents a collection of WBListInfoWorkflow objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBListInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBListInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBListInfoWorkflowCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBListInfoWorkflowCollection : WBInterfaceCollectionBase<WBListInfoWorkflow>
Public NotInheritable Class WBListInfoWorkflowCollection
    Inherits WBInterfaceCollectionBase(Of WBListInfoWorkflow)
public ref class WBListInfoWorkflowCollection sealed : public WBInterfaceCollectionBase<WBListInfoWorkflow^>
[<SealedAttribute>]
type WBListInfoWorkflowCollection =
    class
        inherit WBInterfaceCollectionBase<WBListInfoWorkflow>
    end

The WBListInfoWorkflowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBListInfoWorkflowCollection | Initializes a new instance of the WBListInfoWorkflowCollection class
Top
Properties
 | Name | Description
Public property | ItemGuid | Gets the WBListInfoWorkflow object with the specified BaseID property.
Public property | ItemString | Gets the WBListInfoWorkflow object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection Constructor

WBListInfoWorkflowCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBListInfoWorkflowCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBListInfoWorkflowCollection()
Public Sub New
public:
WBListInfoWorkflowCollection()
new : unit -> WBListInfoWorkflowCollection
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection Properties

WBListInfoWorkflowCollection Properties Datapolis Process System Class Reference

The WBListInfoWorkflowCollection type exposes the following members.

Properties
 | Name | Description
Public property | ItemGuid | Gets the WBListInfoWorkflow object with the specified BaseID property.
Public property | ItemString | Gets the WBListInfoWorkflow object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection.Item Property

WBListInfoWorkflowCollectionItem Property Datapolis Process System Class Reference
Overload List
 | Name | Description
Public property | ItemGuid | Gets the WBListInfoWorkflow object with the specified BaseID property.
Public property | ItemString | Gets the WBListInfoWorkflow object with the specified Name property.
Top
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection.Item Property (Guid)

WBListInfoWorkflowCollectionItem Property (Guid) Datapolis Process System Class Reference
Gets the WBListInfoWorkflow object with the specified BaseID property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBListInfoWorkflow this[
    Guid baseID
] { get; }
Public ReadOnly Default Property Item (
    baseID As Guid
) As WBListInfoWorkflow
    Get
public:
property WBListInfoWorkflow^ default[Guid baseID] {
    WBListInfoWorkflow^ get (Guid baseID);
}
member Item : WBListInfoWorkflow with get

Parameters

baseID
Type: SystemGuid
Base ID of the workflow.

Return Value

Type: WBListInfoWorkflow
A WBListInfoWorkflow object that meets the criteria.
See Also

Reference

WBListInfoWorkflowCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection.Item Property (String)

WBListInfoWorkflowCollectionItem Property (String) Datapolis Process System Class Reference
Gets the WBListInfoWorkflow object with the specified Name property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBListInfoWorkflow this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As WBListInfoWorkflow
    Get
public:
property WBListInfoWorkflow^ default[String^ name] {
    WBListInfoWorkflow^ get (String^ name);
}
member Item : WBListInfoWorkflow with get

Parameters

name
Type: SystemString
Workbox workflow's name.

Return Value

Type: WBListInfoWorkflow
A WBListInfoWorkflow object that meets the criteria.
See Also

Reference

WBListInfoWorkflowCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection Methods

WBListInfoWorkflowCollection Methods Datapolis Process System Class Reference

The WBListInfoWorkflowCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection.GetSchema Method

WBListInfoWorkflowCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection.GetWBSchema Method

WBListInfoWorkflowCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection.ReadXml Method

WBListInfoWorkflowCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBListInfoWorkflowCollection.WriteXml Method

WBListInfoWorkflowCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBListInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo Class

WBResultInfo Class Datapolis Process System Class Reference
Represents the result of WBInfo web service method invoke.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBResultInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBResultInfo : WBInterfaceBase
Public NotInheritable Class WBResultInfo
    Inherits WBInterfaceBase
public ref class WBResultInfo sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBResultInfo =
    class
        inherit WBInterfaceBase
    end

The WBResultInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBResultInfo | Initializes a new instance of the WBResultInfo class
Top
Properties
 | Name | Description
Public property | Message | Gets the result's message.
Public property | Result | Gets the result's value. The value is False if there were errors.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo Constructor

WBResultInfo Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBResultInfo class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo()
Public Sub New
public:
WBResultInfo()
new : unit -> WBResultInfo
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo Properties

WBResultInfo Properties Datapolis Process System Class Reference

The WBResultInfo type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets the result's message.
Public property | Result | Gets the result's value. The value is False if there were errors.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo.Message Property

WBResultInfoMessage Property Datapolis Process System Class Reference
Gets the result's message.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
member Message : string with get

Property Value

Type: String
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo.Result Property

WBResultInfoResult Property Datapolis Process System Class Reference
Gets the result's value. The value is False if there were errors.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public bool Result { get; }
Public ReadOnly Property Result As Boolean
    Get
public:
property bool Result {
    bool get ();
}
member Result : bool with get

Property Value

Type: Boolean
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo Methods

WBResultInfo Methods Datapolis Process System Class Reference

The WBResultInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo.GetSchema Method

WBResultInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo.GetWBSchema Method

WBResultInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo.ReadXml Method

WBResultInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBResultInfo.WriteXml Method

WBResultInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBResultInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo Class

WBRunAsInfo Class Datapolis Process System Class Reference
Represents an subsitution provided option for action execution in Workbox workflow.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBRunAsInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBRunAsInfo : WBInterfaceBase
Public Class WBRunAsInfo
    Inherits WBInterfaceBase
public ref class WBRunAsInfo : public WBInterfaceBase
type WBRunAsInfo =
    class
        inherit WBInterfaceBase
    end

The WBRunAsInfo type exposes the following members.

Properties
 | Name | Description
Public property | UserId | SPUser Id
Public property | UserLogin | SPUser login name
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo Properties

WBRunAsInfo Properties Datapolis Process System Class Reference

The WBRunAsInfo type exposes the following members.

Properties
 | Name | Description
Public property | UserId | SPUser Id
Public property | UserLogin | SPUser login name
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo.UserId Property

WBRunAsInfoUserId Property Datapolis Process System Class Reference
SPUser Id

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public int UserId { get; }
Public ReadOnly Property UserId As Integer
    Get
public:
property int UserId {
    int get ();
}
member UserId : int with get

Property Value

Type: Int32
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo.UserLogin Property

WBRunAsInfoUserLogin Property Datapolis Process System Class Reference
SPUser login name

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string UserLogin { get; }
Public ReadOnly Property UserLogin As String
    Get
public:
property String^ UserLogin {
    String^ get ();
}
member UserLogin : string with get

Property Value

Type: String
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo Methods

WBRunAsInfo Methods Datapolis Process System Class Reference

The WBRunAsInfo type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceBase_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo._initializeDefaults Method

WBRunAsInfo_initializeDefaults Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo.GetSchema Method

WBRunAsInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo.GetWBSchema Method

WBRunAsInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo.ReadXml Method

WBRunAsInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo.WriteXml Method

WBRunAsInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfo Fields

WBRunAsInfo Fields Datapolis Process System Class Reference

The WBRunAsInfo type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBRunAsInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection Class

WBRunAsInfoCollection Class Datapolis Process System Class Reference
Represents an subsitutions provided options for action execution in Workbox workflow.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBRunAsInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBRunAsInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBRunAsInfoCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public class WBRunAsInfoCollection : WBInterfaceCollectionBase<WBRunAsInfo>
Public Class WBRunAsInfoCollection
    Inherits WBInterfaceCollectionBase(Of WBRunAsInfo)
public ref class WBRunAsInfoCollection : public WBInterfaceCollectionBase<WBRunAsInfo^>
type WBRunAsInfoCollection =
    class
        inherit WBInterfaceCollectionBase<WBRunAsInfo>
    end

The WBRunAsInfoCollection type exposes the following members.

Properties
 | Name | Description
Public property | ItemInt32 | Gets the WBRunAsInfo object with the specified UserId property.
Public property | ItemString | Gets the WBRunAsInfo object with the specified UserLogin property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceCollectionBaseT_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection Properties

WBRunAsInfoCollection Properties Datapolis Process System Class Reference

The WBRunAsInfoCollection type exposes the following members.

Properties
 | Name | Description
Public property | ItemInt32 | Gets the WBRunAsInfo object with the specified UserId property.
Public property | ItemString | Gets the WBRunAsInfo object with the specified UserLogin property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection.Item Property

WBRunAsInfoCollectionItem Property Datapolis Process System Class Reference
Overload List
 | Name | Description
Public property | ItemInt32 | Gets the WBRunAsInfo object with the specified UserId property.
Public property | ItemString | Gets the WBRunAsInfo object with the specified UserLogin property.
Top
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection.Item Property (Int32)

WBRunAsInfoCollectionItem Property (Int32) Datapolis Process System Class Reference
Gets the WBRunAsInfo object with the specified UserId property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBRunAsInfo this[
    int userId
] { get; }
Public ReadOnly Default Property Item (
    userId As Integer
) As WBRunAsInfo
    Get
public:
property WBRunAsInfo^ default[int userId] {
    WBRunAsInfo^ get (int userId);
}
member Item : WBRunAsInfo with get

Parameters

userId
Type: SystemInt32
SPUser Id

Return Value

Type: WBRunAsInfo
A WBRunAsInfo object instance that represents the workflow run as action option
See Also

Reference

WBRunAsInfoCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection.Item Property (String)

WBRunAsInfoCollectionItem Property (String) Datapolis Process System Class Reference
Gets the WBRunAsInfo object with the specified UserLogin property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBRunAsInfo this[
    string loginname
] { get; }
Public ReadOnly Default Property Item (
    loginname As String
) As WBRunAsInfo
    Get
public:
property WBRunAsInfo^ default[String^ loginname] {
    WBRunAsInfo^ get (String^ loginname);
}
member Item : WBRunAsInfo with get

Parameters

loginname
Type: SystemString
User Login name

Return Value

Type: WBRunAsInfo
A WBRunAsInfo object instance that represents the workflow run as action option
See Also

Reference

WBRunAsInfoCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection Methods

WBRunAsInfoCollection Methods Datapolis Process System Class Reference

The WBRunAsInfoCollection type exposes the following members.

Methods
 | Name | Description
Protected method | _initializeDefaults | (Overrides WBInterfaceCollectionBaseT_initializeDefaults.)
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection._initializeDefaults Method

WBRunAsInfoCollection_initializeDefaults Method Datapolis Process System Class Reference

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
protected override void _initializeDefaults()
Protected Overrides Sub _initializeDefaults
protected:
virtual void _initializeDefaults() override
abstract _initializeDefaults : unit -> unit
override _initializeDefaults : unit -> unit
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection.GetSchema Method

WBRunAsInfoCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection.GetWBSchema Method

WBRunAsInfoCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection.ReadXml Method

WBRunAsInfoCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection.WriteXml Method

WBRunAsInfoCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBRunAsInfoCollection Fields

WBRunAsInfoCollection Fields Datapolis Process System Class Reference

The WBRunAsInfoCollection type exposes the following members.

Fields
 | Name | Description
Protected field | ParseExceptionString | Cannot parse XML string. To access the parsed XML, please refer to the exception's XmlResource property. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBRunAsInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo Class

WBSiteInfo Class Datapolis Process System Class Reference
Represents Workbox workflows on a site.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSiteInfo : WBInterfaceBase
Public NotInheritable Class WBSiteInfo
    Inherits WBInterfaceBase
public ref class WBSiteInfo sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBSiteInfo =
    class
        inherit WBInterfaceBase
    end

The WBSiteInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBSiteInfo | Creates a new instance of WBSiteInfo class.
Top
Properties
 | Name | Description
Public property | SiteWBWorkflows | Gets the collection of WBSiteInfoWorkflow objects that represent Workbox workflows on the site.
Public property | ToBeStartedWorkflows | Gets the collection of WBSiteInfoWorkflow objects that represent Workbox workflows which can be started on the site.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo Constructor

WBSiteInfo Constructor Datapolis Process System Class Reference
Creates a new instance of WBSiteInfo class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfo()
Public Sub New
public:
WBSiteInfo()
new : unit -> WBSiteInfo
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo Properties

WBSiteInfo Properties Datapolis Process System Class Reference

The WBSiteInfo type exposes the following members.

Properties
 | Name | Description
Public property | SiteWBWorkflows | Gets the collection of WBSiteInfoWorkflow objects that represent Workbox workflows on the site.
Public property | ToBeStartedWorkflows | Gets the collection of WBSiteInfoWorkflow objects that represent Workbox workflows which can be started on the site.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo.SiteWBWorkflows Property

WBSiteInfoSiteWBWorkflows Property Datapolis Process System Class Reference
Gets the collection of WBSiteInfoWorkflow objects that represent Workbox workflows on the site.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfoWorkflowCollection SiteWBWorkflows { get; }
Public ReadOnly Property SiteWBWorkflows As WBSiteInfoWorkflowCollection
    Get
public:
property WBSiteInfoWorkflowCollection^ SiteWBWorkflows {
    WBSiteInfoWorkflowCollection^ get ();
}
member SiteWBWorkflows : WBSiteInfoWorkflowCollection with get

Property Value

Type: WBSiteInfoWorkflowCollection
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo.ToBeStartedWorkflows Property

WBSiteInfoToBeStartedWorkflows Property Datapolis Process System Class Reference
Gets the collection of WBSiteInfoWorkflow objects that represent Workbox workflows which can be started on the site.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfoWorkflowCollection ToBeStartedWorkflows { get; }
Public ReadOnly Property ToBeStartedWorkflows As WBSiteInfoWorkflowCollection
    Get
public:
property WBSiteInfoWorkflowCollection^ ToBeStartedWorkflows {
    WBSiteInfoWorkflowCollection^ get ();
}
member ToBeStartedWorkflows : WBSiteInfoWorkflowCollection with get

Property Value

Type: WBSiteInfoWorkflowCollection
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo Methods

WBSiteInfo Methods Datapolis Process System Class Reference

The WBSiteInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo.GetSchema Method

WBSiteInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo.GetWBSchema Method

WBSiteInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo.ReadXml Method

WBSiteInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfo.WriteXml Method

WBSiteInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBSiteInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow Class

WBSiteInfoWorkflow Class Datapolis Process System Class Reference
Represents a Workbox workflow definition on a site.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfoWorkflow

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSiteInfoWorkflow : WBInterfaceBase
Public NotInheritable Class WBSiteInfoWorkflow
    Inherits WBInterfaceBase
public ref class WBSiteInfoWorkflow sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBSiteInfoWorkflow =
    class
        inherit WBInterfaceBase
    end

The WBSiteInfoWorkflow type exposes the following members.

Constructors
 | Name | Description
Public method | WBSiteInfoWorkflow | Creates a new instance of WBSiteInfoWorkflow class.
Top
Properties
 | Name | Description
Public property | Associated | Gets a Boolean value that indicates whether the workflow is deployed on the list.
Public property | AssociationID | Gets the workflow's base ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | Description | Gets the workflow's description.
Public property | FormType | Gets the type of the workflow's launch form.
Public property | FormURL | Gets the URL address of the workflow's custom launch form.
Public property | Name | Gets the workflow's name.
Public property | Parameters | Gets the collection of the workflow parameters.
Public property | RedirectURL | Gets the URL address of the page to which the user should be redirected after the workflow has been successfully started.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow Constructor

WBSiteInfoWorkflow Constructor Datapolis Process System Class Reference
Creates a new instance of WBSiteInfoWorkflow class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfoWorkflow()
Public Sub New
public:
WBSiteInfoWorkflow()
new : unit -> WBSiteInfoWorkflow
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow Properties

WBSiteInfoWorkflow Properties Datapolis Process System Class Reference

The WBSiteInfoWorkflow type exposes the following members.

Properties
 | Name | Description
Public property | Associated | Gets a Boolean value that indicates whether the workflow is deployed on the list.
Public property | AssociationID | Gets the workflow's base ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | Description | Gets the workflow's description.
Public property | FormType | Gets the type of the workflow's launch form.
Public property | FormURL | Gets the URL address of the workflow's custom launch form.
Public property | Name | Gets the workflow's name.
Public property | Parameters | Gets the collection of the workflow parameters.
Public property | RedirectURL | Gets the URL address of the page to which the user should be redirected after the workflow has been successfully started.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.Associated Property

WBSiteInfoWorkflowAssociated Property Datapolis Process System Class Reference
Gets a Boolean value that indicates whether the workflow is deployed on the list.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public bool Associated { get; }
Public ReadOnly Property Associated As Boolean
    Get
public:
property bool Associated {
    bool get ();
}
member Associated : bool with get

Property Value

Type: Boolean
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.AssociationID Property

WBSiteInfoWorkflowAssociationID Property Datapolis Process System Class Reference
Gets the workflow's base ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid AssociationID { get; }
Public ReadOnly Property AssociationID As Guid
    Get
public:
property Guid AssociationID {
    Guid get ();
}
member AssociationID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.BaseID Property

WBSiteInfoWorkflowBaseID Property Datapolis Process System Class Reference
Gets the workflow's base ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid BaseID { get; }
Public ReadOnly Property BaseID As Guid
    Get
public:
property Guid BaseID {
    Guid get ();
}
member BaseID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.Description Property

WBSiteInfoWorkflowDescription Property Datapolis Process System Class Reference
Gets the workflow's description.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.FormType Property

WBSiteInfoWorkflowFormType Property Datapolis Process System Class Reference
Gets the type of the workflow's launch form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBLaunchFormType FormType { get; }
Public ReadOnly Property FormType As WBLaunchFormType
    Get
public:
property WBLaunchFormType FormType {
    WBLaunchFormType get ();
}
member FormType : WBLaunchFormType with get

Property Value

Type: WBLaunchFormType
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.FormURL Property

WBSiteInfoWorkflowFormURL Property Datapolis Process System Class Reference
Gets the URL address of the workflow's custom launch form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string FormURL { get; }
Public ReadOnly Property FormURL As String
    Get
public:
property String^ FormURL {
    String^ get ();
}
member FormURL : string with get

Property Value

Type: String
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.Name Property

WBSiteInfoWorkflowName Property Datapolis Process System Class Reference
Gets the workflow's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.Parameters Property

WBSiteInfoWorkflowParameters Property Datapolis Process System Class Reference
Gets the collection of the workflow parameters.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowParameterCollection Parameters { get; }
Public ReadOnly Property Parameters As WBWorkflowParameterCollection
    Get
public:
property WBWorkflowParameterCollection^ Parameters {
    WBWorkflowParameterCollection^ get ();
}
member Parameters : WBWorkflowParameterCollection with get

Property Value

Type: WBWorkflowParameterCollection
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.RedirectURL Property

WBSiteInfoWorkflowRedirectURL Property Datapolis Process System Class Reference
Gets the URL address of the page to which the user should be redirected after the workflow has been successfully started.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string RedirectURL { get; }
Public ReadOnly Property RedirectURL As String
    Get
public:
property String^ RedirectURL {
    String^ get ();
}
member RedirectURL : string with get

Property Value

Type: String
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow Methods

WBSiteInfoWorkflow Methods Datapolis Process System Class Reference

The WBSiteInfoWorkflow type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.GetSchema Method

WBSiteInfoWorkflowGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.GetWBSchema Method

WBSiteInfoWorkflowGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.ReadXml Method

WBSiteInfoWorkflowReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflow.WriteXml Method

WBSiteInfoWorkflowWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBSiteInfoWorkflow Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection Class

WBSiteInfoWorkflowCollection Class Datapolis Process System Class Reference
Represents a collection of WBSiteInfoWorkflow objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBSiteInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBSiteInfoWorkflow
Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfoWorkflowCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBSiteInfoWorkflowCollection : WBInterfaceCollectionBase<WBSiteInfoWorkflow>
Public NotInheritable Class WBSiteInfoWorkflowCollection
    Inherits WBInterfaceCollectionBase(Of WBSiteInfoWorkflow)
public ref class WBSiteInfoWorkflowCollection sealed : public WBInterfaceCollectionBase<WBSiteInfoWorkflow^>
[<SealedAttribute>]
type WBSiteInfoWorkflowCollection =
    class
        inherit WBInterfaceCollectionBase<WBSiteInfoWorkflow>
    end

The WBSiteInfoWorkflowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBSiteInfoWorkflowCollection | Initializes a new instance of the WBSiteInfoWorkflowCollection class
Top
Properties
 | Name | Description
Public property | ItemGuid | Gets the WBSiteInfoWorkflow object with the specified BaseID property.
Public property | ItemString | Gets the WBSiteInfoWorkflow object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection Constructor

WBSiteInfoWorkflowCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBSiteInfoWorkflowCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfoWorkflowCollection()
Public Sub New
public:
WBSiteInfoWorkflowCollection()
new : unit -> WBSiteInfoWorkflowCollection
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection Properties

WBSiteInfoWorkflowCollection Properties Datapolis Process System Class Reference

The WBSiteInfoWorkflowCollection type exposes the following members.

Properties
 | Name | Description
Public property | ItemGuid | Gets the WBSiteInfoWorkflow object with the specified BaseID property.
Public property | ItemString | Gets the WBSiteInfoWorkflow object with the specified Name property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection.Item Property

WBSiteInfoWorkflowCollectionItem Property Datapolis Process System Class Reference
Overload List
 | Name | Description
Public property | ItemGuid | Gets the WBSiteInfoWorkflow object with the specified BaseID property.
Public property | ItemString | Gets the WBSiteInfoWorkflow object with the specified Name property.
Top
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection.Item Property (Guid)

WBSiteInfoWorkflowCollectionItem Property (Guid) Datapolis Process System Class Reference
Gets the WBSiteInfoWorkflow object with the specified BaseID property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfoWorkflow this[
    Guid baseID
] { get; }
Public ReadOnly Default Property Item (
    baseID As Guid
) As WBSiteInfoWorkflow
    Get
public:
property WBSiteInfoWorkflow^ default[Guid baseID] {
    WBSiteInfoWorkflow^ get (Guid baseID);
}
member Item : WBSiteInfoWorkflow with get

Parameters

baseID
Type: SystemGuid
Base ID of the workflow.

Return Value

Type: WBSiteInfoWorkflow
A WBSiteInfoWorkflow object that meets the criteria.
See Also

Reference

WBSiteInfoWorkflowCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection.Item Property (String)

WBSiteInfoWorkflowCollectionItem Property (String) Datapolis Process System Class Reference
Gets the WBSiteInfoWorkflow object with the specified Name property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfoWorkflow this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As WBSiteInfoWorkflow
    Get
public:
property WBSiteInfoWorkflow^ default[String^ name] {
    WBSiteInfoWorkflow^ get (String^ name);
}
member Item : WBSiteInfoWorkflow with get

Parameters

name
Type: SystemString
Workbox workflow's name.

Return Value

Type: WBSiteInfoWorkflow
A WBSiteInfoWorkflow object that meets the criteria.
See Also

Reference

WBSiteInfoWorkflowCollection Class
Item Overload
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection Methods

WBSiteInfoWorkflowCollection Methods Datapolis Process System Class Reference

The WBSiteInfoWorkflowCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection.GetSchema Method

WBSiteInfoWorkflowCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection.GetWBSchema Method

WBSiteInfoWorkflowCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection.ReadXml Method

WBSiteInfoWorkflowCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBSiteInfoWorkflowCollection.WriteXml Method

WBSiteInfoWorkflowCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBSiteInfoWorkflowCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo Class

WBWorkflowInfo Class Datapolis Process System Class Reference
Represents the Workbox workflow's instance. Contains full information about the workflow instance.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowInfo

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBWorkflowInfo : WBInterfaceBase
Public NotInheritable Class WBWorkflowInfo
    Inherits WBInterfaceBase
public ref class WBWorkflowInfo sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBWorkflowInfo =
    class
        inherit WBInterfaceBase
    end

The WBWorkflowInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowInfo | Creates a new instance of WBWorkflowInfo class.
Top
Properties
 | Name | Description
Public property | AssociationID | Gets the workflow instance's association ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | InstanceID | Gets the workflow's instance ID.
Public property | InternalState | Gets the SPWorkflow.InternalState of the workflow.
Public property | ItemID | Gets the item's ID.
Public property | LCID | Gets the LCID code of the workflow's parent web culture (SPWeb.Locale.LCID).
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | Name | Gets the workflow's name.
Public property | State | Gets the name of the current workflow's state.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowActions | Gets the collection of WBActionInfo objects that represent actions available for the current (context) user in the current workflow's state.
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo Constructor

WBWorkflowInfo Constructor Datapolis Process System Class Reference
Creates a new instance of WBWorkflowInfo class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowInfo()
Public Sub New
public:
WBWorkflowInfo()
new : unit -> WBWorkflowInfo
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo Properties

WBWorkflowInfo Properties Datapolis Process System Class Reference

The WBWorkflowInfo type exposes the following members.

Properties
 | Name | Description
Public property | AssociationID | Gets the workflow instance's association ID.
Public property | BaseID | Gets the workflow's base ID.
Public property | InstanceID | Gets the workflow's instance ID.
Public property | InternalState | Gets the SPWorkflow.InternalState of the workflow.
Public property | ItemID | Gets the item's ID.
Public property | LCID | Gets the LCID code of the workflow's parent web culture (SPWeb.Locale.LCID).
Public property | ListDefaultViewUrl | Gets the URL address of the list's default view.
Public property | ListID | Gets the list's ID.
Public property | ListName | Gets the list's name.
Public property | ListUrl | Gets the list's URL address.
Public property | Name | Gets the workflow's name.
Public property | State | Gets the name of the current workflow's state.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Public property | WorkflowActions | Gets the collection of WBActionInfo objects that represent actions available for the current (context) user in the current workflow's state.
Top
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.AssociationID Property

WBWorkflowInfoAssociationID Property Datapolis Process System Class Reference
Gets the workflow instance's association ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid AssociationID { get; }
Public ReadOnly Property AssociationID As Guid
    Get
public:
property Guid AssociationID {
    Guid get ();
}
member AssociationID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.BaseID Property

WBWorkflowInfoBaseID Property Datapolis Process System Class Reference
Gets the workflow's base ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid BaseID { get; }
Public ReadOnly Property BaseID As Guid
    Get
public:
property Guid BaseID {
    Guid get ();
}
member BaseID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.InstanceID Property

WBWorkflowInfoInstanceID Property Datapolis Process System Class Reference
Gets the workflow's instance ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid InstanceID { get; }
Public ReadOnly Property InstanceID As Guid
    Get
public:
property Guid InstanceID {
    Guid get ();
}
member InstanceID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.InternalState Property

WBWorkflowInfoInternalState Property Datapolis Process System Class Reference
Gets the SPWorkflow.InternalState of the workflow.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string InternalState { get; }
Public ReadOnly Property InternalState As String
    Get
public:
property String^ InternalState {
    String^ get ();
}
member InternalState : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.ItemID Property

WBWorkflowInfoItemID Property Datapolis Process System Class Reference
Gets the item's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public int ItemID { get; }
Public ReadOnly Property ItemID As Integer
    Get
public:
property int ItemID {
    int get ();
}
member ItemID : int with get

Property Value

Type: Int32
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.LCID Property

WBWorkflowInfoLCID Property Datapolis Process System Class Reference
Gets the LCID code of the workflow's parent web culture (SPWeb.Locale.LCID).

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public int LCID { get; }
Public ReadOnly Property LCID As Integer
    Get
public:
property int LCID {
    int get ();
}
member LCID : int with get

Property Value

Type: Int32
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.ListDefaultViewUrl Property

WBWorkflowInfoListDefaultViewUrl Property Datapolis Process System Class Reference
Gets the URL address of the list's default view.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListDefaultViewUrl { get; }
Public ReadOnly Property ListDefaultViewUrl As String
    Get
public:
property String^ ListDefaultViewUrl {
    String^ get ();
}
member ListDefaultViewUrl : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.ListID Property

WBWorkflowInfoListID Property Datapolis Process System Class Reference
Gets the list's ID.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Guid ListID { get; }
Public ReadOnly Property ListID As Guid
    Get
public:
property Guid ListID {
    Guid get ();
}
member ListID : Guid with get

Property Value

Type: Guid
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.ListName Property

WBWorkflowInfoListName Property Datapolis Process System Class Reference
Gets the list's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListName { get; }
Public ReadOnly Property ListName As String
    Get
public:
property String^ ListName {
    String^ get ();
}
member ListName : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.ListUrl Property

WBWorkflowInfoListUrl Property Datapolis Process System Class Reference
Gets the list's URL address.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string ListUrl { get; }
Public ReadOnly Property ListUrl As String
    Get
public:
property String^ ListUrl {
    String^ get ();
}
member ListUrl : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.Name Property

WBWorkflowInfoName Property Datapolis Process System Class Reference
Gets the workflow's name.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.State Property

WBWorkflowInfoState Property Datapolis Process System Class Reference
Gets the name of the current workflow's state.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string State { get; }
Public ReadOnly Property State As String
    Get
public:
property String^ State {
    String^ get ();
}
member State : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.WorkflowActions Property

WBWorkflowInfoWorkflowActions Property Datapolis Process System Class Reference
Gets the collection of WBActionInfo objects that represent actions available for the current (context) user in the current workflow's state.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBActionInfoCollection WorkflowActions { get; }
Public ReadOnly Property WorkflowActions As WBActionInfoCollection
    Get
public:
property WBActionInfoCollection^ WorkflowActions {
    WBActionInfoCollection^ get ();
}
member WorkflowActions : WBActionInfoCollection with get

Property Value

Type: WBActionInfoCollection
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo Methods

WBWorkflowInfo Methods Datapolis Process System Class Reference

The WBWorkflowInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.GetSchema Method

WBWorkflowInfoGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.GetWBSchema Method

WBWorkflowInfoGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.ReadXml Method

WBWorkflowInfoReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfo.WriteXml Method

WBWorkflowInfoWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBWorkflowInfo Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection Class

WBWorkflowInfoCollection Class Datapolis Process System Class Reference
Represents the Workbox workflow's instances collection. Contains full information about the workflow instances.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBWorkflowInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBWorkflowInfo
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowInfoCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBWorkflowInfoCollection : WBInterfaceCollectionBase<WBWorkflowInfo>
Public NotInheritable Class WBWorkflowInfoCollection
    Inherits WBInterfaceCollectionBase(Of WBWorkflowInfo)
public ref class WBWorkflowInfoCollection sealed : public WBInterfaceCollectionBase<WBWorkflowInfo^>
[<SealedAttribute>]
type WBWorkflowInfoCollection =
    class
        inherit WBInterfaceCollectionBase<WBWorkflowInfo>
    end

The WBWorkflowInfoCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowInfoCollection | Creates a new instance of WBWorkflowInfoCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the WBWorkflowInfo object with the specified InstanceID property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection Constructor

WBWorkflowInfoCollection Constructor Datapolis Process System Class Reference
Creates a new instance of WBWorkflowInfoCollection class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowInfoCollection()
Public Sub New
public:
WBWorkflowInfoCollection()
new : unit -> WBWorkflowInfoCollection
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection Properties

WBWorkflowInfoCollection Properties Datapolis Process System Class Reference

The WBWorkflowInfoCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the WBWorkflowInfo object with the specified InstanceID property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection.Item Property

WBWorkflowInfoCollectionItem Property Datapolis Process System Class Reference
Gets the WBWorkflowInfo object with the specified InstanceID property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowInfo this[
    Guid instanceID
] { get; }
Public ReadOnly Default Property Item (
    instanceID As Guid
) As WBWorkflowInfo
    Get
public:
property WBWorkflowInfo^ default[Guid instanceID] {
    WBWorkflowInfo^ get (Guid instanceID);
}
member Item : WBWorkflowInfo with get

Parameters

instanceID
Type: SystemGuid
Base ID of the workflow.

Return Value

Type: WBWorkflowInfo
A WBSiteInfoWorkflow object that meets the criteria.
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection Methods

WBWorkflowInfoCollection Methods Datapolis Process System Class Reference

The WBWorkflowInfoCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection.GetSchema Method

WBWorkflowInfoCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection.GetWBSchema Method

WBWorkflowInfoCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection.ReadXml Method

WBWorkflowInfoCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowInfoCollection.WriteXml Method

WBWorkflowInfoCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBWorkflowInfoCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter Class

WBWorkflowParameter Class Datapolis Process System Class Reference
Represents a workflow parameter.
Inheritance Hierarchy
SystemObject
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceBase
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowParameter

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBWorkflowParameter : WBInterfaceBase
Public NotInheritable Class WBWorkflowParameter
    Inherits WBInterfaceBase
public ref class WBWorkflowParameter sealed : public WBInterfaceBase
[<SealedAttribute>]
type WBWorkflowParameter =
    class
        inherit WBInterfaceBase
    end

The WBWorkflowParameter type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowParameter | Creates a new instance of WBWorkflowParameter class.
Top
Properties
 | Name | Description
Public property | Description | Gets the description of the parameter.
Public property | InternalName | Gets the internal name of the parameter.
Public property | Properties | Gets the properties of the form field generated for the workflow parameter on Workflow Launch Form.
Public property | Title | Gets the title of the parameter.
Public property | Type | Gets the WBVariableType value representing the type of the action parameter.
Public property | Value | Gets or sets the parameter value.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter Constructor

WBWorkflowParameter Constructor Datapolis Process System Class Reference
Creates a new instance of WBWorkflowParameter class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowParameter()
Public Sub New
public:
WBWorkflowParameter()
new : unit -> WBWorkflowParameter
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter Properties

WBWorkflowParameter Properties Datapolis Process System Class Reference

The WBWorkflowParameter type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the parameter.
Public property | InternalName | Gets the internal name of the parameter.
Public property | Properties | Gets the properties of the form field generated for the workflow parameter on Workflow Launch Form.
Public property | Title | Gets the title of the parameter.
Public property | Type | Gets the WBVariableType value representing the type of the action parameter.
Public property | Value | Gets or sets the parameter value.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceBase.)
Top
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.Description Property

WBWorkflowParameterDescription Property Datapolis Process System Class Reference
Gets the description of the parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.InternalName Property

WBWorkflowParameterInternalName Property Datapolis Process System Class Reference
Gets the internal name of the parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string InternalName { get; }
Public ReadOnly Property InternalName As String
    Get
public:
property String^ InternalName {
    String^ get ();
}
member InternalName : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.Properties Property

WBWorkflowParameterProperties Property Datapolis Process System Class Reference
Gets the properties of the form field generated for the workflow parameter on Workflow Launch Form.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBDictionary<string, string> Properties { get; }
Public ReadOnly Property Properties As WBDictionary(Of String, String)
    Get
public:
property WBDictionary<String^, String^>^ Properties {
    WBDictionary<String^, String^>^ get ();
}
member Properties : WBDictionary<string, string> with get

Property Value

Type: WBDictionary String, String
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.Title Property

WBWorkflowParameterTitle Property Datapolis Process System Class Reference
Gets the title of the parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.Type Property

WBWorkflowParameterType Property Datapolis Process System Class Reference
Gets the WBVariableType value representing the type of the action parameter.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBVariableType Type { get; }
Public ReadOnly Property Type As WBVariableType
    Get
public:
property WBVariableType Type {
    WBVariableType get ();
}
member Type : WBVariableType with get

Property Value

Type: WBVariableType
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.Value Property

WBWorkflowParameterValue Property Datapolis Process System Class Reference
Gets or sets the parameter value.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter Methods

WBWorkflowParameter Methods Datapolis Process System Class Reference

The WBWorkflowParameter type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceBaseGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceBaseReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceBaseWriteXml(XmlWriter).)
Top
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.GetSchema Method

WBWorkflowParameterGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.GetWBSchema Method

WBWorkflowParameterGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.ReadXml Method

WBWorkflowParameterReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameter.WriteXml Method

WBWorkflowParameterWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBWorkflowParameter Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection Class

WBWorkflowParameterCollection Class Datapolis Process System Class Reference
Represents a collection of WBWorkflowParameter objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList WBWorkflowParameter
Datapolis.WorkBox.Utilities.WBInterfaceWBInterfaceCollectionBase WBWorkflowParameter
Datapolis.WorkBox.Utilities.WBInterfaceWBWorkflowParameterCollection

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBWorkflowParameterCollection : WBInterfaceCollectionBase<WBWorkflowParameter>
Public NotInheritable Class WBWorkflowParameterCollection
    Inherits WBInterfaceCollectionBase(Of WBWorkflowParameter)
public ref class WBWorkflowParameterCollection sealed : public WBInterfaceCollectionBase<WBWorkflowParameter^>
[<SealedAttribute>]
type WBWorkflowParameterCollection =
    class
        inherit WBInterfaceCollectionBase<WBWorkflowParameter>
    end

The WBWorkflowParameterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | WBWorkflowParameterCollection | Initializes a new instance of the WBWorkflowParameterCollection class
Top
Properties
 | Name | Description
Public property | Item | Gets the WBWorkflowParameter with a given InternalName property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection Constructor

WBWorkflowParameterCollection Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBWorkflowParameterCollection class

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowParameterCollection()
Public Sub New
public:
WBWorkflowParameterCollection()
new : unit -> WBWorkflowParameterCollection
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection Properties

WBWorkflowParameterCollection Properties Datapolis Process System Class Reference

The WBWorkflowParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the WBWorkflowParameter with a given InternalName property.
Public property | Version | Gets the object's version. (Inherited from WBInterfaceCollectionBaseT.)
Top
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection.Item Property

WBWorkflowParameterCollectionItem Property Datapolis Process System Class Reference
Gets the WBWorkflowParameter with a given InternalName property.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowParameter this[
    string internalName
] { get; }
Public ReadOnly Default Property Item (
    internalName As String
) As WBWorkflowParameter
    Get
public:
property WBWorkflowParameter^ default[String^ internalName] {
    WBWorkflowParameter^ get (String^ internalName);
}
member Item : WBWorkflowParameter with get

Parameters

internalName
Type: SystemString
InternalName property of the WBWorkflowParameter.

Return Value

Type: WBWorkflowParameter
WBWorkflowParameter that meets the specified criteria.
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection Methods

WBWorkflowParameterCollection Methods Datapolis Process System Class Reference

The WBWorkflowParameterCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class. (Overrides WBInterfaceCollectionBaseTGetSchema.)
 | GetWBSchema | Returns XML Schema Type.
Public method | ReadXml | Generates an object from its XML representation. (Overrides WBInterfaceCollectionBaseTReadXml(XmlReader).)
Public method | WriteXml | Converts an object into its XML representation. (Overrides WBInterfaceCollectionBaseTWriteXml(XmlWriter).)
Top
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection.GetSchema Method

WBWorkflowParameterCollectionGetSchema Method Datapolis Process System Class Reference
This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the System.Xml.Serialization.XmlSchemaProviderAttribute to the class.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override XmlSchema GetSchema()
Public Overrides Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() override
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
An System.Xml.Schema.XmlSchema that describes the XML representation of the object that is produced by the System.Xml.Serialization.IXmlSerializable.WriteXml(System.Xml.XmlWriter) method and consumed by the System.Xml.Serialization.IXmlSerializable.ReadXml(System.Xml.XmlReader) method.

Implements

IXmlSerializableGetSchema
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection.GetWBSchema Method

WBWorkflowParameterCollectionGetWBSchema Method Datapolis Process System Class Reference
Returns XML Schema Type.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public static XmlSchemaComplexType GetWBSchema(
    XmlSchemaSet schemaSet
)
Public Shared Function GetWBSchema (
    schemaSet As XmlSchemaSet
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetWBSchema(
    XmlSchemaSet^ schemaSet
)
static member GetWBSchema :
        schemaSet : XmlSchemaSet -> XmlSchemaComplexType

Parameters

schemaSet
Type: System.Xml.SchemaXmlSchemaSet
XmlSchemaSet object

Return Value

Type: XmlSchemaComplexType
XmlSchemaComplexType object
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection.ReadXml Method

WBWorkflowParameterCollectionReadXml Method Datapolis Process System Class Reference
Generates an object from its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: System.XmlXmlReader
The System.Xml.XmlReader stream from which the object is deserialized.

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


WBWorkflowParameterCollection.WriteXml Method

WBWorkflowParameterCollectionWriteXml Method Datapolis Process System Class Reference
Converts an object into its XML representation.

Namespace: Datapolis.WorkBox.Utilities.WBInterface
Assembly: Datapolis.WorkBox.Utilities (in Datapolis.WorkBox.Utilities.dll) Version: 1.0.0.0 (4.1.0.4707)
Syntax
C#
VB
C++
F#
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
The System.Xml.XmlWriter stream to which the object is serialized.

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

WBWorkflowParameterCollection Class
Datapolis.WorkBox.Utilities.WBInterface Namespace


Datapolis.WorkBox.WebService Namespace

Datapolis.WorkBox.WebService Namespace Datapolis Process System Class Reference
Classes
 | Class | Description
Public class | WBInterface | WBInterface – Workbox information and management web service.
Public class | WBReport | WBReport – Workbox Workflow Reports


WBInterface Class

WBInterface Class Datapolis Process System Class Reference
WBInterface – Workbox information and management web service.
Inheritance Hierarchy
SystemObject
System.ComponentModelMarshalByValueComponent
System.Web.ServicesWebService
Datapolis.WorkBox.WebServiceWBInterface

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBInterface : WebService
Public NotInheritable Class WBInterface
    Inherits WebService
public ref class WBInterface sealed : public WebService
[<SealedAttribute>]
type WBInterface =
    class
        inherit WebService
    end

The WBInterface type exposes the following members.

Constructors
 | Name | Description
Public method | WBInterface | Initializes a new instance of the WBInterface class
Top
Methods
 | Name | Description
Public method | GetWBActions | Returns information about available actions for items in selected list.
Public method | GetWBAllActions | Returns information about all available actions for items in selected list.
Public method | GetWBItemInfo | Returns information about Workbox workflow running/completed/available to start on list item.
Public method | GetWBListInfo | Returns information about Workbox workflows on selected list
Public method | GetWBSiteInfo | Returns information about Workbox workflows on selected site
Public method | GetWBWorkflowInfo | Returns information about Workbox workflow - available actions and theirs parameters.
Public method | IsWBOnList | Return true if there is at least one deployed workbox workflow on selected list.
Public method | LaunchWBAction | Launches choosen action on Workbox workflow.
Public method | LaunchWBActions | Launches a set of workflow actions.
Public method | SimpleLaunchWBAction | Launches choosen action on Workbox workflow.
Public method | StartWBSiteWorkflow | Starts selected Workbox workflow on site.
Public method | StartWBWorkflow | Starts selected Workbox workflow on list item.
Public method | TerminateWBWorkflow | Terminates Workbox workflow.
Top
See Also

Reference

Datapolis.WorkBox.WebService Namespace


WBInterface Constructor

WBInterface Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBInterface class

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBInterface()
Public Sub New
public:
WBInterface()
new : unit -> WBInterface
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface Methods

WBInterface Methods Datapolis Process System Class Reference

The WBInterface type exposes the following members.

Methods
 | Name | Description
Public method | GetWBActions | Returns information about available actions for items in selected list.
Public method | GetWBAllActions | Returns information about all available actions for items in selected list.
Public method | GetWBItemInfo | Returns information about Workbox workflow running/completed/available to start on list item.
Public method | GetWBListInfo | Returns information about Workbox workflows on selected list
Public method | GetWBSiteInfo | Returns information about Workbox workflows on selected site
Public method | GetWBWorkflowInfo | Returns information about Workbox workflow - available actions and theirs parameters.
Public method | IsWBOnList | Return true if there is at least one deployed workbox workflow on selected list.
Public method | LaunchWBAction | Launches choosen action on Workbox workflow.
Public method | LaunchWBActions | Launches a set of workflow actions.
Public method | SimpleLaunchWBAction | Launches choosen action on Workbox workflow.
Public method | StartWBSiteWorkflow | Starts selected Workbox workflow on site.
Public method | StartWBWorkflow | Starts selected Workbox workflow on list item.
Public method | TerminateWBWorkflow | Terminates Workbox workflow.
Top
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.GetWBActions Method

WBInterfaceGetWBActions Method Datapolis Process System Class Reference
Returns information about available actions for items in selected list.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBActions GetWBActions(
    string listUrl,
    int[] itemIds
)
Public Function GetWBActions (
    listUrl As String,
    itemIds As Integer()
) As WBActions
public:
WBActions^ GetWBActions(
    String^ listUrl,
    array<int>^ itemIds
)
member GetWBActions :
        listUrl : string *
        itemIds : int[] -> WBActions

Parameters

listUrl
Type: SystemString
Server relative url to list
itemIds
Type: SystemInt32

Return Value

Type: WBActions
A WBActions object that contains information about available actions.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.GetWBAllActions Method

WBInterfaceGetWBAllActions Method Datapolis Process System Class Reference
Returns information about all available actions for items in selected list.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBAllActions GetWBAllActions(
    string listUrl,
    int[] itemIds
)
Public Function GetWBAllActions (
    listUrl As String,
    itemIds As Integer()
) As WBAllActions
public:
WBAllActions^ GetWBAllActions(
    String^ listUrl,
    array<int>^ itemIds
)
member GetWBAllActions :
        listUrl : string *
        itemIds : int[] -> WBAllActions

Parameters

listUrl
Type: SystemString
Server relative url to list
itemIds
Type: SystemInt32

Return Value

Type: WBAllActions
A WBAllActions object that contains information about all available actions.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.GetWBItemInfo Method

WBInterfaceGetWBItemInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflow running/completed/available to start on list item.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBItemInfo GetWBItemInfo(
    string listUrl,
    int itemID
)
Public Function GetWBItemInfo (
    listUrl As String,
    itemID As Integer
) As WBItemInfo
public:
WBItemInfo^ GetWBItemInfo(
    String^ listUrl,
    int itemID
)
member GetWBItemInfo :
        listUrl : string *
        itemID : int -> WBItemInfo

Parameters

listUrl
Type: SystemString
Server relative url to list
itemID
Type: SystemInt32
Item ID

Return Value

Type: WBItemInfo
A WBItemInfo object that contains information about Workbox workflows on item.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.GetWBListInfo Method

WBInterfaceGetWBListInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflows on selected list

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBListInfo GetWBListInfo(
    string listUrl
)
Public Function GetWBListInfo (
    listUrl As String
) As WBListInfo
public:
WBListInfo^ GetWBListInfo(
    String^ listUrl
)
member GetWBListInfo :
        listUrl : string -> WBListInfo

Parameters

listUrl
Type: SystemString
Server relative url to list

Return Value

Type: WBListInfo
A WBListInfo object that contains information about Workbox workflows on list.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.GetWBSiteInfo Method

WBInterfaceGetWBSiteInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflows on selected site

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBSiteInfo GetWBSiteInfo()
Public Function GetWBSiteInfo As WBSiteInfo
public:
WBSiteInfo^ GetWBSiteInfo()
member GetWBSiteInfo : unit -> WBSiteInfo

Return Value

Type: WBSiteInfo
A WBSiteInfo object that contains information about Workbox workflows on site.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.GetWBWorkflowInfo Method

WBInterfaceGetWBWorkflowInfo Method Datapolis Process System Class Reference
Returns information about Workbox workflow - available actions and theirs parameters.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBWorkflowInfo GetWBWorkflowInfo(
    Guid instanceID
)
Public Function GetWBWorkflowInfo (
    instanceID As Guid
) As WBWorkflowInfo
public:
WBWorkflowInfo^ GetWBWorkflowInfo(
    Guid instanceID
)
member GetWBWorkflowInfo :
        instanceID : Guid -> WBWorkflowInfo

Parameters

instanceID
Type: SystemGuid
Workflow instance ID

Return Value

Type: WBWorkflowInfo
A WBWorkflowInfo object that contains information about Workbox workflow.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.IsWBOnList Method

WBInterfaceIsWBOnList Method Datapolis Process System Class Reference
Return true if there is at least one deployed workbox workflow on selected list.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo IsWBOnList(
    string listUrl
)
Public Function IsWBOnList (
    listUrl As String
) As WBResultInfo
public:
WBResultInfo^ IsWBOnList(
    String^ listUrl
)
member IsWBOnList :
        listUrl : string -> WBResultInfo

Parameters

listUrl
Type: SystemString
Server relative url to list

Return Value

Type: WBResultInfo
A WBResultInfo object that represents Workbox workflow existence on list.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.LaunchWBAction Method

WBInterfaceLaunchWBAction Method Datapolis Process System Class Reference
Launches choosen action on Workbox workflow.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo LaunchWBAction(
    Guid instanceID,
    WBActionInfo action
)
Public Function LaunchWBAction (
    instanceID As Guid,
    action As WBActionInfo
) As WBResultInfo
public:
WBResultInfo^ LaunchWBAction(
    Guid instanceID,
    WBActionInfo^ action
)
member LaunchWBAction :
        instanceID : Guid *
        action : WBActionInfo -> WBResultInfo

Parameters

instanceID
Type: SystemGuid
Workbox workflow instance ID
action
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfo
Action to launch (from WBWorkflowInfo.WorkflowActions[])

Return Value

Type: WBResultInfo
A WBResultInfo object that represents action launch result.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.LaunchWBActions Method

WBInterfaceLaunchWBActions Method Datapolis Process System Class Reference
Launches a set of workflow actions.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo LaunchWBActions(
    List<int> itemIDs,
    Guid baseID,
    WBActionInfo action
)
Public Function LaunchWBActions (
    itemIDs As List(Of Integer),
    baseID As Guid,
    action As WBActionInfo
) As WBResultInfo
public:
WBResultInfo^ LaunchWBActions(
    List<int>^ itemIDs,
    Guid baseID,
    WBActionInfo^ action
)
member LaunchWBActions :
        itemIDs : List<int> *
        baseID : Guid *
        action : WBActionInfo -> WBResultInfo

Parameters

itemIDs
Type: System.Collections.GenericList Int32
IDs of items on which works workflows to launch the actions on.
baseID
Type: SystemGuid
BaseID of workflow.
action
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBActionInfo
Action to launch (from WBWorkflowInfo.WorkflowActions[]).

Return Value

Type: WBResultInfo
A WBResultInfo object that represents bulk actions launch result.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.SimpleLaunchWBAction Method

WBInterfaceSimpleLaunchWBAction Method Datapolis Process System Class Reference
Launches choosen action on Workbox workflow.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo SimpleLaunchWBAction(
    string listUrl,
    int itemID,
    string workflowName,
    string stateTitle,
    string actionTitle
)
Public Function SimpleLaunchWBAction (
    listUrl As String,
    itemID As Integer,
    workflowName As String,
    stateTitle As String,
    actionTitle As String
) As WBResultInfo
public:
WBResultInfo^ SimpleLaunchWBAction(
    String^ listUrl,
    int itemID,
    String^ workflowName,
    String^ stateTitle,
    String^ actionTitle
)
member SimpleLaunchWBAction :
        listUrl : string *
        itemID : int *
        workflowName : string *
        stateTitle : string *
        actionTitle : string -> WBResultInfo

Parameters

listUrl
Type: SystemString
Server relative url to list
itemID
Type: SystemInt32
Item ID
workflowName
Type: SystemString
Workflow definition name
stateTitle
Type: SystemString
State name
actionTitle
Type: SystemString
Action name

Return Value

Type: WBResultInfo
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.StartWBSiteWorkflow Method

WBInterfaceStartWBSiteWorkflow Method Datapolis Process System Class Reference
Starts selected Workbox workflow on site.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo StartWBSiteWorkflow(
    WBSiteInfoWorkflow workflowInfo
)
Public Function StartWBSiteWorkflow (
    workflowInfo As WBSiteInfoWorkflow
) As WBResultInfo
public:
WBResultInfo^ StartWBSiteWorkflow(
    WBSiteInfoWorkflow^ workflowInfo
)
member StartWBSiteWorkflow :
        workflowInfo : WBSiteInfoWorkflow -> WBResultInfo

Parameters

workflowInfo
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBSiteInfoWorkflow
Workbox workflow to start (from WBSiteInfo.ToBeStartedWorkflows[])

Return Value

Type: WBResultInfo
A WBResultInfo object that represents start workflow result.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.StartWBWorkflow Method

WBInterfaceStartWBWorkflow Method Datapolis Process System Class Reference
Starts selected Workbox workflow on list item.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo StartWBWorkflow(
    string listUrl,
    int itemID,
    WBListInfoWorkflow workflowInfo
)
Public Function StartWBWorkflow (
    listUrl As String,
    itemID As Integer,
    workflowInfo As WBListInfoWorkflow
) As WBResultInfo
public:
WBResultInfo^ StartWBWorkflow(
    String^ listUrl,
    int itemID,
    WBListInfoWorkflow^ workflowInfo
)
member StartWBWorkflow :
        listUrl : string *
        itemID : int *
        workflowInfo : WBListInfoWorkflow -> WBResultInfo

Parameters

listUrl
Type: SystemString
Server relative url to list
itemID
Type: SystemInt32
Item ID
workflowInfo
Type: Datapolis.WorkBox.Utilities.WBInterfaceWBListInfoWorkflow
Workbox workflow to start (from WBItemInfo.ToBeStartedWorkflows[])

Return Value

Type: WBResultInfo
A WBResultInfo object that represents start workflow result.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBInterface.TerminateWBWorkflow Method

WBInterfaceTerminateWBWorkflow Method Datapolis Process System Class Reference
Terminates Workbox workflow.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBResultInfo TerminateWBWorkflow(
    Guid instanceID
)
Public Function TerminateWBWorkflow (
    instanceID As Guid
) As WBResultInfo
public:
WBResultInfo^ TerminateWBWorkflow(
    Guid instanceID
)
member TerminateWBWorkflow :
        instanceID : Guid -> WBResultInfo

Parameters

instanceID
Type: SystemGuid
Workflow instance ID

Return Value

Type: WBResultInfo
A WBResultInfo object that represents terminate workflow result.
See Also

Reference

WBInterface Class
Datapolis.WorkBox.WebService Namespace


WBReport Class

WBReport Class Datapolis Process System Class Reference
WBReport – Workbox Workflow Reports
Inheritance Hierarchy
SystemObject
System.ComponentModelMarshalByValueComponent
System.Web.ServicesWebService
Datapolis.WorkBox.WebServiceWBReport

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public sealed class WBReport : WebService
Public NotInheritable Class WBReport
    Inherits WebService
public ref class WBReport sealed : public WebService
[<SealedAttribute>]
type WBReport =
    class
        inherit WebService
    end

The WBReport type exposes the following members.

Constructors
 | Name | Description
Public method | WBReport | Initializes a new instance of the WBReport class
Top
Methods
 | Name | Description
Public method | GetLaunchedActions | The method returns data of all actions executed by all users in all workflows during a given period of time.
Public method | GetStartedWorkflows | The method returns information about all workflows that were started during a given period of time.
Public method | GetUserActions | The method returns all actions a given user can execute in all currently running workflows.
Top
See Also

Reference

Datapolis.WorkBox.WebService Namespace


WBReport Constructor

WBReport Constructor Datapolis Process System Class Reference
Initializes a new instance of the WBReport class

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public WBReport()
Public Sub New
public:
WBReport()
new : unit -> WBReport
See Also

Reference

WBReport Class
Datapolis.WorkBox.WebService Namespace


WBReport Methods

WBReport Methods Datapolis Process System Class Reference

The WBReport type exposes the following members.

Methods
 | Name | Description
Public method | GetLaunchedActions | The method returns data of all actions executed by all users in all workflows during a given period of time.
Public method | GetStartedWorkflows | The method returns information about all workflows that were started during a given period of time.
Public method | GetUserActions | The method returns all actions a given user can execute in all currently running workflows.
Top
See Also

Reference

WBReport Class
Datapolis.WorkBox.WebService Namespace


WBReport.GetLaunchedActions Method

WBReportGetLaunchedActions Method Datapolis Process System Class Reference
The method returns data of all actions executed by all users in all workflows during a given period of time.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string GetLaunchedActions(
    string scope,
    string url,
    string dateFrom,
    string dateTo
)
Public Function GetLaunchedActions (
    scope As String,
    url As String,
    dateFrom As String,
    dateTo As String
) As String
public:
String^ GetLaunchedActions(
    String^ scope,
    String^ url,
    String^ dateFrom,
    String^ dateTo
)
member GetLaunchedActions :
        scope : string *
        url : string *
        dateFrom : string *
        dateTo : string -> string

Parameters

scope
Type: SystemString
(Required) Defines which workflows include in the report, depending on where they are running. Allowed values for this parameter are: Farm, Web Application, Site Collection, Site, List.
url
Type: SystemString

URL address pointing to the location specified in Scope parameter. If empty, the site where the web service is running will be assumed.

Note: Cannot be empty if Scope is set to List.

dateFrom
Type: SystemString
(Required) Defines starting date of the period for which to generate the report. Actions executed after the date will be included in the report.
dateTo
Type: SystemString
(Required) Defines end date of the period for which to generate the report. Actions executed before the date will be included in the report.

Return Value

Type: String
Returns XML in the following format: <WBReport> <WBReportProperties> <Errors> <Error></Error> </Errors> <Scope></Scope> <Url></Url> <DateFrom></DateFrom> <DateTo></DateTo> </WBReportProperties> <WBRecordCollection> <WBRecord> <WorkflowName></WorkflowName> <WorkflowInstanceId></WorkflowInstanceId> <ActionName></ActionName> <ActionInternalName></ActionInternalName> <StartedByUserName></StartedByUserName> <StartedByLogin></StartedByLogin> <SourceStateName></SourceStateName> <DestinationStateName></DestinationStateName> <SourceStateDuration></SourceStateDuration> <StartTime></StartTime> <ExecutionTime></ExecutionTime> <WorkflowDuration></WorkflowDuration> <ItemName></ItemName> <ItemTitle></ItemTitle> <ItemId></ItemId> <ItemUrl></ItemUrl> <ListId></ListId> <ListUrl></ListUrl> <SiteId></SiteId> <SiteUrl></SiteUrl> </WBRecord> </WBRecordCollection> </WBReport>
See Also

Reference

WBReport Class
Datapolis.WorkBox.WebService Namespace


WBReport.GetStartedWorkflows Method

WBReportGetStartedWorkflows Method Datapolis Process System Class Reference
The method returns information about all workflows that were started during a given period of time.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string GetStartedWorkflows(
    string scope,
    string url,
    string dateFrom,
    string dateTo
)
Public Function GetStartedWorkflows (
    scope As String,
    url As String,
    dateFrom As String,
    dateTo As String
) As String
public:
String^ GetStartedWorkflows(
    String^ scope,
    String^ url,
    String^ dateFrom,
    String^ dateTo
)
member GetStartedWorkflows :
        scope : string *
        url : string *
        dateFrom : string *
        dateTo : string -> string

Parameters

scope
Type: SystemString
(Required) Defines which workflows include in the report, depending on where they are running. Allowed values for this parameter are: Farm, Web Application, Site Collection, Site, List.
url
Type: SystemString

URL address pointing to the location specified in Scope parameter. If empty, the site where the web service is running will be assumed.

Note: Cannot be empty if Scope is set to List.

dateFrom
Type: SystemString
(Required) Defines starting date of the period for which to generate the report. Workflows started after the date will be included in the report.
dateTo
Type: SystemString
(Required) Defines end date of the period for which to generate the report. Workflows started before the date will be included in the report.

Return Value

Type: String
Returns XML in the following format: <WBReport> <WBReportProperties> <Errors> <Error></Error> </Errors> <Scope></Scope> <Url></Url> <DateFrom></DateFrom> <DateTo></DateTo> </WBReportProperties> <WBRecordCollection> <WBRecord> <SiteId></SiteId> <SiteUrl></SiteUrl> <ListId></ListId> <ListUrl></ListUrl> <ItemId></ItemId> <ItemUrl></ItemUrl> <WorkflowName></WorkflowName> <WorkflowInstanceId></WorkflowInstanceId> <StartTime></StartTime> <StartDuration></StartDuration> <WorkflowDuration></WorkflowDuration> <ExecutionTime></ExecutionTime> <StartedByUserName></StartedByUserName> <StartedByLogin></StartedByLogin> <WorkflowStatus></WorkflowStatus> <WorkflowStateName></WorkflowStateName> <ItemName></ItemName> <ItemTitle></ItemTitle> </WBRecord> </WBRecordCollection> </WBReport>
See Also

Reference

WBReport Class
Datapolis.WorkBox.WebService Namespace


WBReport.GetUserActions Method

WBReportGetUserActions Method Datapolis Process System Class Reference
The method returns all actions a given user can execute in all currently running workflows.

Namespace: Datapolis.WorkBox.WebService
Assembly: Datapolis.WorkBox (in Datapolis.WorkBox.dll) Version: 1.0.0.0 (4.4.0.4737)
Syntax
C#
VB
C++
F#
Copy
public string GetUserActions(
    string scope,
    string url,
    string username
)
Public Function GetUserActions (
    scope As String,
    url As String,
    username As String
) As String
public:
String^ GetUserActions(
    String^ scope,
    String^ url,
    String^ username
)
member GetUserActions :
        scope : string *
        url : string *
        username : string -> string

Parameters

scope
Type: SystemString
(Required) Defines which workflows include in the report, depending on where they are running. Allowed values for this parameter are: Farm, Web Application, Site Collection, Site, List.
url
Type: SystemString

URL address pointing to the location specified in Scope parameter. If empty, the site where the web service is running will be assumed.

Note: Cannot be empty if Scope is set to List.

username
Type: SystemString
Login of the user for whom his or her available actions are to be retrieved. If empty, actions for the user invoking the method will be returned.

Return Value

Type: String
Returns XML in the following format: <WBReport> <WBReportProperties> <Errors> <Error></Error> </Errors> <Scope></Scope> <Url></Url> <UserName></UserName> </WBReportProperties> <WBRecordCollection> <WBRecord> <SiteTitle></SiteTitle> <SiteUrl></SiteUrl> <ItemName></ItemName> <ItemId></ItemId> <ItemUrl></ItemUrl> <WorkflowName></WorkflowName> <ActionInternalName></ActionInternalName> <ActionTitle></ActionTitle> <ActionUrl></ActionUrl> </WBRecord> </WBRecordCollection> </WBReport>
See Also

Reference

WBReport Class
Datapolis.WorkBox.WebService Namespace